9372be66b332b18a2e0c969c4848153ec70af50a
[packages/nodejs.git] / 0001-Disable-running-gyp-on-shared-deps.patch
1 From a560ff12ff44d9732ce325ca4bcde6e536fe3ed0 Mon Sep 17 00:00:00 2001
2 From: Zuzana Svetlikova <zsvetlik@redhat.com>
3 Date: Thu, 27 Apr 2017 14:25:42 +0200
4 Subject: [PATCH 1/3] Disable running gyp on shared deps
5
6 ---
7  Makefile | 6 +++---
8  1 file changed, 3 insertions(+), 3 deletions(-)
9
10 diff --git a/Makefile b/Makefile
11 index 0947300f24028d00bcfb79b38d96bded136228e3..5d4f88a705053fbdd6b56ec85e9997670c6a69c5 100644
12 --- a/Makefile
13 +++ b/Makefile
14 @@ -141,9 +141,9 @@ test-code-cache: with-code-cache
15         echo "'test-code-cache' target is a noop"
16  
17  out/Makefile: config.gypi common.gypi node.gyp \
18 -       deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
19 -       tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
20 -       tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
21 +  deps/llhttp/llhttp.gyp \
22 +  tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
23 +  tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
24         $(PYTHON) tools/gyp_node.py -f make
25  
26  # node_version.h is listed because the N-API version is taken from there
27 -- 
28 2.23.0
29
30 --- node-v12.16.1/deps/uvwasi/uvwasi.gyp.orig   2020-02-18 06:08:33.000000000 +0100
31 +++ node-v12.16.1/deps/uvwasi/uvwasi.gyp        2020-03-21 17:51:55.372551818 +0100
32 @@ -14,9 +14,6 @@
33          'src/uv_mapping.c',
34          'src/uvwasi.c',
35        ],
36 -      'dependencies': [
37 -        '../uv/uv.gyp:libuv',
38 -      ],
39        'direct_dependent_settings': {
40          'include_dirs': ['include']
41        },
This page took 0.038654 seconds and 2 git commands to generate.