]> git.pld-linux.org Git - packages/nodejs.git/blame_incremental - nodejs.spec
icu rebuild
[packages/nodejs.git] / nodejs.spec
... / ...
CommitLineData
1# TODO
2# - unpackaged files
3# /usr/share/doc/node/gdbinit
4
5# Conditional build:
6%bcond_without system_brotli # system brotli
7%bcond_without system_uv # system uv
8%bcond_with http_parser # system http-parser and llhttp
9
10%define _enable_debug_packages 0
11
12# NOTES:
13# - https://nodejs.org/en/download/releases/
14
15# NODE_MODULE_VERSION refers to the ABI (application binary interface) version
16# number of Node.js, used to determine which versions of Node.js compiled C++
17# add-on binaries can be loaded in to without needing to be re-compiled. It
18# used to be stored as hex value in earlier versions, but is now represented as
19# an integer.
20%define node_module_version 83
21Summary: Asynchronous JavaScript Engine
22Summary(pl.UTF-8): Asynchroniczny silnik JavaScriptu
23Name: nodejs
24# 14.x LTS - https://github.com/nodejs/Release
25# Active start: 2020-10-27
26# Maintenance start: October 2020
27# Maintenance end: April 2023
28Version: 14.17.4
29Release: 3
30License: BSD and MIT and Apache v2.0 and GPL v3
31Group: Development/Languages
32Source0: https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
33# Source0-md5: d46ffad24b7637bdd47995a799bcec7d
34
35# force node to use /usr/lib/node as the systemwide module directory
36Patch2: %{name}-libpath.patch
37# use /usr/lib64/node as an arch-specific module dir when appropriate
38Patch3: %{name}-lib64path.patch
39Patch4: 0001-Disable-running-gyp-on-shared-deps.patch
40Patch5: 0002-Install-both-binaries-and-use-libdir.patch
41URL: https://nodejs.org/
42BuildRequires: c-ares-devel >= 1.17.1
43BuildRequires: gcc >= 6:6.3
44%if %{with http_parser}
45BuildRequires: http-parser-devel >= 2.9.3
46BuildRequires: llhttp-devel >= 2.1.3
47%endif
48%{?with_system_brotli:BuildRequires: libbrotli-devel >= 1.0.9}
49BuildRequires: libicu-devel >= 67
50BuildRequires: libstdc++-devel >= 6:4.8
51%{?with_system_uv:BuildRequires: libuv-devel >= 1.41.0}
52BuildRequires: nghttp2-devel >= 1.42.0
53BuildRequires: openssl-devel >= 1.0.1
54BuildRequires: pkgconfig
55BuildRequires: python3
56BuildRequires: python3-modules
57BuildRequires: rpm >= 4.4.9-56
58BuildRequires: rpmbuild(macros) >= 1.752
59BuildRequires: sed >= 4.0
60BuildRequires: zlib-devel >= 1.2.11
61Requires: c-ares >= 1.17.1
62Requires: ca-certificates
63%{?with_http_parser:Requires: http-parser >= 2.9.3}
64%{?with_system_brotli:Requires: libbrotli >= 1.0.9}
65%{?with_system_uv:Requires: libuv >= 1.41.0}
66Requires: nghttp2-libs >= 1.42.0
67Requires: zlib >= 1.2.11
68Provides: nodejs(engine) = %{version}
69Provides: nodejs(module-version) = %{node_module_version}
70Obsoletes: nodejs-waf
71ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64
72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74%define sover %(echo %{version} | cut -d. -f2)
75# add macro, so adapter won't replace it back literal
76%define doc_ver %{version}
77
78%description
79Node.js is a platform built on Chrome's JavaScript runtime for easily
80building fast, scalable network applications. Node.js uses an
81event-driven, non-blocking I/O model that makes it lightweight and
82efficient, perfect for data-intensive real-time applications that run
83across distributed devices.
84
85%description -l pl.UTF-8
86Node.js to platforma zbudowana w opacriu o silnik JavaScriptu
87przeglądarki Chrome, służąca do tworzenia szybkich, skalowalnych
88aplikacji sieciowych. Node.js wykorzystuje nieblokujący model
89wejścia/wyjścia sterowany zdarzeniami, dzięki czemu jest lekki i
90wydajny, dobrze nadający się do aplikacji przetwarzających duże
91ilości danych w czasie rzeczywistym, uruchamianych na rozproszonych
92urządzeniach.
93
94%package devel
95Summary: Development headers for nodejs
96Summary(pl.UTF-8): Pliki nagłówkowe nodejs
97Group: Development/Libraries
98Requires: %{name} = %{version}-%{release}
99Requires: gcc
100%{?with_http_parser:Requires: http-parser-devel >= 2.9.3}
101Requires: libstdc++-devel
102%{?with_system_uv:Requires: libuv-devel >= 1.41.0}
103Requires: openssl-devel
104Requires: zlib-devel >= 1.2.11
105
106%description devel
107Development headers for nodejs.
108
109%description devel -l pl.UTF-8
110Pliki nagłówkowe nodejs.
111
112%package doc
113Summary: Documentation for Node.js engine
114Summary(pl.UTF-8): Dokumentacja silnika Node.js
115Group: Documentation
116URL: https://nodejs.org/dist/v%{doc_ver}/docs/api
117BuildArch: noarch
118
119%description doc
120Node.js is a server-side JavaScript environment that uses an
121asynchronous event-driven model. Node's goal is to provide an easy way
122to build scalable network programs.
123
124This package contains the documentation for Node.js.
125
126%description doc -l pl.UTF-8
127Node.js to serwerowe środowisko JavaScriptu wykorzystujące
128asynchroniczny model sterowany zdarzeniami. Celem Node jest
129zapewnienie łatwego sposobu tworzenia skalowalnych programów
130sieciowych.
131
132Ten pakiet zawiera dokumentację Node.js.
133
134%package -n systemtap-nodejs
135Summary: systemtap/dtrace probes for Node.js
136Summary(pl.UTF-8): Sondy systemtap/dtrace dla Node.js
137Group: Development/Tools
138Requires: %{name} = %{version}-%{release}
139Requires: systemtap-client
140
141%description -n systemtap-nodejs
142systemtap/dtrace probes for Node.js.
143
144%description -n systemtap-nodejs -l pl.UTF-8
145Sondy systemtap/dtrace dla Node.js.
146
147%prep
148%setup -q -n node-v%{version}
149%if "%{_lib}" == "lib64"
150%patch3 -p1
151%else
152%patch2 -p1
153%endif
154%patch4 -p1
155%patch5 -p1
156
157grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python3},'
158
159%{?with_system_brotli:%{__rm} -r deps/brotli}
160%{__rm} -r deps/cares
161%if %{with http_parser}
162%{__rm} -r deps/http_parser
163%{__rm} -r deps/llhttp
164%endif
165%{__rm} -r deps/icu-small
166%{__rm} -r deps/nghttp2
167%{__rm} -r deps/npm
168%{__rm} -r deps/openssl
169%{?with_system_uv:%{__rm} -r deps/uv}
170%{__rm} -r deps/zlib
171
172%build
173ver=$(awk '/#define NODE_MODULE_VERSION/{print $3}' src/node_version.h)
174test "$ver" = "%{node_module_version}"
175
176# CC used only to detect if CC is clang, not used for compiling
177CC="%{__cc}" \
178CXX="%{__cxx}" \
179GYP_DEFINES="soname_version=%{sover}" \
180./configure \
181 --prefix=%{_prefix} \
182 --libdir=%{_lib} \
183 --openssl-use-def-ca-store \
184 --shared \
185 %{?with_system_brotli:--shared-brotli} \
186 --shared-cares \
187 %{?with_http_parser:--shared-http-parser} \
188 %{?with_system_uv:--shared-libuv} \
189 --shared-nghttp2 \
190 --shared-openssl \
191 --shared-zlib \
192 --with-intl=system-icu \
193 --without-dtrace \
194 --without-npm
195
196# add LFS defines from libuv (RHBZ#892601)
197# CXXFLAGS must be exported, as it is needed for make, not gyp
198CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
199LDFLAGS="%{rpmldflags}" \
200%{__make} -C out \
201 BUILDTYPE=Release \
202 V=1
203
204%install
205rm -rf $RPM_BUILD_ROOT
206
207%{__python3} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
208
209ln -s libnode.so.%{node_module_version} $RPM_BUILD_ROOT%{_libdir}/libnode.so
210
211echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
212
213install -d $RPM_BUILD_ROOT%{_includedir}/node
214cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
215
216# install for node-gyp
217install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
218cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
219ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
220
221# for compat of fedora derivered scripts (shebangs)
222ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
223
224# globally installed node modules (noarch)
225install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
226
227# default searchpaths
228install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
229
230# create pkgconfig
231install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
232cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
233version=%{version}
234prefix=%{_prefix}
235libdir=${prefix}/%{_lib}
236includedir=${prefix}/include/node
237
238Name: nodejs
239Description: Evented I/O for V8 JavaScript.
240Version: ${version}
241Cflags: -I${includedir}
242EOF
243
244# install documentation
245install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
246cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
247%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.md
248%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
249
250%clean
251rm -rf $RPM_BUILD_ROOT
252
253%post -p /sbin/ldconfig
254%postun -p /sbin/ldconfig
255
256%files
257%defattr(644,root,root,755)
258%doc AUTHORS CHANGELOG.md LICENSE README.md SECURITY.md
259%attr(755,root,root) %{_bindir}/node
260%attr(755,root,root) %{_bindir}/nodejs
261%attr(755,root,root) %{_libdir}/libnode.so.%{node_module_version}
262%if "%{_lib}" != "lib"
263%dir %{_libdir}/node
264%endif
265%dir %{_prefix}/lib/node
266%dir %{_prefix}/lib/node_modules
267%{_mandir}/man1/node.1*
268%{_mandir}/man1/nodejs.1*
269
270%files devel
271%defattr(644,root,root,755)
272%attr(755,root,root) %{_libdir}/libnode.so
273%{_includedir}/node
274%{_pkgconfigdir}/nodejs.pc
275%{_usrsrc}/%{name}
276
277%files doc
278%defattr(644,root,root,755)
279%doc %{_docdir}/%{name}-doc-%{version}
280
281%files -n systemtap-nodejs
282%defattr(644,root,root,755)
283%{_datadir}/systemtap/tapset/node.stp
This page took 0.070012 seconds and 4 git commands to generate.