]> git.pld-linux.org Git - packages/nodejs.git/blame - nodejs.spec
- use system brotli by default
[packages/nodejs.git] / nodejs.spec
CommitLineData
cc3de6db
ER
1# TODO
2# - unpackaged files
3# /usr/share/doc/node/gdbinit
cc3de6db 4
29d6d704 5# Conditional build:
ab77d514 6%bcond_without system_brotli # system brotli
4a5eff4b 7%bcond_without system_uv # system uv
ab77d514 8%bcond_with http_parser # system http-parser and llhttp
29d6d704 9
8611106e
ER
10# NOTES:
11# - https://nodejs.org/en/download/releases/
12
e9b6043f
ER
13# NODE_MODULE_VERSION refers to the ABI (application binary interface) version
14# number of Node.js, used to determine which versions of Node.js compiled C++
15# add-on binaries can be loaded in to without needing to be re-compiled. It
16# used to be stored as hex value in earlier versions, but is now represented as
17# an integer.
c2768f1e 18%define node_module_version 72
210abff9 19Summary: Asynchronous JavaScript Engine
9a1229ff 20Summary(pl.UTF-8): Asynchroniczny silnik JavaScriptu
210abff9 21Name: nodejs
c2768f1e
AM
22# 12.x LTS - https://github.com/nodejs/Release
23# Active start: 2019-10-21
24# Maintenance start: October 2020
25# Maintenance end: April 2022
9f44cba6 26Version: 12.18.3
2c145010 27Release: 1
d5764a43 28License: BSD and MIT and Apache v2.0 and GPL v3
e85103e0 29Group: Development/Languages
8611106e 30Source0: https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
9f44cba6 31# Source0-md5: 28bf6a4d98b238403fa58a0805f4a979
c2768f1e 32
a6070ceb
ER
33# force node to use /usr/lib/node as the systemwide module directory
34Patch2: %{name}-libpath.patch
35# use /usr/lib64/node as an arch-specific module dir when appropriate
36Patch3: %{name}-lib64path.patch
c2768f1e
AM
37Patch4: 0001-Disable-running-gyp-on-shared-deps.patch
38Patch5: 0002-Install-both-binaries-and-use-libdir.patch
8611106e 39URL: https://nodejs.org/
ab77d514 40BuildRequires: c-ares-devel >= 1.16.0
8c0b403f 41BuildRequires: gcc >= 6:4.8
4398233e
JB
42%if %{with http_parser}
43BuildRequires: http-parser-devel >= 2.9.3
ab77d514 44BuildRequires: llhttp-devel >= 2.0.4
c2768f1e 45%endif
ab77d514 46%{?with_shared_brotli:BuildRequires: libbrotli-devel >= 1.0.7}
c2768f1e 47BuildRequires: libicu-devel >= 0.64
8c0b403f 48BuildRequires: libstdc++-devel >= 6:4.8
ab77d514 49%{?with_system_uv:BuildRequires: libuv-devel >= 1.38.0}
2c145010 50BuildRequires: nghttp2-devel >= 1.41.0
94f7bd52 51BuildRequires: openssl-devel >= 1.0.1
cd4c73aa 52BuildRequires: pkgconfig
91adacca 53BuildRequires: python >= 1:2.7
a6070ceb 54BuildRequires: python-jsmin
8c0b403f 55BuildRequires: python-modules >= 1:2.7
12a49d35 56BuildRequires: rpm >= 4.4.9-56
d44c8857 57BuildRequires: rpmbuild(macros) >= 1.219
536f9f5a 58BuildRequires: sed >= 4.0
ab77d514
JB
59BuildRequires: zlib-devel >= 1.2.11
60Requires: c-ares >= 1.16.0
61Requires: ca-certificates
4398233e 62%{?with_http_parser:Requires: http-parser >= 2.9.3}
ab77d514
JB
63%{?with_system_brotli:Requires: libbrotli >= 1.0.7}
64%{?with_system_uv:Requires: libuv >= 1.38.0}
2c145010 65Requires: nghttp2-libs >= 1.41.0
ab77d514 66Requires: zlib >= 1.2.11
8d8e2928 67Provides: nodejs(engine) = %{version}
56d9fb33 68Provides: nodejs(module-version) = %{node_module_version}
5ef76b51 69Obsoletes: nodejs-waf
a7c6ab18 70ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64
210abff9 71BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
dc60a63b 73%define sover %(echo %{version} | cut -d. -f2)
05e85ef1
ER
74# add macro, so adapter won't replace it back literal
75%define doc_ver %{version}
dc60a63b 76
210abff9 77%description
c3b531ba
ER
78Node.js is a platform built on Chrome's JavaScript runtime for easily
79building fast, scalable network applications. Node.js uses an
80event-driven, non-blocking I/O model that makes it lightweight and
81efficient, perfect for data-intensive real-time applications that run
82across distributed devices.
210abff9 83
9a1229ff
JB
84%description -l pl.UTF-8
85Node.js to platforma zbudowana w opacriu o silnik JavaScriptu
86przeglądarki Chrome, służąca do tworzenia szybkich, skalowalnych
87aplikacji sieciowych. Node.js wykorzystuje nieblokujący model
88wejścia/wyjścia sterowany zdarzeniami, dzięki czemu jest lekki i
89wydajny, dobrze nadający się do aplikacji przetwarzających duże
90ilości danych w czasie rzeczywistym, uruchamianych na rozproszonych
91urządzeniach.
92
210abff9 93%package devel
12a49d35 94Summary: Development headers for nodejs
9a1229ff 95Summary(pl.UTF-8): Pliki nagłówkowe nodejs
210abff9 96Group: Development/Libraries
a8f57a3f 97Requires: %{name} = %{version}-%{release}
d44c8857 98Requires: gcc
4398233e 99%{?with_http_parser:Requires: http-parser-devel >= 2.9.3}
d44c8857 100Requires: libstdc++-devel
ab77d514 101%{?with_system_uv:Requires: libuv-devel >= 1.38.0}
96f19ba5 102Requires: openssl-devel
ab77d514 103Requires: zlib-devel >= 1.2.11
210abff9 104
105%description devel
12a49d35 106Development headers for nodejs.
210abff9 107
9a1229ff
JB
108%description devel -l pl.UTF-8
109Pliki nagłówkowe nodejs.
110
a6070ceb 111%package doc
9a1229ff
JB
112Summary: Documentation for Node.js engine
113Summary(pl.UTF-8): Dokumentacja silnika Node.js
a6070ceb 114Group: Documentation
05e85ef1 115URL: https://nodejs.org/dist/v%{doc_ver}/docs/api
4398233e 116%if "%{_rpmversion}" >= "4.6"
b6b2dd9b
ER
117BuildArch: noarch
118%endif
a6070ceb
ER
119
120%description doc
121Node.js is a server-side JavaScript environment that uses an
122asynchronous event-driven model. Node's goal is to provide an easy way
123to build scalable network programs.
124
9a1229ff
JB
125This package contains the documentation for Node.js.
126
127%description doc -l pl.UTF-8
128Node.js to serwerowe środowisko JavaScriptu wykorzystujące
129asynchroniczny model sterowany zdarzeniami. Celem Node jest
130zapewnienie łatwego sposobu tworzenia skalowalnych programów
131sieciowych.
132
133Ten pakiet zawiera dokumentację Node.js.
a6070ceb 134
8c0b403f
JB
135%package -n systemtap-nodejs
136Summary: systemtap/dtrace probes for Node.js
137Summary(pl.UTF-8): Sondy systemtap/dtrace dla Node.js
138Group: Development/Tools
139Requires: %{name} = %{version}-%{release}
140Requires: systemtap-client
141
142%description -n systemtap-nodejs
143systemtap/dtrace probes for Node.js.
144
145%description -n systemtap-nodejs -l pl.UTF-8
146Sondy systemtap/dtrace dla Node.js.
147
210abff9 148%prep
149%setup -q -n node-v%{version}
a6070ceb
ER
150%if %{_lib} == "lib64"
151%patch3 -p1
152%else
153%patch2 -p1
154%endif
c2768f1e
AM
155%patch4 -p1
156%patch5 -p1
c4aa3bb0 157
536f9f5a
ER
158grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
159
9a1229ff 160%{__rm} -r deps/npm
4398233e 161%{?with_http_parser:%{__rm} -r deps/http_parser}
9a1229ff
JB
162%{__rm} -r deps/openssl
163%{?with_system_uv:%{__rm} -r deps/uv}
164%{__rm} -r deps/zlib
e3e8568d 165
210abff9 166%build
c8ef6556 167ver=$(awk '/#define NODE_MODULE_VERSION/{print $3}' src/node_version.h)
145d5ed0 168test "$ver" = "%{node_module_version}"
56d9fb33 169
a11025a6
ER
170# CC used only to detect if CC is clang, not used for compiling
171CC="%{__cc}" \
172CXX="%{__cxx}" \
dc60a63b 173GYP_DEFINES="soname_version=%{sover}" \
a6070ceb 174./configure \
4398233e
JB
175 --prefix=%{_prefix} \
176 --libdir=%{_lib} \
e2a62df7 177 --openssl-use-def-ca-store \
c2768f1e 178 --shared \
ab77d514 179 %{?with_system_brotli:--shared-brotli} \
c2768f1e 180 --shared-cares \
4398233e 181 %{?with_http_parser:--shared-http-parser} \
8c0b403f 182 %{?with_system_uv:--shared-libuv} \
4398233e
JB
183 --shared-nghttp2 \
184 --shared-openssl \
8c0b403f 185 --shared-zlib \
4398233e 186 --with-intl=system-icu \
c1c359b8 187 --without-dtrace \
4398233e 188 --without-npm
210abff9 189
a11025a6
ER
190# add LFS defines from libuv (RHBZ#892601)
191# CXXFLAGS must be exported, as it is needed for make, not gyp
192CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
193LDFLAGS="%{rpmldflags}" \
9a1229ff
JB
194%{__make} -C out \
195 BUILDTYPE=Release \
196 V=1
210abff9 197
198%install
199rm -rf $RPM_BUILD_ROOT
9a1229ff 200
9618d15b 201%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
4174c079 202
c2768f1e 203ln -s libnode.so.%{node_module_version} $RPM_BUILD_ROOT%{_libdir}/libnode.so
a6070ceb 204
c7898157
ER
205echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
206
1ed21df5 207install -d $RPM_BUILD_ROOT%{_includedir}/node
4174c079 208cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
d5764a43
ER
209
210# install for node-gyp
211install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
212cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
213ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
1ed21df5 214
e85103e0 215# for compat of fedora derivered scripts (shebangs)
c3b531ba
ER
216ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
217
e85103e0
ER
218# globally installed node modules (noarch)
219install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
220
221# default searchpaths
222install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
223
a6070ceb
ER
224# create pkgconfig
225install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
226cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
227version=%{version}
c3b531ba 228prefix=%{_prefix}
87c4fdf2 229libdir=${prefix}/%{_lib}
a6070ceb
ER
230includedir=${prefix}/include/node
231
232Name: nodejs
233Description: Evented I/O for V8 JavaScript.
234Version: ${version}
235Cflags: -I${includedir}
236EOF
a752c1c0 237
a6070ceb 238# install documentation
6f7eebb5
ER
239install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
240cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
9a1229ff
JB
241%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.md
242%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
a6070ceb 243
210abff9 244%clean
245rm -rf $RPM_BUILD_ROOT
246
4174c079 247%post -p /sbin/ldconfig
7372d27d 248%postun -p /sbin/ldconfig
249
210abff9 250%files
251%defattr(644,root,root,755)
4398233e 252%doc AUTHORS CHANGELOG.md LICENSE README.md SECURITY.md
210abff9 253%attr(755,root,root) %{_bindir}/node
c3b531ba 254%attr(755,root,root) %{_bindir}/nodejs
c2768f1e 255%attr(755,root,root) %{_libdir}/libnode.so.%{node_module_version}
a600c300 256%if "%{_lib}" != "lib"
8791ea86 257%dir %{_libdir}/node
a600c300
ŁC
258%endif
259%dir %{_prefix}/lib/node
e85103e0 260%dir %{_prefix}/lib/node_modules
210abff9 261%{_mandir}/man1/node.1*
9a1229ff 262%{_mandir}/man1/nodejs.1*
210abff9 263
210abff9 264%files devel
265%defattr(644,root,root,755)
9a1229ff 266%attr(755,root,root) %{_libdir}/libnode.so
58494f0c 267%{_includedir}/node
a6070ceb 268%{_pkgconfigdir}/nodejs.pc
d5764a43 269%{_usrsrc}/%{name}
a6070ceb
ER
270
271%files doc
272%defattr(644,root,root,755)
273%doc %{_docdir}/%{name}-doc-%{version}
8c0b403f
JB
274
275%files -n systemtap-nodejs
276%defattr(644,root,root,755)
277%{_datadir}/systemtap/tapset/node.stp
This page took 0.311038 seconds and 4 git commands to generate.