]> git.pld-linux.org Git - packages/nodejs.git/blame - nodejs.spec
up to 14.16.0 (fixes CVE-2021-22883 CVE-2021-22884)
[packages/nodejs.git] / nodejs.spec
CommitLineData
cc3de6db
ER
1# TODO
2# - unpackaged files
3# /usr/share/doc/node/gdbinit
cc3de6db 4
29d6d704 5# Conditional build:
ab77d514 6%bcond_without system_brotli # system brotli
4a5eff4b 7%bcond_without system_uv # system uv
ab77d514 8%bcond_with http_parser # system http-parser and llhttp
29d6d704 9
5e8b83c0
JP
10%define _enable_debug_packages 0
11
8611106e
ER
12# NOTES:
13# - https://nodejs.org/en/download/releases/
14
e9b6043f
ER
15# NODE_MODULE_VERSION refers to the ABI (application binary interface) version
16# number of Node.js, used to determine which versions of Node.js compiled C++
17# add-on binaries can be loaded in to without needing to be re-compiled. It
18# used to be stored as hex value in earlier versions, but is now represented as
19# an integer.
ab907bdb 20%define node_module_version 83
210abff9 21Summary: Asynchronous JavaScript Engine
9a1229ff 22Summary(pl.UTF-8): Asynchroniczny silnik JavaScriptu
210abff9 23Name: nodejs
ab907bdb
JP
24# 14.x LTS - https://github.com/nodejs/Release
25# Active start: 2020-10-27
c2768f1e 26# Maintenance start: October 2020
ab907bdb 27# Maintenance end: April 2023
713af70d 28Version: 14.16.0
2c145010 29Release: 1
d5764a43 30License: BSD and MIT and Apache v2.0 and GPL v3
e85103e0 31Group: Development/Languages
8611106e 32Source0: https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
713af70d 33# Source0-md5: 7dc3666f407bf4e12a01ce1be2883d31
c2768f1e 34
a6070ceb
ER
35# force node to use /usr/lib/node as the systemwide module directory
36Patch2: %{name}-libpath.patch
37# use /usr/lib64/node as an arch-specific module dir when appropriate
38Patch3: %{name}-lib64path.patch
c2768f1e
AM
39Patch4: 0001-Disable-running-gyp-on-shared-deps.patch
40Patch5: 0002-Install-both-binaries-and-use-libdir.patch
8611106e 41URL: https://nodejs.org/
ab907bdb
JP
42BuildRequires: c-ares-devel >= 1.16.1
43BuildRequires: gcc >= 6:6.3
4398233e
JB
44%if %{with http_parser}
45BuildRequires: http-parser-devel >= 2.9.3
ab907bdb 46BuildRequires: llhttp-devel >= 2.1.3
c2768f1e 47%endif
ab907bdb
JP
48%{?with_system_brotli:BuildRequires: libbrotli-devel >= 1.0.9}
49BuildRequires: libicu-devel >= 67
8c0b403f 50BuildRequires: libstdc++-devel >= 6:4.8
ab907bdb 51%{?with_system_uv:BuildRequires: libuv-devel >= 1.38.1}
2c145010 52BuildRequires: nghttp2-devel >= 1.41.0
94f7bd52 53BuildRequires: openssl-devel >= 1.0.1
cd4c73aa 54BuildRequires: pkgconfig
ab907bdb
JP
55BuildRequires: python3
56BuildRequires: python3-modules
12a49d35 57BuildRequires: rpm >= 4.4.9-56
d047ca74 58BuildRequires: rpmbuild(macros) >= 1.752
536f9f5a 59BuildRequires: sed >= 4.0
ab77d514 60BuildRequires: zlib-devel >= 1.2.11
ab907bdb 61Requires: c-ares >= 1.16.1
ab77d514 62Requires: ca-certificates
4398233e 63%{?with_http_parser:Requires: http-parser >= 2.9.3}
ab907bdb
JP
64%{?with_system_brotli:Requires: libbrotli >= 1.0.9}
65%{?with_system_uv:Requires: libuv >= 1.38.1}
2c145010 66Requires: nghttp2-libs >= 1.41.0
ab77d514 67Requires: zlib >= 1.2.11
8d8e2928 68Provides: nodejs(engine) = %{version}
56d9fb33 69Provides: nodejs(module-version) = %{node_module_version}
5ef76b51 70Obsoletes: nodejs-waf
a7c6ab18 71ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64
210abff9 72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
dc60a63b 74%define sover %(echo %{version} | cut -d. -f2)
05e85ef1
ER
75# add macro, so adapter won't replace it back literal
76%define doc_ver %{version}
dc60a63b 77
210abff9 78%description
c3b531ba
ER
79Node.js is a platform built on Chrome's JavaScript runtime for easily
80building fast, scalable network applications. Node.js uses an
81event-driven, non-blocking I/O model that makes it lightweight and
82efficient, perfect for data-intensive real-time applications that run
83across distributed devices.
210abff9 84
9a1229ff
JB
85%description -l pl.UTF-8
86Node.js to platforma zbudowana w opacriu o silnik JavaScriptu
87przeglądarki Chrome, służąca do tworzenia szybkich, skalowalnych
88aplikacji sieciowych. Node.js wykorzystuje nieblokujący model
89wejścia/wyjścia sterowany zdarzeniami, dzięki czemu jest lekki i
90wydajny, dobrze nadający się do aplikacji przetwarzających duże
91ilości danych w czasie rzeczywistym, uruchamianych na rozproszonych
92urządzeniach.
93
210abff9 94%package devel
12a49d35 95Summary: Development headers for nodejs
9a1229ff 96Summary(pl.UTF-8): Pliki nagłówkowe nodejs
210abff9 97Group: Development/Libraries
a8f57a3f 98Requires: %{name} = %{version}-%{release}
d44c8857 99Requires: gcc
4398233e 100%{?with_http_parser:Requires: http-parser-devel >= 2.9.3}
d44c8857 101Requires: libstdc++-devel
ab907bdb 102%{?with_system_uv:Requires: libuv-devel >= 1.38.1}
96f19ba5 103Requires: openssl-devel
ab77d514 104Requires: zlib-devel >= 1.2.11
210abff9 105
106%description devel
12a49d35 107Development headers for nodejs.
210abff9 108
9a1229ff
JB
109%description devel -l pl.UTF-8
110Pliki nagłówkowe nodejs.
111
a6070ceb 112%package doc
9a1229ff
JB
113Summary: Documentation for Node.js engine
114Summary(pl.UTF-8): Dokumentacja silnika Node.js
a6070ceb 115Group: Documentation
05e85ef1 116URL: https://nodejs.org/dist/v%{doc_ver}/docs/api
d047ca74 117%{?noarchpackage}
a6070ceb
ER
118
119%description doc
120Node.js is a server-side JavaScript environment that uses an
121asynchronous event-driven model. Node's goal is to provide an easy way
122to build scalable network programs.
123
9a1229ff
JB
124This package contains the documentation for Node.js.
125
126%description doc -l pl.UTF-8
127Node.js to serwerowe środowisko JavaScriptu wykorzystujące
128asynchroniczny model sterowany zdarzeniami. Celem Node jest
129zapewnienie łatwego sposobu tworzenia skalowalnych programów
130sieciowych.
131
132Ten pakiet zawiera dokumentację Node.js.
a6070ceb 133
8c0b403f
JB
134%package -n systemtap-nodejs
135Summary: systemtap/dtrace probes for Node.js
136Summary(pl.UTF-8): Sondy systemtap/dtrace dla Node.js
137Group: Development/Tools
138Requires: %{name} = %{version}-%{release}
139Requires: systemtap-client
140
141%description -n systemtap-nodejs
142systemtap/dtrace probes for Node.js.
143
144%description -n systemtap-nodejs -l pl.UTF-8
145Sondy systemtap/dtrace dla Node.js.
146
210abff9 147%prep
148%setup -q -n node-v%{version}
d23cf2d6 149%if "%{_lib}" == "lib64"
a6070ceb
ER
150%patch3 -p1
151%else
152%patch2 -p1
153%endif
c2768f1e
AM
154%patch4 -p1
155%patch5 -p1
c4aa3bb0 156
ab907bdb 157grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python3},'
536f9f5a 158
a6b4cff8
JP
159%{?with_system_brotli:%{__rm} -r deps/brotli}
160%{__rm} -r deps/cares
161%if %{with http_parser}
162%{__rm} -r deps/http_parser
163%{__rm} -r deps/llhttp
164%endif
165%{__rm} -r deps/icu-small
166%{__rm} -r deps/nghttp2
9a1229ff 167%{__rm} -r deps/npm
9a1229ff
JB
168%{__rm} -r deps/openssl
169%{?with_system_uv:%{__rm} -r deps/uv}
170%{__rm} -r deps/zlib
e3e8568d 171
210abff9 172%build
c8ef6556 173ver=$(awk '/#define NODE_MODULE_VERSION/{print $3}' src/node_version.h)
145d5ed0 174test "$ver" = "%{node_module_version}"
56d9fb33 175
a11025a6
ER
176# CC used only to detect if CC is clang, not used for compiling
177CC="%{__cc}" \
178CXX="%{__cxx}" \
dc60a63b 179GYP_DEFINES="soname_version=%{sover}" \
a6070ceb 180./configure \
4398233e
JB
181 --prefix=%{_prefix} \
182 --libdir=%{_lib} \
e2a62df7 183 --openssl-use-def-ca-store \
c2768f1e 184 --shared \
ab77d514 185 %{?with_system_brotli:--shared-brotli} \
c2768f1e 186 --shared-cares \
4398233e 187 %{?with_http_parser:--shared-http-parser} \
8c0b403f 188 %{?with_system_uv:--shared-libuv} \
4398233e
JB
189 --shared-nghttp2 \
190 --shared-openssl \
8c0b403f 191 --shared-zlib \
4398233e 192 --with-intl=system-icu \
c1c359b8 193 --without-dtrace \
4398233e 194 --without-npm
210abff9 195
a11025a6
ER
196# add LFS defines from libuv (RHBZ#892601)
197# CXXFLAGS must be exported, as it is needed for make, not gyp
198CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
199LDFLAGS="%{rpmldflags}" \
9a1229ff
JB
200%{__make} -C out \
201 BUILDTYPE=Release \
202 V=1
210abff9 203
204%install
205rm -rf $RPM_BUILD_ROOT
9a1229ff 206
ab907bdb 207%{__python3} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
4174c079 208
c2768f1e 209ln -s libnode.so.%{node_module_version} $RPM_BUILD_ROOT%{_libdir}/libnode.so
a6070ceb 210
c7898157
ER
211echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
212
1ed21df5 213install -d $RPM_BUILD_ROOT%{_includedir}/node
4174c079 214cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
d5764a43
ER
215
216# install for node-gyp
217install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
218cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
219ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
1ed21df5 220
e85103e0 221# for compat of fedora derivered scripts (shebangs)
c3b531ba
ER
222ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
223
e85103e0
ER
224# globally installed node modules (noarch)
225install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
226
227# default searchpaths
228install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
229
a6070ceb
ER
230# create pkgconfig
231install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
232cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
233version=%{version}
c3b531ba 234prefix=%{_prefix}
87c4fdf2 235libdir=${prefix}/%{_lib}
a6070ceb
ER
236includedir=${prefix}/include/node
237
238Name: nodejs
239Description: Evented I/O for V8 JavaScript.
240Version: ${version}
241Cflags: -I${includedir}
242EOF
a752c1c0 243
a6070ceb 244# install documentation
6f7eebb5
ER
245install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
246cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
9a1229ff
JB
247%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.md
248%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
a6070ceb 249
210abff9 250%clean
251rm -rf $RPM_BUILD_ROOT
252
4174c079 253%post -p /sbin/ldconfig
7372d27d 254%postun -p /sbin/ldconfig
255
210abff9 256%files
257%defattr(644,root,root,755)
4398233e 258%doc AUTHORS CHANGELOG.md LICENSE README.md SECURITY.md
210abff9 259%attr(755,root,root) %{_bindir}/node
c3b531ba 260%attr(755,root,root) %{_bindir}/nodejs
c2768f1e 261%attr(755,root,root) %{_libdir}/libnode.so.%{node_module_version}
a600c300 262%if "%{_lib}" != "lib"
8791ea86 263%dir %{_libdir}/node
a600c300
ŁC
264%endif
265%dir %{_prefix}/lib/node
e85103e0 266%dir %{_prefix}/lib/node_modules
210abff9 267%{_mandir}/man1/node.1*
9a1229ff 268%{_mandir}/man1/nodejs.1*
210abff9 269
210abff9 270%files devel
271%defattr(644,root,root,755)
9a1229ff 272%attr(755,root,root) %{_libdir}/libnode.so
58494f0c 273%{_includedir}/node
a6070ceb 274%{_pkgconfigdir}/nodejs.pc
d5764a43 275%{_usrsrc}/%{name}
a6070ceb
ER
276
277%files doc
278%defattr(644,root,root,755)
279%doc %{_docdir}/%{name}-doc-%{version}
8c0b403f
JB
280
281%files -n systemtap-nodejs
282%defattr(644,root,root,755)
283%{_datadir}/systemtap/tapset/node.stp
This page took 0.141524 seconds and 4 git commands to generate.