]> git.pld-linux.org Git - packages/nocache.git/commitdiff
- initial auto/th/nocache-1.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 24 Oct 2018 07:06:23 +0000 (09:06 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 24 Oct 2018 07:06:23 +0000 (09:06 +0200)
nocache.spec [new file with mode: 0644]

diff --git a/nocache.spec b/nocache.spec
new file mode 100644 (file)
index 0000000..ee9b1fe
--- /dev/null
@@ -0,0 +1,55 @@
+Summary:       Minimize filesystem caching effects
+Name:          nocache
+Version:       1.0
+Release:       1
+License:       BSD
+Group:         Base
+Source0:       https://github.com/Feh/nocache/archive/v%{version}.tar.gz
+# Source0-md5: 29a177c7d990a75570645902c7ad9a4b
+URL:           https://github.com/Feh/nocache
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+The nocache tool tries to minimize the effect an application has on
+the Linux file system cache. This is done by intercepting the open and
+close system calls and calling posix_fadvise with the
+POSIX_FADV_DONTNEED parameter. Because the library remembers which
+pages (ie., 4K-blocks of the file) were already in file system cache
+when the file was opened, these will not be marked as "don't need",
+because other applications might need that, although they are not
+actively used (think: hot standby).
+
+Use case: backup processes that should not interfere with the present
+state of the cache.
+
+%prep
+%setup -q
+
+%build
+%{__make} \
+       CFLAGS+="%{rpmcppflags} %{rpmcflags}" \
+       LDFLAGS+="%{rpmldflags}"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       PREFIX= \
+       LIBDIR=%{_libdir} \
+       BINDIR=%{_bindir} \
+       MANDIR=%{_mandir}/man1
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README
+%attr(755,root,root) %{_bindir}/cachedel
+%attr(755,root,root) %{_bindir}/cachestats
+%attr(755,root,root) %{_bindir}/nocache
+%attr(755,root,root) %{_libdir}/nocache.so
+%{_mandir}/man1/cachedel.1*
+%{_mandir}/man1/cachestats.1*
+%{_mandir}/man1/nocache.1*
This page took 0.070384 seconds and 4 git commands to generate.