]> git.pld-linux.org Git - packages/netsurf.git/commitdiff
- updated to 3.6
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Mon, 21 Nov 2016 16:59:27 +0000 (17:59 +0100)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Mon, 21 Nov 2016 16:59:27 +0000 (17:59 +0100)
- some changes in patches

fixes.patch [new file with mode: 0644]
netsurf-link.patch
netsurf.spec
nsfb-ldflags.patch
optflags.patch

diff --git a/fixes.patch b/fixes.patch
new file mode 100644 (file)
index 0000000..3ec4f83
--- /dev/null
@@ -0,0 +1,22 @@
+--- netsurf-3.6/content/handlers/image/video.c.orig    2016-11-19 14:37:41.000000000 +0100
++++ netsurf-3.6/content/handlers/image/video.c 2016-11-21 17:24:58.168353942 +0100
+@@ -20,8 +20,10 @@
+ #include "content/content_factory.h"
+ #include "content/content_protected.h"
++#include "content/llcache.h"
+ #include "image/video.h"
++#include "utils/utils.h"
+ typedef struct nsvideo_content {
+       struct content base;
+@@ -67,7 +69,7 @@ static void nsvideo_source_event(GObject
+ }
+ static nserror nsvideo_create(const content_handler *handler,
+-              lwc_string *imime_type, const http_parameter *params,
++              lwc_string *imime_type, const struct http_parameter *params,
+               llcache_handle *llcache,
+               const char *fallback_charset, bool quirks,
+               struct content **c)
index 32d3927cfcf7d73d83037f53b8709d0e2d89380a..82a3567e39a2e22306f2288d17ef8f042a39748f 100644 (file)
@@ -1,55 +1,14 @@
---- netsurf-3.4/framebuffer/Makefile.target.orig       2016-02-27 16:48:23.588244698 +0100
-+++ netsurf-3.4/framebuffer/Makefile.target    2016-02-27 16:54:49.101350399 +0100
-@@ -4,13 +4,16 @@
- # define additional CFLAGS and LDFLAGS requirements for pkg-configed libs here
- NETSURF_FEATURE_RSVG_CFLAGS := -DWITH_RSVG
-+NETSURF_FEATURE_NSSVG_CFLAGS := -DWITH_NS_SVG
- NETSURF_FEATURE_ROSPRITE_CFLAGS := -DWITH_NSSPRITE
- NETSURF_FEATURE_HUBBUB_CFLAGS := -DWITH_HUBBUB
- NETSURF_FEATURE_PNG_CFLAGS := -DWITH_PNG
- NETSURF_FEATURE_BMP_CFLAGS := -DWITH_BMP
- NETSURF_FEATURE_GIF_CFLAGS := -DWITH_GIF
-+NETSURF_FEATURE_WEBP_CFLAGS := -DWITH_WEBP
- NETSURF_FEATURE_JS_CFLAGS := -DWITH_JS -DJS_HAS_FILE_OBJECT=0
- NETSURF_FEATURE_MOZJS_CFLAGS := -DWITH_MOZJS -DJS_HAS_FILE_OBJECT=0
-+NETSURF_FEATURE_VIDEO_CFLAGS := -DWITH_VIDEO
- CFLAGS += -Dnsframebuffer 
-@@ -63,8 +66,12 @@ $(eval $(call pkg_config_find_and_add_en
+--- netsurf-3.6/Makefile.orig  2016-11-19 14:37:41.000000000 +0100
++++ netsurf-3.6/Makefile       2016-11-21 17:41:51.001343161 +0100
+@@ -563,6 +563,11 @@ $(eval $(call pkg_config_find_and_add_en
+ $(eval $(call pkg_config_find_and_add_enabled,NSSVG,libsvgtiny,SVG))
  $(eval $(call pkg_config_find_and_add_enabled,ROSPRITE,librosprite,Sprite))
- $(eval $(call pkg_config_find_and_add_enabled,BMP,libnsbmp,BMP))
- $(eval $(call pkg_config_find_and_add_enabled,GIF,libnsgif,GIF))
--$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs185,JavaScript))
+ $(eval $(call pkg_config_find_and_add_enabled,NSPSL,libnspsl,PSL))
 +$(eval $(call pkg_config_find_and_add_enabled,RSVG,librsvg-2.0,SVG))
 +$(eval $(call pkg_config_find_and_add_enabled,NSSVG,libsvgtiny,SVG))
 +$(eval $(call feature_enabled,WEBP,-DWITH_WEBP,-lwebp,WebP (libwebp)))
-+$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs187,JavaScript))
- $(eval $(call pkg_config_find_and_add_enabled,JS,mozilla-js,JavaScript))
 +$(eval $(call pkg_config_find_and_add_enabled,VIDEO,gstreamer-0.10,Video))
++
  
- # ----------------------------------------------------------------------------
---- netsurf-3.4/monkey/Makefile.target.orig    2016-02-16 14:30:38.000000000 +0100
-+++ netsurf-3.4/monkey/Makefile.target 2016-02-27 16:55:46.374649928 +0100
-@@ -40,7 +40,7 @@ $(eval $(call pkg_config_find_and_add_en
- $(eval $(call pkg_config_find_and_add_enabled,BMP,libnsbmp,BMP))
- $(eval $(call pkg_config_find_and_add_enabled,GIF,libnsgif,GIF))
- $(eval $(call pkg_config_find_and_add_enabled,PNG,libpng,PNG  ))
--$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs185,JavaScript))
-+$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs187,JavaScript))
- $(eval $(call pkg_config_find_and_add_enabled,JS,mozilla-js,JavaScript))
- # ---------------------------------------------------------------------------
---- netsurf-3.4/riscos/Makefile.target.orig    2016-02-16 14:30:38.000000000 +0100
-+++ netsurf-3.4/riscos/Makefile.target 2016-02-27 16:56:44.121296264 +0100
-@@ -28,7 +28,7 @@ NETSURF_FEATURE_MOZJS_CFLAGS := -DWITH_M
- $(eval $(call pkg_config_find_and_add_enabled,BMP,libnsbmp,BMP))
- $(eval $(call pkg_config_find_and_add_enabled,GIF,libnsgif,GIF))
- $(eval $(call pkg_config_find_and_add_enabled,PNG,libpng,PNG  ))
--$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs185,JavaScript))
-+$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs187,JavaScript))
- $(eval $(call pkg_config_find_and_add_enabled,JS,mozilla-js,JavaScript))
+ # List of directories in which headers are searched for
+ INCLUDE_DIRS :=. include $(OBJROOT)
index 4161b3e4ea0aec34ec4fd0b45bb7bb87fa9da997..8211658662991a2877a73218e3a22cbb8057debc 100644 (file)
@@ -8,40 +8,42 @@
 Summary:       Light WWW browser with CSS support
 Summary(pl.UTF-8):     Lekka przeglądarka WWW z obsługą CSS
 Name:          netsurf
-Version:       3.5
+Version:       3.6
 Release:       1
 License:       GPL v2 with OpenSSL exception (code), MIT (artwork)
 Group:         Applications/Networking
 Source0:       http://download.netsurf-browser.org/netsurf/releases/source/%{name}-%{version}-src.tar.gz
-# Source0-md5: eab97038417ce412b21abc2df0b98845
+# Source0-md5: 105e1ee258cf283b945489dd36e7effa
 Source1:       %{name}.desktop
 Patch0:                nsfb-ldflags.patch
 Patch1:                %{name}-link.patch
 Patch3:                optflags.patch
+Patch4:                fixes.patch
 URL:           http://netsurf-browser.org/
 BuildRequires: curl-devel
 BuildRequires: freetype-devel >= 2
 %{?with_gstreamer:BuildRequires:       gstreamer0.10-devel >= 0.10}
 BuildRequires: gtk+2-devel >= 2.0
-BuildRequires: libCSS-devel >= 0.6.0
-BuildRequires: libdom-devel >= 0.3.0
+BuildRequires: libCSS-devel >= 0.6.1
+BuildRequires: libdom-devel >= 0.3.1
 %{?with_pdf:BuildRequires:     libharu-devel}
 BuildRequires: libhubbub-devel >= 0.3.3
 BuildRequires: libjpeg-devel
-BuildRequires: libnsbmp-devel >= 0.1.3
-BuildRequires: libnsfb-devel >= 0.1.4
-BuildRequires: libnsgif-devel >= 0.1.3
-BuildRequires: libnsutils-devel >= 0.0.2
+BuildRequires: libnsbmp-devel >= 0.1.4
+BuildRequires: libnsfb-devel >= 0.1.5
+BuildRequires: libnsgif-devel >= 0.1.4
+BuildRequires: libnspsl-devel >= 0.1.0
+BuildRequires: libnsutils-devel >= 0.0.3
 BuildRequires: libparserutils-devel >= 0.2.3
 BuildRequires: libpng-devel
 BuildRequires: librsvg-devel
-BuildRequires: libsvgtiny-devel >= 0.1.4
+BuildRequires: libsvgtiny-devel >= 0.1.5
 BuildRequires: libutf8proc-devel >= 1.3.1
-BuildRequires: libwapcaplet-devel >= 0.3.0
+BuildRequires: libwapcaplet-devel >= 0.4.0
 %{?with_webp:BuildRequires:    libwebp-devel}
 BuildRequires: openssl-devel
 BuildRequires: netsurf-buildsystem >= 1.5
-BuildRequires: nsgenbind >= 0.3
+BuildRequires: nsgenbind >= 0.4
 BuildRequires: perl-HTML-Parser
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
@@ -131,6 +133,7 @@ Ten pakiet zawiera wersję SDL.
 %patch0 -p1
 %patch1 -p1
 %patch3 -p1
+%patch4 -p1
 
 cat << EOF > Makefile.config
 NETSURF_FB_FONTLIB := freetype
@@ -144,10 +147,10 @@ EOF
 
 %if %{with gstreamer}
 # GStreamer 0.10 uses now deprecated glib mutex APIs
-%{__sed} -i -e '/-DG_DISABLE_DEPRECATED/d' gtk/Makefile.target
+%{__sed} -i -e '/-DG_DISABLE_DEPRECATED/d' frontends/gtk/Makefile
 %endif
 # gdk-pixbuf 2.31 deprecates GdkPixdata
-%{__sed} -i -e '/-DGDK_PIXBUF_DISABLE_DEPRECATED/d' gtk/Makefile.target
+%{__sed} -i -e '/-DGDK_PIXBUF_DISABLE_DEPRECATED/d' frontends/gtk/Makefile
 
 %build
 export CC="%{__cc}"
@@ -162,14 +165,14 @@ export LDFLAGS="%{rpmldflags}"
 
 # make -j1 or it won't find libwapcaplet/libwapcaplet.h
 
-%{__make} -j1 \
+%{__make} \
        OPTFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable -D_GNU_SOURCE" \
        OPTLDFLAGS="%{rpmldflags}" \
        PREFIX=%{_prefix} \
        Q='' \
        TARGET=gtk
 
-%{__make} -j1 \
+%{__make} \
        OPTFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable -D_GNU_SOURCE" \
        OPTLDFLAGS="%{rpmldflags}" \
        PREFIX=%{_prefix} \
index 9b0aefd533118d3629fcef0e1ea8c1d766b7b57c..e0a9efe24e57fbcd37e3c2e3f25bd519b32bb9e7 100644 (file)
@@ -1,5 +1,5 @@
---- netsurf-3.4/framebuffer/Makefile.target.orig       2016-02-16 14:30:38.000000000 +0100
-+++ netsurf-3.4/framebuffer/Makefile.target    2016-02-27 16:44:59.385032043 +0100
+--- netsurf-3.6/frontends/framebuffer/Makefile.orig    2016-02-16 14:30:38.000000000 +0100
++++ netsurf-3.6/frontends/framebuffer/Makefile 2016-02-27 16:44:59.385032043 +0100
 @@ -39,9 +39,7 @@ CFLAGS += -std=c99 -g -Dsmall \
  LDFLAGS += -lm
  
index 83536de419a32d6184653679340bfde4f8224d14..708d8b54494cecdd68e568abcd512e48362a9434 100644 (file)
@@ -1,17 +1,11 @@
---- netsurf-3.3/Makefile.orig  2015-03-16 12:53:40.421670394 +0100
-+++ netsurf-3.3/Makefile       2015-03-16 12:55:55.214273473 +0100
-@@ -500,11 +500,11 @@
- $(eval $(call pkg_config_find_and_add,libnsutils,nsutils))
+--- netsurf-3.6/Makefile.orig  2016-11-19 14:37:41.000000000 +0100
++++ netsurf-3.6/Makefile       2016-11-21 14:50:30.664966026 +0100
+@@ -530,7 +530,7 @@
+ $(eval $(call pkg_config_find_and_add,libutf8proc,utf8proc))
  
  # Common libraries without pkg-config support
 -LDFLAGS += -lz
 +LDFLAGS += -lz $(OPTLDFLAGS)
  
- # add top level and build directory to include search path
--CFLAGS += -I. -I$(OBJROOT)
--CXXFLAGS += -I. -I$(OBJROOT)
-+CFLAGS += -I. -I$(OBJROOT) $(OPTFLAGS)
-+CXXFLAGS += -I. -I$(OBJROOT) $(OPTFLAGS)
+ # Optional libraries with pkgconfig
  
- # export the user agent format
- CFLAGS += -DNETSURF_UA_FORMAT_STRING=\"$(NETSURF_UA_FORMAT_STRING)\"
This page took 0.19796 seconds and 4 git commands to generate.