]> git.pld-linux.org Git - packages/netcdf-cxx4.git/commitdiff
- updated to 4.3.1 auto/th/netcdf-cxx4-4.3.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 28 Dec 2019 08:43:52 +0000 (09:43 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 28 Dec 2019 08:44:07 +0000 (09:44 +0100)
- added link patch (fix libnetcdf_c++4 linking)
- drop .la file

netcdf-cxx4-link.patch [new file with mode: 0644]
netcdf-cxx4.spec

diff --git a/netcdf-cxx4-link.patch b/netcdf-cxx4-link.patch
new file mode 100644 (file)
index 0000000..a452025
--- /dev/null
@@ -0,0 +1,17 @@
+--- netcdf-cxx4-4.3.1/cxx4/Makefile.am.orig    2019-09-11 21:16:15.000000000 +0200
++++ netcdf-cxx4-4.3.1/cxx4/Makefile.am 2019-12-28 09:27:36.041713209 +0100
+@@ -4,11 +4,13 @@
+ # This file builds the new C++-4 interface.
+ # Point pre-preprocessor to netcdf-4 directory (libsrc4).
+-LDADD = $(top_builddir)/cxx4/libnetcdf_c++4.la  -lnetcdf
++LDADD = $(top_builddir)/cxx4/libnetcdf_c++4.la
+ # This is our output library.
+ lib_LTLIBRARIES = libnetcdf_c++4.la
++libnetcdf_c__4_la_LIBADD = -lnetcdf
++
+ # For rules updating the version info, see
+ # http://www.gnu.org/s/libtool/manual/html_node/Updating-version-info.html
+ libnetcdf_c__4_la_LDFLAGS = -version-info 2:0:1 -no-undefined
index 5477ded8535f4fabb0515d165560ae556e4f84c9..6f14fded98899a2c051b41af36cbd19995bab333 100644 (file)
@@ -1,25 +1,26 @@
 #
 # Conditional build:
-%bcond_without tests           # don't perform "make check"
-                               # (note: tests need endoder-enabled szip)
+%bcond_without static_libs     # static library
+%bcond_without tests           # unit tests (encoder-enabled szip required)
 #
 Summary:       NetCDF C++ library
 Summary(pl.UTF-8):     Biblioteka NetCDF dla języka C++
 Name:          netcdf-cxx4
-Version:       4.3.0
-Release:       3
+Version:       4.3.1
+Release:       1
 License:       BSD-like
 Group:         Libraries
 Source0:       ftp://ftp.unidata.ucar.edu/pub/netcdf/%{name}-%{version}.tar.gz
-# Source0-md5: b4a9783b2b0b98d4e6f36cc19c8d08ef
+# Source0-md5: 19cccc27a24fc9095ddbe84bf90ebc83
+Patch0:                %{name}-link.patch
 URL:           http://www.unidata.ucar.edu/packages/netcdf/
 BuildRequires: autoconf >= 2.66
 BuildRequires: automake
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:2.2
-BuildRequires: netcdf-devel >= 4.2
+BuildRequires: netcdf-devel >= 4.6.0
 BuildRequires: texinfo
-Requires:      netcdf >= 4.2
+Requires:      netcdf >= 4.6.0
 Obsoletes:     netcdf-c++
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -49,7 +50,7 @@ Summary(pl.UTF-8):    Pliki nagłówkowe interfejsu netCDF dla języka C++
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      libstdc++-devel
-Requires:      netcdf-devel >= 4.2
+Requires:      netcdf-devel >= 4.6.0
 Obsoletes:     netcdf-c++-devel
 
 %description devel
@@ -73,6 +74,7 @@ Statyczna wersja biblioteki netCDF dla języka C++.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -80,7 +82,8 @@ Statyczna wersja biblioteki netCDF dla języka C++.
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
+%configure \
+       %{!?with_static_libs:--disable-static}
 
 %{__make}
 
@@ -94,6 +97,11 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# bzip2 plugin packaged in base netcdf
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libh5bzip2.*
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libnetcdf_c++4.la
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -102,7 +110,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYRIGHT
+%doc COPYRIGHT README.md RELEASE_NOTES.md
 %attr(755,root,root) %{_libdir}/libnetcdf_c++4.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libnetcdf_c++4.so.1
 
@@ -110,7 +118,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/ncxx4-config
 %attr(755,root,root) %{_libdir}/libnetcdf_c++4.so
-%{_libdir}/libnetcdf_c++4.la
 %{_includedir}/ncAtt.h
 %{_includedir}/ncByte.h
 %{_includedir}/ncChar.h
@@ -140,6 +147,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/netcdf
 %{_pkgconfigdir}/netcdf-cxx4.pc
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libnetcdf_c++4.a
+%endif
This page took 0.073749 seconds and 4 git commands to generate.