]> git.pld-linux.org Git - packages/net-snmp.git/blobdiff - net-snmp-acfix.patch
Bug 1314610 - snmpd complaining twice "Cannot statfs net:[********]#***: No such...
[packages/net-snmp.git] / net-snmp-acfix.patch
index 63fa75db9f1658b0ef4785abef4344f5c1bd2e04..6ab2d96ec8abaf1d07134b622780ed4422307976 100644 (file)
@@ -1,7 +1,13 @@
-diff -ur net-snmp-5.3.org/configure.in net-snmp-5.3/configure.in
---- net-snmp-5.3.org/configure.in      2005-12-28 18:20:56.000000000 +0100
-+++ net-snmp-5.3/configure.in  2006-01-09 01:07:39.031490000 +0100
-@@ -1704,11 +1704,11 @@
+--- net-snmp-5.4.1/configure.ac        2007-09-08 16:13:11.531748373 +0200
++++ net-snmp-5.4.1-ac/configure.ac     2007-11-14 20:58:16.361317122 +0200
+@@ -1726,16 +1726,18 @@
+ rebuilt_new_with_security=
+ already_checked_krb5=no
++KRB5_LIBS=
++AC_SUBST(KRB5_LIBS)
+ for sec in $new_with_security
+ do
    if test "x$sec" = "xksm" -a "xyes" = "x$already_checked_krb5"; then
      continue
    fi
@@ -14,8 +20,29 @@ diff -ur net-snmp-5.3.org/configure.in net-snmp-5.3/configure.in
      if test no = $trykrb5; then
        AC_MSG_NOTICE([configured not to use krb5. disabling ksm])
        continue
-@@ -1763,15 +1763,13 @@
+@@ -1745,7 +1747,7 @@
  
+     if test no != $krb5_config; then
+       CPPFLAGS="$CPPFLAGS `$krb5_config --cflags`"
+-      LIBS="$LIBS `$krb5_config --libs`"
++      KRB5_LIBS="`$krb5_config --libs`"
+     elif test $krb5path != no; then
+       AC_ADD_SEARCH_PATH($krb5path)
+     else
+@@ -1782,29 +1784,35 @@
+     if test $ac_cv_heimdal = yes; then
+       AC_DEFINE(NETSNMP_USE_KERBEROS_HEIMDAL)
+       if test no = $krb5_config; then
+-      LIBS="$LIBS -lkrb5 -lasn1 -lcom_err -lroken"
++      KRB5_LIBS="-lkrb5 -lasn1 -lcom_err -lroken"
+       fi
+     elif test no = $krb5_config; then
+-      LIBS="$LIBS -lkrb5 -lcom_err"
++      KRB5_LIBS="-lkrb5 -lcom_err"
+     fi
++    old_LIBS="$LIBS"
++    LIBS="$LIBS $KRB5_LIBS"
      AC_MSG_CHECKING([to see which crypto API we need to use])
      AC_CHECK_FUNC(krb5_c_encrypt,[
 -    AC_CACHE_VAL(ac_cv_NETSNMP_USE_KERBEROS_MIT,
@@ -28,63 +55,24 @@ diff -ur net-snmp-5.3.org/configure.in net-snmp-5.3/configure.in
 +      )
  
 -    if test yes = $ac_cv_NETSNMP_USE_KERBEROS_MIT; then
-+    AC_DEFINE(NETSNMP_USE_KERBEROS_MIT)
+-      AC_MSG_RESULT(new MIT crypto API)
 +    if test yes = $ac_cv_MIT_NEW_CRYPTo; then
-       AC_MSG_RESULT(new MIT crypto API)
--      AC_DEFINE(NETSNMP_USE_KERBEROS_MIT)
+       AC_DEFINE(NETSNMP_USE_KERBEROS_MIT)
++      AC_MSG_RESULT(new MIT crypto API)
        if test no = $krb5_config; then
-       LIBS="$LIBS -lk5crypto"
+-      LIBS="$LIBS -lk5crypto"
++      KRB5_LIBS="$LIBS -lk5crypto"
++      else
++      CFLAGS="$CFLAGS `$krb5_config --cflags`"
++      KRB5_LIBS="$LIBS `$krb5_config --libs`"
        fi
-@@ -2661,23 +2661,6 @@
-     LIBS="${LIBS} -ladm"
-     AGENTLIBS="${AGENTLIBS} -ladm"))
--case $target_os in
--    aix*) # AIX perfstat library, needed for CPU/memory statistics
--        AC_CHECK_HEADERS(libperfstat.h,
--            AC_CHECK_LIB(perfstat, perfstat_cpu_total, AC_DEFINE(HAVE_PERFSTAT)
--            AGENTLIBS="${AGENTLIBS} -lperfstat"), AC_MSG_ERROR([
--
--*** To monitor CPU/memory values in AIX you need to install
--*** libperfstat which can be found in bos.perf
--]))
--        ;;
--    hpux*) # HP-UX agent needs open_mib
--        AC_CHECK_LIB(nm, open_mib, AC_DEFINE(HAVE_LIBNM)
--            AGENTLIBS="${AGENTLIBS} -lnm")
--        ;;
--    *)
--        ;;
--esac
- # WIN32
- # (mingw32 must link winsock explicitly)
- AC_CHECK_HEADERS(winsock.h,[
-@@ -2880,7 +2863,7 @@
- AC_MSG_RESULT([$ac_cv_type_ssize_t])
- if test $ac_cv_type_ssize_t = yes; then
--  AC_DEFINE(HAVE_SSIZE_T)
-+  AC_DEFINE(HAVE_SSIZE_T,,[have ssize_t])
- fi
- # Check ps args
---- net-snmp-5.4/agent/mibgroup/Makefile.in.orig       2006-09-13 19:00:27.000000000 +0200
-+++ net-snmp-5.4/agent/mibgroup/Makefile.in    2006-12-02 11:51:38.369040000 +0100
-@@ -22,9 +22,13 @@
- .c.o:
-       $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
--OBJS  = @mib_module_list_o@
--LOBJS = @mib_module_list_lo@
--SRCS  = @mib_module_list_c@
-+@mib_module_list_o@
-+@mib_module_list_lo@
-+@mib_module_list_c@
-+
-+OBJS  = $(mib_module_list_o)
-+LOBJS = $(mib_module_list_lo)
-+SRCS  = $(mib_module_list_c)
- all: standardall $(LOBJS)
+     else
+-      AC_MSG_RESULT(old MIT crypto API)])
++      AC_MSG_RESULT(old MIT crypto API)
+     fi
++    ])
++    LNETSNMPLIBS="$LNETSNMPLIBS $KRB5_LIBS"
++    LIBS="$old_LIBS"
+   fi
+ done
  
-
This page took 0.034954 seconds and 4 git commands to generate.