]> git.pld-linux.org Git - packages/neovim.git/commitdiff
use lua51 instead of luajit, to build also for x32
authorElan Ruusamäe <glen@delfi.ee>
Sun, 18 Sep 2016 07:32:46 +0000 (10:32 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 18 Sep 2016 07:32:46 +0000 (10:32 +0300)
lua does not seem to be used run time, but it's used to generate some
source code and run tests.

neovim.spec

index 5598c451c3499f1fd107ccb8e4714b8852523ba0..bf5817f5cdf11ea08a6365c1d6a5d4af8c34ff53 100644 (file)
@@ -28,9 +28,10 @@ BuildRequires:       pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.596
 BuildRequires: unibilium-devel
 %if %{with lua}
+BuildRequires: lua-bitop >= 1.0.2
 BuildRequires: lua-lpeg
 BuildRequires: lua-mpack >= 1.0.2
-BuildRequires: luajit
+BuildRequires: lua51
 %endif
 Requires:      desktop-file-utils
 Requires:      gtk-update-icon-cache
@@ -77,7 +78,7 @@ cd .deps
 
 cd ../build
 %cmake \
-       -DLUA_PRG=/usr/bin/luajit \
+       -DLUA_PRG=/usr/bin/lua5.1 \
        -DENABLE_JEMALLOC=ON \
        -DLUAJIT_USE_BUNDLED=OFF \
        -DLIBUV_USE_BUNDLED=OFF \
This page took 0.306148 seconds and 4 git commands to generate.