]> git.pld-linux.org Git - packages/neovim.git/commitdiff
Rename bcond to prefer_lua, fix for x32 auto/th/neovim-0.3.8-1
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 6 Nov 2020 14:27:23 +0000 (16:27 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Fri, 6 Nov 2020 14:29:00 +0000 (16:29 +0200)
luajit not available on x32

neovim.spec

index 66c7b5a510f675dee35a50b8c558e961dc51be3c..7b24fd3c9526e240956f86a7b6bff53da2f36e0c 100644 (file)
@@ -4,7 +4,11 @@
 #   https://github.com/neovim/neovim/issues/5576
 #
 # Conditional build:
-%bcond_without lua             # Prefer Lua over LuaJit
+%bcond_with    prefer_lua              # Prefer Lua over LuaJit
+
+%ifarch x32
+%define        with_prefer_lua 1
+%endif
 
 Summary:       Vim-fork focused on extensibility and agility
 Name:          neovim
@@ -35,7 +39,7 @@ BuildRequires:        msgpack-devel >= 1.1.0
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.596
 BuildRequires: unibilium-devel
-%if %{with lua}
+%if %{with prefer_lua}
 BuildRequires: lua51
 BuildRequires: lua51-devel
 %else
@@ -89,6 +93,7 @@ cd .deps
 
 cd ../build
 %cmake \
+       -DPREFER_LUA=%{!?with_prefer_lua:OFF}%{?with_prefer_lua:ON} \
        -DLUA_PRG=/usr/bin/lua5.1 \
        -DENABLE_JEMALLOC=ON \
        -DLUAJIT_USE_BUNDLED=OFF \
This page took 0.317439 seconds and 4 git commands to generate.