]> git.pld-linux.org Git - packages/neovim.git/commitdiff
new, version 0.1.5
authorElan Ruusamäe <glen@delfi.ee>
Tue, 13 Sep 2016 20:29:53 +0000 (23:29 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 13 Sep 2016 20:31:29 +0000 (23:31 +0300)
based on opensuse package
http://fr2.rpmfind.net/linux/opensuse/source/tumbleweed/repo/oss/suse/src/neovim-0.1.5-1.2.src.rpm

neovim.desktop [new file with mode: 0644]
neovim.spec [new file with mode: 0644]
neovim.svg [new file with mode: 0644]

diff --git a/neovim.desktop b/neovim.desktop
new file mode 100644 (file)
index 0000000..be105d6
--- /dev/null
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Neovim
+Categories=ConsoleOnly;Application;Utility;TextEditor;
+GenericName=Text Editor
+MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
+Exec=xdg-terminal "nvim %f"
+Icon=neovim
+Type=Application
+Terminal=false
diff --git a/neovim.spec b/neovim.spec
new file mode 100644 (file)
index 0000000..d9e27f6
--- /dev/null
@@ -0,0 +1,91 @@
+# TODO
+# - -rt subpackage? -lang subpackage?
+Summary:       Vim-fork focused on extensibility and agility
+Name:          neovim
+Version:       0.1.5
+Release:       0.1
+License:       Apache v2.0
+Group:         Applications/Editors/Vim
+Source0:       https://github.com/neovim/neovim/archive/v%{version}/%{name}-%{version}.tar.gz
+URL:           https://neovim.io/
+Source1:       %{name}.desktop
+Source2:       %{name}.svg
+BuildRequires: cmake
+BuildRequires: fdupes
+BuildRequires: hicolor-icon-theme
+BuildRequires: jemalloc-devel
+BuildRequires: libmsgpack-devel >= 1.2.0
+BuildRequires: libmsgpackc-devel >= 1.2.0
+BuildRequires: libstdc++-devel
+BuildRequires: libuv-devel
+BuildRequires: lua51-BitOp
+BuildRequires: lua51-LPeg
+BuildRequires: lua51-mpack
+BuildRequires: luajit-devel
+BuildRequires: pkgconfig
+BuildRequires: pkgconfig(termkey)
+BuildRequires: pkgconfig(unibilium)
+BuildRequires: pkgconfig(vterm)
+BuildRequires: update-desktop-files
+Suggests:      python-neovim
+Suggests:      python3-neovim
+Suggests:      xsel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Neovim is a refactor - and sometimes redactor - in the tradition of
+Vim, which itself derives from Stevie. It is not a rewrite, but a
+continuation and extension of Vim. Many rewrites, clones, emulators
+and imitators exist; some are very clever, but none are Vim. Neovim
+strives to be a superset of Vim, notwithstanding some intentionally
+removed misfeatures; excepting those few and carefully-considered
+excisions, Neovim is Vim. It is built for users who want the good
+parts of Vim, without compromise, and more.
+
+%prep
+%setup -q
+
+# Remove __DATE__ and __TIME__.
+BUILD_TIME=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{H}:%{M}')
+BUILD_DATE=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{b} %{d} %{Y}')
+sed -i "s/__TIME__/\"$BUILD_TIME\"/" $(grep -rl '__TIME__')
+sed -i "s/__DATE__/\"$BUILD_DATE\"/" $(grep -rl '__DATE__')
+
+%build
+%cmake \
+       -DLUA_PRG=%{_bindir}/lua \
+       -DUSE_BUNDLED=OFF               \
+       -DLUAJIT_USE_BUNDLED=OFF \
+       -DENABLE_JEMALLOC=ON
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/neovim.desktop
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/neovim.svg
+
+%find_lang nvim
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%update_desktop_database
+%icon_theme_cache_post
+
+%postun
+%update_desktop_database
+%icon_theme_cache_postun
+
+%files -f nvim.lang
+%defattr(644,root,root,755)
+%doc BACKERS.md CONTRIBUTING.md LICENSE README.md
+%attr(755,root,root) %{_bindir}/nvim
+%{_datadir}/nvim
+%{_desktopdir}/%{name}.desktop
+%{_iconsdir}/hicolor/*/apps/%{name}.svg
+%{_mandir}/man1/nvim.1*
diff --git a/neovim.svg b/neovim.svg
new file mode 100644 (file)
index 0000000..46c5eb8
--- /dev/null
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<svg width="602px" height="734px" viewBox="0 0 602 734" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:sketch="http://www.bohemiancoding.com/sketch/ns">
+    <title>neovim-mark@2x</title>
+    <description>Created with Sketch (http://www.bohemiancoding.com/sketch)</description>
+    <defs>
+        <linearGradient x1="50%" y1="0%" x2="50%" y2="100%" id="linearGradient-1">
+            <stop stop-color="#16B0ED" stop-opacity="0.800235524" offset="0%"></stop>
+            <stop stop-color="#0F59B2" stop-opacity="0.83700023" offset="100%"></stop>
+        </linearGradient>
+        <linearGradient x1="50%" y1="0%" x2="50%" y2="100%" id="linearGradient-2">
+            <stop stop-color="#7DB643" offset="0%"></stop>
+            <stop stop-color="#367533" offset="100%"></stop>
+        </linearGradient>
+        <linearGradient x1="50%" y1="0%" x2="50%" y2="100%" id="linearGradient-3">
+            <stop stop-color="#88C649" stop-opacity="0.8" offset="0%"></stop>
+            <stop stop-color="#439240" stop-opacity="0.84" offset="100%"></stop>
+        </linearGradient>
+    </defs>
+    <g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd" sketch:type="MSPage">
+        <g id="mark-copy" sketch:type="MSLayerGroup" transform="translate(2.000000, 3.000000)">
+            <path d="M0,155.5704 L155,-1 L154.999997,727 L0,572.237919 L0,155.5704 Z" id="Left---green" fill="url(#linearGradient-1)" sketch:type="MSShapeGroup"></path>
+            <path d="M443.060403,156.982405 L600,-1 L596.818792,727 L442,572.219941 L443.060403,156.982405 Z" id="Right---blue" fill="url(#linearGradient-2)" sketch:type="MSShapeGroup" transform="translate(521.000000, 363.500000) scale(-1, 1) translate(-521.000000, -363.500000) "></path>
+            <path d="M154.986294,0 L558,615.189696 L445.224605,728 L42,114.172017 L154.986294,0 Z" id="Cross---blue" fill="url(#linearGradient-3)" sketch:type="MSShapeGroup"></path>
+            <path d="M155,283.83232 L154.786754,308 L31,124.710606 L42.4619486,113 L155,283.83232 Z" id="Shadow" fill-opacity="0.13" fill="#000000" sketch:type="MSShapeGroup"></path>
+        </g>
+    </g>
+</svg>
\ No newline at end of file
This page took 0.104462 seconds and 4 git commands to generate.