]> git.pld-linux.org Git - packages/neovim.git/blobdiff - neovim.spec
Requires unibilium 2.0.0
[packages/neovim.git] / neovim.spec
index d31c4f8100d0878b66c65126e45cd9767e28535e..4a1c6e117f9f0c2f41fa49b10f34794472556227 100644 (file)
@@ -1,36 +1,46 @@
 # TODO
 # - -rt subpackage? -lang subpackage?
+# - <meta>-xxx keybindings (alt+something) incompatibility
+#   https://github.com/neovim/neovim/issues/5576
 #
 # Conditional build:
-%bcond_with    lua             # LUA
+%bcond_with    prefer_lua              # Prefer Lua over LuaJit
+
+%ifarch x32
+%define        with_prefer_lua 1
+%endif
 
 Summary:       Vim-fork focused on extensibility and agility
 Name:          neovim
-Version:       0.1.5
-Release:       0.2
+Version:       0.4.4
+Release:       1
 License:       Apache v2.0
 Group:         Applications/Editors/Vim
+# Source0Download: https://github.com/neovim/neovim/releases
 Source0:       https://github.com/neovim/neovim/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 526e6a9194d6d65fd5e7faa4b506e7c8
 URL:           https://neovim.io/
-Source1:       %{name}.desktop
 Source2:       %{name}.svg
+Patch0:                desktop.patch
 BuildRequires: cmake >= 2.8.7
-BuildRequires: fdupes
 BuildRequires: gcc >= 6:4.4
-BuildRequires: hicolor-icon-theme
+BuildRequires: gettext-devel
 BuildRequires: jemalloc-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtermkey-devel
 BuildRequires: libuv-devel
-BuildRequires: msgpack-devel >= 1.2.0
+BuildRequires: libvterm-devel < 0.1.3
+BuildRequires: lua-bitop >= 1.0.2
+BuildRequires: lua-lpeg
+BuildRequires: lua-mpack >= 1.0.2
+BuildRequires: msgpack-devel >= 1.1.0
 BuildRequires: pkgconfig
-#BuildRequires:        pkgconfig(vterm)
 BuildRequires: rpmbuild(macros) >= 1.596
-BuildRequires: unibilium-devel
-%if %{with lua}
-BuildRequires: lua51-BitOp
-BuildRequires: lua51-LPeg
-BuildRequires: lua51-mpack
+BuildRequires: unibilium-devel >= 2.0.0
+%if %{with prefer_lua}
+BuildRequires: lua51
+BuildRequires: lua51-devel
+%else
 BuildRequires: luajit-devel
 %endif
 Requires:      desktop-file-utils
@@ -38,10 +48,14 @@ Requires:   gtk-update-icon-cache
 Requires:      hicolor-icon-theme
 Suggests:      python-neovim
 Suggests:      python3-neovim
+Suggests:      ruby-neovim
 Suggests:      xsel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix /usr/local
+# gcc 4.0 and better turn on _FORTIFY_SOURCE=2 automatically. This currently
+# does not work with Neovim due to some uses of dynamically-sized structures.
+# See https://github.com/neovim/neovim/issues/223 for details.
+%define                filterout_c     -Wp,-D_FORTIFY_SOURCE=2
 
 %description
 Neovim is a refactor - and sometimes redactor - in the tradition of
@@ -55,45 +69,58 @@ parts of Vim, without compromise, and more.
 
 %prep
 %setup -q
-
-%if 0
-# Remove __DATE__ and __TIME__.
-BUILD_TIME=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{H}:%{M}')
-BUILD_DATE=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{b} %{d} %{Y}')
-sed -i "s/__TIME__/\"$BUILD_TIME\"/" $(grep -rl '__TIME__')
-sed -i "s/__DATE__/\"$BUILD_DATE\"/" $(grep -rl '__DATE__')
-%endif
+%patch0 -p1
 
 %build
-%if 0
+install -d .deps build
+cd .deps
 %cmake \
-       -DLUA_PRG=%{_bindir}/lua \
-       -DUSE_BUNDLED=OFF               \
-       -DLUAJIT_USE_BUNDLED=OFF \
-       -DENABLE_JEMALLOC=ON \
-\
-       -DUSE_BUNDLED_JEMALLOC=ON \
-       -DUSE_BUNDLED_UNIBILIUM=ON \
-       -DUSE_BUNDLED_LIBTERMKEY=ON \
-       -DUSE_BUNDLED_LIBVTERM=ON \
-       -DUSE_BUNDLED_LIBUV=ON \
-       -DUSE_BUNDLED_MSGPACK=ON \
-       -DUSE_BUNDLED_LUAJIT=ON \
-       -DUSE_BUNDLED_LUAROCKS=ON \
-       -DUSE_BUNDLED_LUV=ON \
+       -DUSE_BUNDLED=OFF \
+       -DUSE_BUNDLED_JEMALLOC=OFF \
+       -DUSE_BUNDLED_UNIBILIUM=OFF \
+       -DUSE_BUNDLED_LIBTERMKEY=OFF \
+       -DUSE_BUNDLED_LIBVTERM=OFF \
+       -DUSE_BUNDLED_LIBUV=OFF \
+       -DUSE_BUNDLED_MSGPACK=OFF \
+       -DUSE_BUNDLED_LUAJIT=OFF \
+       -DUSE_BUNDLED_LUAROCKS=OFF \
+       -DUSE_BUNDLED_LUV=OFF \
+       ../third-party
+%{__make}
 
-%endif
+cd ../build
+%cmake \
+       -DPREFER_LUA=%{!?with_prefer_lua:OFF}%{?with_prefer_lua:ON} \
+       -DLUA_PRG=/usr/bin/lua5.1 \
+       -DENABLE_JEMALLOC=ON \
+       -DLUAJIT_USE_BUNDLED=OFF \
+       -DLIBUV_USE_BUNDLED=OFF \
+       -DMSGPACK_USE_BUNDLED=OFF \
+       -DUNIBILIUM_USE_BUNDLED=OFF \
+       -DLIBTERMKEY_USE_BUNDLED=OFF \
+       -DLIBVTERM_USE_BUNDLED=OFF \
+       -DJEMALLOC_USE_BUNDLED=OFF \
+       ..
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_iconsdir}/hicolor/scalable/apps}
-cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/neovim.desktop
-cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/neovim.svg
+install -d $RPM_BUILD_ROOT{/etc/xdg/nvim,%{_iconsdir}/hicolor/scalable/apps}
+touch $RPM_BUILD_ROOT/etc/xdg/nvim/init.vim
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/nvim.svg
+
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs.cp1250
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.euc-jp
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ko.UTF-8
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/no
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/pl.UTF-8
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sk.cp1250
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.UTF-8
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_TW.UTF-8
 
 %find_lang nvim
 
@@ -103,6 +130,23 @@ rm -rf $RPM_BUILD_ROOT
 %post
 %update_desktop_database
 %update_icon_cache hicolor
+%banner -e -o %{name} << 'EOF'
+
+The Neovim executable is called 'nvim'. To use your existing Vim
+configuration:
+    ln -s ~/.vim ~/.config/nvim
+    ln -s ~/.vimrc ~/.config/nvim/init.vim
+See ':help nvim' for more information on Neovim.
+
+If you want support for Python plugins such as YouCompleteMe, you need
+to install a Python module in addition to Neovim itself.
+
+See ':help provider-python' or this page for more information:
+    http://neovim.io/doc/user/provider.html
+
+If you have any questions, have a look at:
+    https://github.com/neovim/neovim/wiki/FAQ.
+EOF
 
 %postun
 %update_desktop_database
@@ -111,8 +155,11 @@ rm -rf $RPM_BUILD_ROOT
 %files -f nvim.lang
 %defattr(644,root,root,755)
 %doc BACKERS.md CONTRIBUTING.md LICENSE README.md
+%dir /etc/xdg/nvim
+%config(noreplace) %verify(not md5 mtime size) /etc/xdg/nvim/init.vim
 %attr(755,root,root) %{_bindir}/nvim
-%{_datadir}/nvim
-%{_desktopdir}/%{name}.desktop
-%{_iconsdir}/hicolor/*/apps/%{name}.svg
 %{_mandir}/man1/nvim.1*
+%{_datadir}/nvim
+%{_desktopdir}/nvim.desktop
+%{_pixmapsdir}/nvim.png
+%{_iconsdir}/hicolor/*/apps/nvim.svg
This page took 0.119093 seconds and 4 git commands to generate.