]> git.pld-linux.org Git - packages/neovim.git/blame - neovim.spec
cleanup/update BR
[packages/neovim.git] / neovim.spec
CommitLineData
0a9d0af1
ER
1# TODO
2# - -rt subpackage? -lang subpackage?
ccead671
ER
3#
4# Conditional build:
48fc3284 5%bcond_without lua # LUA
ccead671 6
0a9d0af1
ER
7Summary: Vim-fork focused on extensibility and agility
8Name: neovim
9Version: 0.1.5
8c8b1ac4 10Release: 0.6
0a9d0af1
ER
11License: Apache v2.0
12Group: Applications/Editors/Vim
13Source0: https://github.com/neovim/neovim/archive/v%{version}/%{name}-%{version}.tar.gz
8c8b1ac4 14# Source0-md5: 27598e4ee52b6c02af2b5353fe99b6e4
0a9d0af1
ER
15URL: https://neovim.io/
16Source1: %{name}.desktop
17Source2: %{name}.svg
ccead671 18BuildRequires: cmake >= 2.8.7
ccead671 19BuildRequires: gcc >= 6:4.4
8c8b1ac4 20BuildRequires: gettext-devel
0a9d0af1 21BuildRequires: jemalloc-devel
0a9d0af1 22BuildRequires: libstdc++-devel
ccead671 23BuildRequires: libtermkey-devel
0a9d0af1 24BuildRequires: libuv-devel
7d69921c
ER
25BuildRequires: libvterm-devel
26BuildRequires: msgpack-devel >= 1.1.0
ccead671 27BuildRequires: pkgconfig
ccead671
ER
28BuildRequires: rpmbuild(macros) >= 1.596
29BuildRequires: unibilium-devel
30%if %{with lua}
7d69921c
ER
31BuildRequires: lua-lpeg
32BuildRequires: lua-mpack >= 1.0.2
8c8b1ac4 33BuildRequires: luajit
ccead671
ER
34%endif
35Requires: desktop-file-utils
36Requires: gtk-update-icon-cache
37Requires: hicolor-icon-theme
0a9d0af1
ER
38Suggests: python-neovim
39Suggests: python3-neovim
40Suggests: xsel
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
a2169a2f
ER
43# gcc 4.0 and better turn on _FORTIFY_SOURCE=2 automatically. This currently
44# does not work with Neovim due to some uses of dynamically-sized structures.
45# See https://github.com/neovim/neovim/issues/223 for details.
46%define filterout_c -Wp,-D_FORTIFY_SOURCE=2
47
0a9d0af1
ER
48%description
49Neovim is a refactor - and sometimes redactor - in the tradition of
50Vim, which itself derives from Stevie. It is not a rewrite, but a
51continuation and extension of Vim. Many rewrites, clones, emulators
52and imitators exist; some are very clever, but none are Vim. Neovim
53strives to be a superset of Vim, notwithstanding some intentionally
54removed misfeatures; excepting those few and carefully-considered
55excisions, Neovim is Vim. It is built for users who want the good
56parts of Vim, without compromise, and more.
57
58%prep
59%setup -q
60
0a9d0af1 61%build
7d69921c
ER
62install -d .deps build
63cd .deps
0a9d0af1 64%cmake \
7d69921c
ER
65 -DUSE_BUNDLED=OFF \
66 -DUSE_BUNDLED_JEMALLOC=OFF \
67 -DUSE_BUNDLED_UNIBILIUM=OFF \
68 -DUSE_BUNDLED_LIBTERMKEY=OFF \
69 -DUSE_BUNDLED_LIBVTERM=OFF \
70 -DUSE_BUNDLED_LIBUV=OFF \
71 -DUSE_BUNDLED_MSGPACK=OFF \
48fc3284
ER
72 -DUSE_BUNDLED_LUAJIT=OFF \
73 -DUSE_BUNDLED_LUAROCKS=OFF \
74 -DUSE_BUNDLED_LUV=OFF \
7d69921c
ER
75 ../third-party
76%{__make}
ccead671 77
7d69921c
ER
78cd ../build
79%cmake \
80 -DLUA_PRG=/usr/bin/luajit \
81 -DENABLE_JEMALLOC=ON \
82 -DLUAJIT_USE_BUNDLED=OFF \
83 -DLIBUV_USE_BUNDLED=OFF \
84 -DMSGPACK_USE_BUNDLED=OFF \
85 -DUNIBILIUM_USE_BUNDLED=OFF \
86 -DLIBTERMKEY_USE_BUNDLED=OFF \
87 -DLIBVTERM_USE_BUNDLED=OFF \
88 -DJEMALLOC_USE_BUNDLED=OFF \
89 ..
0a9d0af1
ER
90
91%{__make}
92
93%install
94rm -rf $RPM_BUILD_ROOT
7d69921c 95%{__make} -C build install \
0a9d0af1
ER
96 DESTDIR=$RPM_BUILD_ROOT
97
ccead671 98install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_iconsdir}/hicolor/scalable/apps}
0a9d0af1 99cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/neovim.desktop
ccead671 100cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/neovim.svg
0a9d0af1 101
46240029
ER
102%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs.cp1250
103%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.euc-jp
104%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.sjis
105%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ko.UTF-8
106%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/no
107%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/pl.UTF-8
108%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/pl.cp1250
109%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ru.cp1251
110%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sk.cp1250
111%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/uk.cp1251
112%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.UTF-8
113%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.cp936
114%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_TW.UTF-8
115
0a9d0af1
ER
116%find_lang nvim
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post
122%update_desktop_database
ccead671 123%update_icon_cache hicolor
b086dcf2
ER
124%banner -e -o %{name} << 'EOF'
125
126The Neovim executable is called 'nvim'. To use your existing Vim
127configuration:
128 ln -s ~/.vim ~/.config/nvim
129 ln -s ~/.vimrc ~/.config/nvim/init.vim
130See ':help nvim' for more information on Neovim.
131
132If you want support for Python plugins such as YouCompleteMe, you need
133to install a Python module in addition to Neovim itself.
134
135See ':help provider-python' or this page for more information:
136 http://neovim.io/doc/user/provider.html
137
138If you have any questions, have a look at:
139 https://github.com/neovim/neovim/wiki/FAQ.
140EOF
0a9d0af1
ER
141
142%postun
143%update_desktop_database
ccead671 144%update_icon_cache hicolor
0a9d0af1
ER
145
146%files -f nvim.lang
147%defattr(644,root,root,755)
148%doc BACKERS.md CONTRIBUTING.md LICENSE README.md
149%attr(755,root,root) %{_bindir}/nvim
150%{_datadir}/nvim
151%{_desktopdir}/%{name}.desktop
152%{_iconsdir}/hicolor/*/apps/%{name}.svg
153%{_mandir}/man1/nvim.1*
This page took 0.781542 seconds and 4 git commands to generate.