]> git.pld-linux.org Git - packages/neovim.git/blame - neovim.spec
up to 0.1.6
[packages/neovim.git] / neovim.spec
CommitLineData
0a9d0af1
ER
1# TODO
2# - -rt subpackage? -lang subpackage?
9277ef3a 3# - <meta>-xxx keybindings do not work (alt+something)
ccead671
ER
4#
5# Conditional build:
48fc3284 6%bcond_without lua # LUA
ccead671 7
0a9d0af1
ER
8Summary: Vim-fork focused on extensibility and agility
9Name: neovim
4350fc35
ER
10Version: 0.1.6
11Release: 1
0a9d0af1
ER
12License: Apache v2.0
13Group: Applications/Editors/Vim
14Source0: https://github.com/neovim/neovim/archive/v%{version}/%{name}-%{version}.tar.gz
4350fc35 15# Source0-md5: 307978937c7fc2ebd796b345d99ed7cd
0a9d0af1
ER
16URL: https://neovim.io/
17Source1: %{name}.desktop
18Source2: %{name}.svg
ccead671 19BuildRequires: cmake >= 2.8.7
ccead671 20BuildRequires: gcc >= 6:4.4
8c8b1ac4 21BuildRequires: gettext-devel
0a9d0af1 22BuildRequires: jemalloc-devel
0a9d0af1 23BuildRequires: libstdc++-devel
ccead671 24BuildRequires: libtermkey-devel
0a9d0af1 25BuildRequires: libuv-devel
7d69921c
ER
26BuildRequires: libvterm-devel
27BuildRequires: msgpack-devel >= 1.1.0
ccead671 28BuildRequires: pkgconfig
ccead671
ER
29BuildRequires: rpmbuild(macros) >= 1.596
30BuildRequires: unibilium-devel
31%if %{with lua}
2d2f06ed 32BuildRequires: lua-bitop >= 1.0.2
7d69921c
ER
33BuildRequires: lua-lpeg
34BuildRequires: lua-mpack >= 1.0.2
2d2f06ed 35BuildRequires: lua51
ccead671
ER
36%endif
37Requires: desktop-file-utils
38Requires: gtk-update-icon-cache
39Requires: hicolor-icon-theme
0a9d0af1
ER
40Suggests: python-neovim
41Suggests: python3-neovim
3f05c041 42Suggests: ruby-neovim
0a9d0af1
ER
43Suggests: xsel
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
a2169a2f
ER
46# gcc 4.0 and better turn on _FORTIFY_SOURCE=2 automatically. This currently
47# does not work with Neovim due to some uses of dynamically-sized structures.
48# See https://github.com/neovim/neovim/issues/223 for details.
49%define filterout_c -Wp,-D_FORTIFY_SOURCE=2
50
0a9d0af1
ER
51%description
52Neovim is a refactor - and sometimes redactor - in the tradition of
53Vim, which itself derives from Stevie. It is not a rewrite, but a
54continuation and extension of Vim. Many rewrites, clones, emulators
55and imitators exist; some are very clever, but none are Vim. Neovim
56strives to be a superset of Vim, notwithstanding some intentionally
57removed misfeatures; excepting those few and carefully-considered
58excisions, Neovim is Vim. It is built for users who want the good
59parts of Vim, without compromise, and more.
60
61%prep
62%setup -q
63
0a9d0af1 64%build
7d69921c
ER
65install -d .deps build
66cd .deps
0a9d0af1 67%cmake \
7d69921c
ER
68 -DUSE_BUNDLED=OFF \
69 -DUSE_BUNDLED_JEMALLOC=OFF \
70 -DUSE_BUNDLED_UNIBILIUM=OFF \
71 -DUSE_BUNDLED_LIBTERMKEY=OFF \
72 -DUSE_BUNDLED_LIBVTERM=OFF \
73 -DUSE_BUNDLED_LIBUV=OFF \
74 -DUSE_BUNDLED_MSGPACK=OFF \
48fc3284
ER
75 -DUSE_BUNDLED_LUAJIT=OFF \
76 -DUSE_BUNDLED_LUAROCKS=OFF \
77 -DUSE_BUNDLED_LUV=OFF \
7d69921c
ER
78 ../third-party
79%{__make}
ccead671 80
7d69921c
ER
81cd ../build
82%cmake \
2d2f06ed 83 -DLUA_PRG=/usr/bin/lua5.1 \
7d69921c
ER
84 -DENABLE_JEMALLOC=ON \
85 -DLUAJIT_USE_BUNDLED=OFF \
86 -DLIBUV_USE_BUNDLED=OFF \
87 -DMSGPACK_USE_BUNDLED=OFF \
88 -DUNIBILIUM_USE_BUNDLED=OFF \
89 -DLIBTERMKEY_USE_BUNDLED=OFF \
90 -DLIBVTERM_USE_BUNDLED=OFF \
91 -DJEMALLOC_USE_BUNDLED=OFF \
92 ..
0a9d0af1
ER
93
94%{__make}
95
96%install
97rm -rf $RPM_BUILD_ROOT
7d69921c 98%{__make} -C build install \
0a9d0af1
ER
99 DESTDIR=$RPM_BUILD_ROOT
100
3fb7b0d6
ER
101install -d $RPM_BUILD_ROOT{/etc/xdg/nvim,%{_desktopdir},%{_iconsdir}/hicolor/scalable/apps}
102touch $RPM_BUILD_ROOT/etc/xdg/nvim/init.vim
0a9d0af1 103cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/neovim.desktop
ccead671 104cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/neovim.svg
0a9d0af1 105
46240029
ER
106%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs.cp1250
107%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.euc-jp
108%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.sjis
109%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ko.UTF-8
110%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/no
111%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/pl.UTF-8
112%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/pl.cp1250
113%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ru.cp1251
114%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sk.cp1250
115%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/uk.cp1251
116%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.UTF-8
117%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.cp936
118%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_TW.UTF-8
119
0a9d0af1
ER
120%find_lang nvim
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post
126%update_desktop_database
ccead671 127%update_icon_cache hicolor
b086dcf2
ER
128%banner -e -o %{name} << 'EOF'
129
130The Neovim executable is called 'nvim'. To use your existing Vim
131configuration:
132 ln -s ~/.vim ~/.config/nvim
133 ln -s ~/.vimrc ~/.config/nvim/init.vim
134See ':help nvim' for more information on Neovim.
135
136If you want support for Python plugins such as YouCompleteMe, you need
137to install a Python module in addition to Neovim itself.
138
139See ':help provider-python' or this page for more information:
140 http://neovim.io/doc/user/provider.html
141
142If you have any questions, have a look at:
143 https://github.com/neovim/neovim/wiki/FAQ.
144EOF
0a9d0af1
ER
145
146%postun
147%update_desktop_database
ccead671 148%update_icon_cache hicolor
0a9d0af1
ER
149
150%files -f nvim.lang
151%defattr(644,root,root,755)
152%doc BACKERS.md CONTRIBUTING.md LICENSE README.md
3fb7b0d6
ER
153%dir /etc/xdg/nvim
154%config(noreplace) %verify(not md5 mtime size) /etc/xdg/nvim/init.vim
0a9d0af1
ER
155%attr(755,root,root) %{_bindir}/nvim
156%{_datadir}/nvim
157%{_desktopdir}/%{name}.desktop
158%{_iconsdir}/hicolor/*/apps/%{name}.svg
159%{_mandir}/man1/nvim.1*
This page took 0.130511 seconds and 4 git commands to generate.