]> git.pld-linux.org Git - packages/ncurses.git/blobdiff - ncurses.spec
- updated to 6.2-20200822
[packages/ncurses.git] / ncurses.spec
index 34955adb663c2401d279156b38ec65af2615d107..d351a2f41f5cdf972913412aba1b0a1cb30527a5 100644 (file)
@@ -1,45 +1,39 @@
 #
 # Conditional build:
-%bcond_with    ada             # do not build Ada95 bindings
-%bcond_without cxx             # do not build C++ ncurses bindings and demo programs
-#                              # (this is neccessary to build ncurses linked with uClibc).
-%bcond_without gpm             # build without (dynamically loadable) libgpm support
+%bcond_without ada             # Ada95 bindings
+%bcond_without cxx             # C++ ncurses bindings and demo programs [disable when using uClibc]
+%bcond_without gpm             # (dynamically loadable) libgpm support
 
 %ifarch sparc64 x32
 %undefine with_ada
 %endif
 
+%define        basever 6.2
+%define        patchlevel      20200822
 Summary:       curses terminal control library
 Summary(de.UTF-8):     curses-Terminal-Control-Library
 Summary(es.UTF-8):     Biblioteca de control de terminal curses
 Summary(fr.UTF-8):     La bibliothéque de contrôle de terminal curses
-Summary(pl.UTF-8):     Biblioteki do kontrolowania terminala
+Summary(pl.UTF-8):     Biblioteki do sterowania terminalem
 Summary(pt_BR.UTF-8):  Biblioteca de controle de terminal curses
 Summary(ru.UTF-8):     ncurses - новая библиотека управления терминалами
 Summary(tr.UTF-8):     Terminal kontrol kitaplığı
 Summary(uk.UTF-8):     ncurses - нова бібліотека керування терміналами
 Name:          ncurses
-Version:       6.0
-Release:       0.1
+Version:       %{basever}.%{patchlevel}
+Release:       1
 License:       distributable
 Group:         Libraries
-Source0:       ftp://dickey.his.com/ncurses/%{name}-%{version}.tar.gz
-# Source0-md5: ee13d052e1ead260d7c28071f46eefb1
+Source0:       ftp://ftp.invisible-island.net/ncurses/current/%{name}-%{basever}-%{patchlevel}.tgz
+# Source0-md5: 54d3f5aaeafb3b7755db7399d753ce06
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 3b05ee835dc20c306e9af2a9d3fbf1f1
-Patch100:      %{name}-screen_hpa_fix.patch
-Patch101:      %{name}-xterm_hpa_fix.patch
-Patch102:      %{name}-meta.patch
-Patch103:      %{name}-xterm-home-end.patch
-Patch104:      %{name}-mouse_trafo-warning.patch
-Patch105:      %{name}-gnome-terminal.patch
-# disable rain demo; triggers gcc bug: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=14998
-Patch107:      %{name}-no-rain-demo.patch
-Patch108:      %{name}-fix-nonunicode-breakage.patch
+Patch100:      %{name}-xterm-home-end.patch
+Patch101:      %{name}-gnome-terminal.patch
 URL:           http://dickey.his.com/ncurses/ncurses.html
 BuildRequires: automake
 %if %{with ada}
-BuildRequires: gcc-ada
+BuildRequires: gcc-ada >= 6:4.1.0
 # gnat bug: https://bugzilla.redhat.com/show_bug.cgi?id=613407
 # gcc patch: https://bugzilla.redhat.com/attachment.cgi?id=435931
 # seems worker around when using gcc 4.6.2? --q
@@ -49,8 +43,7 @@ BuildRequires:        gcc-ada
 %{?with_cxx:BuildRequires:     libstdc++-devel}
 %{?with_ada:BuildRequires:     m4}
 BuildRequires: pkgconfig
-BuildRequires: sharutils
-Obsoletes:     libncurses5
+Conflicts:     slang-libs < 1:2.3.1a-2
 Conflicts:     terminfo < 5.4-0.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -133,7 +126,7 @@ Summary(pt_BR.UTF-8):       Base de dados terminfo para terminais adicionais (menos us
 Group:         Applications/Terminal
 Requires:      %{name} = %{version}-%{release}
 Obsoletes:     ncurses-extraterms
-%if "%{_rpmversion}" >= "5"
+%if "%{_rpmversion}" >= "4.6"
 BuildArch:     noarch
 %endif
 
@@ -307,15 +300,9 @@ Ten pakiet zawiera pliki nagłówkowe i biblioteki potrzebne do
 tworzenia aplikacji używających ncurses w języku Ada95.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{basever}-%{patchlevel}
 %patch100 -p1
 %patch101 -p1
-%patch102 -p1
-%patch103 -p1
-%patch104 -p1
-%patch105 -p1
-%patch107 -p1
-%patch108 -p1
 
 %build
 unset TERMINFO || :
@@ -324,37 +311,36 @@ gcc_version=%{cc_version}
 CFLAGS="%{rpmcflags} -DPURE_TERMINFO -D_FILE_OFFSET_BITS=64"
 cp -f /usr/share/automake/config.sub .
 
-for t in narrowc wideclowcolor widec; do
+for t in narrowc widec; do
 install -d obj-$t
 cd obj-$t
 ../%configure \
        --with-install-prefix=$RPM_BUILD_ROOT \
-       --with-normal \
-       --with-shared \
+       --with-pkg-config-libdir=%{_pkgconfigdir} \
+       --with-ada-include=%{_libdir}/gcc/$gcc_target/$gcc_version/adainclude/ \
+       --with-ada-objects=%{_libdir}/gcc/$gcc_target/$gcc_version/adalib/ \
        --with%{!?with_ada:out}-ada \
        --with%{!?with_cxx:out}-cxx \
        --with%{!?with_cxx:out}-cxx-binding \
        --with%{!?debug:out}-debug \
        --with%{!?with_gpm:out}-gpm \
-       --without-profile \
        --with-largefile \
+       --with-manpage-aliases \
+       --with-manpage-format=normal \
+       --without-manpage-symlinks \
+       --with-normal \
        --with-ospeed=unsigned \
+       --without-profile \
+       --with-shared \
+       --with-chtype='long' \
+       --with-mmask-t='long' \
        --disable-lp64 \
+       --enable-colorfgbg \
        --enable-hard-tabs \
-       --enable-xmc-glitch \
        --enable-pc-files \
-       --with-pkg-config-libdir=%{_pkgconfigdir} \
-       --enable-colorfgbg \
-       --with-chtype='long' \
-       --with-mmask-t='long' \
-       --with-manpage-aliases \
-       --with-manpage-format=normal \
-       --with-ada-include=%{_libdir}/gcc/$gcc_target/$gcc_version/adainclude/ \
-       --with-ada-objects=%{_libdir}/gcc/$gcc_target/$gcc_version/adalib/ \
+       --enable-xmc-glitch \
        `[ "$t" = "narrowc" ] && echo --includedir=%{_includedir}/ncursesn` \
-       `[ "$t" = "wideclowcolor" ] && echo --enable-widec --disable-ext-colors --includedir=%{_includedir}/ncurseswlc` \
        `[ "$t" = "widec" ] && echo --enable-widec --enable-ext-colors --enable-ext-mouse --includedir=%{_includedir}/ncursesw` \
-       --without-manpage-symlinks
 
 %{__make} -j1
 
@@ -382,14 +368,16 @@ done
 ln -sf ../l/linux $RPM_BUILD_ROOT%{_datadir}/terminfo/c/console
 
 # used by /{bin,sbin} programs
-mv -f $RPM_BUILD_ROOT%{_libdir}/libncursesw.so.6* $RPM_BUILD_ROOT/%{_lib}
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/libncursesw.so.6* $RPM_BUILD_ROOT/%{_lib}
 # adjust symlinks for libncursesw.so.6 in /%{_lib}
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libncursesw.so.6.*) $RPM_BUILD_ROOT%{_libdir}/libncursesw.so
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libncursesw.so.6.*) $RPM_BUILD_ROOT%{_libdir}/libcursesw.so
+ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libncursesw.so.6.*) $RPM_BUILD_ROOT%{_libdir}/libtinfow.so
 
 # force ncursesw also for legacy -lncurses/-lcurses/-ltinfo linking
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libncursesw.so.6.*) $RPM_BUILD_ROOT%{_libdir}/libcurses.so
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libncursesw.so.6.*) $RPM_BUILD_ROOT%{_libdir}/libncurses.so
+ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libncursesw.so.6.*) $RPM_BUILD_ROOT%{_libdir}/libtinfo.so
 # force wide ext libraries
 ln -sf $(basename $RPM_BUILD_ROOT%{_libdir}/libformw.so.6.*) $RPM_BUILD_ROOT%{_libdir}/libform.so
 ln -sf $(basename $RPM_BUILD_ROOT%{_libdir}/libmenuw.so.6.*) $RPM_BUILD_ROOT%{_libdir}/libmenu.so
@@ -417,6 +405,9 @@ rm -rf $RPM_BUILD_ROOT
 %post  ext -p /sbin/ldconfig
 %postun        ext -p /sbin/ldconfig
 
+%triggerpostun -- %{name} < 6.0.20151128-2
+/sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc ANNOUNCE README
@@ -439,8 +430,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %dir %{_datadir}/terminfo
 %{_datadir}/terminfo/E
-%dir %{_datadir}/terminfo/[cdgklprsvx]
+%dir %{_datadir}/terminfo/[acdgklprsvx]
 
+%{_datadir}/terminfo/a/ansi
 %{_datadir}/terminfo/c/cygwin*
 %{_datadir}/terminfo/d/dumb
 %{_datadir}/terminfo/g/gnome*
@@ -467,8 +459,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/toe.1m*
 %{_mandir}/man1/tput.1*
 %{_mandir}/man1/tset.1*
+%{_mandir}/man5/scr_dump.5*
 %{_mandir}/man5/term.5*
 %{_mandir}/man5/terminfo.5*
+%{_mandir}/man5/user_caps.5*
 %{_mandir}/man7/term.7*
 %lang(fi) %{_mandir}/fi/man1/*
 %lang(fr) %{_mandir}/fr/man1/*
@@ -481,6 +475,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_datadir}/terminfo/[1-9ALMNPQXa-ce-jm-rt-uwz]
 %{_datadir}/terminfo/[dklsvx]/*
+%exclude %{_datadir}/terminfo/a/ansi
 %exclude %{_datadir}/terminfo/c/cygwin*
 %exclude %{_datadir}/terminfo/d/dumb
 %exclude %{_datadir}/terminfo/g/gnome*
@@ -504,8 +499,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ncursesw6-config
 %attr(755,root,root) %{_libdir}/libcurses.so
 %attr(755,root,root) %{_libdir}/libncurses.so
+%attr(755,root,root) %{_libdir}/libtinfo.so
 %attr(755,root,root) %{_libdir}/libcursesw.so
 %attr(755,root,root) %{_libdir}/libncursesw.so
+%attr(755,root,root) %{_libdir}/libtinfow.so
 %{_includedir}/curses.h
 %{_includedir}/eti.h
 %{_includedir}/nc_tparm.h
@@ -557,6 +554,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/_nc_*.3x*
 %{_mandir}/man3/_trace*.3x*
 %{_mandir}/man3/acs_map.3x*
+%{_mandir}/man3/alloc_pair.3x*
+%{_mandir}/man3/alloc_pair_sp.3x*
 %{_mandir}/man3/add*.3x*
 %{_mandir}/man3/assume_default_colors*.3x*
 %{_mandir}/man3/attr*.3x*
@@ -579,6 +578,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/curs_*.3x*
 %{_mandir}/man3/curscr.3x*
 %{_mandir}/man3/curses_version.3x*
+%{_mandir}/man3/curses_trace.3x*
 %{_mandir}/man3/def_*.3x*
 %{_mandir}/man3/default_colors.3x*
 %{_mandir}/man3/define_key*.3x*
@@ -594,7 +594,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/echo*.3x*
 %{_mandir}/man3/endwin*.3x*
 %{_mandir}/man3/erase*.3x*
+%{_mandir}/man3/exit_curses.3x*
+%{_mandir}/man3/exit_terminfo.3x*
 %{_mandir}/man3/filter*.3x*
+%{_mandir}/man3/find_pair.3x*
+%{_mandir}/man3/find_pair_sp.3x*
 %{_mandir}/man3/flash*.3x*
 %{_mandir}/man3/flushinp*.3x*
 %{_mandir}/man3/get*.3x*
@@ -622,6 +626,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/leaveok.3x*
 %{_mandir}/man3/legacy_coding.3x*
 %{_mandir}/man3/longname.3x*
+%{_mandir}/man3/longname_sp.3x*
 %{_mandir}/man3/mcprint*.3x*
 %{_mandir}/man3/meta.3x*
 %{_mandir}/man3/mouse*.3x*
@@ -778,13 +783,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/menuw.pc
 %{_pkgconfigdir}/panel.pc
 %{_pkgconfigdir}/panelw.pc
-%{_mandir}/man3/TYPE_ALNUM.3x*
-%{_mandir}/man3/TYPE_ALPHA.3x*
-%{_mandir}/man3/TYPE_ENUM.3x*
-%{_mandir}/man3/TYPE_INTEGER.3x*
-%{_mandir}/man3/TYPE_IPV4.3x*
-%{_mandir}/man3/TYPE_NUMERIC.3x*
-%{_mandir}/man3/TYPE_REGEXP.3x*
 %{_mandir}/man3/bottom_panel.3x*
 %{_mandir}/man3/current_field.3x*
 %{_mandir}/man3/current_item.3x*
@@ -793,10 +791,20 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/del_panel.3x*
 %{_mandir}/man3/dup_field.3x*
 %{_mandir}/man3/dynamic_field_info.3x*
+%{_mandir}/man3/extended_color_content.3x*
+%{_mandir}/man3/extended_color_content_sp.3x*
+%{_mandir}/man3/extended_pair_content.3x*
+%{_mandir}/man3/extended_pair_content_sp.3x*
+%{_mandir}/man3/extended_slk_color.3x*
+%{_mandir}/man3/extended_slk_color_sp.3x*
 %{_mandir}/man3/field_*.3x*
 %{_mandir}/man3/form*.3x*
 %{_mandir}/man3/free_*.3x*
 %{_mandir}/man3/hide_panel.3x*
+%{_mandir}/man3/init_extended_color.3x*
+%{_mandir}/man3/init_extended_color_sp.3x*
+%{_mandir}/man3/init_extended_pair.3x*
+%{_mandir}/man3/init_extended_pair_sp.3x*
 %{_mandir}/man3/item_*.3x*
 %{_mandir}/man3/link_field*.3x*
 %{_mandir}/man3/menu*.3x*
@@ -808,6 +816,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/new_item.3x*
 %{_mandir}/man3/new_menu*.3x*
 %{_mandir}/man3/new_page.3x*
+%{_mandir}/man3/new_pair.3x*
 %{_mandir}/man3/new_panel.3x*
 %{_mandir}/man3/panel*.3x*
 %{_mandir}/man3/pos_form_cursor.3x*
@@ -830,6 +839,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/show_panel.3x*
 %{_mandir}/man3/top_panel.3x*
 %{_mandir}/man3/top_row.3x*
+%{_mandir}/man3/TYPE_ALNUM.3x*
+%{_mandir}/man3/TYPE_ALPHA.3x*
+%{_mandir}/man3/TYPE_ENUM.3x*
+%{_mandir}/man3/TYPE_INTEGER.3x*
+%{_mandir}/man3/TYPE_IPV4.3x*
+%{_mandir}/man3/TYPE_NUMERIC.3x*
+%{_mandir}/man3/TYPE_REGEXP.3x*
+%{_mandir}/man3/unfocus_current_field.3x*
 %{_mandir}/man3/unpost_form.3x*
 %{_mandir}/man3/unpost_menu.3x*
 %{_mandir}/man3/update_panels*.3x*
@@ -881,11 +898,12 @@ rm -rf $RPM_BUILD_ROOT
 %files ada-devel
 %defattr(644,root,root,755)
 %doc Ada95/{README,TODO}
-%attr(755,root,root) %{_bindir}/adacurses-config
-%attr(755,root,root) %{_bindir}/adacursesw-config
+%attr(755,root,root) %{_bindir}/adacurses6-config
+%attr(755,root,root) %{_bindir}/adacursesw6-config
 %{_libdir}/gcc/*/*/adainclude/*.ad[bs]
 %{_libdir}/gcc/*/*/adalib/libAdaCurses.a
-%{_mandir}/man1/adacurses-config.1*
-%{_mandir}/man1/adacurses.1*
-%{_mandir}/man1/adacursesw-config.1*
+%{_mandir}/man1/adacurses6.1*
+%{_mandir}/man1/adacurses6-config.1*
+%{_mandir}/man1/adacursesw6.1*
+%{_mandir}/man1/adacursesw6-config.1*
 %endif
This page took 0.035632 seconds and 4 git commands to generate.