]> git.pld-linux.org Git - packages/ncmpcpp.git/commitdiff
upstream patch to fix build with gcc 10
authorJan Palus <atler@pld-linux.org>
Mon, 29 Jun 2020 23:04:19 +0000 (01:04 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 29 Jun 2020 23:04:19 +0000 (01:04 +0200)
gcc10.patch [new file with mode: 0644]
ncmpcpp.spec

diff --git a/gcc10.patch b/gcc10.patch
new file mode 100644 (file)
index 0000000..466abce
--- /dev/null
@@ -0,0 +1,26 @@
+From 399e0f47008b487df3505476c959b4f42d8bc1b1 Mon Sep 17 00:00:00 2001
+From: Louis Sautier <sautier.louis@gmail.com>
+Date: Sat, 9 May 2020 14:31:52 +0200
+Subject: [PATCH] Fix build with GCC 10 by adding missing include
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes the following error:
+./mpdpp.h:438:15: error: ‘runtime_error’ is not a member of ‘std’
+---
+ src/mpdpp.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/mpdpp.h b/src/mpdpp.h
+index a2bb79eb..abd3666c 100644
+--- a/src/mpdpp.h
++++ b/src/mpdpp.h
+@@ -25,6 +25,7 @@
+ #include <exception>
+ #include <random>
+ #include <set>
++#include <stdexcept>
+ #include <vector>
+ #include <mpd/client.h>
index 975048933f9812aaebabad0bee34cb38ebcf15e1..176c207395edc2833d61fa42630b66e7fdeb1d60 100644 (file)
@@ -7,6 +7,7 @@ License:        GPL v2
 Group:         Applications
 Source0:       http://ncmpcpp.rybczak.net/stable/%{name}-%{version}.tar.bz2
 # Source0-md5: af161ee347d92e7077c42ea8ad4865ec
+Patch0:                gcc10.patch
 URL:           http://ncmpcpp.rybczak.net
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -38,6 +39,7 @@ plików lokalnych oraz inne drobne udogodnienia.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
This page took 0.132083 seconds and 4 git commands to generate.