]> git.pld-linux.org Git - packages/nagios.git/blobdiff - nagios.spec
package /etc/nagios/nrpe.d to nagios-common
[packages/nagios.git] / nagios.spec
index 3e5ab721f418b6f7370473b09f836927500cf638..02314bf698552122e73cca6cd69a0cfd7eea1fe4 100644 (file)
@@ -12,17 +12,18 @@ Summary:    Open Source host, service and network monitoring program
 Summary(pl.UTF-8):     Program do monitorowania serwerów/usług/sieci
 Summary(pt_BR.UTF-8):  Programa para monitoração de máquinas e serviços
 Name:          nagios
-Version:       4.0.1
+Version:       4.3.3
 Release:       2
 License:       GPL v2+
 Group:         Networking
-Source0:       http://downloads.sourceforge.net/nagios/nagios-4.x/%{name}-%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: c41fcd11703a98d61fe54ea99697b8d3
+Source0:       https://assets.nagios.com/downloads/nagioscore/releases/%{name}-%{version}.tar.gz
+# Source0-md5: b733310c87b8eb6ce0f7a5768829c94c
 Source1:       %{name}-apache.conf
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
-Source4:       %{name}-config-20090914.tar.bz2
-# Source4-md5: 605f1cd28c00db961dad6f529d849f16
+# http://git.pld-linux.org/projects/nagios-config/
+Source4:       %{name}-config-20150805.tar.xz
+# Source4-md5: 16683172c72cc2c09662261c82abef40
 Source5:       %{name}-lighttpd.conf
 Source6:       http://www.google.com/mapfiles/shadow50.png
 # Source6-md5: eff99f302f21b95a900d321743fce72b
@@ -33,21 +34,23 @@ Source9:    %{name}wall.php
 Patch0:                %{name}-resources.patch
 Patch1:                %{name}-iconv-in-libc.patch
 Patch2:                %{name}-webapps.patch
-Patch3:                %{name}-cgi-http_charset.patch
+
 Patch4:                %{name}-cmd-typo.patch
 Patch5:                config.patch
 Patch6:                %{name}-googlemap.patch
 Patch7:                %{name}-doc-usermacros.patch
 Patch8:                archivelog-timeformat.patch
-Patch9:                system-magpierss.patch
+
 Patch10:       system-jquery.patch
 Patch11:       do-not-fetch-rss.patch
-URL:           http://www.nagios.org/
+URL:           https://www.nagios.org/projects/nagios-core/
 BuildRequires: autoconf
 BuildRequires: automake
 %{?with_doc:BuildRequires:     doxygen}
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: sed >= 4.0
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 %if %{with gd}
 BuildRequires: gd-devel
 BuildRequires: libjpeg-devel
@@ -74,6 +77,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                cgidir          %{_libdir}/%{name}/cgi
 %define                htmldir         %{_prefix}/share/%{name}
 %define                _localstatedir  /var/lib/%{name}
+%define                nagioshome      %{_localstatedir}
 %define                _webapps        /etc/webapps
 %define                _webapp         %{name}
 
@@ -153,7 +157,6 @@ Requires:   webserver(auth)
 Requires:      webserver(cgi)
 Requires:      webserver(indexfile)
 Suggests:      %{name}-doc
-Suggests:      php-magpierss >= 0.72
 
 %description cgi
 CGI webinterface for Nagios.
@@ -248,14 +251,14 @@ mv %{name}-%{version}/* .
 %patch0 -p0
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+
 #fixed
 #%patch4 -p1
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
-%patch9 -p1
+
 %patch10 -p1
 %patch11 -p1
 
@@ -324,7 +327,7 @@ cd ..
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_webapps}/%{_webapp}} \
        $RPM_BUILD_ROOT{%{_var}/log/%{name}/archives,%{_localstatedir}/rw} \
-       $RPM_BUILD_ROOT%{_sysconfdir}/{plugins,objects} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/{plugins,objects,nrpe.d} \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/{eventhandlers,plugins,brokers} \
 %if "%{_lib}" != "lib"
        $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/{eventhandlers,plugins} \
@@ -374,7 +377,7 @@ done
 > $RPM_BUILD_ROOT%{_localstatedir}/rw/%{name}.qh
 
 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
-%{__cp} -a Documentation/html/* $RPM_BUILD_ROOT%{_docdir}/%{name}
+%{?with_doc:%{__cp} -a Documentation/html/* $RPM_BUILD_ROOT%{_docdir}/%{name}}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -407,9 +410,14 @@ fi
 %groupadd -g 72 nagios
 %groupadd -g 147 -f nagcmd
 if [ -n "$(id -u netsaint 2>/dev/null)" ] && [ "$(id -u netsaint)" = "72" ]; then
-       /usr/sbin/usermod -d %{_libdir}/%{name} -l nagios -c "Nagios Daemon" -G nagcmd netsaint
+       /usr/sbin/usermod -d %{nagioshome} -l nagios -c "Nagios Daemon" -G nagcmd netsaint
+fi
+%useradd -u 72 -d %{nagioshome} -s /bin/false -c "Nagios Daemon" -g nagios -G nagcmd nagios
+# update nagios user home
+home=$(IFS=:; set -- $(getent passwd nagios); echo $6)
+if [ "$home" != %{nagioshome} ]; then
+       /usr/sbin/usermod -d %{nagioshome} nagios
 fi
-%useradd -u 72 -d %{_libdir}/%{name} -s /bin/false -c "Nagios Daemon" -g nagios -G nagcmd nagios
 
 %postun common
 if [ "$1" = "0" ]; then
@@ -461,6 +469,14 @@ for a in dependencies.cfg services.cfg serviceextinfo.cfg hosts.cfg hostgroups.c
 done
 %{__sed} -i -e 's,^check_result_path=.*,check_result_path=%{_var}/spool/%{name}/checkresults,' %{_sysconfdir}/%{name}.cfg
 
+
+%triggerpostun -- nagios-common < 4.0.8-2.2
+%banner -e %{name}-common <<EOF
+
+IMPORTANT: nagios user home changed to %{nagioshome}, you may need to move files from previous location %{_libdir}/%{name}.
+
+EOF
+
 %files
 %defattr(644,root,root,755)
 %doc Changelog README* UPGRADING INSTALLING LICENSE
@@ -504,6 +520,7 @@ done
 %defattr(644,root,root,755)
 %attr(750,root,nagcmd) %dir %{_sysconfdir}
 %attr(750,root,nagios) %dir %{_sysconfdir}/plugins
+%attr(750,root,nagios) %dir %{_sysconfdir}/nrpe.d
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/plugins
 %dir %{_libdir}/%{name}/eventhandlers
@@ -520,9 +537,11 @@ done
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/mrtg/conf.d/%{name}.cfg
 
+%if %{with doc}
 %files doc
 %defattr(644,root,root,755)
 %{_docdir}/%{name}
+%endif
 
 %files cgi
 %defattr(644,root,root,755)
@@ -542,6 +561,7 @@ done
 %dir %{htmldir}/stylesheets
 %{htmldir}/robots.txt
 %{htmldir}/contexthelp
+%{htmldir}/jsonquery.html
 %{htmldir}/media
 %{htmldir}/ssi
 %{htmldir}/images/favicon.ico
@@ -549,6 +569,27 @@ done
 %{htmldir}/images/shadow50.png
 %{htmldir}/nagioswall.php
 
+%{htmldir}/angularjs
+%{htmldir}/bootstrap-3.3.0
+%{htmldir}/d3
+%{htmldir}/spin
+%{htmldir}/graph-header.html
+%{htmldir}/histogram-form.html
+%{htmldir}/histogram-graph.html
+%{htmldir}/histogram-links.html
+%{htmldir}/histogram.html
+%{htmldir}/infobox.html
+%{htmldir}/map-directive.html
+%{htmldir}/map-form.html
+%{htmldir}/map-links.html
+%{htmldir}/map-popup.html
+%{htmldir}/trends-form.html
+%{htmldir}/trends-graph.html
+%{htmldir}/trends-host-yaxis.html
+%{htmldir}/trends-links.html
+%{htmldir}/trends-service-yaxis.html
+%{htmldir}/trends.html
+
 %files theme-classicui
 %defattr(644,root,root,755)
 %exclude %{htmldir}/nagioswall.php
This page took 0.217503 seconds and 4 git commands to generate.