]> git.pld-linux.org Git - packages/nagios-nrpe.git/blob - nagios-nrpe.spec
move nrpe command definitions to nrpe.d/commands.cfg
[packages/nagios-nrpe.git] / nagios-nrpe.spec
1 Summary:        Nagios remote plugin execution service/plugin
2 Summary(pl.UTF-8):      Demon i wtyczka zdalnego wywoływania wtyczek Nagios
3 Name:           nagios-nrpe
4 Version:        2.15
5 Release:        4
6 License:        GPL v2
7 Group:          Networking
8 Source0:        http://downloads.sourceforge.net/nagios/nrpe-%{version}.tar.gz
9 # Source0-md5:  3921ddc598312983f604541784b35a50
10 Source1:        nrpe.init
11 Source2:        nrpe-command.cfg
12 Source3:        %{name}.tmpfiles
13 Source4:        commands.cfg
14 Patch0:         %{name}-config.patch
15 Patch1:         nrpe_check_control.patch
16 URL:            http://www.nagios.org/
17 BuildRequires:  openssl-devel
18 BuildRequires:  openssl-tools
19 BuildRequires:  rpmbuild(macros) >= 1.647
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       nagios-common
22 Requires:       rc-scripts
23 Provides:       nagios-core
24 Obsoletes:      netsaint-nrpe
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sysconfdir     /etc/nagios
28 %define         _datadir        %{_prefix}/share/%{name}
29 %define         _plugindir      %{_libdir}/nagios/plugins
30 %define         _libexecdir     %{_plugindir}
31 %define         _localstatedir  %{_var}/log/nagios
32 %define         nsport          5666
33
34 %description
35 NPRE (Nagios Remote Plugin Executor) is a system daemon that will
36 execute various Nagios plugins locally on behalf of a remote
37 (monitoring) host that uses the check_nrpe plugin.
38
39 %description -l pl.UTF-8
40 NRPE to dodatek do Nagiosa pozwalający na wywoływanie "lokalnych"
41 wtyczek (takich jak check_disk, check_procs itp.) na zdalnych
42 maszynach. Wtyczka check_nrpe jest wywoływana z poziomu Nagiosa i
43 wysyła żądania uruchomienia wtyczek do demona NRPE działającego na
44 zdalnej maszynie (jako samodzielny demon lub usługa inetd). Obsługuje
45 przekazywanie argumentów poleceń do serwera, a także natywne
46 szyfrowanie SSL/TLS (w trybie anonimowego DH).
47
48 %package -n nagios-plugin-check_nrpe
49 Summary:        check_nrpe plugin for Nagios
50 Summary(pl.UTF-8):      Wtyczka check_nrpe dla Nagiosa
51 Group:          Networking
52 Requires:       nagios-common
53 Provides:       %{name}-plugin = %{version}-%{release}
54 Obsoletes:      nagios-nrpe-plugin < 2.12-6
55
56 %description -n nagios-plugin-check_nrpe
57 The check_nrpe plugin is called from Nagios and makes plugin execution
58 requests to the NRPE daemon running on the remote host. Supports
59 passing command arguments to server, as well as native SSL/TLS
60 encryption (anonymous DH mode).
61
62 %description -n nagios-plugin-check_nrpe -l pl.UTF-8
63 Wtyczka check_nrpe dla Nagiosa. Pozwala na zdalne uruchamianie wtyczek
64 na innych komputerach za pomocą demona nrpe.
65
66 %prep
67 %setup -q -n nrpe-%{version}
68 %undos contrib/nrpe_check_control.c
69 %patch0 -p1
70 %patch1 -p1
71
72 %build
73 %configure \
74         --with-nrpe-port=%{nsport} \
75         --with-nrpe-user=nagios \
76         --with-nrpe-group=nagios \
77         --enable-ssl \
78         --with-ssl-lib=%{_libdir} \
79         --enable-command-args
80
81 %{__make} all
82
83 %{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} contrib/nrpe_check_control.c -o contrib/nrpe_check_control
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/{plugins,nrpe.d},%{_libdir}/nagios/plugins,%{_sbindir}} \
88         $RPM_BUILD_ROOT{%{_localstatedir},/var/run/nrpe} \
89         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
90
91 cp -p sample-config/nrpe.cfg $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.cfg
92 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.d
93 sed -e 's,@plugindir@,%{_plugindir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/plugins/check_nrpe.cfg
94 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/nrpe
95 install -p src/nrpe $RPM_BUILD_ROOT%{_sbindir}
96 install -p src/check_nrpe $RPM_BUILD_ROOT%{_plugindir}
97 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 /sbin/chkconfig --add nrpe
104 %service nrpe restart
105
106 %preun
107 if [ "$1" = "0" ] ; then
108         %service nrpe stop
109         /sbin/chkconfig --del nrpe
110 fi
111
112 %triggerpostun -- %{name} < 2.15-4
113 # skip *this* trigger on downgrade
114 [ $1 -le 1 ] && exit 0
115
116 # check if need to migrate
117 grep -q '^command\['  %{_sysconfdir}/nrpe.cfg || exit 0
118
119 # move command definitions to separate file
120 mv -f  %{_sysconfdir}/nrpe.d/commands.cfg{,.rpmnew}
121 grep '^command\['  %{_sysconfdir}/nrpe.cfg > %{_sysconfdir}/nrpe.d/commands.cfg
122 cp -f %{_sysconfdir}/nrpe.cfg{,.rpmsave}
123 sed -i -e '/^command\[/d' %{_sysconfdir}/nrpe.cfg
124 %service nrpe restart
125
126 %triggerpostun -- %{name} < 2.6-1.1
127 %{__sed} -i -e 's,/var/run/nrpe.pid,/var/run/nrpe/nrpe.pid,' %{_sysconfdir}/nrpe.cfg
128
129 %triggerpostun -n nagios-plugin-check_nrpe -- nagios-plugin-check_nrpe < 2.12-7.1
130 if [ -f %{_sysconfdir}/plugins/nrpe.cfg.rpmsave ]; then
131         cp -f %{_sysconfdir}/plugins/check_nrpe.cfg{,.rpmnew}
132         mv -f %{_sysconfdir}/plugins/{nrpe.cfg.rpmsave,check_nrpe.cfg}
133         sed -i -e 's,-c \$ARG1\$,$ARG1$,' %{_sysconfdir}/plugins/check_nrpe.cfg
134 fi
135
136 %files
137 %defattr(644,root,root,755)
138 %doc Changelog LEGAL README* SECURITY
139 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.cfg
140 %attr(750,root,nagios) %dir %{_sysconfdir}/nrpe.d
141 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.d/commands.cfg
142 %attr(755,root,root) %{_sbindir}/nrpe
143 %attr(754,root,root) /etc/rc.d/init.d/nrpe
144 %dir %attr(775,root,nagios) /var/run/nrpe
145 %{systemdtmpfilesdir}/%{name}.conf
146
147 %files -n nagios-plugin-check_nrpe
148 %defattr(644,root,root,755)
149 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plugins/check_nrpe.cfg
150 %attr(755,root,root) %{_plugindir}/check_nrpe
This page took 0.058142 seconds and 3 git commands to generate.