]> git.pld-linux.org Git - packages/nagios-nrpe.git/blob - nagios-nrpe.spec
6da90d6051639e8f4ebc17a282bd1c6462478514
[packages/nagios-nrpe.git] / nagios-nrpe.spec
1 Summary:        Nagios remote plugin execution service/plugin
2 Summary(pl.UTF-8):      Demon i wtyczka zdalnego wywoływania wtyczek Nagios
3 Name:           nagios-nrpe
4 Version:        3.0
5 Release:        1
6 License:        GPL v2
7 Group:          Networking
8 Source0:        http://downloads.sourceforge.net/nagios/nrpe-%{version}.tar.gz
9 # Source0-md5:  e2e8e0bcd9a3924b0ea94e76500f147b
10 Source1:        nrpe.init
11 Source2:        nrpe-command.cfg
12 Source3:        %{name}.tmpfiles
13 Source4:        commands.cfg
14 Patch0:         %{name}-config.patch
15 Patch1:         nrpe_check_control.patch
16 URL:            http://www.nagios.org/
17 BuildRequires:  openssl-devel
18 BuildRequires:  openssl-tools
19 BuildRequires:  rpmbuild(macros) >= 1.647
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       nagios-common
22 Requires:       rc-scripts >= 0.4.1.26
23 Provides:       nagios-core
24 Obsoletes:      netsaint-nrpe
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sysconfdir     /etc/nagios
28 %define         _datadir        %{_prefix}/share/%{name}
29 %define         _plugindir      %{_libdir}/nagios/plugins
30 %define         _localstatedir  %{_var}/log/nagios
31 %define         nsport          5666
32
33 %description
34 NPRE (Nagios Remote Plugin Executor) is a system daemon that will
35 execute various Nagios plugins locally on behalf of a remote
36 (monitoring) host that uses the check_nrpe plugin.
37
38 %description -l pl.UTF-8
39 NRPE to dodatek do Nagiosa pozwalający na wywoływanie "lokalnych"
40 wtyczek (takich jak check_disk, check_procs itp.) na zdalnych
41 maszynach. Wtyczka check_nrpe jest wywoływana z poziomu Nagiosa i
42 wysyła żądania uruchomienia wtyczek do demona NRPE działającego na
43 zdalnej maszynie (jako samodzielny demon lub usługa inetd). Obsługuje
44 przekazywanie argumentów poleceń do serwera, a także natywne
45 szyfrowanie SSL/TLS (w trybie anonimowego DH).
46
47 %package -n nagios-plugin-check_nrpe
48 Summary:        check_nrpe plugin for Nagios
49 Summary(pl.UTF-8):      Wtyczka check_nrpe dla Nagiosa
50 Group:          Networking
51 Requires:       nagios-common
52 Provides:       %{name}-plugin = %{version}-%{release}
53 Obsoletes:      nagios-nrpe-plugin < 2.12-6
54
55 %description -n nagios-plugin-check_nrpe
56 The check_nrpe plugin is called from Nagios and makes plugin execution
57 requests to the NRPE daemon running on the remote host. Supports
58 passing command arguments to server, as well as native SSL/TLS
59 encryption (anonymous DH mode).
60
61 %description -n nagios-plugin-check_nrpe -l pl.UTF-8
62 Wtyczka check_nrpe dla Nagiosa. Pozwala na zdalne uruchamianie wtyczek
63 na innych komputerach za pomocą demona nrpe.
64
65 %prep
66 %setup -q -n nrpe-%{version}
67 %undos contrib/nrpe_check_control.c
68 %patch0 -p1
69 %patch1 -p1
70
71 %build
72 %configure \
73         --with-nrpe-port=%{nsport} \
74         --with-nrpe-user=nagios \
75         --with-nrpe-group=nagios \
76         --enable-ssl \
77         --with-ssl-lib=%{_libdir} \
78         --enable-command-args
79
80 %{__make} all
81
82 %{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} contrib/nrpe_check_control.c -o contrib/nrpe_check_control
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/{plugins,nrpe.d},%{_libdir}/nagios/plugins,%{_sbindir}} \
87         $RPM_BUILD_ROOT{%{_localstatedir},/var/run/nrpe} \
88         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
89
90 cp -p sample-config/nrpe.cfg $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.cfg
91 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.d
92 sed -e 's,@plugindir@,%{_plugindir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/plugins/check_nrpe.cfg
93 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/nrpe
94 install -p src/nrpe $RPM_BUILD_ROOT%{_sbindir}
95 install -p src/check_nrpe $RPM_BUILD_ROOT%{_plugindir}
96 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post
102 /sbin/chkconfig --add nrpe
103 %service nrpe restart
104
105 %preun
106 if [ "$1" = "0" ] ; then
107         %service nrpe stop
108         /sbin/chkconfig --del nrpe
109 fi
110
111 %triggerpostun -- %{name} < 2.15-5
112 # skip *this* trigger on downgrade
113 [ $1 -le 1 ] && exit 0
114
115 # ensure there's include_dir directive
116 if ! grep -q '^include_dir=%{_sysconfdir}/nrpe.d' %{_sysconfdir}/nrpe.cfg; then
117         echo 'include_dir=%{_sysconfdir}/nrpe.d' >> %{_sysconfdir}/nrpe.cfg
118 fi
119
120 # check if need to migrate
121 grep -q '^command\[' %{_sysconfdir}/nrpe.cfg || exit 0
122
123 # move command definitions to separate file
124 mv -f  %{_sysconfdir}/nrpe.d/commands.cfg{,.rpmnew}
125 grep '^command\['  %{_sysconfdir}/nrpe.cfg > %{_sysconfdir}/nrpe.d/commands.cfg
126 cp -f %{_sysconfdir}/nrpe.cfg{,.rpmsave}
127 sed -i -e '/^command\[/d' %{_sysconfdir}/nrpe.cfg
128
129 %service nrpe restart
130
131 %triggerpostun -- %{name} < 2.6-1.1
132 %{__sed} -i -e 's,/var/run/nrpe.pid,/var/run/nrpe/nrpe.pid,' %{_sysconfdir}/nrpe.cfg
133
134 %triggerpostun -n nagios-plugin-check_nrpe -- nagios-plugin-check_nrpe < 2.12-7.1
135 if [ -f %{_sysconfdir}/plugins/nrpe.cfg.rpmsave ]; then
136         cp -f %{_sysconfdir}/plugins/check_nrpe.cfg{,.rpmnew}
137         mv -f %{_sysconfdir}/plugins/{nrpe.cfg.rpmsave,check_nrpe.cfg}
138         sed -i -e 's,-c \$ARG1\$,$ARG1$,' %{_sysconfdir}/plugins/check_nrpe.cfg
139 fi
140
141 %files
142 %defattr(644,root,root,755)
143 %doc Changelog LEGAL README* SECURITY.md update-cfg.pl
144 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.cfg
145 %attr(750,root,nagios) %dir %{_sysconfdir}/nrpe.d
146 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.d/commands.cfg
147 %attr(755,root,root) %{_sbindir}/nrpe
148 %attr(754,root,root) /etc/rc.d/init.d/nrpe
149 %dir %attr(775,root,nagios) /var/run/nrpe
150 %{systemdtmpfilesdir}/%{name}.conf
151
152 %files -n nagios-plugin-check_nrpe
153 %defattr(644,root,root,755)
154 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plugins/check_nrpe.cfg
155 %attr(755,root,root) %{_plugindir}/check_nrpe
This page took 0.028285 seconds and 2 git commands to generate.