]> git.pld-linux.org Git - packages/nagios-nrpe.git/blob - nagios-nrpe.spec
add CVE-2014-2913 fix from fedora
[packages/nagios-nrpe.git] / nagios-nrpe.spec
1 Summary:        Nagios remote plugin execution service/plugin
2 Summary(pl.UTF-8):      Demon i wtyczka zdalnego wywoływania wtyczek Nagios
3 Name:           nagios-nrpe
4 Version:        2.15
5 Release:        6
6 License:        GPL v2
7 Group:          Networking
8 Source0:        http://downloads.sourceforge.net/nagios/nrpe-%{version}.tar.gz
9 # Source0-md5:  3921ddc598312983f604541784b35a50
10 Source1:        nrpe.init
11 Source2:        nrpe-command.cfg
12 Source3:        %{name}.tmpfiles
13 Source4:        commands.cfg
14 Patch0:         %{name}-config.patch
15 Patch1:         nrpe_check_control.patch
16 Patch2:         CVE-2014-2913-nasty-metacharacters.patch
17 URL:            http://www.nagios.org/
18 BuildRequires:  openssl-devel
19 BuildRequires:  openssl-tools
20 BuildRequires:  rpmbuild(macros) >= 1.647
21 Requires(post,preun):   /sbin/chkconfig
22 Requires:       nagios-common
23 Requires:       rc-scripts
24 Provides:       nagios-core
25 Obsoletes:      netsaint-nrpe
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _sysconfdir     /etc/nagios
29 %define         _datadir        %{_prefix}/share/%{name}
30 %define         _plugindir      %{_libdir}/nagios/plugins
31 %define         _libexecdir     %{_plugindir}
32 %define         _localstatedir  %{_var}/log/nagios
33 %define         nsport          5666
34
35 %description
36 NPRE (Nagios Remote Plugin Executor) is a system daemon that will
37 execute various Nagios plugins locally on behalf of a remote
38 (monitoring) host that uses the check_nrpe plugin.
39
40 %description -l pl.UTF-8
41 NRPE to dodatek do Nagiosa pozwalający na wywoływanie "lokalnych"
42 wtyczek (takich jak check_disk, check_procs itp.) na zdalnych
43 maszynach. Wtyczka check_nrpe jest wywoływana z poziomu Nagiosa i
44 wysyła żądania uruchomienia wtyczek do demona NRPE działającego na
45 zdalnej maszynie (jako samodzielny demon lub usługa inetd). Obsługuje
46 przekazywanie argumentów poleceń do serwera, a także natywne
47 szyfrowanie SSL/TLS (w trybie anonimowego DH).
48
49 %package -n nagios-plugin-check_nrpe
50 Summary:        check_nrpe plugin for Nagios
51 Summary(pl.UTF-8):      Wtyczka check_nrpe dla Nagiosa
52 Group:          Networking
53 Requires:       nagios-common
54 Provides:       %{name}-plugin = %{version}-%{release}
55 Obsoletes:      nagios-nrpe-plugin < 2.12-6
56
57 %description -n nagios-plugin-check_nrpe
58 The check_nrpe plugin is called from Nagios and makes plugin execution
59 requests to the NRPE daemon running on the remote host. Supports
60 passing command arguments to server, as well as native SSL/TLS
61 encryption (anonymous DH mode).
62
63 %description -n nagios-plugin-check_nrpe -l pl.UTF-8
64 Wtyczka check_nrpe dla Nagiosa. Pozwala na zdalne uruchamianie wtyczek
65 na innych komputerach za pomocą demona nrpe.
66
67 %prep
68 %setup -q -n nrpe-%{version}
69 %undos contrib/nrpe_check_control.c
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73
74 %build
75 %configure \
76         --with-nrpe-port=%{nsport} \
77         --with-nrpe-user=nagios \
78         --with-nrpe-group=nagios \
79         --enable-ssl \
80         --with-ssl-lib=%{_libdir} \
81         --enable-command-args
82
83 %{__make} all
84
85 %{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} contrib/nrpe_check_control.c -o contrib/nrpe_check_control
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/{plugins,nrpe.d},%{_libdir}/nagios/plugins,%{_sbindir}} \
90         $RPM_BUILD_ROOT{%{_localstatedir},/var/run/nrpe} \
91         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
92
93 cp -p sample-config/nrpe.cfg $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.cfg
94 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.d
95 sed -e 's,@plugindir@,%{_plugindir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/plugins/check_nrpe.cfg
96 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/nrpe
97 install -p src/nrpe $RPM_BUILD_ROOT%{_sbindir}
98 install -p src/check_nrpe $RPM_BUILD_ROOT%{_plugindir}
99 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post
105 /sbin/chkconfig --add nrpe
106 %service nrpe restart
107
108 %preun
109 if [ "$1" = "0" ] ; then
110         %service nrpe stop
111         /sbin/chkconfig --del nrpe
112 fi
113
114 %triggerpostun -- %{name} < 2.15-5
115 # skip *this* trigger on downgrade
116 [ $1 -le 1 ] && exit 0
117
118 # ensure there's include_dir directive
119 if ! grep -q '^include_dir=%{_sysconfdir}/nrpe.d' %{_sysconfdir}/nrpe.cfg; then
120         echo 'include_dir=%{_sysconfdir}/nrpe.d' >> %{_sysconfdir}/nrpe.cfg
121 fi
122
123 # check if need to migrate
124 grep -q '^command\[' %{_sysconfdir}/nrpe.cfg || exit 0
125
126 # move command definitions to separate file
127 mv -f  %{_sysconfdir}/nrpe.d/commands.cfg{,.rpmnew}
128 grep '^command\['  %{_sysconfdir}/nrpe.cfg > %{_sysconfdir}/nrpe.d/commands.cfg
129 cp -f %{_sysconfdir}/nrpe.cfg{,.rpmsave}
130 sed -i -e '/^command\[/d' %{_sysconfdir}/nrpe.cfg
131
132 %service nrpe restart
133
134 %triggerpostun -- %{name} < 2.6-1.1
135 %{__sed} -i -e 's,/var/run/nrpe.pid,/var/run/nrpe/nrpe.pid,' %{_sysconfdir}/nrpe.cfg
136
137 %triggerpostun -n nagios-plugin-check_nrpe -- nagios-plugin-check_nrpe < 2.12-7.1
138 if [ -f %{_sysconfdir}/plugins/nrpe.cfg.rpmsave ]; then
139         cp -f %{_sysconfdir}/plugins/check_nrpe.cfg{,.rpmnew}
140         mv -f %{_sysconfdir}/plugins/{nrpe.cfg.rpmsave,check_nrpe.cfg}
141         sed -i -e 's,-c \$ARG1\$,$ARG1$,' %{_sysconfdir}/plugins/check_nrpe.cfg
142 fi
143
144 %files
145 %defattr(644,root,root,755)
146 %doc Changelog LEGAL README* SECURITY
147 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.cfg
148 %attr(750,root,nagios) %dir %{_sysconfdir}/nrpe.d
149 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.d/commands.cfg
150 %attr(755,root,root) %{_sbindir}/nrpe
151 %attr(754,root,root) /etc/rc.d/init.d/nrpe
152 %dir %attr(775,root,nagios) /var/run/nrpe
153 %{systemdtmpfilesdir}/%{name}.conf
154
155 %files -n nagios-plugin-check_nrpe
156 %defattr(644,root,root,755)
157 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plugins/check_nrpe.cfg
158 %attr(755,root,root) %{_plugindir}/check_nrpe
This page took 0.185987 seconds and 3 git commands to generate.