]> git.pld-linux.org Git - packages/mythtv.git/blobdiff - mythtv.spec
- typo
[packages/mythtv.git] / mythtv.spec
index 536617fca461e9fcfb99a96da5d02f9fc1bd9b4c..3cd943eac3a534a65edf907fefd14ebc0e544b09 100644 (file)
@@ -2,6 +2,8 @@
 # - bconds: altivec joystick lcd
 # - lcd? (app-misc/lcdproc)
 # - alpha, sparc, ppc arches?
+# - http://outflux.net/software/pkgs/mythtvfs-fuse/
+# - vaapi support - check for compatible versions of libva?
 #
 # Specfile for MythTV
 #
 %bcond_without lirc            # lirc support
 %bcond_without alsa            # alsa support
 %bcond_without oss             # oss support
-%bcond_with    arts            # arts support
 %bcond_without jack            # jack audio connection kit
+%bcond_without  pulseaudio     # pulseaudio support
 %bcond_without opengl          # opengl vsync
 %bcond_without dvb             # DVB support
 %bcond_without xrandr          # disable X11 resolution switching
 %bcond_without ivtv            # ivtv support (PVR-250, PVR-350) NFY
 %bcond_without iptv
-%bcond_with    firewire        # ieee1394 (NFY)
+%bcond_without firewire        # ieee1394 (NFY)
 %bcond_without xvmc            # do not use XvMCW
+%bcond_without  vdpau          # disable nvidia vdpau support
+%bcond_without  fftw3          # disable fftw3 support
 %bcond_with    mmx             # enable MMX
+%bcond_without nellymoserdec
+%bcond_with    vaapi           # enable vaapi
 %bcond_with     dshowserver    # enable directshow codecs server
 %bcond_with    directfb
+%bcond_with    nvidia_headers  # build vdpau support with nvidia headers 
+                               # instead of libvdpau
 
 # enable mmx automatically on arches having it
 %ifarch %{ix86} %{x8664}
 %undefine with_dshowserver
 %endif
 
-%define snap 20090518
-#%define rel 0.1
 Summary:       A personal video recorder (PVR) application
 Summary(pl.UTF-8):     Osobista aplikacja do nagrywania obrazu (PVR)
 Name:          mythtv
-Version:       0.22
-Release:       0.%{snap}.1
+Version:       0.23.1
+Release:       4
 License:       GPL v2
 Group:         Applications/Multimedia
-Source0:       %{name}-%{version}-%{snap}.tar.bz2
-# Source0-md5: 22f837c4cf0ebb4410d97d2cc1d29546
+Source0:       ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
+# Source0-md5: 3379a5fd12ae866cd10c5b5d23439898
 Source1:       mythbackend.sysconfig
 Source2:       mythbackend.init
 Source3:       mythbackend.logrotate
 Source5:       pld-mythfrontend.desktop
-# Source5-md5:  f37a903ac97463683bebacdf29406951
+# Source5-md5: f37a903ac97463683bebacdf29406951
 Source6:       pld-mythfrontend.png
-# Source6-md5:  bf76bd1463a022e174e4af976a03e678
+# Source6-md5: bf76bd1463a022e174e4af976a03e678
 Source20:      dshowcodecs
-# Source20-md5: 48327772b9e150f69e1ab8ff44b9a76c
-#Patch100: %{name}-branch.diff
+# Source20-md5:        48327772b9e150f69e1ab8ff44b9a76c
 Patch0:                %{name}-configure.patch
-#Patch1: %{name}-mythstream.patch
-#Patch2: %{name}-pl.patch
-Patch3:                %{name}-sbinpath.patch
-#Patch4: %{name}-dvdnav-shared.patch
-Patch20:       %{name}-dshowserver_trunk.patch
+Patch10:       %{name}-sbinpath.patch
+Patch20:       %{name}-compile_fixes_for_qt_4_7.patch
+Patch30:       %{name}-dshowserver-0.22.patch
 URL:           http://www.mythtv.org/
 BuildRequires: Mesa-libGLU-devel
-BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
 BuildRequires: Qt3Support-devel
 BuildRequires: QtCore-devel
@@ -80,8 +82,8 @@ BuildRequires:        QtSql-devel
 BuildRequires: QtWebKit-devel
 BuildRequires: QtXml-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
-%{?with_arts:BuildRequires:    arts-devel >= 13:0.9.5}
 BuildRequires: ffmpeg-devel
+%{?with_fftw3:BuildRequires: fftw3-devel,fftw3-single-devel}
 BuildRequires: freetype-devel >= 1:2.0.0
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
 BuildRequires: lame-libs-devel
@@ -91,21 +93,27 @@ BuildRequires:      libdts-devel
 BuildRequires: libdvdnav-devel
 %{?with_firewire:BuildRequires:        libiec61883-devel}
 %{?with_firewire:BuildRequires:        libraw1394-devel}
+%{!?with_nvidia_headers:%{?with_vdpau:BuildRequires:   libvdpau-devel}}
 BuildRequires: linux-libc-headers >= 7:2.6.10
 %{?with_lirc:BuildRequires:    lirc-devel}
 BuildRequires: mysql-devel
-#BuildRequires:        patchutils
 BuildRequires: perl-devel
 BuildRequires: perl-tools-pod
+BuildRequires: pkgconfig
+%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
 BuildRequires: python-devel
 BuildRequires: qt4-build
 BuildRequires: qt4-qmake
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.228
 BuildRequires: sed >= 4.0
+BuildRequires: which
+%{?with_nvidia_headers:%{?with_vdpau:BuildRequires: xorg-driver-video-nvidia-devel}}
 BuildRequires: xorg-lib-libXext-devel
 %{?with_xvmc:BuildRequires:    xorg-lib-libXvMC-devel}
 BuildRequires: xorg-lib-libXxf86vm-devel
+%{!?with_pulseaudio:BuildConflicts: pulseaudio-devel}
+%{!?with_nvidia_headers:BuildConflicts:        xorg-driver-video-nvidia-devel}
 # for Perl bindings
 BuildRequires: perl-ExtUtils-MakeMaker
 ExclusiveArch: %{ix86} %{x8664} ppc
@@ -151,6 +159,7 @@ Requires(pre):      /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      libmyth = %{version}-%{release}
 Requires:      mythtv = %{version}-%{release}
+Suggests:      mysql
 Provides:      group(mythtv)
 Provides:      user(mythtv)
 
@@ -172,7 +181,7 @@ mythtv.
 Ten pakiet zawiera tylko oprogramowanie serwerowe, udostępniające
 usługi przechwytywania i kodowania obrazu i dźwięku. Aby było
 przydatne, wymaga instalacji mythtv-frontend - na tym samym systemie,
-albo innym osiągalnym po sieci.
+albo innym osiągalnym w sieci.
 
 %package frontend
 Summary:       Client component of mythtv (a PVR)
@@ -200,8 +209,7 @@ mythtv.
 
 Ten pakiet zawiera tylko oprogramowanie klienckie, dostarczające
 frontend do odtwarzania i konfiguracji. Wymaga dostępu do instalacji
-mythtv-backend - na tym samym systemie, albo innym osiągalnym po
-sieci.
+mythtv-backend - na tym samym systemie, albo innym osiągalnym w sieci.
 
 %package setup
 Summary:       Setup the mythtv backend
@@ -305,7 +313,7 @@ Ten pakiet zawiera moduły Perla do tworzenia dodatków dla mythtv.
 Summary:       MythTV Python bindings
 Summary(pl.UTF-8):     Interfejs Pythona dla MythTV
 Group:         Libraries
-Requires:      MySQL-python
+Requires:      python-MySQLdb
 
 %description -n python-MythTV
 MythTV Python bindings.
@@ -315,16 +323,17 @@ Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
 
 %prep
 
-%setup -q %{SOURCE0}
+%setup -q
 
+%{__sed} -i -e 's,/var/log/mythfilldatabase.log,/var/log/mythtv/mythfilldatabase.log,' \
+       programs/mythbackend/housekeeper.cpp programs/mythwelcome/welcomedialog.cpp
 
-%patch0 -p0
-#%patch1 -p1
-#%patch2 -p1
-%patch3 -p1
-#%patch4 -p1
+%patch0  -p1
+%patch10 -p1
+%patch20 -p1
+#%patch30 -p1
 
-%{?with_dshowserver:%patch20 -p1}
+%{?with_dshowserver:%patch20 -p0}
 rm -rf database/old # not supported in PLD
 
 # lib64 fix - enable to update patch
@@ -388,7 +397,7 @@ fi
 ./configure \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
-       --libdir-name=`basename %{_libdir}` \
+       --libdir-name=%{_lib} \
        --mandir=%{_mandir} \
        --disable-distcc --disable-ccache \
        --compile-type=%{?debug:debug}%{!?debug:release} \
@@ -401,16 +410,18 @@ fi
                %ifarch athlon
                        --arch=athlon \
                %else
-                       --cpu=i386 --tune=pentium4 \
+                       --cpu=%{_target_cpu} --tune=pentium4 \
                %endif
        %endif
+       %ifarch i386 i486 i586
+       --enable-disable-mmx-for-debugging \
+       %endif
        %ifarch %{x8664}
        --arch=x86_64 \
        %endif
        %{?with_mmx:--enable-mmx} \
 %endif
        %{?with_dvb:--enable-dvb --dvb-path=%{_includedir}} \
-       --%{?with_arts:en}%{!?with_arts:dis}able-audio-arts \
        --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
        --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
        --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
@@ -422,22 +433,22 @@ fi
        --%{?with_ivtv:en}%{!?with_ivtv:dis}able-ivtv \
        --%{?with_iptv:en}%{!?with_iptv:dis}able-iptv \
        --%{?with_nellymoserdec:en}%{!?with_nellymoserdec:dis}able-decoder=nellymoser \
+       --%{?with_vaapi:en}%{!?with_vaapi:dis}able-vaapi \
+       --%{?with_vdpau:en}%{!?with_vdpau:dis}able-vdpau \
        --%{?with_directfb:en}%{!?with_directfb:dis}able-directfb \
+       --%{?with_fftw3:en}%{!?with_fftw3:dis}able-libfftw3 \
        --enable-xv \
        --enable-x11 \
 
 %{_libdir}/qt4/bin/qmake mythtv.pro
-#sed -i -e 's/usr\/\/usr/usr/g' config.ep
-
-
 %{__make}
 
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
                $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_desktopdir}} \
-               $RPM_BUILD_ROOT/var/{cache,lib,log,run}/mythtv \
+               $RPM_BUILD_ROOT/var/{cache,log,run}/mythtv \
+               $RPM_BUILD_ROOT/var/lib/mythtv/tmp \
                $RPM_BUILD_ROOT%{_libdir}/mythtv \
                $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins \
                $RPM_BUILD_ROOT%{_pixmapsdir}
@@ -445,11 +456,6 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-# required to build some plugins
-#      install libs/libavcodec/*.h $RPM_BUILD_ROOT%{_includedir}/mythtv \
-#              libs/libavformat/*.h $RPM_BUILD_ROOT%{_includedir}/mythtv \
-#              libs/libavutil/*.h $RPM_BUILD_ROOT%{_includedir}/mythtv
-
 # Install the files that we added on top of mythtv's own stuff
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
@@ -488,13 +494,10 @@ cp -a programs/mythlcdserver/README mythlcdserver
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-# Empty newline after %addusertogroup %{name} video below is intended.
-# Do not remove it until rpm stop joining lines with that macro.
 %pre backend
 %groupadd -g 149 %{name}
 %useradd -u 149 -d /var/lib/mythtv -g %{name} -c "MythTV User" %{name}
 %addusertogroup %{name} video
-
 %addusertogroup %{name} audio
 
 %post backend
@@ -539,6 +542,7 @@ fi
 %attr(755,root,root) %{_bindir}/mythtranscode
 %attr(755,root,root) %{_bindir}/mythreplex
 %attr(775,root,mythtv) %dir /var/lib/mythtv
+%attr(700,root,mythtv) %dir /var/lib/mythtv/tmp
 %attr(775,root,mythtv) %dir /var/cache/mythtv
 %attr(775,root,mythtv) %dir /var/run/mythtv
 %attr(754,root,root) /etc/rc.d/init.d/mythbackend
@@ -550,7 +554,7 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/mythfrontend
 %attr(755,root,root) %{_bindir}/mythshutdown
-%attr(755,root,root) %{_bindir}/mythtv
+%attr(755,root,root) %{_bindir}/mythavtest
 %attr(755,root,root) %{_bindir}/mythtvosd
 %attr(755,root,root) %{_bindir}/mythwelcome
 %dir %{_datadir}/mythtv
@@ -597,12 +601,13 @@ fi
 %{perl_vendorlib}/MythTV.pm
 %dir %{perl_vendorlib}/MythTV
 %{perl_vendorlib}/MythTV/*.pm
+%dir %{perl_vendorlib}/IO/Socket/INET
 %{perl_vendorlib}/IO/Socket/INET/MythTV.pm
 %exclude %{perl_vendorarch}/auto/MythTV/.packlist
 
 %files -n python-MythTV
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/mythpython
 %dir %{py_sitescriptdir}/MythTV
-# XXX: package .py[co] only
 %{py_sitescriptdir}/MythTV/*
 %{py_sitescriptdir}/*.egg-info
This page took 0.11147 seconds and 4 git commands to generate.