]> git.pld-linux.org Git - packages/mythtv.git/blame - mythtv.spec
- fixed new shared lib deps
[packages/mythtv.git] / mythtv.spec
CommitLineData
aa6db6e7 1# TODO
bc34ab39 2# - bconds: altivec joystick lcd
58422b0a 3# - lcd? (app-misc/lcdproc)
bc34ab39 4# - icons for desktop entries
58422b0a 5# - alpha, sparc, ppc arches?
8afae0cb
ER
6#
7# Specfile for MythTV
8#
9# MythTV now uses a fairly intelligent cpu-detection script, so if you are
10# building an rpm by hand on the machine it will be used on, I encourage you
11# to use "--with cpu_autodetect" to let mythtv decide for you.
12#
ed630fed 13# Conditional build:
af73c10e 14%bcond_with cpu_autodetect # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
cb059bf8
ER
15%bcond_without lirc # lirc support
16%bcond_without alsa # alsa support
9dc1d1be 17%bcond_without oss # oss support
cb059bf8
ER
18%bcond_without arts # arts support
19%bcond_without jack # jack audio connection kit
cb059bf8 20%bcond_without opengl # opengl vsync
1e5a2ed2 21%bcond_with dvb # DVB support # invalid option
bc34ab39 22%bcond_without xrandr # disable X11 resolution switching
9dc1d1be
JB
23%bcond_with ivtv # ivtv support (PVR-250, PVR-350) NFY
24%bcond_with firewire # ieee1394 (NFY)
bc34ab39 25%bcond_without xvmc # do not use XvMCW
1e5a2ed2 26%bcond_with mmx # enable mmx
32b3b293
ER
27
28# enable mmx automatically on arches having it
29%ifarch %{ix86} %{x8664}
30%ifnarch i386 i486 i586 i686
31%define with_mmx 1
32%endif
33%endif
cb059bf8 34
ea76f0ee
ER
35#define _snap 20060905
36#define _rev 11046
2360417b 37%define _rel 0.5
b2c9e730
JB
38Summary: A personal video recorder (PVR) application
39Summary(pl): Osobista aplikacja do nagrywania obrazu (PVR)
910a00e3 40Name: mythtv
ea76f0ee 41Version: 0.20
f1992461 42Release: %{?_snap:0.%{_snap}.%{_rev}.}%{_rel}
910a00e3 43License: GPL v2
b2c9e730 44Group: Applications/Multimedia
ea76f0ee
ER
45Source0: http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
46# Source0-md5: 52bec1e0fadf7d24d6dcac3f773ddf74
47#Source0: %{name}-%{_snap}.%{_rev}.tar.bz2
eceeddea
ER
48Source1: mythbackend.sysconfig
49Source2: mythbackend.init
50Source3: mythbackend.logrotate
4cd4742b 51Source5: mythfrontend.desktop
2360417b 52#Patch100: %{name}-branch.diff
c79fdf07 53Patch0: %{name}-lib64.patch
f1992461 54Patch1: mythtv-configure.patch
96b717a5
ER
55Patch2: %{name}-mythstream.patch
56Patch3: %{name}-ldconfig.patch
1e5a2ed2 57#Patch4: %{name}-pl.patch
96b717a5 58Patch5: %{name}-sbinpath.patch
09985e5b 59Patch7: %{name}-optflags.patch
2360417b 60Patch8: mythtv-dvdnav-shared.patch
b2c9e730 61URL: http://www.mythtv.org/
5eccad13 62#BuildRequires: DirectFB-devel
96b717a5 63BuildRequires: XFree86-devel
ed630fed
JB
64%{?with_alsa:BuildRequires: alsa-lib-devel}
65%{?with_arts:BuildRequires: arts-devel >= 13:0.9.5}
c0517663 66BuildRequires: freetype-devel >= 1:2.0.0
cb059bf8 67%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
c0517663
ER
68BuildRequires: lame-libs-devel
69%{?with_xvmc:BuildRequires: libXvMCW-devel}
70%{?with_firewire:BuildRequires: libavc1394-devel}
96b717a5
ER
71%{?with_dvb:BuildRequires: libdvb-devel}
72BuildRequires: libdvdnav-devel
c0517663
ER
73%{?with_firewire:BuildRequires: libiec61883-devel}
74%{?with_firewire:BuildRequires: libraw1394-devel}
a3ec4ed6 75BuildRequires: linux-libc-headers >= 7:2.6.10
f3707f19 76%{?with_lirc:BuildRequires: lirc-devel}
ed630fed 77BuildRequires: mysql-devel
c0517663 78BuildRequires: patchutils
ed630fed
JB
79BuildRequires: qmake >= 6:3.2.1-4
80BuildRequires: qt-devel >= 6:3.2.1-4
4cd4742b 81BuildRequires: rpmbuild(macros) >= 1.228
ed630fed 82BuildRequires: sed >= 4.0
96b717a5
ER
83# for bundled libavcodec
84BuildRequires: libdts-devel
cccbdc0c 85#BuildConflicts: libmyth-devel
97b6efdd 86ExclusiveArch: %{ix86} %{x8664} ppc
910a00e3 87BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
8afae0cb 88
96b717a5
ER
89%define myth_api_version %(echo %{version} | cut -d. -f1,2)
90
8afae0cb 91%description
910a00e3
ER
92MythTV implements the following PVR features, and more, with a unified
93graphical interface:
5eccad13
ER
94- Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
95- Video compression using RTjpeg or MPEG-4
96- Program listing retrieval using XMLTV
97- Themable, semi-transparent on-screen display
98- Electronic program guide
99- Scheduled recording of TV programs
100- Resolution of conflicts between scheduled recordings
101- Basic video editing
8afae0cb 102
ed630fed
JB
103%description -l pl
104