]> git.pld-linux.org Git - packages/mythplugins.git/commitdiff
- rediff patches auto/th/mythplugins-0.26.1-10
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 26 Sep 2021 10:25:30 +0000 (12:25 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 26 Sep 2021 10:25:30 +0000 (12:25 +0200)
- fix rpm macro quoting
- fix building with gcc 11
- rel 10

gcc11.patch [new file with mode: 0644]
mythplugins-mytharchive-INT64.patch
mythplugins.spec
mythweb-chdir.patch

diff --git a/gcc11.patch b/gcc11.patch
new file mode 100644 (file)
index 0000000..f26e00d
--- /dev/null
@@ -0,0 +1,20 @@
+--- mythplugins-0.26.1/mythmusic/mythmusic/importmusic.cpp~    2013-08-15 16:44:02.000000000 +0200
++++ mythplugins-0.26.1/mythmusic/mythmusic/importmusic.cpp     2021-09-26 12:23:50.262781479 +0200
+@@ -1114,13 +1114,13 @@
+     QFileInfo fi(filename);
+     filename = fi.fileName();
+-    if (filename.contains("front", Qt::CaseInsensitive) > 0)
++    if (filename.contains("front", Qt::CaseInsensitive) != 0)
+         m_typeList->SetValue(tr("Front Cover"));
+-    else if (filename.contains("back", Qt::CaseInsensitive) > 0)
++    else if (filename.contains("back", Qt::CaseInsensitive) != 0)
+         m_typeList->SetValue(tr("Back Cover"));
+-    else if (filename.contains("inlay", Qt::CaseInsensitive) > 0)
++    else if (filename.contains("inlay", Qt::CaseInsensitive) != 0)
+         m_typeList->SetValue(tr("Inlay"));
+-    else if (filename.contains("cd", Qt::CaseInsensitive) > 0)
++    else if (filename.contains("cd", Qt::CaseInsensitive) != 0)
+         m_typeList->SetValue(tr("CD"));
+     else
+         m_typeList->SetValue(tr("<Unknown>"));
index c7628c66fbf564c25a9749f275cb14d7f39b35f2..15602b8a0b3a844714ab89c88f3e676609d3567f 100644 (file)
@@ -1,9 +1,9 @@
-diff -urN mythplugins-0.22.orig/mytharchive/mytharchivehelper/main.cpp mythplugins-0.22/mytharchive/mytharchivehelper/main.cpp
---- mythplugins-0.22.orig/mytharchive/mytharchivehelper/main.cpp       2009-02-12 13:53:35.000000000 +0100
-+++ mythplugins-0.22/mytharchive/mytharchivehelper/main.cpp    2009-02-12 18:00:33.000000000 +0100
-@@ -39,6 +39,10 @@
- // mytharchive headers
- #include "../mytharchive/archiveutil.h"
+diff -urNp -x '*.orig' mythplugins-0.26.1.org/mytharchive/mytharchivehelper/main.cpp mythplugins-0.26.1/mytharchive/mytharchivehelper/main.cpp
+--- mythplugins-0.26.1.org/mytharchive/mytharchivehelper/main.cpp      2013-08-15 16:44:02.000000000 +0200
++++ mythplugins-0.26.1/mytharchive/mytharchivehelper/main.cpp  2021-09-26 12:20:08.236252907 +0200
+@@ -103,6 +103,10 @@ namespace
+     };
+ }
  
 +#ifndef INT64_C    // Used in ffmpeg headers to define some constants
 +#define INT64_C(v)   (v ## LL)
index 9e7334d868113614f777ef04428084091f01a7f4..ee51ecaf9c24c890ef95fec264209136bb9168db 100644 (file)
@@ -30,7 +30,7 @@ Summary:      Main MythTV plugins
 Summary(pl.UTF-8):     Główne wtyczki MythTV
 Name:          mythplugins
 Version:       0.26.1
-Release:       9
+Release:       10
 License:       GPL v2
 Group:         Applications/Multimedia
 Source0:       ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
@@ -43,6 +43,7 @@ Source5:      mythweb-httpd.conf
 Patch0:                mythweb-chdir.patch
 Patch1:                system-zmq.patch
 Patch2:                cxx11.patch
+Patch3:                gcc11.patch
 Patch10:       %{name}-compile_fixes_for_qt_4_7.patch
 Patch20:       %{name}-mytharchive-INT64.patch
 URL:           http://www.mythtv.org/
@@ -294,11 +295,12 @@ Obsługa kamer przemysłowych dla MythTV.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 #%patch10 -p1
 %patch20 -p1
 
 # lib64 fix - enable to update patch
-%if %{_lib} != "lib" && 0
+%if "%{_lib}" != "lib" && 0
 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
 xargs grep -l /lib/ . | xargs sed -i -e '
 s,%{_prefix}/lib/,/%{_lib}/,g
index e0a17a936db1494fd71ac4edc835ec984b1c8e2f..1e56396cb130b308ca6c76bb455cbd067445b498 100644 (file)
@@ -1,7 +1,7 @@
-diff -dur -x'*~' mythplugins-0.22.orig/mythweb/mythweb.php mythplugins-0.22/mythweb/mythweb.php
---- mythplugins-0.22.orig/mythweb/mythweb.php  2009-01-20 07:42:03.000000000 +0100
-+++ mythplugins-0.22/mythweb/mythweb.php       2010-01-23 14:34:35.000000000 +0100
-@@ -12,6 +12,9 @@
+diff -urNp -x '*.orig' mythplugins-0.26.1.org/mythweb/mythweb.php mythplugins-0.26.1/mythweb/mythweb.php
+--- mythplugins-0.26.1.org/mythweb/mythweb.php 2013-06-26 23:10:02.000000000 +0200
++++ mythplugins-0.26.1/mythweb/mythweb.php     2021-09-26 12:19:53.182932909 +0200
+@@ -8,6 +8,9 @@
   *
  /**/
  
@@ -9,5 +9,5 @@ diff -dur -x'*~' mythplugins-0.22.orig/mythweb/mythweb.php mythplugins-0.22/myth
 +  chdir('/usr/share/mythweb');
 +
  // Add a custom include path?
-     if (!empty($_SERVER['include_path']) && $_SERVER['include_path'] != '.')
+     if (!empty($_SERVER['include_path']) && $_SERVER['include_path'] != '.') {
          ini_set('include_path', $_SERVER['include_path'].PATH_SEPARATOR.ini_get('include_path'));
This page took 0.069316 seconds and 4 git commands to generate.