]> git.pld-linux.org Git - packages/mythplugins.git/blobdiff - mythplugins.spec
- release 3 (by relup.sh)
[packages/mythplugins.git] / mythplugins.spec
index fb50e44be6b0d2a379d263703097357092aa0939..f2cd7fed85740af0dc23c05eb54349392b0837da 100644 (file)
 #
-# TODO:
-#      - fix mytharchive
-#      - check 64-bit build
-#
 # Conditional build:
 %bcond_without binary          # skip building binary plugins (build only mythweb)
-%bcond_with    mytharchive     # enable mytharchive plugin
-%bcond_without mythbrowser     # disable building mythbrowser plugin
-%bcond_without mythcontrols    # disable mythcontrols plugin
-%bcond_without mythflix        # disable building mythflix plugin
+%bcond_without mytharchive     # disable building mytharchive plugin
+%bcond_without mythbrowser     # disable building building mythbrowser plugin
+%bcond_without mythnetvision   # disable building mythnetvision plugin
 %bcond_without mythgallery     # disable building mythgallery plugin
-%bcond_without mythgame        # disable building mythgallery plugin
+%bcond_without mythgame        # disable building mythgame plugin
 %bcond_without mythmusic       # disable building mythmusic plugin
-%bcond_without mythnews        # disable building mythgallery plugin
-%bcond_without mythphone       # disable building mythgallery plugin
-%bcond_without mythvideo       # disable building mythgallery plugin
-%bcond_without mythweather     # disable building mythgallery plugin
-%bcond_without mythweb         # disable building mythgallery plugin
-%bcond_without mythmovies      # disable building mythmovies plugin
-%bcond_without mythzoneminder  # disable building mythzoneminder plugin
-#
-%if !%{with binary}
+%bcond_without mythnews        # disable building mythnews plugin
+# Mythweather disabled, as we need DateTime::Format::ISO8601 first
+# not present by default in PLD
+%bcond_with    mythweather     # enable building mythweather plugin
+%bcond_without mythweb         # disable building mythweb plugin
+%bcond_without  mythzoneminder  # disable building mythzoneminder plugin
+
+%if %{without binary}
 %undefine      with_mytharchive
 %undefine      with_mythbrowser
-%undefine      with_mythcontrols
-%undefine      with_mythflix
+%undefine      with_mythnetvision
 %undefine      with_mythgallery
 %undefine      with_mythgame
 %undefine      with_mythmusic
 %undefine      with_mythnews
-%undefine      with_mythphone
-%undefine      with_mythvideo
 %undefine      with_mythweather
-%undefine      with_mythmovies
-%undefine      with_mythzoneminder
 %endif
 
 %include       /usr/lib/rpm/macros.perl
 
-#define _snap 20060905
-#define _rev 11046
-%define _rel 0.1
 Summary:       Main MythTV plugins
 Summary(pl.UTF-8):     Główne wtyczki MythTV
 Name:          mythplugins
-Version:       0.21
-Release:       %{?_snap:0.%{_snap}.%{_rev}.}%{_rel}
+Version:       0.26.1
+Release:       3
 License:       GPL v2
 Group:         Applications/Multimedia
 Source0:       ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
-# Source0-md5: 6c08043227bef1384858deee12b5cdc3
-#Source0:      %{name}-%{_snap}.%{_rev}.tar.bz2
-Source1:       mythweb.conf
-Patch0:                %{name}-paths.patch
+# Source0-md5: d896d9f9313ba5dd95e2e977bf9c0f8f
+Source1:       mythweb-apache.conf
+Source2:       mythweb_lighttpd.conf
+Source3:       htdigest.sh
+Source4:       http_servers_conf_tips.txt
+Source5:       mythweb-httpd.conf
+Patch0:                mythweb-chdir.patch
+Patch1:                system-zmq.patch
+Patch10:       %{name}-compile_fixes_for_qt_4_7.patch
+Patch20:       %{name}-mytharchive-INT64.patch
 URL:           http://www.mythtv.org/
 %if %{with binary}
 %if %{with mythgallery} || %{with myhtmusic}
 BuildRequires: OpenGL-devel
 %endif
+BuildRequires: Qt3Support-devel
+BuildRequires: QtCore-devel
+BuildRequires: QtGui-devel
+BuildRequires: QtNetwork-devel
+BuildRequires: QtOpenGL-devel
+BuildRequires: QtSql-devel
+BuildRequires: QtWebKit-devel
+BuildRequires: QtXml-devel
 BuildRequires: SDL-devel
 BuildRequires: a52dec-libs-devel
-BuildRequires: cdparanoia-III-devel
 BuildRequires: faad2-devel >= 2.0-5.2
-%{?with_mythmusic:BuildRequires:       fftw-devel >= 2.1.3}
+%if %{with mythmusic}
+BuildRequires: cdparanoia-III-devel
+BuildRequires: fftw3-devel
+BuildRequires: fftw3-single-devel
 BuildRequires: flac-devel >= 1.0.4
-BuildRequires: freetype-devel
-BuildRequires: kdelibs-devel
+BuildRequires: lame-libs-devel
 BuildRequires: libcdaudio-devel >= 0.99.12p2
+BuildRequires: libvorbis-devel >= 1:1.0
+BuildRequires: taglib-devel
+%endif
+BuildRequires: freetype-devel
 BuildRequires: libdvdcss-devel >= 1.2.7
 BuildRequires: libdvdread-devel >= 0.9.4
 %{?with_mythgallery:BuildRequires:     libexif-devel >= 1:0.6.9}
 BuildRequires: libfame-devel >= 0.9.0
 BuildRequires: libid3tag-devel
 BuildRequires: libmad-devel
-BuildRequires: libmyth-devel >= 0.21
+BuildRequires: libmyth-devel > 0.26
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
-BuildRequires: libvorbis-devel >= 1:1.0
+BuildRequires: libvisual-devel
 BuildRequires: mjpegtools-devel >= 1.6.1
 BuildRequires: nasm
 BuildRequires: patchutils
+%{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
+%{?with_mythweather:BuildRequires:      perl-Image-Size}
+%{?with_mythweather:BuildRequires:     perl-XML-Simple}
+%{?with_mythweather:BuildRequires:      perl-XML-XPath}
+%if %{with mythnetvision}
+BuildRequires: python-MythTV
+BuildRequires: python-lxml
+BuildRequires: python-oauth
+%endif
+BuildRequires: qt4-build
+BuildRequires: qt4-qmake
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: sed >= 4.0
+%{?with_mythmusic:BuildRequires:        taglib-devel}
+BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xvid-devel >= 1:0.9.1
 BuildRequires: zlib-devel
-BuildRequires: xorg-lib-libXext-devel
-BuildRequires: xorg-lib-libXxf86vm-devel
 %endif
 %{?with_mytharchive:Requires:  mytharchive}
 %{?with_mythbrowser:Requires:  mythbrowser}
-%{?with_mythflix:Requires:     mythflix}
 %{?with_mythgallery:Requires:  mythgallery}
 %{?with_mythgame:Requires:     mythgame}
 %{?with_mythmysic:Requires:    mythmusic}
+%{?with_mythnetvision:Requires:        mythnetvision}
 %{?with_mythnews:Requires:     mythnews}
-%{?with_mythphone:Requires:    mythphone}
-%{?with_mythvideo:Requires:    mythvideo}
 %{?with_mythweather:Requires:  mythweather}
 %{?with_mythweb:Requires:      mythweb}
-%{?with_mythmovies:Requires:   mythmovies}
-%{?with_mythzoneminder:Requires:       mythzoneminder}
-ExclusiveArch: %{ix86} %{x8664} ppc
+Obsoletes:     mythdvd < %{version}-%{release}
+Obsoletes:     mythmovies < %{version}-%{release}
+Obsoletes:     mythvideo
+ExclusiveArch: %{ix86} %{x8664} x32 ppc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
+%define                myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
 %define                _webapps        /etc/webapps
 %define                _webapp         mythweb
 
@@ -119,7 +134,12 @@ wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
 Summary:       A MythTV module to create and burn DVDs
 Summary(pl.UTF-8):     Moduł MythTV do tworzenia i wypalania DVD
 Group:         Applications/Multimedia
+Requires:      dvdauthor
+Requires:      mjpegtools
 Requires:      mythtv-frontend-api = %{myth_api_version}
+Requires:      python-MySQLdb
+Requires:      python-PIL
+Suggests:      dvdrtools-mkisofs
 
 %description -n mytharchive
 MythArchive is a MythTV style plugin that uses the Mythburn Script to
@@ -143,23 +163,14 @@ Group:            Applications/Multimedia
 Requires:      mythtv-frontend-api = %{myth_api_version}
 
 %description -n mythmusic
-Music add-on for MythTV.
+Music add-on for MythTV. Support playlists, visualisations, tag
+editing and plays many popular audio file formats - mp3, flac, wav,
+ogg etc.
 
 %description -n mythmusic -l pl.UTF-8
-Odtwarzacz muzyki dla MythTV.
-
-%package -n mythvideo
-Summary:       A generic video player frontend module for MythTV
-Summary(pl.UTF-8):     Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
-Group:         Applications/Multimedia
-Requires:      mplayer
-Requires:      mythtv-frontend-api = %{myth_api_version}
-
-%description -n mythvideo
-A generic video player frontend module for MythTV.
-
-%description -n mythvideo -l pl.UTF-8
-Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
+Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
+wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
+formatów audio - mp3, flac, wav, ogg itd.
 
 %package -n mythweather
 Summary:       A MythTV module that displays a weather forcast
@@ -234,34 +245,15 @@ menu).
 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
 do stron w prostej wtyczce myth.
 
-%package -n mythphone
-Summary:       A video conferencing module for MythTV
-Summary(pl.UTF-8):     Moduł wideokonferencji dla MythTV
-Group:         Applications/Multimedia
-Requires:      mythtv-frontend-api = %{myth_api_version}
-
-%description -n mythphone
-Mythphone is a phone and videophone capability on Myth using the
-standard SIP protocol. It is compatible with Microsoft XP Messenger
-and with SIP Service Providers such as Free World Dialup
-(fwd.pulver.com).
-
-%description -n mythphone -l pl.UTF-8
-Mythphone to funkcjonalność telefonu i wideofonu w Myth przy użyciu
-standardowego protokołu SIP. Jest kompatybilny z Microsoft XP
-Messengerem oraz dostawcami usług SIP, takimi jak Free World Dialup
-(fwd.pulver.com).
-
 %package -n mythweb
 Summary:       The web interface to MythTV
 Summary(pl.UTF-8):     Interfejs WWW do MythTV
 Group:         Applications/Multimedia
-Requires:      webapps
-#Suggests:     apache(mod_auth)
-#Suggests:     apache(mod_env)
 Requires:      php(mysql)
 Requires:      php(posix)
+Requires:      webapps
 Requires:      webserver(php) >= 4.3
+Conflicts:     apache-base < 2.4.0-1
 
 %description -n mythweb
 The web interface to MythTV.
@@ -269,74 +261,47 @@ The web interface to MythTV.
 %description -n mythweb -l pl.UTF-8
 Interfejs WWW do MythTV.
 
-%package -n mythflix
-Summary:       MythFlix (A NetFlix MythTV)
-Summary(pl.UTF-8):     MythFlix (NetFlix MythTV)
+%package -n mythnetvision
+Summary:       Mythtv extension to watch network movie shows
+Summary(pl.UTF-8):     Dodatek do MythTV do oglądania sieciowych transmisji
 Group:         Applications/Multimedia
+Requires:      mythbrowser
 Requires:      mythtv-frontend-api = %{myth_api_version}
+Requires:      python-MythTV
+Requires:      python-oauth
 
-%description -n mythflix
-MythFlix is a MythTV plugin for adding movies to your Netflix queue.
-It currently supports the ability to view your queue and add movies to
-your queue. The browse feature is based on the Netflix RSS feeds. This
-plugin is not very mature, which means things might not work right
-and/or it might break other things.
-
-%description -n mythflix -l pl.UTF-8
-MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
-Aktualnie daje możliwość oglądania kolejki i dodawania do niej filmów.
-Przeglądanie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
-jeszcze zbyt dojrzała, co znaczy, że coś może nie działać lub psuć coś
-innego.
-
-%package -n mythcontrols
-Summary:       MythTV keybindings editor
-Summary(pl.UTF-8):     Edytor przypisań klawiszy MythTV
-Group:         Applications/Multimedia
-Requires:      mythtv-frontend-api = %{myth_api_version}
-
-%description -n mythcontrols
-This plugin allows you to configure your keybindings on the frontend
-without having to use mythweb or edit tables by hand.
-
-%description -n mythcontrols -l pl.UTF-8
-Ta wtyczka pozwala konfigurować przypisania klawiszy we frontendzie
-bez konieczności używania mythweba ani ręcznego modyfikowania tabel.
-
-%package -n mythmovies
-Summary:       MythTV plugin for looking up movie showtimes in a given area
-Group:         Applications/Multimedia
-Requires:      mythtv-frontend-api = %{myth_api_version}
+%description -n mythnetvision
+Mythtv extension to watch network movie shows (ex. YouTube).
 
-%description -n mythmovies
-MythMovies is a plugin for looking up movie showtimes in a given area. 
+%description -n mythnetvision -l pl.UTF-8
+Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
+YouTube.
 
 %package -n mythzoneminder
-Summary:       MythTV plugin to interface ZoneMinder
+Summary:       MythTV security TV manager
+Summary(pl.UTF-8):     Obsługa kamer przemysłowych dla MythTV
 Group:         Applications/Multimedia
 Requires:      mythtv-frontend-api = %{myth_api_version}
 
 %description -n mythzoneminder
-MythZoneMinder is a plugin to interface to some of the features of ZoneMinder.
-You can use it to view a status window similar to the console window in ZM.
-Also there are screens to view live camera shots and replay recorded events.
-Other features may be added at a later time if there is sufficient interest.
+MythTV security TV manager.
 
-ZoneMinder is a Linux video camera security and surveillance solution .
+
+%description -n mythzoneminder -l pl.UTF-8
+Obsługa kamer przemysłowych dla MythTV.
 
 %prep
-%setup -q %{?_snap:-n %{name}}
+%setup -q
 %patch0 -p1
-#filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
-
-# make it visible
-mv mythweb/{data/.,}htaccess
+%patch1 -p1
+#%patch10 -p1
+%patch20 -p1
 
 # lib64 fix - enable to update patch
 %if %{_lib} != "lib" && 0
 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
 xargs grep -l /lib/ . | xargs sed -i -e '
-       s,/usr/lib/,/usr/%{_lib}/,g
+s,%{_prefix}/lib/,/%{_lib}/,g
        s,{PREFIX}/lib,{PREFIX}/%{_lib},g
 '
 exit 1
@@ -347,7 +312,7 @@ exit 1
 export QTDIR="%{_prefix}"
 # Not gnu configure
 %configure \
-       --libdir-name=%{_lib} \
+       --libdir-name=`basename %{_lib}` \
        --enable-all \
        %{!?with_mytharchive:--disable-mytharchive} \
        %{!?with_mythbrowser:--disable-mythbrowser} \
@@ -355,12 +320,9 @@ export QTDIR="%{_prefix}"
        %{!?with_mythgame:--disable-mythgame} \
        %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
        %{!?with_mythnews:--disable-mythnews} \
-       %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
-       %{!?with_mythvideo:--disable-mythvideo} \
        %{!?with_mythweather:--disable-mythweather} \
        %{!?with_mythweb:--disable-mythweb} \
-       %{!?with_mythcontrols:--disable-mythcontrols} \
-       %{!?with_mythflix:--disable-mythflix} \
+       %{!?with_mythnetvision:--disable-mythnetvision} \
 
 mv mythconfig.mak mythconfig.mak.old
 cp mythconfig.mak.old mythconfig.mak
@@ -368,8 +330,8 @@ cat <<'EOF'>> mythconfig.mak
 QMAKE_CXX=%{__cxx}
 QMAKE_CC=%{__cc}
 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
-ECFLAGS=%{rpmcflags} -fomit-frame-pointer
-ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
+ECFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer
+ECXXFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer -D__STDC_CONSTANT_MACROS
 EOF
 
 %{__make}
@@ -377,13 +339,12 @@ EOF
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %if %{with binary}
 export QTDIR="%{_prefix}"
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
+install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,pictures}
 %if %{with mythgame}
 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
@@ -395,23 +356,26 @@ cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
 
 %if %{with mythweb}
 cd mythweb
+cp -a %{SOURCE3} ./
+cp -a %{SOURCE4} ./
 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
-cp -a *.php *.pl data includes js modules objects skins $RPM_BUILD_ROOT%{_datadir}/mythweb
+cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
+ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
-install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
+install %{SOURCE5} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
+install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
+touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
 cd -
 %endif
 
+rm -f $RPM_BUILD_ROOT%{_datadir}/data
 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
-rm $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythflix_nb.ts # i18n source
-for p in mytharchive mythbrowser mythcontrols mythflix mythgallery mythgame mythmusic mythnews mythphone mythvideo mythweather mythmovies mythzoneminder; do
+for p in mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythweather mythzoneminder; do
        for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
-               if [ -f "$l" ] ; then
-                       echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
-               fi
+               echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
        done > $p.lang
 done
 
@@ -424,12 +388,18 @@ rm -rf $RPM_BUILD_ROOT
 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
 %webapp_unregister apache %{_webapp}
 
-%triggerin -n mythweb -- apache < 2.2.0, apache-base
+%triggerin -n mythweb -- apache-base
 %webapp_register httpd %{_webapp}
 
-%triggerun -n mythweb -- apache < 2.2.0, apache-base
+%triggerin -n mythweb -- lighttpd
+%webapp_register lighttpd %{_webapp}
+
+%triggerun -n mythweb -- apache-base
 %webapp_unregister httpd %{_webapp}
 
+%triggerun -n mythweb -- lighttpd
+%webapp_unregister lighttpd %{_webapp}
+
 %triggerpostun -n mythweb -- mythweb < 0.19
 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
        if [ -f /etc/mythweb/$i.rpmsave ]; then
@@ -464,21 +434,28 @@ if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
        %service -q httpd reload
 fi
 
+%post -n mythweb
+echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
+which packages you can need to run mythweb and how to set it quickly."
+
 %files
 %defattr(644,root,root,755)
 
 %if %{with mytharchive}
 %files -n mytharchive -f mytharchive.lang
 %defattr(644,root,root,755)
+%doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
 %attr(755,root,root) %{_bindir}/mytharchivehelper
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
-%{_datadir}/mythtv/archiveformat.xml
 %{_datadir}/mythtv/archivemenu.xml
-%{_datadir}/mythtv/archiveselect.xml
+%{_datadir}/mythtv/archiveutils.xml
 %{_datadir}/mythtv/themes/default/ma_*.png
 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
+%{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
+%{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
+%{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
 %{_datadir}/mythtv/mytharchive
 %endif
 
@@ -490,10 +467,21 @@ fi
 /var/lib/mythmusic
 %{_datadir}/mythtv/musicmenu.xml
 %{_datadir}/mythtv/music_settings.xml
+%dir %{_datadir}/mythtv/mythmusic
+%{_datadir}/mythtv/mythmusic/streams.xml
+%{_datadir}/mythtv/themes/default/music-base.xml
 %{_datadir}/mythtv/themes/default/music-ui.xml
+%{_datadir}/mythtv/themes/default/musicsettings-ui.xml
+%{_datadir}/mythtv/themes/default/mm-titlelines.png
+%{_datadir}/mythtv/themes/default-wide/music-base.xml
+%{_datadir}/mythtv/themes/default-wide/music-ui.xml
+%{_datadir}/mythtv/themes/default-wide/musicsettings-ui.xml
+%{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
+%{_datadir}/mythtv/themes/default-wide/stream-ui.xml
 %{_datadir}/mythtv/themes/default/ff_button_off.png
 %{_datadir}/mythtv/themes/default/ff_button_on.png
 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
+%{_datadir}/mythtv/themes/default/miniplayer_background.png
 %{_datadir}/mythtv/themes/default/mm_*.png
 %{_datadir}/mythtv/themes/default/music-sel-bg.png
 %{_datadir}/mythtv/themes/default/next_button_off.png
@@ -516,41 +504,19 @@ fi
 %{_datadir}/mythtv/themes/default/stop_button_on.png
 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
 %{_datadir}/mythtv/themes/default/track_info_background.png
-%{_datadir}/mythtv/themes/default/miniplayer*.png
-%endif
-
-%if %{with mythvideo}
-%files -n mythvideo -f mythvideo.lang
-%defattr(644,root,root,755)
-%doc mythvideo/README mythvideo/videodb
-%attr(755,root,root) %{_bindir}/mtd
-%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
-%{_datadir}/mythtv/themes/default/dvd-ui.xml
-%{_datadir}/mythtv/themes/default/video-ui.xml
-%{_datadir}/mythtv/themes/default/mv-*.png
-%{_datadir}/mythtv/themes/default/mv_*.png
-%{_datadir}/mythtv/themes/default/md_*.png
-%{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
-%{_datadir}/mythtv/themes/default-wide/video-ui.xml
-%{_datadir}/mythtv/themes/default-wide/mv-*.png
-%{_datadir}/mythtv/themes/default-wide/mv_*.png
-%{_datadir}/mythtv/video_settings.xml
-%{_datadir}/mythtv/videomenu.xml
-%dir %{_datadir}/mythtv/mythvideo
-%dir %{_datadir}/mythtv/mythvideo/scripts
-%{_datadir}/mythtv/mythvideo/scripts/README
-%attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.pl
-%attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
-/var/lib/mythvideo
+%{_datadir}/mythtv/themes/default-wide/mm_*.png
+%{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
 %endif
 
 %if %{with mythweather}
 %files -n mythweather -f mythweather.lang
 %defattr(644,root,root,755)
-%doc mythweather/README
+%doc mythweather/AUTHORS mythweather/README
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
 %{_datadir}/mythtv/mythweather
+%{_datadir}/mythtv/weather_settings.xml
 %{_datadir}/mythtv/themes/default/weather-ui.xml
+%{_datadir}/mythtv/themes/default-wide/weather-ui.xml
 %{_datadir}/mythtv/themes/default/cloudy.png
 %{_datadir}/mythtv/themes/default/fair.png
 %{_datadir}/mythtv/themes/default/flurries.png
@@ -567,29 +533,32 @@ fi
 %{_datadir}/mythtv/themes/default/sunny.png
 %{_datadir}/mythtv/themes/default/thunshowers.png
 %{_datadir}/mythtv/themes/default/unknown.png
-%{_datadir}/mythtv/themes/default-wide/weather-ui.xml
 %{_datadir}/mythtv/themes/default-wide/mw-*.png
-%{_datadir}/mythtv/weather_settings.xml
 %endif
 
 %if %{with mythgallery}
 %files -n mythgallery -f mythgallery.lang
 %defattr(644,root,root,755)
-%doc mythgallery/README
+%doc mythgallery/AUTHORS mythgallery/README
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
 %{_datadir}/mythtv/themes/default/gallery-ui.xml
+%{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
 %{_datadir}/mythtv/themes/default/gallery-*.png
-# FIXME: this is definately stupid path
 /var/lib/pictures
 %endif
 
 %if %{with mythgame}
 %files -n mythgame -f mythgame.lang
 %defattr(644,root,root,755)
+%doc mythgame/contrib
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
 %{_datadir}/mythtv/games
 %{_datadir}/mythtv/game_settings.xml
 %{_datadir}/mythtv/themes/default/game-ui.xml
+%{_datadir}/mythtv/themes/default-wide/game-ui.xml
+%dir %{_datadir}/mythtv/metadata/Game
+%attr(755,root,root) %{_datadir}/mythtv/metadata/Game/giantbomb.py
+%{_datadir}/mythtv/metadata/Game/giantbomb
 %endif
 
 %if %{with mythnews}
@@ -599,42 +568,35 @@ fi
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
 %{_datadir}/mythtv/mythnews
 %{_datadir}/mythtv/themes/default/news-ui.xml
+%{_datadir}/mythtv/themes/default/news-info-bg.png
 %{_datadir}/mythtv/themes/default/enclosures.png
 %{_datadir}/mythtv/themes/default/need-download.png
-# DUPLICATE WITH MYTHFLIX?
-%{_datadir}/mythtv/themes/default/news-info-bg.png
+%{_datadir}/mythtv/themes/default/podcast.png
+%{_datadir}/mythtv/themes/default-wide/news-ui.xml
 %endif
 
 %if %{with mythbrowser}
 %files -n mythbrowser -f mythbrowser.lang
 %defattr(644,root,root,755)
 %doc mythbrowser/README mythbrowser/AUTHORS
-%attr(755,root,root) %{_bindir}/mythbrowser
-%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
-%{_datadir}/mythtv/themes/default/webpage.png
-%endif
-
-%if %{with mythphone}
-%files -n mythphone -f mythphone.lang
-%defattr(644,root,root,755)
-%doc mythphone/README mythphone/AUTHORS mythphone/TODO
-%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
-%{_datadir}/mythtv/themes/default/phone-ui.xml
-%{_datadir}/mythtv/themes/default/webcam-ui.xml
-%{_datadir}/mythtv/themes/default/mp_*.png
-%{_datadir}/mythtv/themes/default/phone.png
+%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
+%{_datadir}/mythtv/themes/default/mb_*.png
+%{_datadir}/mythtv/themes/default/browser-ui.xml
+%{_datadir}/mythtv/themes/default-wide/browser-ui.xml
 %endif
 
 %if %{with mythweb}
 %files -n mythweb
 %defattr(644,root,root,755)
-%doc mythweb/{README,INSTALL,data,htaccess,mythweb.conf.*}
+%doc mythweb/README mythweb/mythweb.conf.lighttpd
+%doc mythweb/htdigest.sh
+%doc mythweb/http_servers_conf_tips.txt
 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
-#%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
-#%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
+%attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
+%attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
 %{_datadir}/mythweb
 %dir %attr(771,root,http) /var/cache/mythweb
 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
@@ -642,50 +604,37 @@ fi
 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
 %endif
 
-%if %{with mythflix}
-%files -n mythflix -f mythflix.lang
-%defattr(644,root,root,755)
-%doc mythflix/{AUTHORS,ChangeLog,README}
-%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
-%dir %{_datadir}/mythtv/mythflix
-%{_datadir}/mythtv/mythflix/netflix-rss.xml
-%dir %{_datadir}/mythtv/mythflix/scripts
-%attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
-%{_datadir}/mythtv/netflix_menu.xml
-%{_datadir}/mythtv/themes/default/title_netflix.png
-%{_datadir}/mythtv/themes/default/netflix-ui.xml
-# DUPLICATE WITH MYTHNEWS?
-%{_datadir}/mythtv/themes/default/news-info-bg.png
-%endif
-
-%if %{with mythcontrols}
-%files -n mythcontrols -f mythcontrols.lang
+%if %{with mythnetvision}
+%files -n mythnetvision -f mythnetvision.lang
 %defattr(644,root,root,755)
-%doc mythcontrols/{AUTHORS,README,TODO}
-%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythcontrols.so
-%{_datadir}/mythtv/themes/default/controls-ui.xml
-%{_datadir}/mythtv/themes/default/kb-button-off.png
-%{_datadir}/mythtv/themes/default/kb-button-on.png
-%endif
-
-%if %{with mythmovies}
-%files -n mythmovies -f mythmovies.lang
-%defattr(644,root,root,755)
-%doc mythmovies/{README,TODO}
-%attr(755,root,root) %{_bindir}/ignyte
-%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
-%{_datadir}/mythtv/themes/default/movies-ui.xml
-%{_datadir}/mythtv/themes/default-wide/movies-ui.xml
+%doc mythnetvision/{AUTHORS,ChangeLog,README}
+%attr(755,root,root) %{_bindir}/mythfillnetvision
+%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
+%dir %{_datadir}/mythtv/mythnetvision
+%{_datadir}/mythtv/netvisionmenu.xml
+%dir %{_datadir}/mythtv/mythnetvision/icons
+%dir %{_datadir}/mythtv/mythnetvision/icons/directories
+%{_datadir}/mythtv/mythnetvision/icons/*.png
+%dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
+%{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
+%dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
+%{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
+%dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
+%{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
+%{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
+%{_datadir}/mythtv/themes/default/netvision-ui.xml
 %endif
 
 %if %{with mythzoneminder}
-%files -n mythzoneminder -f mythzoneminder.lang
+%files -n mythzoneminder
+%defattr(644,root,root,755)
 %defattr(644,root,root,755)
-%doc mythzoneminder/{README,AUTHORS}
+%doc mythzoneminder/{AUTHORS,README}
 %attr(755,root,root) %{_bindir}/mythzmserver
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
+%dir %{_datadir}/mythtv/zonemindermenu.xml
 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
-%{_datadir}/mythtv/themes/default/mz_*.png
-%{_datadir}/mythtv/zonemindermenu.xml
+%{_datadir}/mythtv/themes/default/mz_*png
+%{_datadir}/mythtv/i18n/mythzoneminder_*.qm
 %endif
This page took 0.065239 seconds and 4 git commands to generate.