]> git.pld-linux.org Git - packages/mythplugins.git/blobdiff - mythplugins.spec
- release 3 (by relup.sh)
[packages/mythplugins.git] / mythplugins.spec
index 21ed4d45ca450a1e2a20d550e19341d9c50fcbc3..f2cd7fed85740af0dc23c05eb54349392b0837da 100644 (file)
@@ -1,56 +1,48 @@
 #
 # Conditional build:
 %bcond_without binary          # skip building binary plugins (build only mythweb)
-%bcond_without mytharchive     # disable mytharchive plugin
-%bcond_without mythbrowser     # disable building mythbrowser plugin
-%bcond_without mythmovies      # disable mythmovies plugin
-%bcond_without mythdvd         # mythvideo part
+%bcond_without mytharchive     # disable building mytharchive plugin
+%bcond_without mythbrowser     # disable building building mythbrowser plugin
 %bcond_without mythnetvision   # disable building mythnetvision plugin
 %bcond_without mythgallery     # disable building mythgallery plugin
-%bcond_without mythgame        # disable building mythgallery plugin
+%bcond_without mythgame        # disable building mythgame plugin
 %bcond_without mythmusic       # disable building mythmusic plugin
-%bcond_without mythnews        # disable building mythgallery plugin
-%bcond_without mythvideo       # disable building mythgallery plugin
+%bcond_without mythnews        # disable building mythnews plugin
 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
 # not present by default in PLD
-%bcond_with    mythweather     # building mythgallery plugin disabled by default
-                               # it looks unusable "due to msnbc webpage structure change
-%bcond_without mythweb         # disable building mythgallery plugin
+%bcond_with    mythweather     # enable building mythweather plugin
+%bcond_without mythweb         # disable building mythweb plugin
 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
 
-%if !%{with binary}
+%if %{without binary}
 %undefine      with_mytharchive
 %undefine      with_mythbrowser
-%undefine      with_mythmovies
-%undefine      with_mythdvd
 %undefine      with_mythnetvision
 %undefine      with_mythgallery
 %undefine      with_mythgame
 %undefine      with_mythmusic
 %undefine      with_mythnews
-%undefine      with_mythvideo
 %undefine      with_mythweather
 %endif
 
 %include       /usr/lib/rpm/macros.perl
 
-#%define fix     24635
-
 Summary:       Main MythTV plugins
 Summary(pl.UTF-8):     Główne wtyczki MythTV
 Name:          mythplugins
-Version:       0.23.1
-Release:       2
-#Release:      fix%{fix}.1
+Version:       0.26.1
+Release:       3
 License:       GPL v2
 Group:         Applications/Multimedia
 Source0:       ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
-# Source0-md5: edd9c5f8a9ae0189b1c8951fa8282c4d
-Source1:       mythweb.conf
+# Source0-md5: d896d9f9313ba5dd95e2e977bf9c0f8f
+Source1:       mythweb-apache.conf
 Source2:       mythweb_lighttpd.conf
 Source3:       htdigest.sh
 Source4:       http_servers_conf_tips.txt
+Source5:       mythweb-httpd.conf
 Patch0:                mythweb-chdir.patch
+Patch1:                system-zmq.patch
 Patch10:       %{name}-compile_fixes_for_qt_4_7.patch
 Patch20:       %{name}-mytharchive-INT64.patch
 URL:           http://www.mythtv.org/
@@ -68,22 +60,28 @@ BuildRequires:      QtWebKit-devel
 BuildRequires: QtXml-devel
 BuildRequires: SDL-devel
 BuildRequires: a52dec-libs-devel
-BuildRequires: cdparanoia-III-devel
 BuildRequires: faad2-devel >= 2.0-5.2
-%{?with_mythmusic:BuildRequires:       fftw-devel >= 2.1.3}
+%if %{with mythmusic}
+BuildRequires: cdparanoia-III-devel
+BuildRequires: fftw3-devel
+BuildRequires: fftw3-single-devel
 BuildRequires: flac-devel >= 1.0.4
-BuildRequires: freetype-devel
+BuildRequires: lame-libs-devel
 BuildRequires: libcdaudio-devel >= 0.99.12p2
+BuildRequires: libvorbis-devel >= 1:1.0
+BuildRequires: taglib-devel
+%endif
+BuildRequires: freetype-devel
 BuildRequires: libdvdcss-devel >= 1.2.7
 BuildRequires: libdvdread-devel >= 0.9.4
 %{?with_mythgallery:BuildRequires:     libexif-devel >= 1:0.6.9}
 BuildRequires: libfame-devel >= 0.9.0
 BuildRequires: libid3tag-devel
 BuildRequires: libmad-devel
-BuildRequires: libmyth-devel > 0.21
+BuildRequires: libmyth-devel > 0.26
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
-BuildRequires: libvorbis-devel >= 1:1.0
+BuildRequires: libvisual-devel
 BuildRequires: mjpegtools-devel >= 1.6.1
 BuildRequires: nasm
 BuildRequires: patchutils
@@ -91,28 +89,33 @@ BuildRequires:      patchutils
 %{?with_mythweather:BuildRequires:      perl-Image-Size}
 %{?with_mythweather:BuildRequires:     perl-XML-Simple}
 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
+%if %{with mythnetvision}
+BuildRequires: python-MythTV
+BuildRequires: python-lxml
+BuildRequires: python-oauth
+%endif
 BuildRequires: qt4-build
 BuildRequires: qt4-qmake
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: sed >= 4.0
 %{?with_mythmusic:BuildRequires:        taglib-devel}
-%{?with_mythdvd:BuildRequires: transcode >= 0.6.8}
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xvid-devel >= 1:0.9.1
 BuildRequires: zlib-devel
 %endif
 %{?with_mytharchive:Requires:  mytharchive}
 %{?with_mythbrowser:Requires:  mythbrowser}
-%{?with_mythdvd:Requires:      mythdvd}
 %{?with_mythgallery:Requires:  mythgallery}
 %{?with_mythgame:Requires:     mythgame}
 %{?with_mythmysic:Requires:    mythmusic}
 %{?with_mythnetvision:Requires:        mythnetvision}
 %{?with_mythnews:Requires:     mythnews}
-%{?with_mythvideo:Requires:    mythvideo}
 %{?with_mythweather:Requires:  mythweather}
 %{?with_mythweb:Requires:      mythweb}
-ExclusiveArch: %{ix86} %{x8664} ppc
+Obsoletes:     mythdvd < %{version}-%{release}
+Obsoletes:     mythmovies < %{version}-%{release}
+Obsoletes:     mythvideo
+ExclusiveArch: %{ix86} %{x8664} x32 ppc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
@@ -157,7 +160,6 @@ związane z nimi metadane.
 Summary:       The music player add-on module for MythTV
 Summary(pl.UTF-8):     Moduł odtwarzacza muzyki dla MythTV
 Group:         Applications/Multimedia
-BuildRequires: libvisual-devel
 Requires:      mythtv-frontend-api = %{myth_api_version}
 
 %description -n mythmusic
@@ -170,19 +172,6 @@ Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
 formatów audio - mp3, flac, wav, ogg itd.
 
-%package -n mythvideo
-Summary:       A generic video player frontend module for MythTV
-Summary(pl.UTF-8):     Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
-Group:         Applications/Multimedia
-Requires:      mplayer
-Requires:      mythtv-frontend-api = %{myth_api_version}
-
-%description -n mythvideo
-A generic video and dvd player frontend module for MythTV.
-
-%description -n mythvideo -l pl.UTF-8
-Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
-
 %package -n mythweather
 Summary:       A MythTV module that displays a weather forcast
 Summary(pl.UTF-8):     Moduł MythTV wyświetlający prognozę pogody
@@ -219,29 +208,6 @@ A game frontend (xmame, nes, snes, pc) for MythTV.
 %description -n mythgame -l pl.UTF-8
 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
 
-%package -n mythdvd
-Summary:       A DVD ripper module for MythTV
-Summary(pl.UTF-8):     Moduł rippujący DVD dla MythTV
-Group:         Applications/Multimedia
-Requires:      mythtv-frontend-api = %{myth_api_version}
-Requires:      mythvideo
-Requires:      transcode >= 0.6.8
-
-%description -n mythdvd
-MythDVD is a MythTV module that allows you to rip DVD's and transcode
-their video and audio content to other (generally smaller) formats.
-The playing features are simply myth-style wrappers for your favourite
-DVD playing software (mplayer, ogle, xine, etc). The transcoding is
-based on and derived from the excellent transcode package.
-
-%description -n mythdvd -l pl.UTF-8
-MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
-przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
-formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
-dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
-itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
-pakietu transcode.
-
 %package -n mythnews
 Summary:       A RSS News Feed plugin for MythTV
 Summary(pl.UTF-8):     Wtyczka czytnika nowinek RSS dla MythTV
@@ -287,6 +253,7 @@ Requires:   php(mysql)
 Requires:      php(posix)
 Requires:      webapps
 Requires:      webserver(php) >= 4.3
+Conflicts:     apache-base < 2.4.0-1
 
 %description -n mythweb
 The web interface to MythTV.
@@ -300,6 +267,8 @@ Summary(pl.UTF-8):  Dodatek do MythTV do oglądania sieciowych transmisji
 Group:         Applications/Multimedia
 Requires:      mythbrowser
 Requires:      mythtv-frontend-api = %{myth_api_version}
+Requires:      python-MythTV
+Requires:      python-oauth
 
 %description -n mythnetvision
 Mythtv extension to watch network movie shows (ex. YouTube).
@@ -308,19 +277,6 @@ Mythtv extension to watch network movie shows (ex. YouTube).
 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
 YouTube.
 
-%package -n mythmovies
-Summary:       MythTV cinemas timetable
-Summary(pl.UTF-8):     Moduł MythTV do repertuaru kinowego
-Group:         Applications/Multimedia
-Requires:      mythtv-frontend-api = %{myth_api_version}
-
-%description -n mythmovies
-MythTV cinemas timetable.
-
-
-%description -n mythmovies -l pl.UTF-8
-Moduł MythTV do repertuaru kinowego.
-
 %package -n mythzoneminder
 Summary:       MythTV security TV manager
 Summary(pl.UTF-8):     Obsługa kamer przemysłowych dla MythTV
@@ -337,7 +293,8 @@ Obsługa kamer przemysłowych dla MythTV.
 %prep
 %setup -q
 %patch0 -p1
-%patch10 -p1
+%patch1 -p1
+#%patch10 -p1
 %patch20 -p1
 
 # lib64 fix - enable to update patch
@@ -359,15 +316,12 @@ export QTDIR="%{_prefix}"
        --enable-all \
        %{!?with_mytharchive:--disable-mytharchive} \
        %{!?with_mythbrowser:--disable-mythbrowser} \
-       %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
        %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
        %{!?with_mythgame:--disable-mythgame} \
        %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
        %{!?with_mythnews:--disable-mythnews} \
-       %{!?with_mythvideo:--disable-mythvideo} \
        %{!?with_mythweather:--disable-mythweather} \
        %{!?with_mythweb:--disable-mythweb} \
-       %{!?with_mythmovies:--disable-mythmovies} \
        %{!?with_mythnetvision:--disable-mythnetvision} \
 
 mv mythconfig.mak mythconfig.mak.old
@@ -376,8 +330,8 @@ cat <<'EOF'>> mythconfig.mak
 QMAKE_CXX=%{__cxx}
 QMAKE_CC=%{__cc}
 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
-ECFLAGS=%{rpmcflags} -fomit-frame-pointer
-ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
+ECFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer
+ECXXFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer -D__STDC_CONSTANT_MACROS
 EOF
 
 %{__make}
@@ -390,7 +344,7 @@ export QTDIR="%{_prefix}"
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
+install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,pictures}
 %if %{with mythgame}
 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
@@ -410,7 +364,7 @@ install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
-install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
+install %{SOURCE5} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
@@ -419,7 +373,7 @@ cd -
 
 rm -f $RPM_BUILD_ROOT%{_datadir}/data
 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
-for p in mytharchive mythbrowser mythmovies mythdvd mythgallery mythgame mythmusic mythnews mythnetvision mythvideo mythweather mythzoneminder; do
+for p in mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythweather mythzoneminder; do
        for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
                echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
        done > $p.lang
@@ -434,13 +388,13 @@ rm -rf $RPM_BUILD_ROOT
 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
 %webapp_unregister apache %{_webapp}
 
-%triggerin -n mythweb -- apache < 2.2.0, apache-base
+%triggerin -n mythweb -- apache-base
 %webapp_register httpd %{_webapp}
 
 %triggerin -n mythweb -- lighttpd
 %webapp_register lighttpd %{_webapp}
 
-%triggerun -n mythweb -- apache < 2.2.0, apache-base
+%triggerun -n mythweb -- apache-base
 %webapp_unregister httpd %{_webapp}
 
 %triggerun -n mythweb -- lighttpd
@@ -490,6 +444,7 @@ which packages you can need to run mythweb and how to set it quickly."
 %if %{with mytharchive}
 %files -n mytharchive -f mytharchive.lang
 %defattr(644,root,root,755)
+%doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
 %attr(755,root,root) %{_bindir}/mytharchivehelper
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
 %{_datadir}/mythtv/archivemenu.xml
@@ -512,10 +467,17 @@ which packages you can need to run mythweb and how to set it quickly."
 /var/lib/mythmusic
 %{_datadir}/mythtv/musicmenu.xml
 %{_datadir}/mythtv/music_settings.xml
+%dir %{_datadir}/mythtv/mythmusic
+%{_datadir}/mythtv/mythmusic/streams.xml
+%{_datadir}/mythtv/themes/default/music-base.xml
 %{_datadir}/mythtv/themes/default/music-ui.xml
+%{_datadir}/mythtv/themes/default/musicsettings-ui.xml
 %{_datadir}/mythtv/themes/default/mm-titlelines.png
+%{_datadir}/mythtv/themes/default-wide/music-base.xml
 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
+%{_datadir}/mythtv/themes/default-wide/musicsettings-ui.xml
 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
+%{_datadir}/mythtv/themes/default-wide/stream-ui.xml
 %{_datadir}/mythtv/themes/default/ff_button_off.png
 %{_datadir}/mythtv/themes/default/ff_button_on.png
 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
@@ -546,37 +508,10 @@ which packages you can need to run mythweb and how to set it quickly."
 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
 %endif
 
-%if %{with mythvideo}
-%files -n mythvideo -f mythvideo.lang
-%defattr(644,root,root,755)
-%doc mythvideo/README mythvideo/videodb
-%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
-%{_datadir}/mythtv/themes/default/video-ui.xml
-%{_datadir}/mythtv/themes/default-wide/video-ui.xml
-%{_datadir}/mythtv/themes/default/mv_*.png
-%{_datadir}/mythtv/themes/default-wide/mv_*.png
-%{_datadir}/mythtv/video_settings.xml
-%{_datadir}/mythtv/videomenu.xml
-%dir %{_datadir}/mythtv/mythvideo
-%dir %{_datadir}/mythtv/mythvideo/scripts
-%dir %{_datadir}/mythtv/mythvideo/scripts/Movie
-%dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
-%dir %{_datadir}/mythtv/mythvideo/scripts/Television
-%{_datadir}/mythtv/mythvideo/scripts/README
-%{_datadir}/mythtv/mythvideo/scripts/jamu.README
-%{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
-%attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.pl
-%attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.py
-%{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
-%attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
-%{_datadir}/mythtv/mythvideo/scripts/Television/*
-/var/lib/mythvideo
-%endif
-
 %if %{with mythweather}
 %files -n mythweather -f mythweather.lang
 %defattr(644,root,root,755)
-%doc mythweather/README
+%doc mythweather/AUTHORS mythweather/README
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
 %{_datadir}/mythtv/mythweather
 %{_datadir}/mythtv/weather_settings.xml
@@ -604,33 +539,26 @@ which packages you can need to run mythweb and how to set it quickly."
 %if %{with mythgallery}
 %files -n mythgallery -f mythgallery.lang
 %defattr(644,root,root,755)
-%doc mythgallery/README
+%doc mythgallery/AUTHORS mythgallery/README
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
 %{_datadir}/mythtv/themes/default/gallery-ui.xml
 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
 %{_datadir}/mythtv/themes/default/gallery-*.png
-# FIXME: this is definately stupid path
 /var/lib/pictures
 %endif
 
 %if %{with mythgame}
 %files -n mythgame -f mythgame.lang
 %defattr(644,root,root,755)
-#%doc mythgame/README
+%doc mythgame/contrib
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
 %{_datadir}/mythtv/games
 %{_datadir}/mythtv/game_settings.xml
 %{_datadir}/mythtv/themes/default/game-ui.xml
 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
-%endif
-
-%if %{with mythdvd}
-%files -n mythdvd
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/mtd
-%{_datadir}/mythtv/themes/default/dvd-ui.xml
-%{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
-%{_datadir}/mythtv/themes/default/md_*.png
+%dir %{_datadir}/mythtv/metadata/Game
+%attr(755,root,root) %{_datadir}/mythtv/metadata/Game/giantbomb.py
+%{_datadir}/mythtv/metadata/Game/giantbomb
 %endif
 
 %if %{with mythnews}
@@ -640,7 +568,6 @@ which packages you can need to run mythweb and how to set it quickly."
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
 %{_datadir}/mythtv/mythnews
 %{_datadir}/mythtv/themes/default/news-ui.xml
-# DUPLICATE WITH MYTHFLIX?
 %{_datadir}/mythtv/themes/default/news-info-bg.png
 %{_datadir}/mythtv/themes/default/enclosures.png
 %{_datadir}/mythtv/themes/default/need-download.png
@@ -652,9 +579,8 @@ which packages you can need to run mythweb and how to set it quickly."
 %files -n mythbrowser -f mythbrowser.lang
 %defattr(644,root,root,755)
 %doc mythbrowser/README mythbrowser/AUTHORS
-#%attr(755,root,root) %{_bindir}/mythbrowser
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
-%{_datadir}/mythtv/themes/default/mb_progress*.png
+%{_datadir}/mythtv/themes/default/mb_*.png
 %{_datadir}/mythtv/themes/default/browser-ui.xml
 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
 %endif
@@ -668,8 +594,6 @@ which packages you can need to run mythweb and how to set it quickly."
 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
-#%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
-#%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
@@ -684,45 +608,26 @@ which packages you can need to run mythweb and how to set it quickly."
 %files -n mythnetvision -f mythnetvision.lang
 %defattr(644,root,root,755)
 %doc mythnetvision/{AUTHORS,ChangeLog,README}
+%attr(755,root,root) %{_bindir}/mythfillnetvision
 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
 %dir %{_datadir}/mythtv/mythnetvision
 %{_datadir}/mythtv/netvisionmenu.xml
-%dir %{_datadir}/mythtv/mythnetvision/scripts
-%attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/twit.tv.pl
 %dir %{_datadir}/mythtv/mythnetvision/icons
 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
 %{_datadir}/mythtv/mythnetvision/icons/*.png
-%{_datadir}/mythtv/mythnetvision/icons/vimeo.jpg
 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
-%attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/*.py
-%dir %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs
-%{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs/*
 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
 %{_datadir}/mythtv/themes/default/netvision-ui.xml
 %endif
 
-%if %{with mythmovies}
-%files -n mythmovies
-%defattr(644,root,root,755)
-#-f mythmovies.lang
-%defattr(644,root,root,755)
-%doc mythmovies/{README,TODO}
-%attr(755,root,root) %{_bindir}/ignyte
-%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
-%{_datadir}/mythtv/themes/default/movies-ui.xml
-%{_datadir}/mythtv/themes/default-wide/movies-ui.xml
-%{_datadir}/mythtv/i18n/mythmovies_*.qm
-%endif
-
 %if %{with mythzoneminder}
 %files -n mythzoneminder
 %defattr(644,root,root,755)
-#-f mythmovies.lang
 %defattr(644,root,root,755)
 %doc mythzoneminder/{AUTHORS,README}
 %attr(755,root,root) %{_bindir}/mythzmserver
This page took 0.110411 seconds and 4 git commands to generate.