]> git.pld-linux.org Git - packages/mythplugins.git/blobdiff - mythplugins.spec
- a little correction to api definition
[packages/mythplugins.git] / mythplugins.spec
index f73c00c0f5f49507366644fff77c0b65492105fe..899708f380a84f2b23330314d7a889f68f124e95 100644 (file)
@@ -11,7 +11,9 @@
 %bcond_without mythmusic       # disable building mythmusic plugin
 %bcond_without mythnews        # disable building mythgallery plugin
 %bcond_without mythvideo       # disable building mythgallery plugin
-%bcond_without mythweather     # building mythgallery plugin disabled by default
+# Mythweather disabled, as we need DateTime::Format::ISO8601 first
+# not present by default in PLD
+%bcond_with    mythweather     # building mythgallery plugin disabled by default
                                # it looks unusable "due to msnbc webpage structure change
 %bcond_without mythweb         # disable building mythgallery plugin
 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
 Summary:       Main MythTV plugins
 Summary(pl.UTF-8):     Główne wtyczki MythTV
 Name:          mythplugins
-Version:       0.23
+Version:       0.23.1
 #Release:      fix%{fix}.1
-Release:       0.2
+Release:       2
 License:       GPL v2
 Group:         Applications/Multimedia
 Source0:       ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
-# Source0-md5: be44db841f9e03d0d17ab449545b38aa
+# Source0-md5: edd9c5f8a9ae0189b1c8951fa8282c4d
 Source1:       mythweb.conf
 Source2:        mythweb_lighttpd.conf
 Source3:       htdigest.sh
@@ -51,6 +53,7 @@ Source4:      http_servers_conf_tips.txt
 #Patch0: %{name}-lib64.patch
 #Patch1: %{name}-paths.patch
 Patch2:                mythweb-chdir.patch
+Patch3:                %{name}-compile_fixes_for_qt_4_7.patch
 Patch20:       %{name}-mytharchive-INT64.patch
 #Patch21:      mythmusic_fftw3.patch
 #Patch100:     mythtv-branch.diff
@@ -88,6 +91,10 @@ BuildRequires:       libvorbis-devel >= 1:1.0
 BuildRequires: mjpegtools-devel >= 1.6.1
 BuildRequires: nasm
 BuildRequires: patchutils
+%{?with_mythweather:BuildRequires:     perl-XML-Simple}
+%{?with_mythweather:BuildRequires:      perl-XML-XPath}
+%{?with_mythweather:BuildRequires:      perl-Image-Size}
+%{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
 BuildRequires: qt4-build
 BuildRequires: qt4-qmake
 BuildRequires: rpm-perlprov >= 4.1-13
@@ -112,7 +119,7 @@ BuildRequires:      zlib-devel
 ExclusiveArch: %{ix86} %{x8664} ppc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
+%define                myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
 %define                _webapps        /etc/webapps
 %define                _webapp         mythweb
 
@@ -340,6 +347,7 @@ Obsługa kamer przemysłowych dla MythTV.
 #%endif
 #%patch1 -p1
 %patch2 -p1
+%patch3 -p1
 %patch20 -p1
 #%patch21 -p1
 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
@@ -414,17 +422,13 @@ cp -a %{SOURCE4} ./
 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
-install -d $RPM_BUILD_ROOT/etc/lighthttpd/webapps.d
-#install -d $RPM_BUILD_ROOT%{_docdir}/mythweb-%{version}
 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
-ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/data
+ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/lighthttpd/webapps.d/mythweb.conf
-#install %{SOURCE3} $RPM_BUILD_ROOT%{_docdir}/mythweb-%{version}/htdigest.sh
-#install %{SOURCE4} $RPM_BUILD_ROOT%{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt
+install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
-touch $RPM_BUILD_ROOT%{_datadir}/mythweb/htdigest
+touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
 cd -
 %endif
 
@@ -448,9 +452,15 @@ rm -rf $RPM_BUILD_ROOT
 %triggerin -n mythweb -- apache < 2.2.0, apache-base
 %webapp_register httpd %{_webapp}
 
+%triggerin -n mythweb -- lighttpd
+%webapp_register lighttpd %{_webapp}
+
 %triggerun -n mythweb -- apache < 2.2.0, apache-base
 %webapp_unregister httpd %{_webapp}
 
+%triggerun -n mythweb -- lighttpd
+%webapp_unregister lighttpd %{_webapp}
+
 %triggerpostun -n mythweb -- mythweb < 0.19
 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
        if [ -f /etc/mythweb/$i.rpmsave ]; then
@@ -670,15 +680,14 @@ which packages you can need to run mythweb and how to set it quickly."
 %doc mythweb/README mythweb/mythweb.conf.lighttpd
 %doc mythweb/htdigest.sh
 %doc mythweb/http_servers_conf_tips.txt
-
-#%doc mythweb/data/htaccess
 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/lighthttpd/webapps.d/mythweb.conf
+%attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
+%attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
 %{_datadir}/mythweb
 %dir %attr(771,root,http) /var/cache/mythweb
 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
This page took 0.038212 seconds and 4 git commands to generate.