]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
fe36f01fa95c29ae5658dac6ab3169860511407e
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythnetvision   # disable building mythnetvision plugin
7 %bcond_without  mythgallery     # disable building mythgallery plugin
8 %bcond_without  mythgame        # disable building mythgame plugin
9 %bcond_without  mythmusic       # disable building mythmusic plugin
10 %bcond_without  mythnews        # disable building mythnews plugin
11 %bcond_without  mythvideo       # disable building mythvideo plugin
12 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
13 # not present by default in PLD
14 %bcond_with     mythweather     # enable building mythweather plugin
15 %bcond_without  mythweb         # disable building mythweb plugin
16 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
17
18 %if %{without binary}
19 %undefine       with_mytharchive
20 %undefine       with_mythbrowser
21 %undefine       with_mythnetvision
22 %undefine       with_mythgallery
23 %undefine       with_mythgame
24 %undefine       with_mythmusic
25 %undefine       with_mythnews
26 %undefine       with_mythvideo
27 %undefine       with_mythweather
28 %endif
29
30 %include        /usr/lib/rpm/macros.perl
31
32 Summary:        Main MythTV plugins
33 Summary(pl.UTF-8):      Główne wtyczki MythTV
34 Name:           mythplugins
35 Version:        0.26.0
36 Release:        0.1
37 License:        GPL v2
38 Group:          Applications/Multimedia
39 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
40 # Source0-md5:  15bd7b2f4173488966f3d761e0eacffa
41 Source1:        mythweb-apache.conf
42 Source2:        mythweb_lighttpd.conf
43 Source3:        htdigest.sh
44 Source4:        http_servers_conf_tips.txt
45 Source5:        mythweb-httpd.conf
46 Patch0:         mythweb-chdir.patch
47 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
48 Patch20:        %{name}-mytharchive-INT64.patch
49 URL:            http://www.mythtv.org/
50 %if %{with binary}
51 %if %{with mythgallery} || %{with myhtmusic}
52 BuildRequires:  OpenGL-devel
53 %endif
54 BuildRequires:  Qt3Support-devel
55 BuildRequires:  QtCore-devel
56 BuildRequires:  QtGui-devel
57 BuildRequires:  QtNetwork-devel
58 BuildRequires:  QtOpenGL-devel
59 BuildRequires:  QtSql-devel
60 BuildRequires:  QtWebKit-devel
61 BuildRequires:  QtXml-devel
62 BuildRequires:  SDL-devel
63 BuildRequires:  a52dec-libs-devel
64 BuildRequires:  cdparanoia-III-devel
65 BuildRequires:  faad2-devel >= 2.0-5.2
66 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
67 BuildRequires:  flac-devel >= 1.0.4
68 BuildRequires:  freetype-devel
69 BuildRequires:  libcdaudio-devel >= 0.99.12p2
70 BuildRequires:  libdvdcss-devel >= 1.2.7
71 BuildRequires:  libdvdread-devel >= 0.9.4
72 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
73 BuildRequires:  libfame-devel >= 0.9.0
74 BuildRequires:  libid3tag-devel
75 BuildRequires:  libmad-devel
76 BuildRequires:  libmyth-devel > 0.26
77 BuildRequires:  libstdc++-devel
78 BuildRequires:  libtiff-devel
79 BuildRequires:  libvisual-devel
80 BuildRequires:  libvorbis-devel >= 1:1.0
81 BuildRequires:  mjpegtools-devel >= 1.6.1
82 BuildRequires:  nasm
83 BuildRequires:  patchutils
84 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
85 %{?with_mythweather:BuildRequires:      perl-Image-Size}
86 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
87 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
88 %{?with_mythnetvision:BuildRequires:    python-MythTV}
89 %{?with_mythnetvision:BuildRequires:    python-oauth}
90 BuildRequires:  qt4-build
91 BuildRequires:  qt4-qmake
92 BuildRequires:  rpm-perlprov >= 4.1-13
93 BuildRequires:  sed >= 4.0
94 %{?with_mythmusic:BuildRequires:        taglib-devel}
95 BuildRequires:  xorg-lib-libX11-devel
96 BuildRequires:  xvid-devel >= 1:0.9.1
97 BuildRequires:  zlib-devel
98 %endif
99 Obsoletes:      mythdvd < %{version}-%{release}
100 Obsoletes:      mythmovies < %{version}-%{release}
101 %{?with_mytharchive:Requires:   mytharchive}
102 %{?with_mythbrowser:Requires:   mythbrowser}
103 %{?with_mythgallery:Requires:   mythgallery}
104 %{?with_mythgame:Requires:      mythgame}
105 %{?with_mythmysic:Requires:     mythmusic}
106 %{?with_mythnetvision:Requires: mythnetvision}
107 %{?with_mythnews:Requires:      mythnews}
108 %{?with_mythvideo:Requires:     mythvideo}
109 %{?with_mythweather:Requires:   mythweather}
110 %{?with_mythweb:Requires:       mythweb}
111 ExclusiveArch:  %{ix86} %{x8664} ppc
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
115 %define         _webapps        /etc/webapps
116 %define         _webapp         mythweb
117
118 %description
119 This is a consolidation of all the official MythTV plugins that used
120 to be distributed as separate downloads from mythtv.org.
121
122 %description -l pl.UTF-8
123 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
124 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
125
126 %package -n mytharchive
127 Summary:        A MythTV module to create and burn DVDs
128 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
129 Group:          Applications/Multimedia
130 Requires:       dvdauthor
131 Requires:       mjpegtools
132 Requires:       mythtv-frontend-api = %{myth_api_version}
133 Requires:       python-MySQLdb
134 Requires:       python-PIL
135 Suggests:       dvdrtools-mkisofs
136
137 %description -n mytharchive
138 MythArchive is a MythTV style plugin that uses the Mythburn Script to
139 create and burn DVDs from MythTV recordings, MythVideo files or any
140 video files available on a MythTV system. It can also export
141 recordings to a native archive format that can then be imported back
142 into a MythTV system restoring all the associated metadata.
143
144 %description -n mytharchive -l pl.UTF-8
145 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
146 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
147 innych plików z filmami dostępnych w systemie MythTV. Może także
148 eksportować nagrania do natywnego formatu archiwum, który potem można
149 zaimportować z powrotem do systemu MythTV przywracając wszystkie
150 związane z nimi metadane.
151
152 %package -n mythmusic
153 Summary:        The music player add-on module for MythTV
154 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
155 Group:          Applications/Multimedia
156 Requires:       mythtv-frontend-api = %{myth_api_version}
157
158 %description -n mythmusic
159 Music add-on for MythTV. Support playlists, visualisations, tag
160 editing and plays many popular audio file formats - mp3, flac, wav,
161 ogg etc.
162
163 %description -n mythmusic -l pl.UTF-8
164 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
165 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
166 formatów audio - mp3, flac, wav, ogg itd.
167
168 %package -n mythvideo
169 Summary:        A generic video player frontend module for MythTV
170 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
171 Group:          Applications/Multimedia
172 Requires:       mplayer
173 Requires:       mythtv-frontend-api = %{myth_api_version}
174
175 %description -n mythvideo
176 A generic video and dvd player frontend module for MythTV.
177
178 %description -n mythvideo -l pl.UTF-8
179 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
180
181 %package -n mythweather
182 Summary:        A MythTV module that displays a weather forcast
183 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
184 Group:          Applications/Multimedia
185 Requires:       mythtv-frontend-api = %{myth_api_version}
186
187 %description -n mythweather
188 A MythTV module that displays a weather forcast.
189
190 %description -n mythweather -l pl.UTF-8
191 Moduł MythTV wyświetlający prognozę pogody.
192
193 %package -n mythgallery
194 Summary:        A gallery/slideshow module for MythTV
195 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
196 Group:          Applications/Multimedia
197 Requires:       mythtv-frontend-api = %{myth_api_version}
198
199 %description -n mythgallery
200 A gallery/slideshow module for MythTV.
201
202 %description -n mythgallery -l pl.UTF-8
203 Moduł galerii/pokazu slajdów dla MythTV.
204
205 %package -n mythgame
206 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
207 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
208 Group:          Applications/Multimedia
209 Requires:       mythtv-frontend-api = %{myth_api_version}
210
211 %description -n mythgame
212 A game frontend (xmame, nes, snes, pc) for MythTV.
213
214 %description -n mythgame -l pl.UTF-8
215 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
216
217 %package -n mythnews
218 Summary:        A RSS News Feed plugin for MythTV
219 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
220 Group:          Applications/Multimedia
221 Requires:       mythtv-frontend-api = %{myth_api_version}
222
223 %description -n mythnews
224 A RSS News Feed plugin for MythTV.
225
226 %description -n mythnews -l pl.UTF-8
227 Wtyczka czytnika nowinek RSS dla MythTV.
228
229 %package -n mythbrowser
230 Summary:        A small web browser module for MythTV
231 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
232 Group:          Applications/Multimedia
233 Requires:       mythtv-frontend-api = %{myth_api_version}
234
235 %description -n mythbrowser
236 MythBrowser is a full fledged web-browser (multiple tabs) to display
237 webpages in full-screen mode. Simple page navigation is possible.
238 Starting with version 0.13 it also has full support for mouse driven
239 navigation (right mouse opens and closes the popup menu).
240
241 MythBrowser also contains a BookmarkManager to manage the website
242 links in a simple mythplugin.
243
244 %description -n mythbrowser -l pl.UTF-8
245 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
246 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
247 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
248 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
249 menu).
250
251 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
252 do stron w prostej wtyczce myth.
253
254 %package -n mythweb
255 Summary:        The web interface to MythTV
256 Summary(pl.UTF-8):      Interfejs WWW do MythTV
257 Group:          Applications/Multimedia
258 Requires:       php(mysql)
259 Requires:       php(posix)
260 Requires:       webapps
261 Requires:       webserver(php) >= 4.3
262 Conflicts:      apache-base < 2.4.0-1
263
264 %description -n mythweb
265 The web interface to MythTV.
266
267 %description -n mythweb -l pl.UTF-8
268 Interfejs WWW do MythTV.
269
270 %package -n mythnetvision
271 Summary:        Mythtv extension to watch network movie shows
272 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
273 Group:          Applications/Multimedia
274 Requires:       mythbrowser
275 Requires:       mythtv-frontend-api = %{myth_api_version}
276 Requires:       python-MythTV
277 Requires:       python-oauth
278
279 %description -n mythnetvision
280 Mythtv extension to watch network movie shows (ex. YouTube).
281
282 %description -n mythnetvision -l pl.UTF-8
283 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
284 YouTube.
285
286 %package -n mythzoneminder
287 Summary:        MythTV security TV manager
288 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
289 Group:          Applications/Multimedia
290 Requires:       mythtv-frontend-api = %{myth_api_version}
291
292 %description -n mythzoneminder
293 MythTV security TV manager.
294
295
296 %description -n mythzoneminder -l pl.UTF-8
297 Obsługa kamer przemysłowych dla MythTV.
298
299 %prep
300 %setup -q
301 %patch0 -p1
302 #%patch10 -p1
303 %patch20 -p1
304
305 # lib64 fix - enable to update patch
306 %if %{_lib} != "lib" && 0
307 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
308 xargs grep -l /lib/ . | xargs sed -i -e '
309 s,%{_prefix}/lib/,/%{_lib}/,g
310         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
311 '
312 exit 1
313 %endif
314
315 %build
316 %if %{with binary}
317 export QTDIR="%{_prefix}"
318 # Not gnu configure
319 %configure \
320         --libdir-name=`basename %{_lib}` \
321         --enable-all \
322         %{!?with_mytharchive:--disable-mytharchive} \
323         %{!?with_mythbrowser:--disable-mythbrowser} \
324         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
325         %{!?with_mythgame:--disable-mythgame} \
326         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
327         %{!?with_mythnews:--disable-mythnews} \
328         %{!?with_mythvideo:--disable-mythvideo} \
329         %{!?with_mythweather:--disable-mythweather} \
330         %{!?with_mythweb:--disable-mythweb} \
331         %{!?with_mythnetvision:--disable-mythnetvision} \
332
333 mv mythconfig.mak mythconfig.mak.old
334 cp mythconfig.mak.old mythconfig.mak
335 cat <<'EOF'>> mythconfig.mak
336 QMAKE_CXX=%{__cxx}
337 QMAKE_CC=%{__cc}
338 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
339 ECFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer
340 ECXXFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer -D__STDC_CONSTANT_MACROS
341 EOF
342
343 %{__make}
344 %endif
345
346 %install
347 rm -rf $RPM_BUILD_ROOT
348 %if %{with binary}
349 export QTDIR="%{_prefix}"
350 %{__make} install \
351         INSTALL_ROOT=$RPM_BUILD_ROOT
352
353 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
354 %if %{with mythgame}
355 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
356 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
357 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
358 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
359 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
360 %endif
361 %endif
362
363 %if %{with mythweb}
364 cd mythweb
365 cp -a %{SOURCE3} ./
366 cp -a %{SOURCE4} ./
367 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
368 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
369 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
370 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
371 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
372 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
373 install %{SOURCE5} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
374 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
375 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
376 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
377 cd -
378 %endif
379
380 rm -f $RPM_BUILD_ROOT%{_datadir}/data
381 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
382 for p in mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythvideo mythweather mythzoneminder; do
383         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
384                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
385         done > $p.lang
386 done
387
388 %clean
389 rm -rf $RPM_BUILD_ROOT
390
391 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
392 %webapp_register apache %{_webapp}
393
394 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
395 %webapp_unregister apache %{_webapp}
396
397 %triggerin -n mythweb -- apache-base
398 %webapp_register httpd %{_webapp}
399
400 %triggerin -n mythweb -- lighttpd
401 %webapp_register lighttpd %{_webapp}
402
403 %triggerun -n mythweb -- apache-base
404 %webapp_unregister httpd %{_webapp}
405
406 %triggerun -n mythweb -- lighttpd
407 %webapp_unregister lighttpd %{_webapp}
408
409 %triggerpostun -n mythweb -- mythweb < 0.19
410 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
411         if [ -f /etc/mythweb/$i.rpmsave ]; then
412                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
413                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
414         fi
415 done
416 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
417
418 # migrate from apache-config macros
419 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
420         if [ -d /etc/apache/webapps.d ]; then
421                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
422                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
423         fi
424
425         if [ -d /etc/httpd/webapps.d ]; then
426                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
427                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
428         fi
429         rm -f /etc/mythweb/apache.conf.rpmsave
430 fi
431
432 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
433         rm -f /etc/apache/conf.d/99_mythplugins.conf
434         /usr/sbin/webapp register apache %{_webapp}
435         %service -q apache reload
436 fi
437 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
438         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
439         /usr/sbin/webapp register httpd %{_webapp}
440         %service -q httpd reload
441 fi
442
443 %post -n mythweb
444 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
445 which packages you can need to run mythweb and how to set it quickly."
446
447 %files
448 %defattr(644,root,root,755)
449
450 %if %{with mytharchive}
451 %files -n mytharchive -f mytharchive.lang
452 %defattr(644,root,root,755)
453 %doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
454 %attr(755,root,root) %{_bindir}/mytharchivehelper
455 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
456 %{_datadir}/mythtv/archivemenu.xml
457 %{_datadir}/mythtv/archiveutils.xml
458 %{_datadir}/mythtv/themes/default/ma_*.png
459 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
460 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
461 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
462 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
463 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
464 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
465 %{_datadir}/mythtv/mytharchive
466 %endif
467
468 %if %{with mythmusic}
469 %files -n mythmusic -f mythmusic.lang
470 %defattr(644,root,root,755)
471 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
472 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
473 /var/lib/mythmusic
474 %{_datadir}/mythtv/musicmenu.xml
475 %{_datadir}/mythtv/music_settings.xml
476 %{_datadir}/mythtv/themes/default/music-ui.xml
477 %{_datadir}/mythtv/themes/default/mm-titlelines.png
478 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
479 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
480 %{_datadir}/mythtv/themes/default/ff_button_off.png
481 %{_datadir}/mythtv/themes/default/ff_button_on.png
482 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
483 %{_datadir}/mythtv/themes/default/miniplayer_background.png
484 %{_datadir}/mythtv/themes/default/mm_*.png
485 %{_datadir}/mythtv/themes/default/music-sel-bg.png
486 %{_datadir}/mythtv/themes/default/next_button_off.png
487 %{_datadir}/mythtv/themes/default/next_button_on.png
488 %{_datadir}/mythtv/themes/default/next_button_pushed.png
489 %{_datadir}/mythtv/themes/default/pause_button_off.png
490 %{_datadir}/mythtv/themes/default/pause_button_on.png
491 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
492 %{_datadir}/mythtv/themes/default/play_button_off.png
493 %{_datadir}/mythtv/themes/default/play_button_on.png
494 %{_datadir}/mythtv/themes/default/play_button_pushed.png
495 %{_datadir}/mythtv/themes/default/prev_button_off.png
496 %{_datadir}/mythtv/themes/default/prev_button_on.png
497 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
498 %{_datadir}/mythtv/themes/default/rew_button_off.png
499 %{_datadir}/mythtv/themes/default/rew_button_on.png
500 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
501 %{_datadir}/mythtv/themes/default/selectionbar.png
502 %{_datadir}/mythtv/themes/default/stop_button_off.png
503 %{_datadir}/mythtv/themes/default/stop_button_on.png
504 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
505 %{_datadir}/mythtv/themes/default/track_info_background.png
506 %{_datadir}/mythtv/themes/default-wide/mm_*.png
507 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
508 %endif
509
510 %if %{with mythvideo}
511 %files -n mythvideo -f mythvideo.lang
512 %defattr(644,root,root,755)
513 %doc mythvideo/README* mythvideo/videodb mythvideo/contrib
514 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
515 %{_datadir}/mythtv/themes/default/video-ui.xml
516 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
517 %{_datadir}/mythtv/themes/default/mv_*.png
518 %{_datadir}/mythtv/themes/default-wide/mv_*.png
519 %{_datadir}/mythtv/themes/default/md_*.png
520 %{_datadir}/mythtv/video_settings.xml
521 %{_datadir}/mythtv/videomenu.xml
522 %dir %{_datadir}/mythtv/mythvideo
523 %dir %{_datadir}/mythtv/mythvideo/scripts
524 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
525 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
526 %{_datadir}/mythtv/mythvideo/scripts/README
527 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
528 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
529 %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
530 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
531 /var/lib/mythvideo
532 %endif
533
534 %if %{with mythweather}
535 %files -n mythweather -f mythweather.lang
536 %defattr(644,root,root,755)
537 %doc mythweather/AUTHORS mythweather/README
538 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
539 %{_datadir}/mythtv/mythweather
540 %{_datadir}/mythtv/weather_settings.xml
541 %{_datadir}/mythtv/themes/default/weather-ui.xml
542 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
543 %{_datadir}/mythtv/themes/default/cloudy.png
544 %{_datadir}/mythtv/themes/default/fair.png
545 %{_datadir}/mythtv/themes/default/flurries.png
546 %{_datadir}/mythtv/themes/default/fog.png
547 %{_datadir}/mythtv/themes/default/logo.png
548 %{_datadir}/mythtv/themes/default/lshowers.png
549 %{_datadir}/mythtv/themes/default/mcloudy.png
550 %{_datadir}/mythtv/themes/default/mw_*.png
551 %{_datadir}/mythtv/themes/default/mwmain.png
552 %{_datadir}/mythtv/themes/default/pcloudy.png
553 %{_datadir}/mythtv/themes/default/rainsnow.png
554 %{_datadir}/mythtv/themes/default/showers.png
555 %{_datadir}/mythtv/themes/default/snowshow.png
556 %{_datadir}/mythtv/themes/default/sunny.png
557 %{_datadir}/mythtv/themes/default/thunshowers.png
558 %{_datadir}/mythtv/themes/default/unknown.png
559 %{_datadir}/mythtv/themes/default-wide/mw-*.png
560 %endif
561
562 %if %{with mythgallery}
563 %files -n mythgallery -f mythgallery.lang
564 %defattr(644,root,root,755)
565 %doc mythgallery/AUTHORS mythgallery/README
566 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
567 %{_datadir}/mythtv/themes/default/gallery-ui.xml
568 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
569 %{_datadir}/mythtv/themes/default/gallery-*.png
570 /var/lib/pictures
571 %endif
572
573 %if %{with mythgame}
574 %files -n mythgame -f mythgame.lang
575 %defattr(644,root,root,755)
576 %doc mythgame/contrib
577 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
578 %{_datadir}/mythtv/games
579 %{_datadir}/mythtv/game_settings.xml
580 %{_datadir}/mythtv/themes/default/game-ui.xml
581 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
582 %dir %{_datadir}/mythtv/metadata/Game
583 %attr(755,root,root) %{_datadir}/mythtv/metadata/Game/giantbomb.py
584 %{_datadir}/mythtv/metadata/Game/giantbomb
585 %endif
586
587 %if %{with mythnews}
588 %files -n mythnews -f mythnews.lang
589 %defattr(644,root,root,755)
590 %doc mythnews/README mythnews/AUTHORS
591 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
592 %{_datadir}/mythtv/mythnews
593 %{_datadir}/mythtv/themes/default/news-ui.xml
594 %{_datadir}/mythtv/themes/default/news-info-bg.png
595 %{_datadir}/mythtv/themes/default/enclosures.png
596 %{_datadir}/mythtv/themes/default/need-download.png
597 %{_datadir}/mythtv/themes/default/podcast.png
598 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
599 %endif
600
601 %if %{with mythbrowser}
602 %files -n mythbrowser -f mythbrowser.lang
603 %defattr(644,root,root,755)
604 %doc mythbrowser/README mythbrowser/AUTHORS
605 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
606 %{_datadir}/mythtv/themes/default/mb_progress*.png
607 %{_datadir}/mythtv/themes/default/browser-ui.xml
608 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
609 %endif
610
611 %if %{with mythweb}
612 %files -n mythweb
613 %defattr(644,root,root,755)
614 %doc mythweb/README mythweb/mythweb.conf.lighttpd
615 %doc mythweb/htdigest.sh
616 %doc mythweb/http_servers_conf_tips.txt
617 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
618 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
620 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
621 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
622 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
623 %{_datadir}/mythweb
624 %dir %attr(771,root,http) /var/cache/mythweb
625 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
626 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
627 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
628 %endif
629
630 %if %{with mythnetvision}
631 %files -n mythnetvision -f mythnetvision.lang
632 %defattr(644,root,root,755)
633 %doc mythnetvision/{AUTHORS,ChangeLog,README}
634 %attr(755,root,root) %{_bindir}/mythfillnetvision
635 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
636 %dir %{_datadir}/mythtv/mythnetvision
637 %{_datadir}/mythtv/netvisionmenu.xml
638 %dir %{_datadir}/mythtv/mythnetvision/icons
639 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
640 %{_datadir}/mythtv/mythnetvision/icons/*.png
641 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
642 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
643 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
644 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
645 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
646 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
647 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
648 %{_datadir}/mythtv/themes/default/netvision-ui.xml
649 %endif
650
651 %if %{with mythzoneminder}
652 %files -n mythzoneminder
653 %defattr(644,root,root,755)
654 %defattr(644,root,root,755)
655 %doc mythzoneminder/{AUTHORS,README}
656 %attr(755,root,root) %{_bindir}/mythzmserver
657 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
658 %dir %{_datadir}/mythtv/zonemindermenu.xml
659 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
660 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
661 %{_datadir}/mythtv/themes/default/mz_*png
662 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
663 %endif
This page took 0.092519 seconds and 2 git commands to generate.