]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- rebuild with libass 0.10.2
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythnetvision   # disable building mythnetvision plugin
7 %bcond_without  mythgallery     # disable building mythgallery plugin
8 %bcond_without  mythgame        # disable building mythgame plugin
9 %bcond_without  mythmusic       # disable building mythmusic plugin
10 %bcond_without  mythnews        # disable building mythnews plugin
11 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
12 # not present by default in PLD
13 %bcond_with     mythweather     # enable building mythweather plugin
14 %bcond_without  mythweb         # disable building mythweb plugin
15 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
16
17 %if %{without binary}
18 %undefine       with_mytharchive
19 %undefine       with_mythbrowser
20 %undefine       with_mythnetvision
21 %undefine       with_mythgallery
22 %undefine       with_mythgame
23 %undefine       with_mythmusic
24 %undefine       with_mythnews
25 %undefine       with_mythweather
26 %endif
27
28 %include        /usr/lib/rpm/macros.perl
29
30 Summary:        Main MythTV plugins
31 Summary(pl.UTF-8):      Główne wtyczki MythTV
32 Name:           mythplugins
33 Version:        0.26.0
34 Release:        2
35 License:        GPL v2
36 Group:          Applications/Multimedia
37 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
38 # Source0-md5:  15bd7b2f4173488966f3d761e0eacffa
39 Source1:        mythweb-apache.conf
40 Source2:        mythweb_lighttpd.conf
41 Source3:        htdigest.sh
42 Source4:        http_servers_conf_tips.txt
43 Source5:        mythweb-httpd.conf
44 Patch0:         mythweb-chdir.patch
45 Patch1:         system-zmq.patch
46 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
47 Patch20:        %{name}-mytharchive-INT64.patch
48 URL:            http://www.mythtv.org/
49 %if %{with binary}
50 %if %{with mythgallery} || %{with myhtmusic}
51 BuildRequires:  OpenGL-devel
52 %endif
53 BuildRequires:  Qt3Support-devel
54 BuildRequires:  QtCore-devel
55 BuildRequires:  QtGui-devel
56 BuildRequires:  QtNetwork-devel
57 BuildRequires:  QtOpenGL-devel
58 BuildRequires:  QtSql-devel
59 BuildRequires:  QtWebKit-devel
60 BuildRequires:  QtXml-devel
61 BuildRequires:  SDL-devel
62 BuildRequires:  a52dec-libs-devel
63 BuildRequires:  cdparanoia-III-devel
64 BuildRequires:  faad2-devel >= 2.0-5.2
65 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
66 BuildRequires:  flac-devel >= 1.0.4
67 BuildRequires:  freetype-devel
68 BuildRequires:  libcdaudio-devel >= 0.99.12p2
69 BuildRequires:  libdvdcss-devel >= 1.2.7
70 BuildRequires:  libdvdread-devel >= 0.9.4
71 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
72 BuildRequires:  libfame-devel >= 0.9.0
73 BuildRequires:  libid3tag-devel
74 BuildRequires:  libmad-devel
75 BuildRequires:  libmyth-devel > 0.26
76 BuildRequires:  libstdc++-devel
77 BuildRequires:  libtiff-devel
78 BuildRequires:  libvisual-devel
79 BuildRequires:  libvorbis-devel >= 1:1.0
80 BuildRequires:  mjpegtools-devel >= 1.6.1
81 BuildRequires:  nasm
82 BuildRequires:  patchutils
83 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
84 %{?with_mythweather:BuildRequires:      perl-Image-Size}
85 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
86 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
87 %{?with_mythnetvision:BuildRequires:    python-MythTV}
88 %{?with_mythnetvision:BuildRequires:    python-oauth}
89 BuildRequires:  qt4-build
90 BuildRequires:  qt4-qmake
91 BuildRequires:  rpm-perlprov >= 4.1-13
92 BuildRequires:  sed >= 4.0
93 %{?with_mythmusic:BuildRequires:        taglib-devel}
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  xvid-devel >= 1:0.9.1
96 BuildRequires:  zlib-devel
97 %endif
98 Obsoletes:      mythdvd < %{version}-%{release}
99 Obsoletes:      mythmovies < %{version}-%{release}
100 %{?with_mytharchive:Requires:   mytharchive}
101 %{?with_mythbrowser:Requires:   mythbrowser}
102 %{?with_mythgallery:Requires:   mythgallery}
103 %{?with_mythgame:Requires:      mythgame}
104 %{?with_mythmysic:Requires:     mythmusic}
105 %{?with_mythnetvision:Requires: mythnetvision}
106 %{?with_mythnews:Requires:      mythnews}
107 %{?with_mythweather:Requires:   mythweather}
108 %{?with_mythweb:Requires:       mythweb}
109 Obsoletes:      mythvideo
110 ExclusiveArch:  %{ix86} %{x8664} ppc
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
114 %define         _webapps        /etc/webapps
115 %define         _webapp         mythweb
116
117 %description
118 This is a consolidation of all the official MythTV plugins that used
119 to be distributed as separate downloads from mythtv.org.
120
121 %description -l pl.UTF-8
122 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
123 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
124
125 %package -n mytharchive
126 Summary:        A MythTV module to create and burn DVDs
127 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
128 Group:          Applications/Multimedia
129 Requires:       dvdauthor
130 Requires:       mjpegtools
131 Requires:       mythtv-frontend-api = %{myth_api_version}
132 Requires:       python-MySQLdb
133 Requires:       python-PIL
134 Suggests:       dvdrtools-mkisofs
135
136 %description -n mytharchive
137 MythArchive is a MythTV style plugin that uses the Mythburn Script to
138 create and burn DVDs from MythTV recordings, MythVideo files or any
139 video files available on a MythTV system. It can also export
140 recordings to a native archive format that can then be imported back
141 into a MythTV system restoring all the associated metadata.
142
143 %description -n mytharchive -l pl.UTF-8
144 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
145 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
146 innych plików z filmami dostępnych w systemie MythTV. Może także
147 eksportować nagrania do natywnego formatu archiwum, który potem można
148 zaimportować z powrotem do systemu MythTV przywracając wszystkie
149 związane z nimi metadane.
150
151 %package -n mythmusic
152 Summary:        The music player add-on module for MythTV
153 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
154 Group:          Applications/Multimedia
155 Requires:       mythtv-frontend-api = %{myth_api_version}
156
157 %description -n mythmusic
158 Music add-on for MythTV. Support playlists, visualisations, tag
159 editing and plays many popular audio file formats - mp3, flac, wav,
160 ogg etc.
161
162 %description -n mythmusic -l pl.UTF-8
163 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
164 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
165 formatów audio - mp3, flac, wav, ogg itd.
166
167 %package -n mythweather
168 Summary:        A MythTV module that displays a weather forcast
169 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
170 Group:          Applications/Multimedia
171 Requires:       mythtv-frontend-api = %{myth_api_version}
172
173 %description -n mythweather
174 A MythTV module that displays a weather forcast.
175
176 %description -n mythweather -l pl.UTF-8
177 Moduł MythTV wyświetlający prognozę pogody.
178
179 %package -n mythgallery
180 Summary:        A gallery/slideshow module for MythTV
181 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
182 Group:          Applications/Multimedia
183 Requires:       mythtv-frontend-api = %{myth_api_version}
184
185 %description -n mythgallery
186 A gallery/slideshow module for MythTV.
187
188 %description -n mythgallery -l pl.UTF-8
189 Moduł galerii/pokazu slajdów dla MythTV.
190
191 %package -n mythgame
192 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
193 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
194 Group:          Applications/Multimedia
195 Requires:       mythtv-frontend-api = %{myth_api_version}
196
197 %description -n mythgame
198 A game frontend (xmame, nes, snes, pc) for MythTV.
199
200 %description -n mythgame -l pl.UTF-8
201 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
202
203 %package -n mythnews
204 Summary:        A RSS News Feed plugin for MythTV
205 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
206 Group:          Applications/Multimedia
207 Requires:       mythtv-frontend-api = %{myth_api_version}
208
209 %description -n mythnews
210 A RSS News Feed plugin for MythTV.
211
212 %description -n mythnews -l pl.UTF-8
213 Wtyczka czytnika nowinek RSS dla MythTV.
214
215 %package -n mythbrowser
216 Summary:        A small web browser module for MythTV
217 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
218 Group:          Applications/Multimedia
219 Requires:       mythtv-frontend-api = %{myth_api_version}
220
221 %description -n mythbrowser
222 MythBrowser is a full fledged web-browser (multiple tabs) to display
223 webpages in full-screen mode. Simple page navigation is possible.
224 Starting with version 0.13 it also has full support for mouse driven
225 navigation (right mouse opens and closes the popup menu).
226
227 MythBrowser also contains a BookmarkManager to manage the website
228 links in a simple mythplugin.
229
230 %description -n mythbrowser -l pl.UTF-8
231 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
232 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
233 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
234 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
235 menu).
236
237 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
238 do stron w prostej wtyczce myth.
239
240 %package -n mythweb
241 Summary:        The web interface to MythTV
242 Summary(pl.UTF-8):      Interfejs WWW do MythTV
243 Group:          Applications/Multimedia
244 Requires:       php(mysql)
245 Requires:       php(posix)
246 Requires:       webapps
247 Requires:       webserver(php) >= 4.3
248 Conflicts:      apache-base < 2.4.0-1
249
250 %description -n mythweb
251 The web interface to MythTV.
252
253 %description -n mythweb -l pl.UTF-8
254 Interfejs WWW do MythTV.
255
256 %package -n mythnetvision
257 Summary:        Mythtv extension to watch network movie shows
258 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
259 Group:          Applications/Multimedia
260 Requires:       mythbrowser
261 Requires:       mythtv-frontend-api = %{myth_api_version}
262 Requires:       python-MythTV
263 Requires:       python-oauth
264
265 %description -n mythnetvision
266 Mythtv extension to watch network movie shows (ex. YouTube).
267
268 %description -n mythnetvision -l pl.UTF-8
269 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
270 YouTube.
271
272 %package -n mythzoneminder
273 Summary:        MythTV security TV manager
274 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
275 Group:          Applications/Multimedia
276 Requires:       mythtv-frontend-api = %{myth_api_version}
277
278 %description -n mythzoneminder
279 MythTV security TV manager.
280
281
282 %description -n mythzoneminder -l pl.UTF-8
283 Obsługa kamer przemysłowych dla MythTV.
284
285 %prep
286 %setup -q
287 %patch0 -p1
288 %patch1 -p1
289 #%patch10 -p1
290 %patch20 -p1
291
292 # lib64 fix - enable to update patch
293 %if %{_lib} != "lib" && 0
294 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
295 xargs grep -l /lib/ . | xargs sed -i -e '
296 s,%{_prefix}/lib/,/%{_lib}/,g
297         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
298 '
299 exit 1
300 %endif
301
302 %build
303 %if %{with binary}
304 export QTDIR="%{_prefix}"
305 # Not gnu configure
306 %configure \
307         --libdir-name=`basename %{_lib}` \
308         --enable-all \
309         %{!?with_mytharchive:--disable-mytharchive} \
310         %{!?with_mythbrowser:--disable-mythbrowser} \
311         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
312         %{!?with_mythgame:--disable-mythgame} \
313         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
314         %{!?with_mythnews:--disable-mythnews} \
315         %{!?with_mythweather:--disable-mythweather} \
316         %{!?with_mythweb:--disable-mythweb} \
317         %{!?with_mythnetvision:--disable-mythnetvision} \
318
319 mv mythconfig.mak mythconfig.mak.old
320 cp mythconfig.mak.old mythconfig.mak
321 cat <<'EOF'>> mythconfig.mak
322 QMAKE_CXX=%{__cxx}
323 QMAKE_CC=%{__cc}
324 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
325 ECFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer
326 ECXXFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer -D__STDC_CONSTANT_MACROS
327 EOF
328
329 %{__make}
330 %endif
331
332 %install
333 rm -rf $RPM_BUILD_ROOT
334 %if %{with binary}
335 export QTDIR="%{_prefix}"
336 %{__make} install \
337         INSTALL_ROOT=$RPM_BUILD_ROOT
338
339 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,pictures}
340 %if %{with mythgame}
341 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
342 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
343 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
344 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
345 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
346 %endif
347 %endif
348
349 %if %{with mythweb}
350 cd mythweb
351 cp -a %{SOURCE3} ./
352 cp -a %{SOURCE4} ./
353 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
354 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
355 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
356 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
357 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
358 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
359 install %{SOURCE5} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
360 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
361 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
362 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
363 cd -
364 %endif
365
366 rm -f $RPM_BUILD_ROOT%{_datadir}/data
367 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
368 for p in mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythweather mythzoneminder; do
369         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
370                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
371         done > $p.lang
372 done
373
374 %clean
375 rm -rf $RPM_BUILD_ROOT
376
377 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
378 %webapp_register apache %{_webapp}
379
380 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
381 %webapp_unregister apache %{_webapp}
382
383 %triggerin -n mythweb -- apache-base
384 %webapp_register httpd %{_webapp}
385
386 %triggerin -n mythweb -- lighttpd
387 %webapp_register lighttpd %{_webapp}
388
389 %triggerun -n mythweb -- apache-base
390 %webapp_unregister httpd %{_webapp}
391
392 %triggerun -n mythweb -- lighttpd
393 %webapp_unregister lighttpd %{_webapp}
394
395 %triggerpostun -n mythweb -- mythweb < 0.19
396 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
397         if [ -f /etc/mythweb/$i.rpmsave ]; then
398                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
399                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
400         fi
401 done
402 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
403
404 # migrate from apache-config macros
405 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
406         if [ -d /etc/apache/webapps.d ]; then
407                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
408                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
409         fi
410
411         if [ -d /etc/httpd/webapps.d ]; then
412                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
413                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
414         fi
415         rm -f /etc/mythweb/apache.conf.rpmsave
416 fi
417
418 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
419         rm -f /etc/apache/conf.d/99_mythplugins.conf
420         /usr/sbin/webapp register apache %{_webapp}
421         %service -q apache reload
422 fi
423 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
424         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
425         /usr/sbin/webapp register httpd %{_webapp}
426         %service -q httpd reload
427 fi
428
429 %post -n mythweb
430 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
431 which packages you can need to run mythweb and how to set it quickly."
432
433 %files
434 %defattr(644,root,root,755)
435
436 %if %{with mytharchive}
437 %files -n mytharchive -f mytharchive.lang
438 %defattr(644,root,root,755)
439 %doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
440 %attr(755,root,root) %{_bindir}/mytharchivehelper
441 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
442 %{_datadir}/mythtv/archivemenu.xml
443 %{_datadir}/mythtv/archiveutils.xml
444 %{_datadir}/mythtv/themes/default/ma_*.png
445 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
446 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
447 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
448 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
449 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
450 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
451 %{_datadir}/mythtv/mytharchive
452 %endif
453
454 %if %{with mythmusic}
455 %files -n mythmusic -f mythmusic.lang
456 %defattr(644,root,root,755)
457 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
458 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
459 /var/lib/mythmusic
460 %{_datadir}/mythtv/musicmenu.xml
461 %{_datadir}/mythtv/music_settings.xml
462 %dir %{_datadir}/mythtv/mythmusic
463 %{_datadir}/mythtv/mythmusic/streams.xml
464 %{_datadir}/mythtv/themes/default/music-base.xml
465 %{_datadir}/mythtv/themes/default/music-ui.xml
466 %{_datadir}/mythtv/themes/default/musicsettings-ui.xml
467 %{_datadir}/mythtv/themes/default/mm-titlelines.png
468 %{_datadir}/mythtv/themes/default-wide/music-base.xml
469 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
470 %{_datadir}/mythtv/themes/default-wide/musicsettings-ui.xml
471 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
472 %{_datadir}/mythtv/themes/default-wide/stream-ui.xml
473 %{_datadir}/mythtv/themes/default/ff_button_off.png
474 %{_datadir}/mythtv/themes/default/ff_button_on.png
475 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
476 %{_datadir}/mythtv/themes/default/miniplayer_background.png
477 %{_datadir}/mythtv/themes/default/mm_*.png
478 %{_datadir}/mythtv/themes/default/music-sel-bg.png
479 %{_datadir}/mythtv/themes/default/next_button_off.png
480 %{_datadir}/mythtv/themes/default/next_button_on.png
481 %{_datadir}/mythtv/themes/default/next_button_pushed.png
482 %{_datadir}/mythtv/themes/default/pause_button_off.png
483 %{_datadir}/mythtv/themes/default/pause_button_on.png
484 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
485 %{_datadir}/mythtv/themes/default/play_button_off.png
486 %{_datadir}/mythtv/themes/default/play_button_on.png
487 %{_datadir}/mythtv/themes/default/play_button_pushed.png
488 %{_datadir}/mythtv/themes/default/prev_button_off.png
489 %{_datadir}/mythtv/themes/default/prev_button_on.png
490 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
491 %{_datadir}/mythtv/themes/default/rew_button_off.png
492 %{_datadir}/mythtv/themes/default/rew_button_on.png
493 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
494 %{_datadir}/mythtv/themes/default/selectionbar.png
495 %{_datadir}/mythtv/themes/default/stop_button_off.png
496 %{_datadir}/mythtv/themes/default/stop_button_on.png
497 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
498 %{_datadir}/mythtv/themes/default/track_info_background.png
499 %{_datadir}/mythtv/themes/default-wide/mm_*.png
500 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
501 %endif
502
503 %if %{with mythweather}
504 %files -n mythweather -f mythweather.lang
505 %defattr(644,root,root,755)
506 %doc mythweather/AUTHORS mythweather/README
507 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
508 %{_datadir}/mythtv/mythweather
509 %{_datadir}/mythtv/weather_settings.xml
510 %{_datadir}/mythtv/themes/default/weather-ui.xml
511 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
512 %{_datadir}/mythtv/themes/default/cloudy.png
513 %{_datadir}/mythtv/themes/default/fair.png
514 %{_datadir}/mythtv/themes/default/flurries.png
515 %{_datadir}/mythtv/themes/default/fog.png
516 %{_datadir}/mythtv/themes/default/logo.png
517 %{_datadir}/mythtv/themes/default/lshowers.png
518 %{_datadir}/mythtv/themes/default/mcloudy.png
519 %{_datadir}/mythtv/themes/default/mw_*.png
520 %{_datadir}/mythtv/themes/default/mwmain.png
521 %{_datadir}/mythtv/themes/default/pcloudy.png
522 %{_datadir}/mythtv/themes/default/rainsnow.png
523 %{_datadir}/mythtv/themes/default/showers.png
524 %{_datadir}/mythtv/themes/default/snowshow.png
525 %{_datadir}/mythtv/themes/default/sunny.png
526 %{_datadir}/mythtv/themes/default/thunshowers.png
527 %{_datadir}/mythtv/themes/default/unknown.png
528 %{_datadir}/mythtv/themes/default-wide/mw-*.png
529 %endif
530
531 %if %{with mythgallery}
532 %files -n mythgallery -f mythgallery.lang
533 %defattr(644,root,root,755)
534 %doc mythgallery/AUTHORS mythgallery/README
535 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
536 %{_datadir}/mythtv/themes/default/gallery-ui.xml
537 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
538 %{_datadir}/mythtv/themes/default/gallery-*.png
539 /var/lib/pictures
540 %endif
541
542 %if %{with mythgame}
543 %files -n mythgame -f mythgame.lang
544 %defattr(644,root,root,755)
545 %doc mythgame/contrib
546 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
547 %{_datadir}/mythtv/games
548 %{_datadir}/mythtv/game_settings.xml
549 %{_datadir}/mythtv/themes/default/game-ui.xml
550 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
551 %dir %{_datadir}/mythtv/metadata/Game
552 %attr(755,root,root) %{_datadir}/mythtv/metadata/Game/giantbomb.py
553 %{_datadir}/mythtv/metadata/Game/giantbomb
554 %endif
555
556 %if %{with mythnews}
557 %files -n mythnews -f mythnews.lang
558 %defattr(644,root,root,755)
559 %doc mythnews/README mythnews/AUTHORS
560 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
561 %{_datadir}/mythtv/mythnews
562 %{_datadir}/mythtv/themes/default/news-ui.xml
563 %{_datadir}/mythtv/themes/default/news-info-bg.png
564 %{_datadir}/mythtv/themes/default/enclosures.png
565 %{_datadir}/mythtv/themes/default/need-download.png
566 %{_datadir}/mythtv/themes/default/podcast.png
567 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
568 %endif
569
570 %if %{with mythbrowser}
571 %files -n mythbrowser -f mythbrowser.lang
572 %defattr(644,root,root,755)
573 %doc mythbrowser/README mythbrowser/AUTHORS
574 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
575 %{_datadir}/mythtv/themes/default/mb_*.png
576 %{_datadir}/mythtv/themes/default/browser-ui.xml
577 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
578 %endif
579
580 %if %{with mythweb}
581 %files -n mythweb
582 %defattr(644,root,root,755)
583 %doc mythweb/README mythweb/mythweb.conf.lighttpd
584 %doc mythweb/htdigest.sh
585 %doc mythweb/http_servers_conf_tips.txt
586 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
587 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
588 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
589 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
590 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
591 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
592 %{_datadir}/mythweb
593 %dir %attr(771,root,http) /var/cache/mythweb
594 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
595 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
596 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
597 %endif
598
599 %if %{with mythnetvision}
600 %files -n mythnetvision -f mythnetvision.lang
601 %defattr(644,root,root,755)
602 %doc mythnetvision/{AUTHORS,ChangeLog,README}
603 %attr(755,root,root) %{_bindir}/mythfillnetvision
604 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
605 %dir %{_datadir}/mythtv/mythnetvision
606 %{_datadir}/mythtv/netvisionmenu.xml
607 %dir %{_datadir}/mythtv/mythnetvision/icons
608 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
609 %{_datadir}/mythtv/mythnetvision/icons/*.png
610 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
611 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
612 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
613 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
614 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
615 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
616 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
617 %{_datadir}/mythtv/themes/default/netvision-ui.xml
618 %endif
619
620 %if %{with mythzoneminder}
621 %files -n mythzoneminder
622 %defattr(644,root,root,755)
623 %defattr(644,root,root,755)
624 %doc mythzoneminder/{AUTHORS,README}
625 %attr(755,root,root) %{_bindir}/mythzmserver
626 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
627 %dir %{_datadir}/mythtv/zonemindermenu.xml
628 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
629 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
630 %{_datadir}/mythtv/themes/default/mz_*png
631 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
632 %endif
This page took 0.098921 seconds and 3 git commands to generate.