]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- rebuild with libcdio.so.14
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythnetvision   # disable building mythnetvision plugin
7 %bcond_without  mythgallery     # disable building mythgallery plugin
8 %bcond_without  mythgame        # disable building mythgame plugin
9 %bcond_without  mythmusic       # disable building mythmusic plugin
10 %bcond_without  mythnews        # disable building mythnews plugin
11 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
12 # not present by default in PLD
13 %bcond_with     mythweather     # enable building mythweather plugin
14 %bcond_without  mythweb         # disable building mythweb plugin
15 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
16
17 %if %{without binary}
18 %undefine       with_mytharchive
19 %undefine       with_mythbrowser
20 %undefine       with_mythnetvision
21 %undefine       with_mythgallery
22 %undefine       with_mythgame
23 %undefine       with_mythmusic
24 %undefine       with_mythnews
25 %undefine       with_mythweather
26 %endif
27
28 %include        /usr/lib/rpm/macros.perl
29
30 Summary:        Main MythTV plugins
31 Summary(pl.UTF-8):      Główne wtyczki MythTV
32 Name:           mythplugins
33 Version:        0.26.0
34 Release:        4
35 License:        GPL v2
36 Group:          Applications/Multimedia
37 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
38 # Source0-md5:  15bd7b2f4173488966f3d761e0eacffa
39 Source1:        mythweb-apache.conf
40 Source2:        mythweb_lighttpd.conf
41 Source3:        htdigest.sh
42 Source4:        http_servers_conf_tips.txt
43 Source5:        mythweb-httpd.conf
44 Patch0:         mythweb-chdir.patch
45 Patch1:         system-zmq.patch
46 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
47 Patch20:        %{name}-mytharchive-INT64.patch
48 URL:            http://www.mythtv.org/
49 %if %{with binary}
50 %if %{with mythgallery} || %{with myhtmusic}
51 BuildRequires:  OpenGL-devel
52 %endif
53 BuildRequires:  Qt3Support-devel
54 BuildRequires:  QtCore-devel
55 BuildRequires:  QtGui-devel
56 BuildRequires:  QtNetwork-devel
57 BuildRequires:  QtOpenGL-devel
58 BuildRequires:  QtSql-devel
59 BuildRequires:  QtWebKit-devel
60 BuildRequires:  QtXml-devel
61 BuildRequires:  SDL-devel
62 BuildRequires:  a52dec-libs-devel
63 BuildRequires:  faad2-devel >= 2.0-5.2
64 %if %{with mythmusic}
65 BuildRequires:  cdparanoia-III-devel
66 BuildRequires:  fftw3-devel
67 BuildRequires:  fftw3-single-devel
68 BuildRequires:  flac-devel >= 1.0.4
69 BuildRequires:  lame-libs-devel
70 BuildRequires:  libcdaudio-devel >= 0.99.12p2
71 BuildRequires:  libvorbis-devel >= 1:1.0
72 BuildRequires:  taglib-devel
73 %endif
74 BuildRequires:  freetype-devel
75 BuildRequires:  libdvdcss-devel >= 1.2.7
76 BuildRequires:  libdvdread-devel >= 0.9.4
77 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
78 BuildRequires:  libfame-devel >= 0.9.0
79 BuildRequires:  libid3tag-devel
80 BuildRequires:  libmad-devel
81 BuildRequires:  libmyth-devel > 0.26
82 BuildRequires:  libstdc++-devel
83 BuildRequires:  libtiff-devel
84 BuildRequires:  libvisual-devel
85 BuildRequires:  mjpegtools-devel >= 1.6.1
86 BuildRequires:  nasm
87 BuildRequires:  patchutils
88 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
89 %{?with_mythweather:BuildRequires:      perl-Image-Size}
90 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
91 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
92 %{?with_mythnetvision:BuildRequires:    python-MythTV}
93 %{?with_mythnetvision:BuildRequires:    python-oauth}
94 BuildRequires:  qt4-build
95 BuildRequires:  qt4-qmake
96 BuildRequires:  rpm-perlprov >= 4.1-13
97 BuildRequires:  sed >= 4.0
98 %{?with_mythmusic:BuildRequires:        taglib-devel}
99 BuildRequires:  xorg-lib-libX11-devel
100 BuildRequires:  xvid-devel >= 1:0.9.1
101 BuildRequires:  zlib-devel
102 %endif
103 %{?with_mytharchive:Requires:   mytharchive}
104 %{?with_mythbrowser:Requires:   mythbrowser}
105 %{?with_mythgallery:Requires:   mythgallery}
106 %{?with_mythgame:Requires:      mythgame}
107 %{?with_mythmysic:Requires:     mythmusic}
108 %{?with_mythnetvision:Requires: mythnetvision}
109 %{?with_mythnews:Requires:      mythnews}
110 %{?with_mythweather:Requires:   mythweather}
111 %{?with_mythweb:Requires:       mythweb}
112 Obsoletes:      mythdvd < %{version}-%{release}
113 Obsoletes:      mythmovies < %{version}-%{release}
114 Obsoletes:      mythvideo
115 ExclusiveArch:  %{ix86} %{x8664} ppc
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
119 %define         _webapps        /etc/webapps
120 %define         _webapp         mythweb
121
122 %description
123 This is a consolidation of all the official MythTV plugins that used
124 to be distributed as separate downloads from mythtv.org.
125
126 %description -l pl.UTF-8
127 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
128 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
129
130 %package -n mytharchive
131 Summary:        A MythTV module to create and burn DVDs
132 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
133 Group:          Applications/Multimedia
134 Requires:       dvdauthor
135 Requires:       mjpegtools
136 Requires:       mythtv-frontend-api = %{myth_api_version}
137 Requires:       python-MySQLdb
138 Requires:       python-PIL
139 Suggests:       dvdrtools-mkisofs
140
141 %description -n mytharchive
142 MythArchive is a MythTV style plugin that uses the Mythburn Script to
143 create and burn DVDs from MythTV recordings, MythVideo files or any
144 video files available on a MythTV system. It can also export
145 recordings to a native archive format that can then be imported back
146 into a MythTV system restoring all the associated metadata.
147
148 %description -n mytharchive -l pl.UTF-8
149 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
150 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
151 innych plików z filmami dostępnych w systemie MythTV. Może także
152 eksportować nagrania do natywnego formatu archiwum, który potem można
153 zaimportować z powrotem do systemu MythTV przywracając wszystkie
154 związane z nimi metadane.
155
156 %package -n mythmusic
157 Summary:        The music player add-on module for MythTV
158 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
159 Group:          Applications/Multimedia
160 Requires:       mythtv-frontend-api = %{myth_api_version}
161
162 %description -n mythmusic
163 Music add-on for MythTV. Support playlists, visualisations, tag
164 editing and plays many popular audio file formats - mp3, flac, wav,
165 ogg etc.
166
167 %description -n mythmusic -l pl.UTF-8
168 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
169 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
170 formatów audio - mp3, flac, wav, ogg itd.
171
172 %package -n mythweather
173 Summary:        A MythTV module that displays a weather forcast
174 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
175 Group:          Applications/Multimedia
176 Requires:       mythtv-frontend-api = %{myth_api_version}
177
178 %description -n mythweather
179 A MythTV module that displays a weather forcast.
180
181 %description -n mythweather -l pl.UTF-8
182 Moduł MythTV wyświetlający prognozę pogody.
183
184 %package -n mythgallery
185 Summary:        A gallery/slideshow module for MythTV
186 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
187 Group:          Applications/Multimedia
188 Requires:       mythtv-frontend-api = %{myth_api_version}
189
190 %description -n mythgallery
191 A gallery/slideshow module for MythTV.
192
193 %description -n mythgallery -l pl.UTF-8
194 Moduł galerii/pokazu slajdów dla MythTV.
195
196 %package -n mythgame
197 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
198 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
199 Group:          Applications/Multimedia
200 Requires:       mythtv-frontend-api = %{myth_api_version}
201
202 %description -n mythgame
203 A game frontend (xmame, nes, snes, pc) for MythTV.
204
205 %description -n mythgame -l pl.UTF-8
206 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
207
208 %package -n mythnews
209 Summary:        A RSS News Feed plugin for MythTV
210 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
211 Group:          Applications/Multimedia
212 Requires:       mythtv-frontend-api = %{myth_api_version}
213
214 %description -n mythnews
215 A RSS News Feed plugin for MythTV.
216
217 %description -n mythnews -l pl.UTF-8
218 Wtyczka czytnika nowinek RSS dla MythTV.
219
220 %package -n mythbrowser
221 Summary:        A small web browser module for MythTV
222 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
223 Group:          Applications/Multimedia
224 Requires:       mythtv-frontend-api = %{myth_api_version}
225
226 %description -n mythbrowser
227 MythBrowser is a full fledged web-browser (multiple tabs) to display
228 webpages in full-screen mode. Simple page navigation is possible.
229 Starting with version 0.13 it also has full support for mouse driven
230 navigation (right mouse opens and closes the popup menu).
231
232 MythBrowser also contains a BookmarkManager to manage the website
233 links in a simple mythplugin.
234
235 %description -n mythbrowser -l pl.UTF-8
236 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
237 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
238 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
239 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
240 menu).
241
242 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
243 do stron w prostej wtyczce myth.
244
245 %package -n mythweb
246 Summary:        The web interface to MythTV
247 Summary(pl.UTF-8):      Interfejs WWW do MythTV
248 Group:          Applications/Multimedia
249 Requires:       php(mysql)
250 Requires:       php(posix)
251 Requires:       webapps
252 Requires:       webserver(php) >= 4.3
253 Conflicts:      apache-base < 2.4.0-1
254
255 %description -n mythweb
256 The web interface to MythTV.
257
258 %description -n mythweb -l pl.UTF-8
259 Interfejs WWW do MythTV.
260
261 %package -n mythnetvision
262 Summary:        Mythtv extension to watch network movie shows
263 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
264 Group:          Applications/Multimedia
265 Requires:       mythbrowser
266 Requires:       mythtv-frontend-api = %{myth_api_version}
267 Requires:       python-MythTV
268 Requires:       python-oauth
269
270 %description -n mythnetvision
271 Mythtv extension to watch network movie shows (ex. YouTube).
272
273 %description -n mythnetvision -l pl.UTF-8
274 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
275 YouTube.
276
277 %package -n mythzoneminder
278 Summary:        MythTV security TV manager
279 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
280 Group:          Applications/Multimedia
281 Requires:       mythtv-frontend-api = %{myth_api_version}
282
283 %description -n mythzoneminder
284 MythTV security TV manager.
285
286
287 %description -n mythzoneminder -l pl.UTF-8
288 Obsługa kamer przemysłowych dla MythTV.
289
290 %prep
291 %setup -q
292 %patch0 -p1
293 %patch1 -p1
294 #%patch10 -p1
295 %patch20 -p1
296
297 # lib64 fix - enable to update patch
298 %if %{_lib} != "lib" && 0
299 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
300 xargs grep -l /lib/ . | xargs sed -i -e '
301 s,%{_prefix}/lib/,/%{_lib}/,g
302         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
303 '
304 exit 1
305 %endif
306
307 %build
308 %if %{with binary}
309 export QTDIR="%{_prefix}"
310 # Not gnu configure
311 %configure \
312         --libdir-name=`basename %{_lib}` \
313         --enable-all \
314         %{!?with_mytharchive:--disable-mytharchive} \
315         %{!?with_mythbrowser:--disable-mythbrowser} \
316         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
317         %{!?with_mythgame:--disable-mythgame} \
318         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
319         %{!?with_mythnews:--disable-mythnews} \
320         %{!?with_mythweather:--disable-mythweather} \
321         %{!?with_mythweb:--disable-mythweb} \
322         %{!?with_mythnetvision:--disable-mythnetvision} \
323
324 mv mythconfig.mak mythconfig.mak.old
325 cp mythconfig.mak.old mythconfig.mak
326 cat <<'EOF'>> mythconfig.mak
327 QMAKE_CXX=%{__cxx}
328 QMAKE_CC=%{__cc}
329 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
330 ECFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer
331 ECXXFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer -D__STDC_CONSTANT_MACROS
332 EOF
333
334 %{__make}
335 %endif
336
337 %install
338 rm -rf $RPM_BUILD_ROOT
339 %if %{with binary}
340 export QTDIR="%{_prefix}"
341 %{__make} install \
342         INSTALL_ROOT=$RPM_BUILD_ROOT
343
344 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,pictures}
345 %if %{with mythgame}
346 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
347 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
348 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
349 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
350 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
351 %endif
352 %endif
353
354 %if %{with mythweb}
355 cd mythweb
356 cp -a %{SOURCE3} ./
357 cp -a %{SOURCE4} ./
358 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
359 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
360 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
361 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
362 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
363 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
364 install %{SOURCE5} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
365 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
366 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
367 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
368 cd -
369 %endif
370
371 rm -f $RPM_BUILD_ROOT%{_datadir}/data
372 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
373 for p in mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythweather mythzoneminder; do
374         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
375                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
376         done > $p.lang
377 done
378
379 %clean
380 rm -rf $RPM_BUILD_ROOT
381
382 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
383 %webapp_register apache %{_webapp}
384
385 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
386 %webapp_unregister apache %{_webapp}
387
388 %triggerin -n mythweb -- apache-base
389 %webapp_register httpd %{_webapp}
390
391 %triggerin -n mythweb -- lighttpd
392 %webapp_register lighttpd %{_webapp}
393
394 %triggerun -n mythweb -- apache-base
395 %webapp_unregister httpd %{_webapp}
396
397 %triggerun -n mythweb -- lighttpd
398 %webapp_unregister lighttpd %{_webapp}
399
400 %triggerpostun -n mythweb -- mythweb < 0.19
401 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
402         if [ -f /etc/mythweb/$i.rpmsave ]; then
403                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
404                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
405         fi
406 done
407 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
408
409 # migrate from apache-config macros
410 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
411         if [ -d /etc/apache/webapps.d ]; then
412                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
413                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
414         fi
415
416         if [ -d /etc/httpd/webapps.d ]; then
417                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
418                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
419         fi
420         rm -f /etc/mythweb/apache.conf.rpmsave
421 fi
422
423 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
424         rm -f /etc/apache/conf.d/99_mythplugins.conf
425         /usr/sbin/webapp register apache %{_webapp}
426         %service -q apache reload
427 fi
428 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
429         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
430         /usr/sbin/webapp register httpd %{_webapp}
431         %service -q httpd reload
432 fi
433
434 %post -n mythweb
435 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
436 which packages you can need to run mythweb and how to set it quickly."
437
438 %files
439 %defattr(644,root,root,755)
440
441 %if %{with mytharchive}
442 %files -n mytharchive -f mytharchive.lang
443 %defattr(644,root,root,755)
444 %doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
445 %attr(755,root,root) %{_bindir}/mytharchivehelper
446 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
447 %{_datadir}/mythtv/archivemenu.xml
448 %{_datadir}/mythtv/archiveutils.xml
449 %{_datadir}/mythtv/themes/default/ma_*.png
450 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
451 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
452 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
453 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
454 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
455 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
456 %{_datadir}/mythtv/mytharchive
457 %endif
458
459 %if %{with mythmusic}
460 %files -n mythmusic -f mythmusic.lang
461 %defattr(644,root,root,755)
462 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
463 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
464 /var/lib/mythmusic
465 %{_datadir}/mythtv/musicmenu.xml
466 %{_datadir}/mythtv/music_settings.xml
467 %dir %{_datadir}/mythtv/mythmusic
468 %{_datadir}/mythtv/mythmusic/streams.xml
469 %{_datadir}/mythtv/themes/default/music-base.xml
470 %{_datadir}/mythtv/themes/default/music-ui.xml
471 %{_datadir}/mythtv/themes/default/musicsettings-ui.xml
472 %{_datadir}/mythtv/themes/default/mm-titlelines.png
473 %{_datadir}/mythtv/themes/default-wide/music-base.xml
474 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
475 %{_datadir}/mythtv/themes/default-wide/musicsettings-ui.xml
476 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
477 %{_datadir}/mythtv/themes/default-wide/stream-ui.xml
478 %{_datadir}/mythtv/themes/default/ff_button_off.png
479 %{_datadir}/mythtv/themes/default/ff_button_on.png
480 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
481 %{_datadir}/mythtv/themes/default/miniplayer_background.png
482 %{_datadir}/mythtv/themes/default/mm_*.png
483 %{_datadir}/mythtv/themes/default/music-sel-bg.png
484 %{_datadir}/mythtv/themes/default/next_button_off.png
485 %{_datadir}/mythtv/themes/default/next_button_on.png
486 %{_datadir}/mythtv/themes/default/next_button_pushed.png
487 %{_datadir}/mythtv/themes/default/pause_button_off.png
488 %{_datadir}/mythtv/themes/default/pause_button_on.png
489 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
490 %{_datadir}/mythtv/themes/default/play_button_off.png
491 %{_datadir}/mythtv/themes/default/play_button_on.png
492 %{_datadir}/mythtv/themes/default/play_button_pushed.png
493 %{_datadir}/mythtv/themes/default/prev_button_off.png
494 %{_datadir}/mythtv/themes/default/prev_button_on.png
495 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
496 %{_datadir}/mythtv/themes/default/rew_button_off.png
497 %{_datadir}/mythtv/themes/default/rew_button_on.png
498 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
499 %{_datadir}/mythtv/themes/default/selectionbar.png
500 %{_datadir}/mythtv/themes/default/stop_button_off.png
501 %{_datadir}/mythtv/themes/default/stop_button_on.png
502 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
503 %{_datadir}/mythtv/themes/default/track_info_background.png
504 %{_datadir}/mythtv/themes/default-wide/mm_*.png
505 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
506 %endif
507
508 %if %{with mythweather}
509 %files -n mythweather -f mythweather.lang
510 %defattr(644,root,root,755)
511 %doc mythweather/AUTHORS mythweather/README
512 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
513 %{_datadir}/mythtv/mythweather
514 %{_datadir}/mythtv/weather_settings.xml
515 %{_datadir}/mythtv/themes/default/weather-ui.xml
516 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
517 %{_datadir}/mythtv/themes/default/cloudy.png
518 %{_datadir}/mythtv/themes/default/fair.png
519 %{_datadir}/mythtv/themes/default/flurries.png
520 %{_datadir}/mythtv/themes/default/fog.png
521 %{_datadir}/mythtv/themes/default/logo.png
522 %{_datadir}/mythtv/themes/default/lshowers.png
523 %{_datadir}/mythtv/themes/default/mcloudy.png
524 %{_datadir}/mythtv/themes/default/mw_*.png
525 %{_datadir}/mythtv/themes/default/mwmain.png
526 %{_datadir}/mythtv/themes/default/pcloudy.png
527 %{_datadir}/mythtv/themes/default/rainsnow.png
528 %{_datadir}/mythtv/themes/default/showers.png
529 %{_datadir}/mythtv/themes/default/snowshow.png
530 %{_datadir}/mythtv/themes/default/sunny.png
531 %{_datadir}/mythtv/themes/default/thunshowers.png
532 %{_datadir}/mythtv/themes/default/unknown.png
533 %{_datadir}/mythtv/themes/default-wide/mw-*.png
534 %endif
535
536 %if %{with mythgallery}
537 %files -n mythgallery -f mythgallery.lang
538 %defattr(644,root,root,755)
539 %doc mythgallery/AUTHORS mythgallery/README
540 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
541 %{_datadir}/mythtv/themes/default/gallery-ui.xml
542 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
543 %{_datadir}/mythtv/themes/default/gallery-*.png
544 /var/lib/pictures
545 %endif
546
547 %if %{with mythgame}
548 %files -n mythgame -f mythgame.lang
549 %defattr(644,root,root,755)
550 %doc mythgame/contrib
551 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
552 %{_datadir}/mythtv/games
553 %{_datadir}/mythtv/game_settings.xml
554 %{_datadir}/mythtv/themes/default/game-ui.xml
555 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
556 %dir %{_datadir}/mythtv/metadata/Game
557 %attr(755,root,root) %{_datadir}/mythtv/metadata/Game/giantbomb.py
558 %{_datadir}/mythtv/metadata/Game/giantbomb
559 %endif
560
561 %if %{with mythnews}
562 %files -n mythnews -f mythnews.lang
563 %defattr(644,root,root,755)
564 %doc mythnews/README mythnews/AUTHORS
565 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
566 %{_datadir}/mythtv/mythnews
567 %{_datadir}/mythtv/themes/default/news-ui.xml
568 %{_datadir}/mythtv/themes/default/news-info-bg.png
569 %{_datadir}/mythtv/themes/default/enclosures.png
570 %{_datadir}/mythtv/themes/default/need-download.png
571 %{_datadir}/mythtv/themes/default/podcast.png
572 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
573 %endif
574
575 %if %{with mythbrowser}
576 %files -n mythbrowser -f mythbrowser.lang
577 %defattr(644,root,root,755)
578 %doc mythbrowser/README mythbrowser/AUTHORS
579 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
580 %{_datadir}/mythtv/themes/default/mb_*.png
581 %{_datadir}/mythtv/themes/default/browser-ui.xml
582 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
583 %endif
584
585 %if %{with mythweb}
586 %files -n mythweb
587 %defattr(644,root,root,755)
588 %doc mythweb/README mythweb/mythweb.conf.lighttpd
589 %doc mythweb/htdigest.sh
590 %doc mythweb/http_servers_conf_tips.txt
591 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
592 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
593 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
594 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
595 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
596 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
597 %{_datadir}/mythweb
598 %dir %attr(771,root,http) /var/cache/mythweb
599 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
600 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
601 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
602 %endif
603
604 %if %{with mythnetvision}
605 %files -n mythnetvision -f mythnetvision.lang
606 %defattr(644,root,root,755)
607 %doc mythnetvision/{AUTHORS,ChangeLog,README}
608 %attr(755,root,root) %{_bindir}/mythfillnetvision
609 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
610 %dir %{_datadir}/mythtv/mythnetvision
611 %{_datadir}/mythtv/netvisionmenu.xml
612 %dir %{_datadir}/mythtv/mythnetvision/icons
613 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
614 %{_datadir}/mythtv/mythnetvision/icons/*.png
615 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
616 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
617 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
618 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
619 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
620 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
621 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
622 %{_datadir}/mythtv/themes/default/netvision-ui.xml
623 %endif
624
625 %if %{with mythzoneminder}
626 %files -n mythzoneminder
627 %defattr(644,root,root,755)
628 %defattr(644,root,root,755)
629 %doc mythzoneminder/{AUTHORS,README}
630 %attr(755,root,root) %{_bindir}/mythzmserver
631 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
632 %dir %{_datadir}/mythtv/zonemindermenu.xml
633 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
634 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
635 %{_datadir}/mythtv/themes/default/mz_*png
636 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
637 %endif
This page took 0.114407 seconds and 3 git commands to generate.