]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- fix shebangs and files, rel 11
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythnetvision   # disable building mythnetvision plugin
7 %bcond_without  mythgallery     # disable building mythgallery plugin
8 %bcond_without  mythgame        # disable building mythgame plugin
9 %bcond_without  mythmusic       # disable building mythmusic plugin
10 %bcond_without  mythnews        # disable building mythnews plugin
11 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
12 # not present by default in PLD
13 %bcond_with     mythweather     # enable building mythweather plugin
14 %bcond_without  mythweb         # disable building mythweb plugin
15 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
16
17 %if %{without binary}
18 %undefine       with_mytharchive
19 %undefine       with_mythbrowser
20 %undefine       with_mythnetvision
21 %undefine       with_mythgallery
22 %undefine       with_mythgame
23 %undefine       with_mythmusic
24 %undefine       with_mythnews
25 %undefine       with_mythweather
26 %endif
27
28
29 Summary:        Main MythTV plugins
30 Summary(pl.UTF-8):      Główne wtyczki MythTV
31 Name:           mythplugins
32 Version:        0.26.1
33 Release:        11
34 License:        GPL v2
35 Group:          Applications/Multimedia
36 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
37 # Source0-md5:  d896d9f9313ba5dd95e2e977bf9c0f8f
38 Source1:        mythweb-apache.conf
39 Source2:        mythweb_lighttpd.conf
40 Source3:        htdigest.sh
41 Source4:        http_servers_conf_tips.txt
42 Source5:        mythweb-httpd.conf
43 Patch0:         mythweb-chdir.patch
44 Patch1:         system-zmq.patch
45 Patch2:         cxx11.patch
46 Patch3:         gcc11.patch
47 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
48 Patch20:        %{name}-mytharchive-INT64.patch
49 URL:            http://www.mythtv.org/
50 %if %{with binary}
51 %if %{with mythgallery} || %{with mythmusic}
52 BuildRequires:  OpenGL-devel
53 %endif
54 BuildRequires:  Qt3Support-devel
55 BuildRequires:  QtCore-devel
56 BuildRequires:  QtGui-devel
57 BuildRequires:  QtNetwork-devel
58 BuildRequires:  QtOpenGL-devel
59 BuildRequires:  QtSql-devel
60 BuildRequires:  QtWebKit-devel
61 BuildRequires:  QtXml-devel
62 BuildRequires:  SDL-devel
63 BuildRequires:  a52dec-libs-devel
64 BuildRequires:  faad2-devel >= 2.0-5.2
65 %if %{with mythmusic}
66 BuildRequires:  cdparanoia-III-devel
67 BuildRequires:  fftw3-devel
68 BuildRequires:  fftw3-single-devel
69 BuildRequires:  flac-devel >= 1.0.4
70 BuildRequires:  lame-libs-devel
71 BuildRequires:  libcdaudio-devel >= 0.99.12p2
72 BuildRequires:  libvorbis-devel >= 1:1.0
73 BuildRequires:  taglib-devel
74 %endif
75 BuildRequires:  freetype-devel
76 BuildRequires:  libdvdcss-devel >= 1.2.7
77 BuildRequires:  libdvdread-devel >= 0.9.4
78 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
79 BuildRequires:  libfame-devel >= 0.9.0
80 BuildRequires:  libid3tag-devel
81 BuildRequires:  libmad-devel
82 BuildRequires:  libmyth-devel > 0.26
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libtiff-devel
85 BuildRequires:  libvisual-devel
86 BuildRequires:  mjpegtools-devel >= 1.6.1
87 BuildRequires:  nasm
88 BuildRequires:  patchutils
89 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
90 %{?with_mythweather:BuildRequires:      perl-Image-Size}
91 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
92 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
93 %if %{with mythnetvision}
94 BuildRequires:  python-MythTV
95 BuildRequires:  python-lxml
96 BuildRequires:  python-oauth
97 %endif
98 BuildRequires:  qt4-build
99 BuildRequires:  qt4-qmake
100 BuildRequires:  rpm-perlprov >= 4.1-13
101 BuildRequires:  sed >= 4.0
102 %{?with_mythmusic:BuildRequires:        taglib-devel}
103 BuildRequires:  xorg-lib-libX11-devel
104 BuildRequires:  xvid-devel >= 1:0.9.1
105 BuildRequires:  zlib-devel
106 %endif
107 %{?with_mytharchive:Requires:   mytharchive}
108 %{?with_mythbrowser:Requires:   mythbrowser}
109 %{?with_mythgallery:Requires:   mythgallery}
110 %{?with_mythgame:Requires:      mythgame}
111 %{?with_mythmysic:Requires:     mythmusic}
112 %{?with_mythnetvision:Requires: mythnetvision}
113 %{?with_mythnews:Requires:      mythnews}
114 %{?with_mythweather:Requires:   mythweather}
115 %{?with_mythweb:Requires:       mythweb}
116 Obsoletes:      mythdvd < %{version}-%{release}
117 Obsoletes:      mythmovies < %{version}-%{release}
118 Obsoletes:      mythvideo
119 ExclusiveArch:  %{ix86} %{x8664} x32 ppc
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
123 %define         _webapps        /etc/webapps
124 %define         _webapp         mythweb
125
126 %description
127 This is a consolidation of all the official MythTV plugins that used
128 to be distributed as separate downloads from mythtv.org.
129
130 %description -l pl.UTF-8
131 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
132 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
133
134 %package -n mytharchive
135 Summary:        A MythTV module to create and burn DVDs
136 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
137 Group:          Applications/Multimedia
138 Requires:       dvdauthor
139 Requires:       mjpegtools
140 Requires:       mythtv-frontend-api = %{myth_api_version}
141 Requires:       python-MySQLdb
142 Requires:       python-PIL
143 Suggests:       dvdrtools-mkisofs
144
145 %description -n mytharchive
146 MythArchive is a MythTV style plugin that uses the Mythburn Script to
147 create and burn DVDs from MythTV recordings, MythVideo files or any
148 video files available on a MythTV system. It can also export
149 recordings to a native archive format that can then be imported back
150 into a MythTV system restoring all the associated metadata.
151
152 %description -n mytharchive -l pl.UTF-8
153 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
154 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
155 innych plików z filmami dostępnych w systemie MythTV. Może także
156 eksportować nagrania do natywnego formatu archiwum, który potem można
157 zaimportować z powrotem do systemu MythTV przywracając wszystkie
158 związane z nimi metadane.
159
160 %package -n mythmusic
161 Summary:        The music player add-on module for MythTV
162 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
163 Group:          Applications/Multimedia
164 Requires:       mythtv-frontend-api = %{myth_api_version}
165
166 %description -n mythmusic
167 Music add-on for MythTV. Support playlists, visualisations, tag
168 editing and plays many popular audio file formats - mp3, flac, wav,
169 ogg etc.
170
171 %description -n mythmusic -l pl.UTF-8
172 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
173 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
174 formatów audio - mp3, flac, wav, ogg itd.
175
176 %package -n mythweather
177 Summary:        A MythTV module that displays a weather forcast
178 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
179 Group:          Applications/Multimedia
180 Requires:       mythtv-frontend-api = %{myth_api_version}
181
182 %description -n mythweather
183 A MythTV module that displays a weather forcast.
184
185 %description -n mythweather -l pl.UTF-8
186 Moduł MythTV wyświetlający prognozę pogody.
187
188 %package -n mythgallery
189 Summary:        A gallery/slideshow module for MythTV
190 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
191 Group:          Applications/Multimedia
192 Requires:       mythtv-frontend-api = %{myth_api_version}
193
194 %description -n mythgallery
195 A gallery/slideshow module for MythTV.
196
197 %description -n mythgallery -l pl.UTF-8
198 Moduł galerii/pokazu slajdów dla MythTV.
199
200 %package -n mythgame
201 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
202 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
203 Group:          Applications/Multimedia
204 Requires:       mythtv-frontend-api = %{myth_api_version}
205
206 %description -n mythgame
207 A game frontend (xmame, nes, snes, pc) for MythTV.
208
209 %description -n mythgame -l pl.UTF-8
210 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
211
212 %package -n mythnews
213 Summary:        A RSS News Feed plugin for MythTV
214 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
215 Group:          Applications/Multimedia
216 Requires:       mythtv-frontend-api = %{myth_api_version}
217
218 %description -n mythnews
219 A RSS News Feed plugin for MythTV.
220
221 %description -n mythnews -l pl.UTF-8
222 Wtyczka czytnika nowinek RSS dla MythTV.
223
224 %package -n mythbrowser
225 Summary:        A small web browser module for MythTV
226 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
227 Group:          Applications/Multimedia
228 Requires:       mythtv-frontend-api = %{myth_api_version}
229
230 %description -n mythbrowser
231 MythBrowser is a full fledged web-browser (multiple tabs) to display
232 webpages in full-screen mode. Simple page navigation is possible.
233 Starting with version 0.13 it also has full support for mouse driven
234 navigation (right mouse opens and closes the popup menu).
235
236 MythBrowser also contains a BookmarkManager to manage the website
237 links in a simple mythplugin.
238
239 %description -n mythbrowser -l pl.UTF-8
240 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
241 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
242 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
243 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
244 menu).
245
246 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
247 do stron w prostej wtyczce myth.
248
249 %package -n mythweb
250 Summary:        The web interface to MythTV
251 Summary(pl.UTF-8):      Interfejs WWW do MythTV
252 Group:          Applications/Multimedia
253 Requires:       php(mysql)
254 Requires:       php(posix)
255 Requires:       webapps
256 Requires:       webserver(php) >= 4.3
257 Conflicts:      apache-base < 2.4.0-1
258
259 %description -n mythweb
260 The web interface to MythTV.
261
262 %description -n mythweb -l pl.UTF-8
263 Interfejs WWW do MythTV.
264
265 %package -n mythnetvision
266 Summary:        Mythtv extension to watch network movie shows
267 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
268 Group:          Applications/Multimedia
269 Requires:       mythbrowser
270 Requires:       mythtv-frontend-api = %{myth_api_version}
271 Requires:       python-MythTV
272 Requires:       python-oauth
273
274 %description -n mythnetvision
275 Mythtv extension to watch network movie shows (ex. YouTube).
276
277 %description -n mythnetvision -l pl.UTF-8
278 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
279 YouTube.
280
281 %package -n mythzoneminder
282 Summary:        MythTV security TV manager
283 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
284 Group:          Applications/Multimedia
285 Requires:       mythtv-frontend-api = %{myth_api_version}
286
287 %description -n mythzoneminder
288 MythTV security TV manager.
289
290 %description -n mythzoneminder -l pl.UTF-8
291 Obsługa kamer przemysłowych dla MythTV.
292
293 %prep
294 %setup -q
295 %patch0 -p1
296 %patch1 -p1
297 %patch2 -p1
298 %patch3 -p1
299 #%patch10 -p1
300 %patch20 -p1
301
302 # lib64 fix - enable to update patch
303 %if "%{_lib}" != "lib" && 0
304 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
305 xargs grep -l /lib/ . | xargs sed -i -e '
306 s,%{_prefix}/lib/,/%{_lib}/,g
307         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
308 '
309 exit 1
310 %endif
311
312 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
313       mytharchive/mythburn/scripts/mythburn.py \
314       mythgame/mythgame/scripts/giantbomb.py \
315       mythgame/mythgame/scripts/giantbomb/giantbomb_api.py \
316       mythgame/mythgame/scripts/giantbomb/giantbomb_exceptions.py
317
318 %build
319 %if %{with binary}
320 export QTDIR="%{_prefix}"
321 # Not gnu configure
322 %configure \
323         --libdir-name=`basename %{_lib}` \
324         --enable-all \
325         %{!?with_mytharchive:--disable-mytharchive} \
326         %{!?with_mythbrowser:--disable-mythbrowser} \
327         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
328         %{!?with_mythgame:--disable-mythgame} \
329         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
330         %{!?with_mythnews:--disable-mythnews} \
331         %{!?with_mythweather:--disable-mythweather} \
332         %{!?with_mythweb:--disable-mythweb} \
333         %{!?with_mythnetvision:--disable-mythnetvision} \
334
335 mv mythconfig.mak mythconfig.mak.old
336 cp mythconfig.mak.old mythconfig.mak
337 cat <<'EOF'>> mythconfig.mak
338 QMAKE_CXX=%{__cxx}
339 QMAKE_CC=%{__cc}
340 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
341 ECFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer
342 ECXXFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer -D__STDC_CONSTANT_MACROS
343 EOF
344
345 %{__make}
346 %endif
347
348 %install
349 rm -rf $RPM_BUILD_ROOT
350 %if %{with binary}
351 export QTDIR="%{_prefix}"
352 %{__make} install \
353         INSTALL_ROOT=$RPM_BUILD_ROOT
354
355 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,pictures}
356 %if %{with mythgame}
357 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
358 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
359 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
360 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
361 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
362 %endif
363 %endif
364
365 %if %{with mythweb}
366 cd mythweb
367 cp -a %{SOURCE3} ./
368 cp -a %{SOURCE4} ./
369 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
370 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
371 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
372 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
373 ln -sfr $RPM_BUILD_ROOT/var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
374 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
375 install %{SOURCE5} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
376 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
377 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
378 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
379 cd -
380 %endif
381
382 rm -f $RPM_BUILD_ROOT%{_datadir}/data
383 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
384 for p in mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythweather mythzoneminder; do
385         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
386                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
387         done > $p.lang
388 done
389
390 %clean
391 rm -rf $RPM_BUILD_ROOT
392
393 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
394 %webapp_register apache %{_webapp}
395
396 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
397 %webapp_unregister apache %{_webapp}
398
399 %triggerin -n mythweb -- apache-base
400 %webapp_register httpd %{_webapp}
401
402 %triggerin -n mythweb -- lighttpd
403 %webapp_register lighttpd %{_webapp}
404
405 %triggerun -n mythweb -- apache-base
406 %webapp_unregister httpd %{_webapp}
407
408 %triggerun -n mythweb -- lighttpd
409 %webapp_unregister lighttpd %{_webapp}
410
411 %triggerpostun -n mythweb -- mythweb < 0.19
412 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
413         if [ -f /etc/mythweb/$i.rpmsave ]; then
414                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
415                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
416         fi
417 done
418 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
419
420 # migrate from apache-config macros
421 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
422         if [ -d /etc/apache/webapps.d ]; then
423                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
424                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
425         fi
426
427         if [ -d /etc/httpd/webapps.d ]; then
428                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
429                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
430         fi
431         rm -f /etc/mythweb/apache.conf.rpmsave
432 fi
433
434 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
435         rm -f /etc/apache/conf.d/99_mythplugins.conf
436         /usr/sbin/webapp register apache %{_webapp}
437         %service -q apache reload
438 fi
439 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
440         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
441         /usr/sbin/webapp register httpd %{_webapp}
442         %service -q httpd reload
443 fi
444
445 %post -n mythweb
446 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
447 which packages you can need to run mythweb and how to set it quickly."
448
449 %files
450 %defattr(644,root,root,755)
451
452 %if %{with mytharchive}
453 %files -n mytharchive -f mytharchive.lang
454 %defattr(644,root,root,755)
455 %doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
456 %attr(755,root,root) %{_bindir}/mytharchivehelper
457 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
458 %{_datadir}/mythtv/archivemenu.xml
459 %{_datadir}/mythtv/archiveutils.xml
460 %{_datadir}/mythtv/themes/default/ma_*.png
461 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
462 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
463 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
464 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
465 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
466 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
467 %{_datadir}/mythtv/mytharchive
468 %endif
469
470 %if %{with mythmusic}
471 %files -n mythmusic -f mythmusic.lang
472 %defattr(644,root,root,755)
473 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
474 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
475 /var/lib/mythmusic
476 %{_datadir}/mythtv/musicmenu.xml
477 %{_datadir}/mythtv/music_settings.xml
478 %dir %{_datadir}/mythtv/mythmusic
479 %{_datadir}/mythtv/mythmusic/streams.xml
480 %{_datadir}/mythtv/themes/default/music-base.xml
481 %{_datadir}/mythtv/themes/default/music-ui.xml
482 %{_datadir}/mythtv/themes/default/musicsettings-ui.xml
483 %{_datadir}/mythtv/themes/default/mm-titlelines.png
484 %{_datadir}/mythtv/themes/default-wide/music-base.xml
485 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
486 %{_datadir}/mythtv/themes/default-wide/musicsettings-ui.xml
487 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
488 %{_datadir}/mythtv/themes/default-wide/stream-ui.xml
489 %{_datadir}/mythtv/themes/default/ff_button_off.png
490 %{_datadir}/mythtv/themes/default/ff_button_on.png
491 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
492 %{_datadir}/mythtv/themes/default/miniplayer_background.png
493 %{_datadir}/mythtv/themes/default/mm_*.png
494 %{_datadir}/mythtv/themes/default/music-sel-bg.png
495 %{_datadir}/mythtv/themes/default/next_button_off.png
496 %{_datadir}/mythtv/themes/default/next_button_on.png
497 %{_datadir}/mythtv/themes/default/next_button_pushed.png
498 %{_datadir}/mythtv/themes/default/pause_button_off.png
499 %{_datadir}/mythtv/themes/default/pause_button_on.png
500 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
501 %{_datadir}/mythtv/themes/default/play_button_off.png
502 %{_datadir}/mythtv/themes/default/play_button_on.png
503 %{_datadir}/mythtv/themes/default/play_button_pushed.png
504 %{_datadir}/mythtv/themes/default/prev_button_off.png
505 %{_datadir}/mythtv/themes/default/prev_button_on.png
506 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
507 %{_datadir}/mythtv/themes/default/rew_button_off.png
508 %{_datadir}/mythtv/themes/default/rew_button_on.png
509 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
510 %{_datadir}/mythtv/themes/default/selectionbar.png
511 %{_datadir}/mythtv/themes/default/stop_button_off.png
512 %{_datadir}/mythtv/themes/default/stop_button_on.png
513 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
514 %{_datadir}/mythtv/themes/default/track_info_background.png
515 %{_datadir}/mythtv/themes/default-wide/mm_*.png
516 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
517 %endif
518
519 %if %{with mythweather}
520 %files -n mythweather -f mythweather.lang
521 %defattr(644,root,root,755)
522 %doc mythweather/AUTHORS mythweather/README
523 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
524 %{_datadir}/mythtv/mythweather
525 %{_datadir}/mythtv/weather_settings.xml
526 %{_datadir}/mythtv/themes/default/weather-ui.xml
527 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
528 %{_datadir}/mythtv/themes/default/cloudy.png
529 %{_datadir}/mythtv/themes/default/fair.png
530 %{_datadir}/mythtv/themes/default/flurries.png
531 %{_datadir}/mythtv/themes/default/fog.png
532 %{_datadir}/mythtv/themes/default/logo.png
533 %{_datadir}/mythtv/themes/default/lshowers.png
534 %{_datadir}/mythtv/themes/default/mcloudy.png
535 %{_datadir}/mythtv/themes/default/mw_*.png
536 %{_datadir}/mythtv/themes/default/mwmain.png
537 %{_datadir}/mythtv/themes/default/pcloudy.png
538 %{_datadir}/mythtv/themes/default/rainsnow.png
539 %{_datadir}/mythtv/themes/default/showers.png
540 %{_datadir}/mythtv/themes/default/snowshow.png
541 %{_datadir}/mythtv/themes/default/sunny.png
542 %{_datadir}/mythtv/themes/default/thunshowers.png
543 %{_datadir}/mythtv/themes/default/unknown.png
544 %{_datadir}/mythtv/themes/default-wide/mw-*.png
545 %endif
546
547 %if %{with mythgallery}
548 %files -n mythgallery -f mythgallery.lang
549 %defattr(644,root,root,755)
550 %doc mythgallery/AUTHORS mythgallery/README
551 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
552 %{_datadir}/mythtv/themes/default/gallery-ui.xml
553 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
554 %{_datadir}/mythtv/themes/default/gallery-*.png
555 /var/lib/pictures
556 %endif
557
558 %if %{with mythgame}
559 %files -n mythgame -f mythgame.lang
560 %defattr(644,root,root,755)
561 %doc mythgame/contrib
562 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
563 %{_datadir}/mythtv/games
564 %{_datadir}/mythtv/game_settings.xml
565 %{_datadir}/mythtv/themes/default/game-ui.xml
566 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
567 %dir %{_datadir}/mythtv/metadata/Game
568 %attr(755,root,root) %{_datadir}/mythtv/metadata/Game/giantbomb.py
569 %{_datadir}/mythtv/metadata/Game/giantbomb
570 %endif
571
572 %if %{with mythnews}
573 %files -n mythnews -f mythnews.lang
574 %defattr(644,root,root,755)
575 %doc mythnews/README mythnews/AUTHORS
576 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
577 %{_datadir}/mythtv/mythnews
578 %{_datadir}/mythtv/themes/default/news-ui.xml
579 %{_datadir}/mythtv/themes/default/news-info-bg.png
580 %{_datadir}/mythtv/themes/default/enclosures.png
581 %{_datadir}/mythtv/themes/default/need-download.png
582 %{_datadir}/mythtv/themes/default/podcast.png
583 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
584 %endif
585
586 %if %{with mythbrowser}
587 %files -n mythbrowser -f mythbrowser.lang
588 %defattr(644,root,root,755)
589 %doc mythbrowser/README mythbrowser/AUTHORS
590 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
591 %{_datadir}/mythtv/themes/default/mb_*.png
592 %{_datadir}/mythtv/themes/default/browser-ui.xml
593 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
594 %endif
595
596 %if %{with mythweb}
597 %files -n mythweb
598 %defattr(644,root,root,755)
599 %doc mythweb/README mythweb/mythweb.conf.lighttpd
600 %doc mythweb/htdigest.sh
601 %doc mythweb/http_servers_conf_tips.txt
602 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
603 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
604 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
605 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
606 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
607 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
608 %{_datadir}/mythweb
609 %dir %attr(771,root,http) /var/cache/mythweb
610 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
611 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
612 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
613 %endif
614
615 %if %{with mythnetvision}
616 %files -n mythnetvision -f mythnetvision.lang
617 %defattr(644,root,root,755)
618 %doc mythnetvision/{AUTHORS,ChangeLog,README}
619 %attr(755,root,root) %{_bindir}/mythfillnetvision
620 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
621 %dir %{_datadir}/mythtv/mythnetvision
622 %{_datadir}/mythtv/netvisionmenu.xml
623 %dir %{_datadir}/mythtv/mythnetvision/icons
624 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
625 %{_datadir}/mythtv/mythnetvision/icons/*.png
626 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
627 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
628 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
629 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
630 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
631 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
632 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
633 %{_datadir}/mythtv/themes/default/netvision-ui.xml
634 %endif
635
636 %if %{with mythzoneminder}
637 %files -n mythzoneminder
638 %defattr(644,root,root,755)
639 %defattr(644,root,root,755)
640 %doc mythzoneminder/{AUTHORS,README}
641 %attr(755,root,root) %{_bindir}/mythzmserver
642 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
643 %{_datadir}/mythtv/zonemindermenu.xml
644 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
645 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
646 %{_datadir}/mythtv/themes/default/mz_*png
647 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
648 %endif
This page took 0.114781 seconds and 3 git commands to generate.