]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- up to 0.26.1
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythnetvision   # disable building mythnetvision plugin
7 %bcond_without  mythgallery     # disable building mythgallery plugin
8 %bcond_without  mythgame        # disable building mythgame plugin
9 %bcond_without  mythmusic       # disable building mythmusic plugin
10 %bcond_without  mythnews        # disable building mythnews plugin
11 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
12 # not present by default in PLD
13 %bcond_with     mythweather     # enable building mythweather plugin
14 %bcond_without  mythweb         # disable building mythweb plugin
15 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
16
17 %if %{without binary}
18 %undefine       with_mytharchive
19 %undefine       with_mythbrowser
20 %undefine       with_mythnetvision
21 %undefine       with_mythgallery
22 %undefine       with_mythgame
23 %undefine       with_mythmusic
24 %undefine       with_mythnews
25 %undefine       with_mythweather
26 %endif
27
28 %include        /usr/lib/rpm/macros.perl
29
30 Summary:        Main MythTV plugins
31 Summary(pl.UTF-8):      Główne wtyczki MythTV
32 Name:           mythplugins
33 Version:        0.26.1
34 Release:        1
35 License:        GPL v2
36 Group:          Applications/Multimedia
37 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
38 # Source0-md5:  d896d9f9313ba5dd95e2e977bf9c0f8f
39 Source1:        mythweb-apache.conf
40 Source2:        mythweb_lighttpd.conf
41 Source3:        htdigest.sh
42 Source4:        http_servers_conf_tips.txt
43 Source5:        mythweb-httpd.conf
44 Patch0:         mythweb-chdir.patch
45 Patch1:         system-zmq.patch
46 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
47 Patch20:        %{name}-mytharchive-INT64.patch
48 URL:            http://www.mythtv.org/
49 %if %{with binary}
50 %if %{with mythgallery} || %{with myhtmusic}
51 BuildRequires:  OpenGL-devel
52 %endif
53 BuildRequires:  Qt3Support-devel
54 BuildRequires:  QtCore-devel
55 BuildRequires:  QtGui-devel
56 BuildRequires:  QtNetwork-devel
57 BuildRequires:  QtOpenGL-devel
58 BuildRequires:  QtSql-devel
59 BuildRequires:  QtWebKit-devel
60 BuildRequires:  QtXml-devel
61 BuildRequires:  SDL-devel
62 BuildRequires:  a52dec-libs-devel
63 BuildRequires:  faad2-devel >= 2.0-5.2
64 %if %{with mythmusic}
65 BuildRequires:  cdparanoia-III-devel
66 BuildRequires:  fftw3-devel
67 BuildRequires:  fftw3-single-devel
68 BuildRequires:  flac-devel >= 1.0.4
69 BuildRequires:  lame-libs-devel
70 BuildRequires:  libcdaudio-devel >= 0.99.12p2
71 BuildRequires:  libvorbis-devel >= 1:1.0
72 BuildRequires:  taglib-devel
73 %endif
74 BuildRequires:  freetype-devel
75 BuildRequires:  libdvdcss-devel >= 1.2.7
76 BuildRequires:  libdvdread-devel >= 0.9.4
77 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
78 BuildRequires:  libfame-devel >= 0.9.0
79 BuildRequires:  libid3tag-devel
80 BuildRequires:  libmad-devel
81 BuildRequires:  libmyth-devel > 0.26
82 BuildRequires:  libstdc++-devel
83 BuildRequires:  libtiff-devel
84 BuildRequires:  libvisual-devel
85 BuildRequires:  mjpegtools-devel >= 1.6.1
86 BuildRequires:  nasm
87 BuildRequires:  patchutils
88 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
89 %{?with_mythweather:BuildRequires:      perl-Image-Size}
90 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
91 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
92 %if %{with mythnetvision}
93 BuildRequires:  python-MythTV
94 BuildRequires:  python-lxml
95 BuildRequires:  python-oauth
96 %endif
97 BuildRequires:  qt4-build
98 BuildRequires:  qt4-qmake
99 BuildRequires:  rpm-perlprov >= 4.1-13
100 BuildRequires:  sed >= 4.0
101 %{?with_mythmusic:BuildRequires:        taglib-devel}
102 BuildRequires:  xorg-lib-libX11-devel
103 BuildRequires:  xvid-devel >= 1:0.9.1
104 BuildRequires:  zlib-devel
105 %endif
106 %{?with_mytharchive:Requires:   mytharchive}
107 %{?with_mythbrowser:Requires:   mythbrowser}
108 %{?with_mythgallery:Requires:   mythgallery}
109 %{?with_mythgame:Requires:      mythgame}
110 %{?with_mythmysic:Requires:     mythmusic}
111 %{?with_mythnetvision:Requires: mythnetvision}
112 %{?with_mythnews:Requires:      mythnews}
113 %{?with_mythweather:Requires:   mythweather}
114 %{?with_mythweb:Requires:       mythweb}
115 Obsoletes:      mythdvd < %{version}-%{release}
116 Obsoletes:      mythmovies < %{version}-%{release}
117 Obsoletes:      mythvideo
118 ExclusiveArch:  %{ix86} %{x8664} ppc
119 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
120
121 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
122 %define         _webapps        /etc/webapps
123 %define         _webapp         mythweb
124
125 %description
126 This is a consolidation of all the official MythTV plugins that used
127 to be distributed as separate downloads from mythtv.org.
128
129 %description -l pl.UTF-8
130 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
131 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
132
133 %package -n mytharchive
134 Summary:        A MythTV module to create and burn DVDs
135 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
136 Group:          Applications/Multimedia
137 Requires:       dvdauthor
138 Requires:       mjpegtools
139 Requires:       mythtv-frontend-api = %{myth_api_version}
140 Requires:       python-MySQLdb
141 Requires:       python-PIL
142 Suggests:       dvdrtools-mkisofs
143
144 %description -n mytharchive
145 MythArchive is a MythTV style plugin that uses the Mythburn Script to
146 create and burn DVDs from MythTV recordings, MythVideo files or any
147 video files available on a MythTV system. It can also export
148 recordings to a native archive format that can then be imported back
149 into a MythTV system restoring all the associated metadata.
150
151 %description -n mytharchive -l pl.UTF-8
152 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
153 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
154 innych plików z filmami dostępnych w systemie MythTV. Może także
155 eksportować nagrania do natywnego formatu archiwum, który potem można
156 zaimportować z powrotem do systemu MythTV przywracając wszystkie
157 związane z nimi metadane.
158
159 %package -n mythmusic
160 Summary:        The music player add-on module for MythTV
161 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
162 Group:          Applications/Multimedia
163 Requires:       mythtv-frontend-api = %{myth_api_version}
164
165 %description -n mythmusic
166 Music add-on for MythTV. Support playlists, visualisations, tag
167 editing and plays many popular audio file formats - mp3, flac, wav,
168 ogg etc.
169
170 %description -n mythmusic -l pl.UTF-8
171 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
172 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
173 formatów audio - mp3, flac, wav, ogg itd.
174
175 %package -n mythweather
176 Summary:        A MythTV module that displays a weather forcast
177 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
178 Group:          Applications/Multimedia
179 Requires:       mythtv-frontend-api = %{myth_api_version}
180
181 %description -n mythweather
182 A MythTV module that displays a weather forcast.
183
184 %description -n mythweather -l pl.UTF-8
185 Moduł MythTV wyświetlający prognozę pogody.
186
187 %package -n mythgallery
188 Summary:        A gallery/slideshow module for MythTV
189 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
190 Group:          Applications/Multimedia
191 Requires:       mythtv-frontend-api = %{myth_api_version}
192
193 %description -n mythgallery
194 A gallery/slideshow module for MythTV.
195
196 %description -n mythgallery -l pl.UTF-8
197 Moduł galerii/pokazu slajdów dla MythTV.
198
199 %package -n mythgame
200 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
201 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
202 Group:          Applications/Multimedia
203 Requires:       mythtv-frontend-api = %{myth_api_version}
204
205 %description -n mythgame
206 A game frontend (xmame, nes, snes, pc) for MythTV.
207
208 %description -n mythgame -l pl.UTF-8
209 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
210
211 %package -n mythnews
212 Summary:        A RSS News Feed plugin for MythTV
213 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
214 Group:          Applications/Multimedia
215 Requires:       mythtv-frontend-api = %{myth_api_version}
216
217 %description -n mythnews
218 A RSS News Feed plugin for MythTV.
219
220 %description -n mythnews -l pl.UTF-8
221 Wtyczka czytnika nowinek RSS dla MythTV.
222
223 %package -n mythbrowser
224 Summary:        A small web browser module for MythTV
225 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
226 Group:          Applications/Multimedia
227 Requires:       mythtv-frontend-api = %{myth_api_version}
228
229 %description -n mythbrowser
230 MythBrowser is a full fledged web-browser (multiple tabs) to display
231 webpages in full-screen mode. Simple page navigation is possible.
232 Starting with version 0.13 it also has full support for mouse driven
233 navigation (right mouse opens and closes the popup menu).
234
235 MythBrowser also contains a BookmarkManager to manage the website
236 links in a simple mythplugin.
237
238 %description -n mythbrowser -l pl.UTF-8
239 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
240 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
241 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
242 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
243 menu).
244
245 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
246 do stron w prostej wtyczce myth.
247
248 %package -n mythweb
249 Summary:        The web interface to MythTV
250 Summary(pl.UTF-8):      Interfejs WWW do MythTV
251 Group:          Applications/Multimedia
252 Requires:       php(mysql)
253 Requires:       php(posix)
254 Requires:       webapps
255 Requires:       webserver(php) >= 4.3
256 Conflicts:      apache-base < 2.4.0-1
257
258 %description -n mythweb
259 The web interface to MythTV.
260
261 %description -n mythweb -l pl.UTF-8
262 Interfejs WWW do MythTV.
263
264 %package -n mythnetvision
265 Summary:        Mythtv extension to watch network movie shows
266 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
267 Group:          Applications/Multimedia
268 Requires:       mythbrowser
269 Requires:       mythtv-frontend-api = %{myth_api_version}
270 Requires:       python-MythTV
271 Requires:       python-oauth
272
273 %description -n mythnetvision
274 Mythtv extension to watch network movie shows (ex. YouTube).
275
276 %description -n mythnetvision -l pl.UTF-8
277 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
278 YouTube.
279
280 %package -n mythzoneminder
281 Summary:        MythTV security TV manager
282 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
283 Group:          Applications/Multimedia
284 Requires:       mythtv-frontend-api = %{myth_api_version}
285
286 %description -n mythzoneminder
287 MythTV security TV manager.
288
289
290 %description -n mythzoneminder -l pl.UTF-8
291 Obsługa kamer przemysłowych dla MythTV.
292
293 %prep
294 %setup -q
295 %patch0 -p1
296 %patch1 -p1
297 #%patch10 -p1
298 %patch20 -p1
299
300 # lib64 fix - enable to update patch
301 %if %{_lib} != "lib" && 0
302 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
303 xargs grep -l /lib/ . | xargs sed -i -e '
304 s,%{_prefix}/lib/,/%{_lib}/,g
305         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
306 '
307 exit 1
308 %endif
309
310 %build
311 %if %{with binary}
312 export QTDIR="%{_prefix}"
313 # Not gnu configure
314 %configure \
315         --libdir-name=`basename %{_lib}` \
316         --enable-all \
317         %{!?with_mytharchive:--disable-mytharchive} \
318         %{!?with_mythbrowser:--disable-mythbrowser} \
319         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
320         %{!?with_mythgame:--disable-mythgame} \
321         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
322         %{!?with_mythnews:--disable-mythnews} \
323         %{!?with_mythweather:--disable-mythweather} \
324         %{!?with_mythweb:--disable-mythweb} \
325         %{!?with_mythnetvision:--disable-mythnetvision} \
326
327 mv mythconfig.mak mythconfig.mak.old
328 cp mythconfig.mak.old mythconfig.mak
329 cat <<'EOF'>> mythconfig.mak
330 QMAKE_CXX=%{__cxx}
331 QMAKE_CC=%{__cc}
332 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
333 ECFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer
334 ECXXFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer -D__STDC_CONSTANT_MACROS
335 EOF
336
337 %{__make}
338 %endif
339
340 %install
341 rm -rf $RPM_BUILD_ROOT
342 %if %{with binary}
343 export QTDIR="%{_prefix}"
344 %{__make} install \
345         INSTALL_ROOT=$RPM_BUILD_ROOT
346
347 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,pictures}
348 %if %{with mythgame}
349 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
350 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
351 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
352 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
353 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
354 %endif
355 %endif
356
357 %if %{with mythweb}
358 cd mythweb
359 cp -a %{SOURCE3} ./
360 cp -a %{SOURCE4} ./
361 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
362 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
363 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
364 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
365 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
366 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
367 install %{SOURCE5} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
368 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
369 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
370 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
371 cd -
372 %endif
373
374 rm -f $RPM_BUILD_ROOT%{_datadir}/data
375 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
376 for p in mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythweather mythzoneminder; do
377         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
378                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
379         done > $p.lang
380 done
381
382 %clean
383 rm -rf $RPM_BUILD_ROOT
384
385 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
386 %webapp_register apache %{_webapp}
387
388 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
389 %webapp_unregister apache %{_webapp}
390
391 %triggerin -n mythweb -- apache-base
392 %webapp_register httpd %{_webapp}
393
394 %triggerin -n mythweb -- lighttpd
395 %webapp_register lighttpd %{_webapp}
396
397 %triggerun -n mythweb -- apache-base
398 %webapp_unregister httpd %{_webapp}
399
400 %triggerun -n mythweb -- lighttpd
401 %webapp_unregister lighttpd %{_webapp}
402
403 %triggerpostun -n mythweb -- mythweb < 0.19
404 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
405         if [ -f /etc/mythweb/$i.rpmsave ]; then
406                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
407                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
408         fi
409 done
410 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
411
412 # migrate from apache-config macros
413 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
414         if [ -d /etc/apache/webapps.d ]; then
415                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
416                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
417         fi
418
419         if [ -d /etc/httpd/webapps.d ]; then
420                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
421                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
422         fi
423         rm -f /etc/mythweb/apache.conf.rpmsave
424 fi
425
426 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
427         rm -f /etc/apache/conf.d/99_mythplugins.conf
428         /usr/sbin/webapp register apache %{_webapp}
429         %service -q apache reload
430 fi
431 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
432         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
433         /usr/sbin/webapp register httpd %{_webapp}
434         %service -q httpd reload
435 fi
436
437 %post -n mythweb
438 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
439 which packages you can need to run mythweb and how to set it quickly."
440
441 %files
442 %defattr(644,root,root,755)
443
444 %if %{with mytharchive}
445 %files -n mytharchive -f mytharchive.lang
446 %defattr(644,root,root,755)
447 %doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
448 %attr(755,root,root) %{_bindir}/mytharchivehelper
449 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
450 %{_datadir}/mythtv/archivemenu.xml
451 %{_datadir}/mythtv/archiveutils.xml
452 %{_datadir}/mythtv/themes/default/ma_*.png
453 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
454 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
455 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
456 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
457 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
458 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
459 %{_datadir}/mythtv/mytharchive
460 %endif
461
462 %if %{with mythmusic}
463 %files -n mythmusic -f mythmusic.lang
464 %defattr(644,root,root,755)
465 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
466 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
467 /var/lib/mythmusic
468 %{_datadir}/mythtv/musicmenu.xml
469 %{_datadir}/mythtv/music_settings.xml
470 %dir %{_datadir}/mythtv/mythmusic
471 %{_datadir}/mythtv/mythmusic/streams.xml
472 %{_datadir}/mythtv/themes/default/music-base.xml
473 %{_datadir}/mythtv/themes/default/music-ui.xml
474 %{_datadir}/mythtv/themes/default/musicsettings-ui.xml
475 %{_datadir}/mythtv/themes/default/mm-titlelines.png
476 %{_datadir}/mythtv/themes/default-wide/music-base.xml
477 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
478 %{_datadir}/mythtv/themes/default-wide/musicsettings-ui.xml
479 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
480 %{_datadir}/mythtv/themes/default-wide/stream-ui.xml
481 %{_datadir}/mythtv/themes/default/ff_button_off.png
482 %{_datadir}/mythtv/themes/default/ff_button_on.png
483 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
484 %{_datadir}/mythtv/themes/default/miniplayer_background.png
485 %{_datadir}/mythtv/themes/default/mm_*.png
486 %{_datadir}/mythtv/themes/default/music-sel-bg.png
487 %{_datadir}/mythtv/themes/default/next_button_off.png
488 %{_datadir}/mythtv/themes/default/next_button_on.png
489 %{_datadir}/mythtv/themes/default/next_button_pushed.png
490 %{_datadir}/mythtv/themes/default/pause_button_off.png
491 %{_datadir}/mythtv/themes/default/pause_button_on.png
492 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
493 %{_datadir}/mythtv/themes/default/play_button_off.png
494 %{_datadir}/mythtv/themes/default/play_button_on.png
495 %{_datadir}/mythtv/themes/default/play_button_pushed.png
496 %{_datadir}/mythtv/themes/default/prev_button_off.png
497 %{_datadir}/mythtv/themes/default/prev_button_on.png
498 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
499 %{_datadir}/mythtv/themes/default/rew_button_off.png
500 %{_datadir}/mythtv/themes/default/rew_button_on.png
501 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
502 %{_datadir}/mythtv/themes/default/selectionbar.png
503 %{_datadir}/mythtv/themes/default/stop_button_off.png
504 %{_datadir}/mythtv/themes/default/stop_button_on.png
505 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
506 %{_datadir}/mythtv/themes/default/track_info_background.png
507 %{_datadir}/mythtv/themes/default-wide/mm_*.png
508 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
509 %endif
510
511 %if %{with mythweather}
512 %files -n mythweather -f mythweather.lang
513 %defattr(644,root,root,755)
514 %doc mythweather/AUTHORS mythweather/README
515 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
516 %{_datadir}/mythtv/mythweather
517 %{_datadir}/mythtv/weather_settings.xml
518 %{_datadir}/mythtv/themes/default/weather-ui.xml
519 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
520 %{_datadir}/mythtv/themes/default/cloudy.png
521 %{_datadir}/mythtv/themes/default/fair.png
522 %{_datadir}/mythtv/themes/default/flurries.png
523 %{_datadir}/mythtv/themes/default/fog.png
524 %{_datadir}/mythtv/themes/default/logo.png
525 %{_datadir}/mythtv/themes/default/lshowers.png
526 %{_datadir}/mythtv/themes/default/mcloudy.png
527 %{_datadir}/mythtv/themes/default/mw_*.png
528 %{_datadir}/mythtv/themes/default/mwmain.png
529 %{_datadir}/mythtv/themes/default/pcloudy.png
530 %{_datadir}/mythtv/themes/default/rainsnow.png
531 %{_datadir}/mythtv/themes/default/showers.png
532 %{_datadir}/mythtv/themes/default/snowshow.png
533 %{_datadir}/mythtv/themes/default/sunny.png
534 %{_datadir}/mythtv/themes/default/thunshowers.png
535 %{_datadir}/mythtv/themes/default/unknown.png
536 %{_datadir}/mythtv/themes/default-wide/mw-*.png
537 %endif
538
539 %if %{with mythgallery}
540 %files -n mythgallery -f mythgallery.lang
541 %defattr(644,root,root,755)
542 %doc mythgallery/AUTHORS mythgallery/README
543 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
544 %{_datadir}/mythtv/themes/default/gallery-ui.xml
545 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
546 %{_datadir}/mythtv/themes/default/gallery-*.png
547 /var/lib/pictures
548 %endif
549
550 %if %{with mythgame}
551 %files -n mythgame -f mythgame.lang
552 %defattr(644,root,root,755)
553 %doc mythgame/contrib
554 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
555 %{_datadir}/mythtv/games
556 %{_datadir}/mythtv/game_settings.xml
557 %{_datadir}/mythtv/themes/default/game-ui.xml
558 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
559 %dir %{_datadir}/mythtv/metadata/Game
560 %attr(755,root,root) %{_datadir}/mythtv/metadata/Game/giantbomb.py
561 %{_datadir}/mythtv/metadata/Game/giantbomb
562 %endif
563
564 %if %{with mythnews}
565 %files -n mythnews -f mythnews.lang
566 %defattr(644,root,root,755)
567 %doc mythnews/README mythnews/AUTHORS
568 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
569 %{_datadir}/mythtv/mythnews
570 %{_datadir}/mythtv/themes/default/news-ui.xml
571 %{_datadir}/mythtv/themes/default/news-info-bg.png
572 %{_datadir}/mythtv/themes/default/enclosures.png
573 %{_datadir}/mythtv/themes/default/need-download.png
574 %{_datadir}/mythtv/themes/default/podcast.png
575 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
576 %endif
577
578 %if %{with mythbrowser}
579 %files -n mythbrowser -f mythbrowser.lang
580 %defattr(644,root,root,755)
581 %doc mythbrowser/README mythbrowser/AUTHORS
582 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
583 %{_datadir}/mythtv/themes/default/mb_*.png
584 %{_datadir}/mythtv/themes/default/browser-ui.xml
585 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
586 %endif
587
588 %if %{with mythweb}
589 %files -n mythweb
590 %defattr(644,root,root,755)
591 %doc mythweb/README mythweb/mythweb.conf.lighttpd
592 %doc mythweb/htdigest.sh
593 %doc mythweb/http_servers_conf_tips.txt
594 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
595 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
596 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
597 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
598 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
599 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
600 %{_datadir}/mythweb
601 %dir %attr(771,root,http) /var/cache/mythweb
602 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
603 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
604 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
605 %endif
606
607 %if %{with mythnetvision}
608 %files -n mythnetvision -f mythnetvision.lang
609 %defattr(644,root,root,755)
610 %doc mythnetvision/{AUTHORS,ChangeLog,README}
611 %attr(755,root,root) %{_bindir}/mythfillnetvision
612 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
613 %dir %{_datadir}/mythtv/mythnetvision
614 %{_datadir}/mythtv/netvisionmenu.xml
615 %dir %{_datadir}/mythtv/mythnetvision/icons
616 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
617 %{_datadir}/mythtv/mythnetvision/icons/*.png
618 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
619 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
620 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
621 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
622 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
623 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
624 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
625 %{_datadir}/mythtv/themes/default/netvision-ui.xml
626 %endif
627
628 %if %{with mythzoneminder}
629 %files -n mythzoneminder
630 %defattr(644,root,root,755)
631 %defattr(644,root,root,755)
632 %doc mythzoneminder/{AUTHORS,README}
633 %attr(755,root,root) %{_bindir}/mythzmserver
634 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
635 %dir %{_datadir}/mythtv/zonemindermenu.xml
636 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
637 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
638 %{_datadir}/mythtv/themes/default/mz_*png
639 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
640 %endif
This page took 0.143226 seconds and 3 git commands to generate.