]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
2e0b2431854fa545d8a066d2fb89e44b05469cfc
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable building mytharchive plugin
5 %bcond_without  mythbrowser     # disable building building mythbrowser plugin
6 %bcond_without  mythnetvision   # disable building mythnetvision plugin
7 %bcond_without  mythgallery     # disable building mythgallery plugin
8 %bcond_without  mythgame        # disable building mythgame plugin
9 %bcond_without  mythmusic       # disable building mythmusic plugin
10 %bcond_without  mythnews        # disable building mythnews plugin
11 # Mythweather disabled, as we need DateTime::Format::ISO8601 first
12 # not present by default in PLD
13 %bcond_with     mythweather     # enable building mythweather plugin
14 %bcond_without  mythweb         # disable building mythweb plugin
15 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
16
17 %if %{without binary}
18 %undefine       with_mytharchive
19 %undefine       with_mythbrowser
20 %undefine       with_mythnetvision
21 %undefine       with_mythgallery
22 %undefine       with_mythgame
23 %undefine       with_mythmusic
24 %undefine       with_mythnews
25 %undefine       with_mythweather
26 %endif
27
28 %include        /usr/lib/rpm/macros.perl
29
30 Summary:        Main MythTV plugins
31 Summary(pl.UTF-8):      Główne wtyczki MythTV
32 Name:           mythplugins
33 Version:        0.26.1
34 Release:        4
35 License:        GPL v2
36 Group:          Applications/Multimedia
37 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
38 # Source0-md5:  d896d9f9313ba5dd95e2e977bf9c0f8f
39 Source1:        mythweb-apache.conf
40 Source2:        mythweb_lighttpd.conf
41 Source3:        htdigest.sh
42 Source4:        http_servers_conf_tips.txt
43 Source5:        mythweb-httpd.conf
44 Patch0:         mythweb-chdir.patch
45 Patch1:         system-zmq.patch
46 Patch2:         cxx11.patch
47 Patch10:        %{name}-compile_fixes_for_qt_4_7.patch
48 Patch20:        %{name}-mytharchive-INT64.patch
49 URL:            http://www.mythtv.org/
50 %if %{with binary}
51 %if %{with mythgallery} || %{with myhtmusic}
52 BuildRequires:  OpenGL-devel
53 %endif
54 BuildRequires:  Qt3Support-devel
55 BuildRequires:  QtCore-devel
56 BuildRequires:  QtGui-devel
57 BuildRequires:  QtNetwork-devel
58 BuildRequires:  QtOpenGL-devel
59 BuildRequires:  QtSql-devel
60 BuildRequires:  QtWebKit-devel
61 BuildRequires:  QtXml-devel
62 BuildRequires:  SDL-devel
63 BuildRequires:  a52dec-libs-devel
64 BuildRequires:  faad2-devel >= 2.0-5.2
65 %if %{with mythmusic}
66 BuildRequires:  cdparanoia-III-devel
67 BuildRequires:  fftw3-devel
68 BuildRequires:  fftw3-single-devel
69 BuildRequires:  flac-devel >= 1.0.4
70 BuildRequires:  lame-libs-devel
71 BuildRequires:  libcdaudio-devel >= 0.99.12p2
72 BuildRequires:  libvorbis-devel >= 1:1.0
73 BuildRequires:  taglib-devel
74 %endif
75 BuildRequires:  freetype-devel
76 BuildRequires:  libdvdcss-devel >= 1.2.7
77 BuildRequires:  libdvdread-devel >= 0.9.4
78 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
79 BuildRequires:  libfame-devel >= 0.9.0
80 BuildRequires:  libid3tag-devel
81 BuildRequires:  libmad-devel
82 BuildRequires:  libmyth-devel > 0.26
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libtiff-devel
85 BuildRequires:  libvisual-devel
86 BuildRequires:  mjpegtools-devel >= 1.6.1
87 BuildRequires:  nasm
88 BuildRequires:  patchutils
89 %{?with_mythweather:BuildRequires:      perl-DateTime-Format-ISO8601}
90 %{?with_mythweather:BuildRequires:      perl-Image-Size}
91 %{?with_mythweather:BuildRequires:      perl-XML-Simple}
92 %{?with_mythweather:BuildRequires:      perl-XML-XPath}
93 %if %{with mythnetvision}
94 BuildRequires:  python-MythTV
95 BuildRequires:  python-lxml
96 BuildRequires:  python-oauth
97 %endif
98 BuildRequires:  qt4-build
99 BuildRequires:  qt4-qmake
100 BuildRequires:  rpm-perlprov >= 4.1-13
101 BuildRequires:  sed >= 4.0
102 %{?with_mythmusic:BuildRequires:        taglib-devel}
103 BuildRequires:  xorg-lib-libX11-devel
104 BuildRequires:  xvid-devel >= 1:0.9.1
105 BuildRequires:  zlib-devel
106 %endif
107 %{?with_mytharchive:Requires:   mytharchive}
108 %{?with_mythbrowser:Requires:   mythbrowser}
109 %{?with_mythgallery:Requires:   mythgallery}
110 %{?with_mythgame:Requires:      mythgame}
111 %{?with_mythmysic:Requires:     mythmusic}
112 %{?with_mythnetvision:Requires: mythnetvision}
113 %{?with_mythnews:Requires:      mythnews}
114 %{?with_mythweather:Requires:   mythweather}
115 %{?with_mythweb:Requires:       mythweb}
116 Obsoletes:      mythdvd < %{version}-%{release}
117 Obsoletes:      mythmovies < %{version}-%{release}
118 Obsoletes:      mythvideo
119 ExclusiveArch:  %{ix86} %{x8664} x32 ppc
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %define         myth_api_version %(awk -vFS=. '/^LIBVERSION/{sub("LIBVERSION = ", ""); printf ("%s.%s", $1, $2)}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
123 %define         _webapps        /etc/webapps
124 %define         _webapp         mythweb
125
126 %description
127 This is a consolidation of all the official MythTV plugins that used
128 to be distributed as separate downloads from mythtv.org.
129
130 %description -l pl.UTF-8
131 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
132 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
133
134 %package -n mytharchive
135 Summary:        A MythTV module to create and burn DVDs
136 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
137 Group:          Applications/Multimedia
138 Requires:       dvdauthor
139 Requires:       mjpegtools
140 Requires:       mythtv-frontend-api = %{myth_api_version}
141 Requires:       python-MySQLdb
142 Requires:       python-PIL
143 Suggests:       dvdrtools-mkisofs
144
145 %description -n mytharchive
146 MythArchive is a MythTV style plugin that uses the Mythburn Script to
147 create and burn DVDs from MythTV recordings, MythVideo files or any
148 video files available on a MythTV system. It can also export
149 recordings to a native archive format that can then be imported back
150 into a MythTV system restoring all the associated metadata.
151
152 %description -n mytharchive -l pl.UTF-8
153 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
154 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
155 innych plików z filmami dostępnych w systemie MythTV. Może także
156 eksportować nagrania do natywnego formatu archiwum, który potem można
157 zaimportować z powrotem do systemu MythTV przywracając wszystkie
158 związane z nimi metadane.
159
160 %package -n mythmusic
161 Summary:        The music player add-on module for MythTV
162 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
163 Group:          Applications/Multimedia
164 Requires:       mythtv-frontend-api = %{myth_api_version}
165
166 %description -n mythmusic
167 Music add-on for MythTV. Support playlists, visualisations, tag
168 editing and plays many popular audio file formats - mp3, flac, wav,
169 ogg etc.
170
171 %description -n mythmusic -l pl.UTF-8
172 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania,
173 wizualizacje, edycję tagów. Potrafi odtwarzać wiele popularnych
174 formatów audio - mp3, flac, wav, ogg itd.
175
176 %package -n mythweather
177 Summary:        A MythTV module that displays a weather forcast
178 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
179 Group:          Applications/Multimedia
180 Requires:       mythtv-frontend-api = %{myth_api_version}
181
182 %description -n mythweather
183 A MythTV module that displays a weather forcast.
184
185 %description -n mythweather -l pl.UTF-8
186 Moduł MythTV wyświetlający prognozę pogody.
187
188 %package -n mythgallery
189 Summary:        A gallery/slideshow module for MythTV
190 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
191 Group:          Applications/Multimedia
192 Requires:       mythtv-frontend-api = %{myth_api_version}
193
194 %description -n mythgallery
195 A gallery/slideshow module for MythTV.
196
197 %description -n mythgallery -l pl.UTF-8
198 Moduł galerii/pokazu slajdów dla MythTV.
199
200 %package -n mythgame
201 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
202 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
203 Group:          Applications/Multimedia
204 Requires:       mythtv-frontend-api = %{myth_api_version}
205
206 %description -n mythgame
207 A game frontend (xmame, nes, snes, pc) for MythTV.
208
209 %description -n mythgame -l pl.UTF-8
210 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
211
212 %package -n mythnews
213 Summary:        A RSS News Feed plugin for MythTV
214 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
215 Group:          Applications/Multimedia
216 Requires:       mythtv-frontend-api = %{myth_api_version}
217
218 %description -n mythnews
219 A RSS News Feed plugin for MythTV.
220
221 %description -n mythnews -l pl.UTF-8
222 Wtyczka czytnika nowinek RSS dla MythTV.
223
224 %package -n mythbrowser
225 Summary:        A small web browser module for MythTV
226 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
227 Group:          Applications/Multimedia
228 Requires:       mythtv-frontend-api = %{myth_api_version}
229
230 %description -n mythbrowser
231 MythBrowser is a full fledged web-browser (multiple tabs) to display
232 webpages in full-screen mode. Simple page navigation is possible.
233 Starting with version 0.13 it also has full support for mouse driven
234 navigation (right mouse opens and closes the popup menu).
235
236 MythBrowser also contains a BookmarkManager to manage the website
237 links in a simple mythplugin.
238
239 %description -n mythbrowser -l pl.UTF-8
240 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
241 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
242 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
243 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
244 menu).
245
246 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
247 do stron w prostej wtyczce myth.
248
249 %package -n mythweb
250 Summary:        The web interface to MythTV
251 Summary(pl.UTF-8):      Interfejs WWW do MythTV
252 Group:          Applications/Multimedia
253 Requires:       php(mysql)
254 Requires:       php(posix)
255 Requires:       webapps
256 Requires:       webserver(php) >= 4.3
257 Conflicts:      apache-base < 2.4.0-1
258
259 %description -n mythweb
260 The web interface to MythTV.
261
262 %description -n mythweb -l pl.UTF-8
263 Interfejs WWW do MythTV.
264
265 %package -n mythnetvision
266 Summary:        Mythtv extension to watch network movie shows
267 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
268 Group:          Applications/Multimedia
269 Requires:       mythbrowser
270 Requires:       mythtv-frontend-api = %{myth_api_version}
271 Requires:       python-MythTV
272 Requires:       python-oauth
273
274 %description -n mythnetvision
275 Mythtv extension to watch network movie shows (ex. YouTube).
276
277 %description -n mythnetvision -l pl.UTF-8
278 Dodatek do MythTV do oglądania sieciowych transmisji. Na przykład z
279 YouTube.
280
281 %package -n mythzoneminder
282 Summary:        MythTV security TV manager
283 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
284 Group:          Applications/Multimedia
285 Requires:       mythtv-frontend-api = %{myth_api_version}
286
287 %description -n mythzoneminder
288 MythTV security TV manager.
289
290
291 %description -n mythzoneminder -l pl.UTF-8
292 Obsługa kamer przemysłowych dla MythTV.
293
294 %prep
295 %setup -q
296 %patch0 -p1
297 %patch1 -p1
298 %patch2 -p1
299 #%patch10 -p1
300 %patch20 -p1
301
302 # lib64 fix - enable to update patch
303 %if %{_lib} != "lib" && 0
304 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
305 xargs grep -l /lib/ . | xargs sed -i -e '
306 s,%{_prefix}/lib/,/%{_lib}/,g
307         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
308 '
309 exit 1
310 %endif
311
312 %build
313 %if %{with binary}
314 export QTDIR="%{_prefix}"
315 # Not gnu configure
316 %configure \
317         --libdir-name=`basename %{_lib}` \
318         --enable-all \
319         %{!?with_mytharchive:--disable-mytharchive} \
320         %{!?with_mythbrowser:--disable-mythbrowser} \
321         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
322         %{!?with_mythgame:--disable-mythgame} \
323         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
324         %{!?with_mythnews:--disable-mythnews} \
325         %{!?with_mythweather:--disable-mythweather} \
326         %{!?with_mythweb:--disable-mythweb} \
327         %{!?with_mythnetvision:--disable-mythnetvision} \
328
329 mv mythconfig.mak mythconfig.mak.old
330 cp mythconfig.mak.old mythconfig.mak
331 cat <<'EOF'>> mythconfig.mak
332 QMAKE_CXX=%{__cxx}
333 QMAKE_CC=%{__cc}
334 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
335 ECFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer
336 ECXXFLAGS=%{rpmcflags} %{rpmcppflags} -fomit-frame-pointer -D__STDC_CONSTANT_MACROS
337 EOF
338
339 %{__make}
340 %endif
341
342 %install
343 rm -rf $RPM_BUILD_ROOT
344 %if %{with binary}
345 export QTDIR="%{_prefix}"
346 %{__make} install \
347         INSTALL_ROOT=$RPM_BUILD_ROOT
348
349 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,pictures}
350 %if %{with mythgame}
351 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
352 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
353 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
354 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
355 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
356 %endif
357 %endif
358
359 %if %{with mythweb}
360 cd mythweb
361 cp -a %{SOURCE3} ./
362 cp -a %{SOURCE4} ./
363 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
364 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
365 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
366 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
367 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/mythweb/data
368 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
369 install %{SOURCE5} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
370 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
371 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
372 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htdigest
373 cd -
374 %endif
375
376 rm -f $RPM_BUILD_ROOT%{_datadir}/data
377 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
378 for p in mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythweather mythzoneminder; do
379         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
380                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
381         done > $p.lang
382 done
383
384 %clean
385 rm -rf $RPM_BUILD_ROOT
386
387 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
388 %webapp_register apache %{_webapp}
389
390 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
391 %webapp_unregister apache %{_webapp}
392
393 %triggerin -n mythweb -- apache-base
394 %webapp_register httpd %{_webapp}
395
396 %triggerin -n mythweb -- lighttpd
397 %webapp_register lighttpd %{_webapp}
398
399 %triggerun -n mythweb -- apache-base
400 %webapp_unregister httpd %{_webapp}
401
402 %triggerun -n mythweb -- lighttpd
403 %webapp_unregister lighttpd %{_webapp}
404
405 %triggerpostun -n mythweb -- mythweb < 0.19
406 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
407         if [ -f /etc/mythweb/$i.rpmsave ]; then
408                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
409                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
410         fi
411 done
412 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
413
414 # migrate from apache-config macros
415 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
416         if [ -d /etc/apache/webapps.d ]; then
417                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
418                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
419         fi
420
421         if [ -d /etc/httpd/webapps.d ]; then
422                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
423                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
424         fi
425         rm -f /etc/mythweb/apache.conf.rpmsave
426 fi
427
428 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
429         rm -f /etc/apache/conf.d/99_mythplugins.conf
430         /usr/sbin/webapp register apache %{_webapp}
431         %service -q apache reload
432 fi
433 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
434         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
435         /usr/sbin/webapp register httpd %{_webapp}
436         %service -q httpd reload
437 fi
438
439 %post -n mythweb
440 echo "Read %{_docdir}/mythweb-%{version}/http_servers_conf_tips.txt.gz to find
441 which packages you can need to run mythweb and how to set it quickly."
442
443 %files
444 %defattr(644,root,root,755)
445
446 %if %{with mytharchive}
447 %files -n mytharchive -f mytharchive.lang
448 %defattr(644,root,root,755)
449 %doc mytharchive/AUTHORS mytharchive/README mytharchive/TODO
450 %attr(755,root,root) %{_bindir}/mytharchivehelper
451 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
452 %{_datadir}/mythtv/archivemenu.xml
453 %{_datadir}/mythtv/archiveutils.xml
454 %{_datadir}/mythtv/themes/default/ma_*.png
455 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
456 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
457 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
458 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
459 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
460 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
461 %{_datadir}/mythtv/mytharchive
462 %endif
463
464 %if %{with mythmusic}
465 %files -n mythmusic -f mythmusic.lang
466 %defattr(644,root,root,755)
467 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
468 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
469 /var/lib/mythmusic
470 %{_datadir}/mythtv/musicmenu.xml
471 %{_datadir}/mythtv/music_settings.xml
472 %dir %{_datadir}/mythtv/mythmusic
473 %{_datadir}/mythtv/mythmusic/streams.xml
474 %{_datadir}/mythtv/themes/default/music-base.xml
475 %{_datadir}/mythtv/themes/default/music-ui.xml
476 %{_datadir}/mythtv/themes/default/musicsettings-ui.xml
477 %{_datadir}/mythtv/themes/default/mm-titlelines.png
478 %{_datadir}/mythtv/themes/default-wide/music-base.xml
479 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
480 %{_datadir}/mythtv/themes/default-wide/musicsettings-ui.xml
481 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
482 %{_datadir}/mythtv/themes/default-wide/stream-ui.xml
483 %{_datadir}/mythtv/themes/default/ff_button_off.png
484 %{_datadir}/mythtv/themes/default/ff_button_on.png
485 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
486 %{_datadir}/mythtv/themes/default/miniplayer_background.png
487 %{_datadir}/mythtv/themes/default/mm_*.png
488 %{_datadir}/mythtv/themes/default/music-sel-bg.png
489 %{_datadir}/mythtv/themes/default/next_button_off.png
490 %{_datadir}/mythtv/themes/default/next_button_on.png
491 %{_datadir}/mythtv/themes/default/next_button_pushed.png
492 %{_datadir}/mythtv/themes/default/pause_button_off.png
493 %{_datadir}/mythtv/themes/default/pause_button_on.png
494 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
495 %{_datadir}/mythtv/themes/default/play_button_off.png
496 %{_datadir}/mythtv/themes/default/play_button_on.png
497 %{_datadir}/mythtv/themes/default/play_button_pushed.png
498 %{_datadir}/mythtv/themes/default/prev_button_off.png
499 %{_datadir}/mythtv/themes/default/prev_button_on.png
500 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
501 %{_datadir}/mythtv/themes/default/rew_button_off.png
502 %{_datadir}/mythtv/themes/default/rew_button_on.png
503 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
504 %{_datadir}/mythtv/themes/default/selectionbar.png
505 %{_datadir}/mythtv/themes/default/stop_button_off.png
506 %{_datadir}/mythtv/themes/default/stop_button_on.png
507 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
508 %{_datadir}/mythtv/themes/default/track_info_background.png
509 %{_datadir}/mythtv/themes/default-wide/mm_*.png
510 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
511 %endif
512
513 %if %{with mythweather}
514 %files -n mythweather -f mythweather.lang
515 %defattr(644,root,root,755)
516 %doc mythweather/AUTHORS mythweather/README
517 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
518 %{_datadir}/mythtv/mythweather
519 %{_datadir}/mythtv/weather_settings.xml
520 %{_datadir}/mythtv/themes/default/weather-ui.xml
521 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
522 %{_datadir}/mythtv/themes/default/cloudy.png
523 %{_datadir}/mythtv/themes/default/fair.png
524 %{_datadir}/mythtv/themes/default/flurries.png
525 %{_datadir}/mythtv/themes/default/fog.png
526 %{_datadir}/mythtv/themes/default/logo.png
527 %{_datadir}/mythtv/themes/default/lshowers.png
528 %{_datadir}/mythtv/themes/default/mcloudy.png
529 %{_datadir}/mythtv/themes/default/mw_*.png
530 %{_datadir}/mythtv/themes/default/mwmain.png
531 %{_datadir}/mythtv/themes/default/pcloudy.png
532 %{_datadir}/mythtv/themes/default/rainsnow.png
533 %{_datadir}/mythtv/themes/default/showers.png
534 %{_datadir}/mythtv/themes/default/snowshow.png
535 %{_datadir}/mythtv/themes/default/sunny.png
536 %{_datadir}/mythtv/themes/default/thunshowers.png
537 %{_datadir}/mythtv/themes/default/unknown.png
538 %{_datadir}/mythtv/themes/default-wide/mw-*.png
539 %endif
540
541 %if %{with mythgallery}
542 %files -n mythgallery -f mythgallery.lang
543 %defattr(644,root,root,755)
544 %doc mythgallery/AUTHORS mythgallery/README
545 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
546 %{_datadir}/mythtv/themes/default/gallery-ui.xml
547 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
548 %{_datadir}/mythtv/themes/default/gallery-*.png
549 /var/lib/pictures
550 %endif
551
552 %if %{with mythgame}
553 %files -n mythgame -f mythgame.lang
554 %defattr(644,root,root,755)
555 %doc mythgame/contrib
556 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
557 %{_datadir}/mythtv/games
558 %{_datadir}/mythtv/game_settings.xml
559 %{_datadir}/mythtv/themes/default/game-ui.xml
560 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
561 %dir %{_datadir}/mythtv/metadata/Game
562 %attr(755,root,root) %{_datadir}/mythtv/metadata/Game/giantbomb.py
563 %{_datadir}/mythtv/metadata/Game/giantbomb
564 %endif
565
566 %if %{with mythnews}
567 %files -n mythnews -f mythnews.lang
568 %defattr(644,root,root,755)
569 %doc mythnews/README mythnews/AUTHORS
570 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
571 %{_datadir}/mythtv/mythnews
572 %{_datadir}/mythtv/themes/default/news-ui.xml
573 %{_datadir}/mythtv/themes/default/news-info-bg.png
574 %{_datadir}/mythtv/themes/default/enclosures.png
575 %{_datadir}/mythtv/themes/default/need-download.png
576 %{_datadir}/mythtv/themes/default/podcast.png
577 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
578 %endif
579
580 %if %{with mythbrowser}
581 %files -n mythbrowser -f mythbrowser.lang
582 %defattr(644,root,root,755)
583 %doc mythbrowser/README mythbrowser/AUTHORS
584 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
585 %{_datadir}/mythtv/themes/default/mb_*.png
586 %{_datadir}/mythtv/themes/default/browser-ui.xml
587 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
588 %endif
589
590 %if %{with mythweb}
591 %files -n mythweb
592 %defattr(644,root,root,755)
593 %doc mythweb/README mythweb/mythweb.conf.lighttpd
594 %doc mythweb/htdigest.sh
595 %doc mythweb/http_servers_conf_tips.txt
596 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
597 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
598 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
599 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
600 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
601 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htdigest
602 %{_datadir}/mythweb
603 %dir %attr(771,root,http) /var/cache/mythweb
604 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
605 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
606 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
607 %endif
608
609 %if %{with mythnetvision}
610 %files -n mythnetvision -f mythnetvision.lang
611 %defattr(644,root,root,755)
612 %doc mythnetvision/{AUTHORS,ChangeLog,README}
613 %attr(755,root,root) %{_bindir}/mythfillnetvision
614 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
615 %dir %{_datadir}/mythtv/mythnetvision
616 %{_datadir}/mythtv/netvisionmenu.xml
617 %dir %{_datadir}/mythtv/mythnetvision/icons
618 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
619 %{_datadir}/mythtv/mythnetvision/icons/*.png
620 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
621 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
622 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
623 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
624 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
625 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
626 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml
627 %{_datadir}/mythtv/themes/default/netvision-ui.xml
628 %endif
629
630 %if %{with mythzoneminder}
631 %files -n mythzoneminder
632 %defattr(644,root,root,755)
633 %defattr(644,root,root,755)
634 %doc mythzoneminder/{AUTHORS,README}
635 %attr(755,root,root) %{_bindir}/mythzmserver
636 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
637 %dir %{_datadir}/mythtv/zonemindermenu.xml
638 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
639 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
640 %{_datadir}/mythtv/themes/default/mz_*png
641 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
642 %endif
This page took 0.056915 seconds and 2 git commands to generate.