]> git.pld-linux.org Git - packages/mysql.git/blobdiff - mysql.spec
- remove non-existent cmake options WITH_FAST_MUTEXES and WITH_PAM
[packages/mysql.git] / mysql.spec
index dc930bce225af8d4ecb47fb64b47ed4bc3fb85c3..ff981c16d3ec206c8170e95fcef9095986061b21 100644 (file)
@@ -9,15 +9,8 @@
 # - segfaults on select from non-mysql user (caused by builder environment):
 #     https://bugs.launchpad.net/pld-linux/+bug/381904
 #     (profiling disabled temporaily to workaround this)
-# - unpackaged files:
-#        /usr/bin/mysqlxtest
-#        /usr/lib64/libmysqlservices.a
-#        /usr/lib64/mysql/plugin/connection_control.so
-#        /usr/lib64/mysql/plugin/group_replication.so
-#        /usr/lib64/mysql/plugin/test_udf_services.so
 #
 # Conditional build:
-%bcond_with    autodeps        # BR packages needed only for resolving deps
 %bcond_without innodb          # InnoDB storage engine support
 %bcond_without big_tables      # Support tables with more than 4G rows even on 32 bit platforms
 %bcond_without federated       # Federated storage engine support
@@ -28,7 +21,7 @@
 %bcond_without sphinx          # Sphinx storage engine support
 # mysql needs boost 1.59.0 and doesn't support newer/older boost versions
 %bcond_with    system_boost
-%bcond_with    tests           # FIXME: don't run correctly
+%bcond_without tests           # run test suite
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
 
 %include       /usr/lib/rpm/macros.perl
@@ -41,12 +34,12 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.7.17
-Release:       0.1
+Version:       5.7.21
+Release:       3
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 Source0:       http://cdn.mysql.com/Downloads/MySQL-5.7/%{name}-%{version}.tar.gz
-# Source0-md5: db2a87ede6132b226f8d43d3ac349284
+# Source0-md5: e26523b174bdc3fd0fde6f36791ce17e
 Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.11-release.tar.gz
 # Source100-md5:       5cac34f3d78a9d612ca4301abfcbd666
 %if %{without system_boost}
@@ -74,29 +67,27 @@ Patch18:    %{name}-sphinx.patch
 Patch19:       %{name}-chain-certs.patch
 
 Patch24:       %{name}-cmake.patch
+Patch25:       %{name}-readline.patch
 
-Patch26:       mysqldumpslow-clusters.patch
+Patch26:       %{name}dumpslow-clusters.patch
 URL:           http://www.mysql.com/products/community/
 BuildRequires: bison >= 1.875
 %{?with_system_boost:BuildRequires:    boost-devel >= 1.59.0}
-BuildRequires: cmake >= 2.6
+BuildRequires: cmake >= 2.8.2
 BuildRequires: libaio-devel
-BuildRequires: readline-devel >= 6.2
-%if "%{pld_release}" == "ac"
-BuildRequires: libstdc++4-devel >= 5:4.0
-%else
-BuildRequires: libstdc++-devel >= 5:4.0
-%endif
-BuildRequires: automake
+BuildRequires: libevent-devel
 BuildRequires: libhsclient-devel
+BuildRequires: libstdc++-devel >= 5:4.0
 %{?with_tcpd:BuildRequires:    libwrap-devel}
 BuildRequires: lz4-devel
+BuildRequires: mecab-devel
 BuildRequires: ncurses-devel >= 4.2
 %{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
 BuildRequires: pam-devel
-%{?with_autodeps:BuildRequires:        perl-DBI}
 BuildRequires: perl-devel >= 1:5.6.1
+BuildRequires: protobuf-devel >= 2.5
 BuildRequires: python-modules
+BuildRequires: readline-devel >= 6.2
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.597
 BuildRequires: sed >= 4.0
@@ -235,6 +226,9 @@ MySQL - це SQL (Structured Query Language) сервер бази даних. M
 Summary:       MySQL - character sets definitions
 Summary(pl.UTF-8):     MySQL - definicje kodowań znaków
 Group:         Applications/Databases
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description charsets
 This package contains character sets definitions needed by both client
@@ -264,8 +258,6 @@ Summary:    MySQL additional utilities written in Perl
 Summary(pl.UTF-8):     Dodatkowe narzędzia do MySQL napisane w Perlu
 Group:         Applications/Databases
 Requires:      %{name}-extras = %{version}-%{release}
-# this is just for the sake of smooth upgrade, not to break systems
-Requires:      mysqlhotcopy = %{version}-%{release}
 Requires:      perl-DBD-mysql
 
 %description extras-perl
@@ -484,6 +476,7 @@ mv sphinx-*/mysqlse storage/sphinx
 %patch19 -p1
 
 %patch24 -p1
+%patch25 -p1
 
 %patch26 -p1
 
@@ -502,13 +495,6 @@ cd build
 # (it defaults to first cluster but user may change it to whatever
 # cluster it wants)
 
-%if "%{pld_release}" == "ac"
-# add suffix, but allow ccache, etc in ~/.rpmmacros
-%{expand:%%define      __cc    %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
-%{expand:%%define      __cxx   %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
-%{expand:%%define      __cpp   %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
-%endif
-
 CPPFLAGS="%{rpmcppflags}" \
 %cmake .. \
        -DCMAKE_BUILD_TYPE=%{!?debug:RelWithDebInfo}%{?debug:Debug} \
@@ -528,21 +514,19 @@ CPPFLAGS="%{rpmcppflags}" \
        -DMYSQL_UNIX_ADDR=/var/lib/%{name}/%{name}.sock \
        %{?debug:-DWITH_DEBUG=ON} \
        -DWITHOUT_EXAMPLE_STORAGE_ENGINE=1 \
-       -DWITH_FAST_MUTEXES=ON \
        -DWITH_LIBWRAP=%{?with_tcpd:ON}%{!?with_tcpd:OFF} \
-       -DWITH_PAM=ON \
        -DWITH_PERFSCHEMA_STORAGE_ENGINE=1 \
        -DWITH_PIC=ON \
        -DWITH_LZ4=system \
-%if "%{pld_release}" == "ac"
-       -DWITH_SSL=%{?with_ssl:bundled}%{!?with_ssl:no} \
-%else
+       -DWITH_LIBEVENT=system \
+       -DWITH_PROTOBUF=system \
        -DWITH_SSL=%{?with_ssl:system}%{!?with_ssl:no} \
-%endif
        -DWITH_UNIT_TESTS=%{?with_tests:ON}%{!?with_tests:OFF} \
        %{!?with_system_boost:-DWITH_BOOST="$(pwd)/$(ls -1d ../boost_*)"} \
        -DWITH_ZLIB=system \
-       -DWITH_READLINE=system
+       -DWITH_EDITLINE=system \
+       -DWITH_MECAB=system \
+       -DTMPDIR=/var/tmp
 
 %{__make}
 
@@ -638,7 +622,8 @@ mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/mysqlcheck
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/comp_err.1*
 
 # we don't package those (we have no -test or -testsuite pkg) and some of them just segfault
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/mysql_client_test
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/{mysql_client_test,mysqlxtest}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/mysql/plugin/test_udf_services.so
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/mysql_client_test.1*
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/mysql_client_test_embedded.1*
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/mysql-stress-test.pl.1*
@@ -891,7 +876,6 @@ done
 
 %files
 %defattr(644,root,root,755)
-%doc build/support-files/*.cnf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
 %attr(754,root,root) /etc/rc.d/init.d/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
@@ -914,8 +898,12 @@ done
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth_socket.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth_test_plugin.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/authentication_ldap_sasl_client.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/connection_control.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/group_replication.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/keyring_file.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/keyring_udf.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/libpluginmecab.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/locking_service.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/mypluglib.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/mysql_no_login.so
@@ -1070,6 +1058,7 @@ done
 %{_pkgconfigdir}/mysqlclient.pc
 # static-only so far
 %{_libdir}/libmysqld.a
+%{_libdir}/libmysqlservices.a
 %{_includedir}/mysql
 %{_aclocaldir}/mysql.m4
 %{_mandir}/man1/mysql_config.1*
This page took 0.156245 seconds and 4 git commands to generate.