]> git.pld-linux.org Git - packages/mysql-workbench.git/commitdiff
- fix building on non 64bit archs
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 8 Mar 2018 14:49:01 +0000 (14:49 +0000)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 8 Mar 2018 14:49:01 +0000 (14:49 +0000)
format-string.patch [new file with mode: 0644]
mysql-workbench.spec
types.patch [new file with mode: 0644]

diff --git a/format-string.patch b/format-string.patch
new file mode 100644 (file)
index 0000000..c73b9ac
--- /dev/null
@@ -0,0 +1,26 @@
+--- mysql-workbench-community-6.3.10-src/library/base/jsonparser.cpp~  2017-11-09 16:11:42.000000000 +0000
++++ mysql-workbench-community-6.3.10-src/library/base/jsonparser.cpp   2018-03-08 13:43:48.632064990 +0000
+@@ -343,7 +343,11 @@
+    */
+   JsonValue &JsonArray::at(SizeType pos) {
+     if (pos > _data.size())
++#ifdef __x86_64__
+       throw std::out_of_range(base::strfmt("Index '%lu' is out of range.", pos));
++#else
++      throw std::out_of_range(base::strfmt("Index '%u' is out of range.", pos));
++#endif
+     return _data.at(pos);
+   }
+@@ -358,7 +362,11 @@
+    */
+   const JsonValue &JsonArray::at(SizeType pos) const {
+     if (pos > _data.size())
++#ifdef __x86_64__
+       throw std::out_of_range(base::strfmt("Index '%lu' is out of range.", pos));
++#else
++      throw std::out_of_range(base::strfmt("Index '%u' is out of range.", pos));
++#endif
+     return _data.at(pos);
+   }
index 5d59b93aa6ad5f10e3fe803a8bdd2256d13cdab5..2fe01219cca9269f2b731b69741191d1fc35ffe2 100644 (file)
@@ -30,6 +30,8 @@ Patch3:               wrapper-exec.patch
 Patch4:                antlr-res.patch
 Patch5:                mysql-version.patch
 Patch6:                ldconfig.patch
+Patch7:                format-string.patch
+Patch8:                types.patch
 URL:           http://wb.mysql.com/
 BuildRequires: OpenGL-devel
 BuildRequires: autoconf
@@ -108,6 +110,8 @@ skomplikowanych migracji do MySQL-a.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
+%patch8 -p1
 cp -p '%{SOURCE2}' res/mysql.profiles
 
 %if %{with system_antlr}
diff --git a/types.patch b/types.patch
new file mode 100644 (file)
index 0000000..90dc2ad
--- /dev/null
@@ -0,0 +1,15 @@
+--- mysql-workbench-community-6.3.10-src/library/base/jsonparser.cpp~  2017-11-09 16:11:42.000000000 +0000
++++ mysql-workbench-community-6.3.10-src/library/base/jsonparser.cpp   2018-03-08 13:43:48.632064990 +0000
+@@ -1677,10 +1677,10 @@
+         _output += std::to_string((double)value);
+         break;
+       case VInt64:
+-        _output += std::to_string((int64_t)value);
++        _output += std::to_string((ssize_t)value);
+         break;
+       case VUint64:
+-        _output += std::to_string((uint64_t)value);
++        _output += std::to_string((size_t)value);
+         break;
+       case VObject:
+         write((JsonObject)value);
This page took 0.089325 seconds and 4 git commands to generate.