- rel 3; build with new openjpeg2 auto/th/mupdf-1.3-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 4 Nov 2014 21:50:21 +0000 (22:50 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 4 Nov 2014 21:50:21 +0000 (22:50 +0100)
mupdf-openjpeg.patch
mupdf.spec

index cda593596a35017bf8b67142bbb56d71c7f78b9c..7f83cba303f6c601a9b26f3ebdc00c03a3cb78af 100644 (file)
  SYS_JBIG2DEC_LIBS = -ljbig2dec
  SYS_JPEG_LIBS = -ljpeg
  SYS_ZLIB_LIBS = -lz
+--- mupdf-1.3-source/source/fitz/load-jpx.c~   2013-08-14 14:41:20.000000000 +0200
++++ mupdf-1.3-source/source/fitz/load-jpx.c    2014-11-04 22:47:25.217970803 +0100
+@@ -117,7 +117,7 @@
+       opj_stream_set_read_function(stream, stream_read);
+       opj_stream_set_skip_function(stream, stream_skip);
+       opj_stream_set_seek_function(stream, stream_seek);
+-      opj_stream_set_user_data(stream, &sb);
++      opj_stream_set_user_data(stream, &sb, NULL);
+       /* Set the length to avoid an assert */
+       opj_stream_set_user_data_length(stream, size);
index b7cfcad137fb3044edb5ccdcfde745bd21cffab3..1c2842647686f239d0c7245026a8bd099feda627 100644 (file)
@@ -2,7 +2,7 @@ Summary:        MuPDF - lightweight PDF, XPS and CBZ viewer and parser/rendering librar
 Summary(pl.UTF-8):     MuPDF - lekka przeglądarka oraz biblioteka renderująca PDF, XPS, CBZ
 Name:          mupdf
 Version:       1.3
-Release:       2
+Release:       3
 License:       AGPL v3+
 Group:         Applications/Text
 #Source0Download: http://code.google.com/p/mupdf/downloads/list?q=source
@@ -18,7 +18,7 @@ BuildRequires:        freetype-devel >= 2
 BuildRequires: jbig2dec-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libstdc++-devel
-BuildRequires: openjpeg2-devel >= 2
+BuildRequires: openjpeg2-devel >= 2.1.0
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: v8-devel
@@ -59,7 +59,7 @@ Requires:     freetype-devel >= 2
 Requires:      jbig2dec-devel
 Requires:      libjpeg-devel
 Requires:      libstdc++-devel
-Requires:      openjpeg2-devel >= 2
+Requires:      openjpeg2-devel >= 2.1.0
 Requires:      openssl-devel
 Requires:      v8-devel
 Requires:      zlib-devel
@@ -99,6 +99,7 @@ LDFLAGS="%{rpmldflags}" \
        CC="%{__cc}" \
        CXX="%{__cxx}" \
        V8_PRESENT=yes \
+       SYS_OPENJPEG_CFLAGS="$(pkg-config --cflags libopenjp2)" \
        build=release \
        libdir=%{_libdir} \
        verbose=1
This page took 0.059861 seconds and 4 git commands to generate.