]> git.pld-linux.org Git - packages/mpv.git/commitdiff
upstream patch to fix build with libplacebo 3
authorJan Palus <atler@pld-linux.org>
Sun, 10 Jan 2021 12:48:19 +0000 (13:48 +0100)
committerJan Palus <atler@pld-linux.org>
Sun, 10 Jan 2021 12:48:19 +0000 (13:48 +0100)
libplacebo.patch [new file with mode: 0644]
mpv.spec

diff --git a/libplacebo.patch b/libplacebo.patch
new file mode 100644 (file)
index 0000000..5aaaf7b
--- /dev/null
@@ -0,0 +1,84 @@
+From 7c4465cefb27d4e0d07535d368febdf77b579566 Mon Sep 17 00:00:00 2001
+From: Niklas Haas <git@haasn.xyz>
+Date: Thu, 3 Dec 2020 08:25:23 +0100
+Subject: [PATCH] vo_gpu: placebo: update for upstream API changes
+
+The concept of sample/address modes was moved from `pl_tex` to
+`pl_desc_binding`.
+
+The `pl_tex_blit()` function also underwent an API change.
+---
+ video/out/placebo/ra_pl.c | 31 +++++++++++++++++++++++++++++--
+ 1 file changed, 29 insertions(+), 2 deletions(-)
+
+diff --git a/video/out/placebo/ra_pl.c b/video/out/placebo/ra_pl.c
+index f8df590511..8244acff26 100644
+--- a/video/out/placebo/ra_pl.c
++++ b/video/out/placebo/ra_pl.c
+@@ -144,8 +144,14 @@ bool mppl_wrap_tex(struct ra *ra, const struct pl_tex *pltex,
+             .blit_dst = pltex->params.blit_dst,
+             .host_mutable = pltex->params.host_writable,
+             .downloadable = pltex->params.host_readable,
++#if PL_API_VER >= 103
++            // These don't exist upstream, so just pick something reasonable
++            .src_linear = pltex->params.format->caps & PL_FMT_CAP_LINEAR,
++            .src_repeat = false,
++#else
+             .src_linear = pltex->params.sample_mode == PL_TEX_SAMPLE_LINEAR,
+             .src_repeat = pltex->params.address_mode == PL_TEX_ADDRESS_REPEAT,
++#endif
+         },
+         .priv = (void *) pltex,
+     };
+@@ -195,10 +201,12 @@ static struct ra_tex *tex_create_pl(struct ra *ra,
+         .blit_dst = params->blit_dst || params->render_dst,
+         .host_writable = params->host_mutable,
+         .host_readable = params->downloadable,
++#if PL_API_VER < 103
+         .sample_mode = params->src_linear ? PL_TEX_SAMPLE_LINEAR
+                                           : PL_TEX_SAMPLE_NEAREST,
+         .address_mode = params->src_repeat ? PL_TEX_ADDRESS_REPEAT
+                                            : PL_TEX_ADDRESS_CLAMP,
++#endif
+         .initial_data = params->initial_data,
+     });
+@@ -399,7 +407,18 @@ static void blit_pl(struct ra *ra, struct ra_tex *dst, struct ra_tex *src,
+         pldst.y1 = MPMIN(MPMAX(dst_rc->y1, 0), dst->params.h);
+     }
++#if PL_API_VER >= 103
++    pl_tex_blit(get_gpu(ra), &(struct pl_tex_blit_params) {
++        .src = src->priv,
++        .dst = dst->priv,
++        .src_rc = plsrc,
++        .dst_rc = pldst,
++        .sample_mode = src->params.src_linear ? PL_TEX_SAMPLE_LINEAR
++                                              : PL_TEX_SAMPLE_NEAREST,
++    });
++#else
+     pl_tex_blit(get_gpu(ra), dst->priv, src->priv, pldst, plsrc);
++#endif
+ }
+ static const enum pl_var_type var_type[RA_VARTYPE_COUNT] = {
+@@ -627,9 +646,17 @@ static void renderpass_run_pl(struct ra *ra,
+             struct pl_desc_binding bind;
+             switch (inp->type) {
+             case RA_VARTYPE_TEX:
+-            case RA_VARTYPE_IMG_W:
+-                bind.object = (* (struct ra_tex **) val->data)->priv;
++            case RA_VARTYPE_IMG_W: {
++                struct ra_tex *tex = *((struct ra_tex **) val->data);
++                bind.object = tex->priv;
++#if PL_API_VER >= 103
++                bind.sample_mode = tex->params.src_linear ? PL_TEX_SAMPLE_LINEAR
++                                                          : PL_TEX_SAMPLE_NEAREST;
++                bind.address_mode = tex->params.src_repeat ? PL_TEX_ADDRESS_REPEAT
++                                                           : PL_TEX_ADDRESS_CLAMP;
++#endif
+                 break;
++            }
+             case RA_VARTYPE_BUF_RO:
+             case RA_VARTYPE_BUF_RW:
+                 bind.object = (* (struct ra_buf **) val->data)->priv;
index d460e68a99725338ab766d5fb4ac41762486cf9e..61944bba4e04382a62a3ee906a9526187a04aa78 100644 (file)
--- a/mpv.spec
+++ b/mpv.spec
@@ -21,6 +21,7 @@ Source0:      http://github.com/mpv-player/mpv/archive/v%{version}/%{name}-%{version}
 # Source0-md5: b08d25d3a44c3362984636e5dfa78ecc
 Source1:       %{name}.conf
 Patch0:                %{name}-shaderc.patch
+Patch1:                libplacebo.patch
 URL:           http://mpv.io/
 BuildRequires: EGL-devel
 BuildRequires: Mesa-libgbm-devel
@@ -168,6 +169,7 @@ Dopełnianie parametrów mpv dla powłoki ZSH.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %waf configure \
This page took 0.183163 seconds and 4 git commands to generate.