]> git.pld-linux.org Git - packages/mpv.git/blob - mpv.spec
d278de0c9ac0e06b40ef1a4e5c346a36d9ae4d2f
[packages/mpv.git] / mpv.spec
1 Summary:        Movie player based on MPlayer and mplayer2
2 Name:           mpv
3 Version:        0.24.0
4 Release:        1
5 License:        GPL v2+
6 Group:          Applications/Multimedia
7 Source0:        http://github.com/mpv-player/mpv/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
8 # Source0-md5:  5c85d1163911e49315a5bf1ca1fae13d
9 Source1:        %{name}.conf
10 Patch0:         %{name}-lua.patch
11 URL:            http://mpv.io/
12 BuildRequires:  Mesa-libEGL-devel >= 9.0.0
13 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0.0
14 BuildRequires:  OpenAL-devel >= 1.13
15 BuildRequires:  OpenGL-devel
16 BuildRequires:  SDL-devel
17 BuildRequires:  alsa-lib-devel
18 BuildRequires:  docutils
19 BuildRequires:  ffmpeg-devel >= 3.2
20 BuildRequires:  jack-audio-connection-kit-devel
21 BuildRequires:  lcms2-devel >= 2.6
22 BuildRequires:  libass-devel >= 0.12.1
23 %ifarch i386 i486
24 BuildRequires:  libatomic-devel
25 %endif
26 BuildRequires:  libbluray-devel >= 0.3.0
27 BuildRequires:  libcaca-devel >= 0.99
28 BuildRequires:  libcdio-paranoia-devel
29 BuildRequires:  libdvdnav-devel >= 4.2.0
30 BuildRequires:  libdvdread-devel >= 4.1.0
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libsmbclient-devel
33 BuildRequires:  libv4l-devel
34 BuildRequires:  libva-devel >= 1.2.0
35 BuildRequires:  libva-glx-devel >= 1.2.0
36 BuildRequires:  libvdpau-devel >= 0.2
37 BuildRequires:  lua51-devel
38 BuildRequires:  pkgconfig
39 BuildRequires:  pulseaudio-devel >= 0.9
40 BuildRequires:  rpmbuild(macros) >= 1.336
41 BuildRequires:  uchardet-devel
42 BuildRequires:  waf >= 1.8.12
43 BuildRequires:  wayland-devel >= 1.3.0
44 BuildRequires:  xorg-lib-libX11-devel
45 BuildRequires:  xorg-lib-libXScrnSaver-devel
46 BuildRequires:  xorg-lib-libXdamage-devel
47 BuildRequires:  xorg-lib-libXext-devel
48 BuildRequires:  xorg-lib-libXinerama-devel
49 BuildRequires:  xorg-lib-libXv-devel
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
52 BuildRequires:  xorg-proto-xproto-devel
53 Requires:       Mesa-libwayland-egl >= 9.0.0
54 Requires:       OpenAL >= 1.13
55 Requires:       OpenGL
56 %requires_eq    ffmpeg-libs
57 Requires:       lcms2 >= 2.6
58 Requires:       libass >= 0.12.1
59 Requires:       libbluray >= 0.3.0
60 Requires:       libcaca >= 0.99
61 Requires:       libdvdnav >= 4.2.0
62 Requires:       libdvdread >= 4.1.0
63 Requires:       libva >= 1.2.0
64 Requires:       libva-glx >= 1.2.0
65 Requires:       libvdpau >= 0.2
66 Requires:       pulseaudio-libs >= 1.0
67 Requires:       wayland >= 1.6.0
68 Requires:       xorg-lib-libxkbcommon >= 0.3.0
69 Suggests:       youtube-dl >= 2:20150223
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
73
74 %define         zshdir %{_datadir}/zsh/site-functions
75
76 %description
77 Movie player based on MPlayer and mplayer2.
78
79 %package client-libs
80 Summary:        Client library for controlling mpv
81 Group:          Development/Libraries
82
83 %description client-libs
84 Client library for controlling mpv.
85
86 %package client-devel
87 Summary:        Development files for mpv client library
88 Group:          Development/Libraries
89 Requires:       %{name}-client-libs = %{version}-%{release}
90
91 %description client-devel
92 Development files for mpv client library.
93
94 %package -n zsh-completion-mpv
95 Summary:        zsh-completion for mpv
96 Group:          Applications/Shells
97 Requires:       %{name} = %{version}-%{release}
98
99 %description -n zsh-completion-mpv
100 zsh-completion for mpv.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105
106 %build
107 %waf configure \
108                 --prefix=%{_prefix} \
109                 --bindir=%{_bindir} \
110                 --confdir=%{_sysconfdir}/mpv \
111                 --libdir=%{_libdir} \
112                 --datadir=%{_datadir} \
113                 --mandir=%{_mandir} \
114                 --disable-debug-build \
115                 --enable-alsa \
116                 --enable-audio-input \
117                 --enable-caca \
118                 --enable-cdda \
119                 --enable-dvb \
120                 --enable-dvbin \
121                 --enable-dvdnav \
122                 --enable-dvdread \
123                 --enable-encoding \
124                 --enable-gl-wayland \
125                 --enable-gl-x11 \
126                 --enable-iconv \
127                 --enable-jack \
128                 --enable-jpeg \
129                 --enable-lcms2 \
130                 --enable-libass \
131                 --enable-libass-osd \
132                 --enable-libavdevice \
133                 --enable-libbluray \
134                 --enable-libmpv-shared \
135                 --enable-libsmbclient \
136                 --enable-libv4l2 \
137                 --enable-openal \
138                 --enable-oss-audio \
139                 --enable-pulse \
140                 --enable-sdl1 \
141                 --enable-shm \
142                 --enable-tv \
143                 --enable-tv-v4l2 \
144                 --enable-uchardet \
145                 --enable-vaapi \
146                 --enable-vaapi-glx \
147                 --enable-vaapi-hwaccel \
148                 --enable-vdpau \
149                 --enable-vdpau-gl-x11 \
150                 --enable-vdpau-hwaccel \
151                 --enable-wayland \
152                 --enable-x11 \
153                 --enable-xext \
154                 --enable-xinerama \
155                 --enable-xss \
156                 --enable-xv \
157                 --enable-zsh-comp \
158                 --lua=51pld \
159                 --zshdir=%{zshdir}
160
161 %waf build -v
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 %waf install --destdir=$RPM_BUILD_ROOT
167
168 install -d $RPM_BUILD_ROOT%{_sysconfdir}/mpv
169 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mpv
170
171 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   client-libs -p /sbin/ldconfig
177 %postun client-libs -p /sbin/ldconfig
178
179 %files
180 %defattr(644,root,root,755)
181 %doc README.md RELEASE_NOTES etc/input.conf etc/mplayer-input.conf etc/mpv.conf etc/restore-old-bindings.conf
182 %dir %{_sysconfdir}/mpv
183 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/encoding-profiles.conf
184 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/mpv.conf
185 %attr(755,root,root) %{_bindir}/%{name}
186 %{_desktopdir}/mpv.desktop
187 %{_iconsdir}/hicolor/*/apps/mpv.png
188 %{_iconsdir}/hicolor/scalable/apps/mpv.svg
189 %{_iconsdir}/hicolor/symbolic/apps/mpv-symbolic.svg
190 %{_mandir}/man1/mpv.1*
191
192 %files client-libs
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libmpv.so.*.*.*
195 %attr(755,root,root) %ghost %{_libdir}/libmpv.so.1
196
197 %files client-devel
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/libmpv.so
200 %{_includedir}/mpv
201 %{_pkgconfigdir}/mpv.pc
202
203 %files -n zsh-completion-mpv
204 %defattr(644,root,root,755)
205 %{zshdir}/_mpv
This page took 0.0552820000000001 seconds and 2 git commands to generate.