]> git.pld-linux.org Git - packages/mpv.git/blob - mpv.spec
- release 3 (by relup.sh)
[packages/mpv.git] / mpv.spec
1 Summary:        Movie player based on MPlayer and mplayer2
2 Name:           mpv
3 Version:        0.27.0
4 Release:        3
5 License:        GPL v2+
6 Group:          Applications/Multimedia
7 Source0:        http://github.com/mpv-player/mpv/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
8 # Source0-md5:  ec86f42b091d891f9a932de0f6e873ad
9 Source1:        %{name}.conf
10 Patch0:         %{name}-lua.patch
11 URL:            http://mpv.io/
12 BuildRequires:  Mesa-libEGL-devel >= 9.0.0
13 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0.0
14 BuildRequires:  OpenAL-devel >= 1.13
15 BuildRequires:  OpenGL-devel
16 BuildRequires:  SDL-devel
17 BuildRequires:  alsa-lib-devel >= 1.0.18
18 BuildRequires:  docutils
19 BuildRequires:  ffmpeg-devel >= 3.2.2
20 BuildRequires:  jack-audio-connection-kit-devel
21 BuildRequires:  lcms2-devel >= 2.6
22 BuildRequires:  libass-devel >= 0.12.1
23 %ifarch i386 i486
24 BuildRequires:  libatomic-devel
25 %endif
26 BuildRequires:  libbluray-devel >= 0.3.0
27 BuildRequires:  libcaca-devel >= 0.99-0.beta18.1
28 BuildRequires:  libcdio-paranoia-devel
29 BuildRequires:  libdvdnav-devel >= 4.2.0
30 BuildRequires:  libdvdread-devel >= 4.1.0
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libsmbclient-devel
33 BuildRequires:  libv4l-devel
34 BuildRequires:  libva-devel >= 1.4.0
35 BuildRequires:  libva-glx-devel >= 1.4.0
36 BuildRequires:  libvdpau-devel >= 0.2
37 BuildRequires:  lua51-devel
38 BuildRequires:  pkgconfig
39 BuildRequires:  pulseaudio-devel >= 1.0
40 BuildRequires:  rpmbuild(macros) >= 1.336
41 BuildRequires:  uchardet-devel
42 BuildRequires:  waf >= 1.8.12
43 BuildRequires:  wayland-devel >= 1.3.0
44 BuildRequires:  xorg-lib-libX11-devel >= 1.0.0
45 BuildRequires:  xorg-lib-libXScrnSaver-devel >= 1.0.0
46 BuildRequires:  xorg-lib-libXdamage-devel
47 BuildRequires:  xorg-lib-libXext-devel >= 1.0.0
48 BuildRequires:  xorg-lib-libXinerama-devel >= 1.0.0
49 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2.0
50 BuildRequires:  xorg-lib-libXv-devel
51 BuildRequires:  xorg-lib-libXxf86vm-devel
52 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
53 BuildRequires:  xorg-proto-xproto-devel
54 Requires:       Mesa-libwayland-egl >= 9.0.0
55 Requires:       OpenAL >= 1.13
56 Requires:       OpenGL
57 Requires:       alsa-lib >= 1.0.18
58 %requires_eq    ffmpeg-libs
59 Requires:       lcms2 >= 2.6
60 Requires:       libass >= 0.12.1
61 Requires:       libbluray >= 0.3.0
62 Requires:       libcaca >= 0.99-0.beta18.1
63 Requires:       libdvdnav >= 4.2.0
64 Requires:       libdvdread >= 4.1.0
65 Requires:       libva >= 1.4.0
66 Requires:       libva-glx >= 1.4.0
67 Requires:       libvdpau >= 0.2
68 Requires:       pulseaudio-libs >= 1.0
69 Requires:       wayland >= 1.6.0
70 Requires:       xorg-lib-libX11 >= 1.0.0
71 Requires:       xorg-lib-libXScrnSaver >= 1.0.0
72 Requires:       xorg-lib-libXext >= 1.0.0
73 Requires:       xorg-lib-libXinerama >= 1.0.0
74 Requires:       xorg-lib-libXrandr >= 1.2.0
75 Requires:       xorg-lib-libxkbcommon >= 0.3.0
76 Suggests:       youtube-dl >= 2:20150223
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
80
81 %define         zshdir %{_datadir}/zsh/site-functions
82
83 %description
84 Movie player based on MPlayer and mplayer2.
85
86 %package client-libs
87 Summary:        Client library for controlling mpv
88 Group:          Development/Libraries
89
90 %description client-libs
91 Client library for controlling mpv.
92
93 %package client-devel
94 Summary:        Development files for mpv client library
95 Group:          Development/Libraries
96 Requires:       %{name}-client-libs = %{version}-%{release}
97
98 %description client-devel
99 Development files for mpv client library.
100
101 %package -n zsh-completion-mpv
102 Summary:        zsh-completion for mpv
103 Group:          Applications/Shells
104 Requires:       %{name} = %{version}-%{release}
105
106 %description -n zsh-completion-mpv
107 zsh-completion for mpv.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112
113 %build
114 %waf configure \
115                 --prefix=%{_prefix} \
116                 --bindir=%{_bindir} \
117                 --confdir=%{_sysconfdir}/mpv \
118                 --libdir=%{_libdir} \
119                 --datadir=%{_datadir} \
120                 --mandir=%{_mandir} \
121                 --disable-debug-build \
122                 --enable-alsa \
123                 --enable-audio-input \
124                 --enable-caca \
125                 --enable-cdda \
126                 --enable-cplugins \
127                 --enable-dvb \
128                 --enable-dvbin \
129                 --enable-dvdnav \
130                 --enable-dvdread \
131                 --enable-encoding \
132                 --enable-gl-wayland \
133                 --enable-gl-x11 \
134                 --enable-iconv \
135                 --enable-jack \
136                 --enable-jpeg \
137                 --enable-lcms2 \
138                 --enable-libass \
139                 --enable-libass-osd \
140                 --enable-libavdevice \
141                 --enable-libbluray \
142                 --enable-libmpv-shared \
143                 --enable-libsmbclient \
144                 --enable-libv4l2 \
145                 --enable-openal \
146                 --enable-oss-audio \
147                 --enable-pulse \
148                 --enable-sdl1 \
149                 --enable-shm \
150                 --enable-tv \
151                 --enable-tv-v4l2 \
152                 --enable-uchardet \
153                 --enable-vaapi \
154                 --enable-vaapi-glx \
155                 --enable-vaapi-hwaccel \
156                 --enable-vdpau \
157                 --enable-vdpau-gl-x11 \
158                 --enable-vdpau-hwaccel \
159                 --enable-wayland \
160                 --enable-x11 \
161                 --enable-xv \
162                 --enable-zsh-comp \
163                 --lua=51pld \
164                 --zshdir=%{zshdir}
165
166 %waf build -v
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170
171 %waf install --destdir=$RPM_BUILD_ROOT
172
173 install -d $RPM_BUILD_ROOT%{_sysconfdir}/mpv
174 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mpv
175
176 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post   client-libs -p /sbin/ldconfig
182 %postun client-libs -p /sbin/ldconfig
183
184 %files
185 %defattr(644,root,root,755)
186 %doc README.md RELEASE_NOTES etc/input.conf etc/mplayer-input.conf etc/mpv.conf etc/restore-old-bindings.conf
187 %dir %{_sysconfdir}/mpv
188 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/encoding-profiles.conf
189 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/mpv.conf
190 %attr(755,root,root) %{_bindir}/%{name}
191 %{_desktopdir}/mpv.desktop
192 %{_iconsdir}/hicolor/*/apps/mpv.png
193 %{_iconsdir}/hicolor/scalable/apps/mpv.svg
194 %{_iconsdir}/hicolor/symbolic/apps/mpv-symbolic.svg
195 %{_mandir}/man1/mpv.1*
196
197 %files client-libs
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/libmpv.so.*.*.*
200 %attr(755,root,root) %ghost %{_libdir}/libmpv.so.1
201
202 %files client-devel
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/libmpv.so
205 %{_includedir}/mpv
206 %{_pkgconfigdir}/mpv.pc
207
208 %files -n zsh-completion-mpv
209 %defattr(644,root,root,755)
210 %{zshdir}/_mpv
This page took 0.073307 seconds and 3 git commands to generate.