]> git.pld-linux.org Git - packages/mpv.git/blob - mpv.spec
2b202434858fb20ab13aa9e1d13a5e58400ccccb
[packages/mpv.git] / mpv.spec
1 Summary:        Movie player based on MPlayer and mplayer2
2 Name:           mpv
3 Version:        0.24.0
4 Release:        2
5 License:        GPL v2+
6 Group:          Applications/Multimedia
7 Source0:        http://github.com/mpv-player/mpv/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
8 # Source0-md5:  5c85d1163911e49315a5bf1ca1fae13d
9 Source1:        %{name}.conf
10 Patch0:         %{name}-lua.patch
11 URL:            http://mpv.io/
12 BuildRequires:  Mesa-libEGL-devel >= 9.0.0
13 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0.0
14 BuildRequires:  OpenAL-devel >= 1.13
15 BuildRequires:  OpenGL-devel
16 BuildRequires:  SDL-devel
17 BuildRequires:  alsa-lib-devel
18 BuildRequires:  docutils
19 BuildRequires:  ffmpeg-devel >= 3.2
20 BuildRequires:  jack-audio-connection-kit-devel
21 BuildRequires:  lcms2-devel >= 2.6
22 BuildRequires:  libass-devel >= 0.12.1
23 %ifarch i386 i486
24 BuildRequires:  libatomic-devel
25 %endif
26 BuildRequires:  libbluray-devel >= 0.3.0
27 BuildRequires:  libcaca-devel >= 0.99
28 BuildRequires:  libcdio-paranoia-devel
29 BuildRequires:  libdvdnav-devel >= 4.2.0
30 BuildRequires:  libdvdread-devel >= 4.1.0
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libsmbclient-devel
33 BuildRequires:  libv4l-devel
34 BuildRequires:  libva-devel >= 1.2.0
35 BuildRequires:  libva-glx-devel >= 1.2.0
36 BuildRequires:  libvdpau-devel >= 0.2
37 BuildRequires:  lua51-devel
38 BuildRequires:  pkgconfig
39 BuildRequires:  pulseaudio-devel >= 0.9
40 BuildRequires:  rpmbuild(macros) >= 1.336
41 BuildRequires:  uchardet-devel
42 BuildRequires:  waf >= 1.8.12
43 BuildRequires:  wayland-devel >= 1.3.0
44 BuildRequires:  xorg-lib-libX11-devel
45 BuildRequires:  xorg-lib-libXScrnSaver-devel
46 BuildRequires:  xorg-lib-libXdamage-devel
47 BuildRequires:  xorg-lib-libXext-devel
48 BuildRequires:  xorg-lib-libXinerama-devel
49 BuildRequires:  xorg-lib-libXv-devel
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
52 BuildRequires:  xorg-proto-xproto-devel
53 Requires:       Mesa-libwayland-egl >= 9.0.0
54 Requires:       OpenAL >= 1.13
55 Requires:       OpenGL
56 %requires_eq    ffmpeg-libs
57 Requires:       lcms2 >= 2.6
58 Requires:       libass >= 0.12.1
59 Requires:       libbluray >= 0.3.0
60 Requires:       libcaca >= 0.99
61 Requires:       libdvdnav >= 4.2.0
62 Requires:       libdvdread >= 4.1.0
63 Requires:       libva >= 1.2.0
64 Requires:       libva-glx >= 1.2.0
65 Requires:       libvdpau >= 0.2
66 Requires:       pulseaudio-libs >= 1.0
67 Requires:       wayland >= 1.6.0
68 Requires:       xorg-lib-libxkbcommon >= 0.3.0
69 Suggests:       youtube-dl >= 2:20150223
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
73
74 %define         zshdir %{_datadir}/zsh/site-functions
75
76 %description
77 Movie player based on MPlayer and mplayer2.
78
79 %package client-libs
80 Summary:        Client library for controlling mpv
81 Group:          Development/Libraries
82
83 %description client-libs
84 Client library for controlling mpv.
85
86 %package client-devel
87 Summary:        Development files for mpv client library
88 Group:          Development/Libraries
89 Requires:       %{name}-client-libs = %{version}-%{release}
90
91 %description client-devel
92 Development files for mpv client library.
93
94 %package -n zsh-completion-mpv
95 Summary:        zsh-completion for mpv
96 Group:          Applications/Shells
97 Requires:       %{name} = %{version}-%{release}
98
99 %description -n zsh-completion-mpv
100 zsh-completion for mpv.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105
106 %build
107 %waf configure \
108                 --prefix=%{_prefix} \
109                 --bindir=%{_bindir} \
110                 --confdir=%{_sysconfdir}/mpv \
111                 --libdir=%{_libdir} \
112                 --datadir=%{_datadir} \
113                 --mandir=%{_mandir} \
114                 --disable-debug-build \
115                 --enable-alsa \
116                 --enable-audio-input \
117                 --enable-caca \
118                 --enable-cdda \
119                 --enable-cplugins \
120                 --enable-dvb \
121                 --enable-dvbin \
122                 --enable-dvdnav \
123                 --enable-dvdread \
124                 --enable-encoding \
125                 --enable-gl-wayland \
126                 --enable-gl-x11 \
127                 --enable-iconv \
128                 --enable-jack \
129                 --enable-jpeg \
130                 --enable-lcms2 \
131                 --enable-libass \
132                 --enable-libass-osd \
133                 --enable-libavdevice \
134                 --enable-libbluray \
135                 --enable-libmpv-shared \
136                 --enable-libsmbclient \
137                 --enable-libv4l2 \
138                 --enable-openal \
139                 --enable-oss-audio \
140                 --enable-pulse \
141                 --enable-sdl1 \
142                 --enable-shm \
143                 --enable-tv \
144                 --enable-tv-v4l2 \
145                 --enable-uchardet \
146                 --enable-vaapi \
147                 --enable-vaapi-glx \
148                 --enable-vaapi-hwaccel \
149                 --enable-vdpau \
150                 --enable-vdpau-gl-x11 \
151                 --enable-vdpau-hwaccel \
152                 --enable-wayland \
153                 --enable-x11 \
154                 --enable-xext \
155                 --enable-xinerama \
156                 --enable-xss \
157                 --enable-xv \
158                 --enable-zsh-comp \
159                 --lua=51pld \
160                 --zshdir=%{zshdir}
161
162 %waf build -v
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166
167 %waf install --destdir=$RPM_BUILD_ROOT
168
169 install -d $RPM_BUILD_ROOT%{_sysconfdir}/mpv
170 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mpv
171
172 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   client-libs -p /sbin/ldconfig
178 %postun client-libs -p /sbin/ldconfig
179
180 %files
181 %defattr(644,root,root,755)
182 %doc README.md RELEASE_NOTES etc/input.conf etc/mplayer-input.conf etc/mpv.conf etc/restore-old-bindings.conf
183 %dir %{_sysconfdir}/mpv
184 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/encoding-profiles.conf
185 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/mpv.conf
186 %attr(755,root,root) %{_bindir}/%{name}
187 %{_desktopdir}/mpv.desktop
188 %{_iconsdir}/hicolor/*/apps/mpv.png
189 %{_iconsdir}/hicolor/scalable/apps/mpv.svg
190 %{_iconsdir}/hicolor/symbolic/apps/mpv-symbolic.svg
191 %{_mandir}/man1/mpv.1*
192
193 %files client-libs
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libmpv.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libmpv.so.1
197
198 %files client-devel
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/libmpv.so
201 %{_includedir}/mpv
202 %{_pkgconfigdir}/mpv.pc
203
204 %files -n zsh-completion-mpv
205 %defattr(644,root,root,755)
206 %{zshdir}/_mpv
This page took 0.054152 seconds and 2 git commands to generate.