]> git.pld-linux.org Git - packages/mplayer2.git/blobdiff - mplayer2.spec
- drop vidix bcond and BR, not used anymore
[packages/mplayer2.git] / mplayer2.spec
index 5c24702d579299a705424a1540e4fdc54b0b2cf4..ba8fcf1e411ae4d051bc5b03cf7c9901537b3c5e 100644 (file)
@@ -24,7 +24,7 @@
 %bcond_without libdts          # disable libdts support
 %bcond_without libdv           # disable libdv en/decoding support
 %bcond_without lirc            # without lirc support
-%bcond_without live            # without LIVE555 libraries
+%bcond_with    live            # without LIVE555 libraries
 %bcond_without lzo             # with LZO support (requires lzo 2.x)
 %bcond_without mad             # without mad (audio MPEG) support
 %bcond_without pulseaudio      # without pulseaudio output
 %bcond_without theora          # without theora support
 %bcond_without win32           # without win32 codecs support
 %bcond_without vdpau           # disable vdpau
-%bcond_without vidix           # disable vidix
 %bcond_without vorbis          # without Ogg-Vorbis audio support
 %bcond_with    system_vorbis   # use system libvorbis instead of internal tremor
 %bcond_without xvid            # disable XviD codec
 %bcond_without mencoder        # disable mencoder (a/v encoder) compilation
 %bcond_without sdl             # disable SDL
 %bcond_without doc             # don't build docs (slow)
-%bcond_with    shared          # experimental libmplayer.so support
 %bcond_without amr             # enable Adaptive Multi Rate (AMR) speech codec support
 %bcond_without gnomess         # disable controling gnome screensaver
 %bcond_without ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
 %bcond_with    system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
 %bcond_with    on2             # with patches from On2 Flix Engine for Linux
 
+%bcond_with    nonfree         # non free options of package
+%bcond_without va              # VAAPI (Video Acceleration API)
+%bcond_without vpx             # VP8, a high-quality video codec
 
-%if %{_lib} == "lib64"
-%define                _suf    64
-%else
-%define                _suf    32
-%endif
-
-%define                subver  rc2
-%define                rel     1
 Summary:       MPlayer - THE Movie Player for UN*X
 Summary(de.UTF-8):     MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
 Summary(es.UTF-8):     Otro reproductor de películas
@@ -69,11 +62,13 @@ Summary(pl.UTF-8):  Odtwarzacz filmów dla systemów uniksowych
 Summary(pt_BR.UTF-8):  Reprodutor de filmes
 Name:          mplayer2
 Version:       2.0
-Release:       0.%{subver}.%{rel}
+Release:       17
 License:       GPL
 Group:         Applications/Multimedia
-Source0:       http://ftp.mplayer2.org/pub/release/%{name}-build-%{version}-%{subver}.tar.xz
-# Source0-md5: 92793d629181e059384c43972fa9a701
+Source0:       http://ftp.mplayer2.org/pub/release/%{name}-build-%{version}.tar.xz
+# Source0-md5: 05b93784de995235e2758f182de15f73
+Patch0:                format-security.patch
+Patch1:                libdvdnav5.patch
 URL:           http://www.mplayer2.org/
 BuildRequires: OpenAL-devel
 BuildRequires: OpenGL-devel
@@ -95,15 +90,14 @@ BuildRequires:      faac-devel
 BuildRequires: freetype-devel >= 2.0.9
 BuildRequires: fribidi-devel
 BuildRequires: tar >= 1:1.22
-%{?with_vidix:BuildRequires:   vidix-devel}
 %{?with_altivec:BuildRequires: gcc >= 5:4.1}
 %{?with_gnomess:BuildRequires: dbus-glib-devel}
 %{?with_gif:BuildRequires:     giflib-devel}
 %{?with_gui:BuildRequires:     gtk+2-devel}
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
-%{?with_jack:%requires_eq      jack-audio-connection-kit-libs}
 BuildRequires: lame-libs-devel
 %{?with_caca:BuildRequires:    libcaca-devel}
+BuildRequires: libdc1394-devel
 %{?with_libdts:BuildRequires:  libdts-devel}
 %{?with_libdv:BuildRequires:   libdv-devel > 0.9.5}
 %{?with_dvdnav:BuildRequires:  libdvdnav-devel >= 4.1.3}
@@ -116,8 +110,10 @@ BuildRequires:     libpng-devel
 %{?with_smb:BuildRequires:     libsmbclient-devel}
 %{?with_theora:BuildRequires:  libtheora-devel}
 %{?with_vdpau:BuildRequires:   libvdpau-devel}
+BuildRequires: libvorbis-devel
+%{?with_vpx:BuildRequires:     libvpx-devel >= 0.9.1}
 %{?with_system_vorbis:BuildRequires:   libvorbis-devel}
-%{?with_x264:BuildRequires:    libx264-devel >= 0.1.3}
+%{?with_x264:BuildRequires:    libx264-devel >= 0.1.3-1.20110327}
 BuildRequires: libxslt-progs
 %{?with_lirc:BuildRequires:    lirc-devel}
 %{?with_live:BuildRequires:    live-devel}
@@ -125,8 +121,10 @@ BuildRequires:     libxslt-progs
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
 %{?with_amr:BuildRequires:     opencore-amr-devel}
+BuildRequires: openjpeg-devel
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel >= 0.9}
+BuildRequires: python-modules
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.527
 BuildRequires: schroedinger-devel
@@ -222,14 +220,63 @@ MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
 
 %prep
-%setup -q -n %{name}
+%setup -q -n %{name}-build-%{version}
+%patch0 -p1
+%patch1 -p1
+
+# set ffmpeg options:
+echo " --arch=%{_target_base_arch}" >>ffmpeg_options
+echo " --cc="%{__cc}"" >>ffmpeg_options
+echo " --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags} -I/usr/include/openjpeg-1.5"" >>ffmpeg_options
+echo " --extra-ldflags="%{rpmcflags} %{rpmldflags}"" >>ffmpeg_options
+echo " --disable-debug" >>ffmpeg_options
+echo " --disable-optimizations" >>ffmpeg_options
+echo " --disable-stripping" >>ffmpeg_options
+echo " --enable-avfilter" >>ffmpeg_options
+echo " --enable-gpl" >>ffmpeg_options
+echo " --enable-version3" >>ffmpeg_options
+echo " --enable-libdc1394" >>ffmpeg_options
+echo " --enable-libdirac" >>ffmpeg_options
+#echo "        --enable-libfaad" >>ffmpeg_options
+#echo "        --enable-libfaadbin" >>ffmpeg_options
+# no libgsm-devel
+#echo "        --enable-libgsm" >>ffmpeg_options 
+echo " --enable-libmp3lame" >>ffmpeg_options
+echo " --enable-libschroedinger" >>ffmpeg_options
+echo " --enable-libspeex" >>ffmpeg_options
+echo " --enable-libtheora" >>ffmpeg_options
+echo " --enable-libvorbis" >>ffmpeg_options
+echo " %{?with_vpx:--enable-libvpx}" >>ffmpeg_options
+# x264 API >= 0.99
+echo " --enable-libx264" >>ffmpeg_options
+echo " --enable-libxvid" >>ffmpeg_options
+echo " --enable-libopencore-amrnb" >>ffmpeg_options
+echo " --enable-libopencore-amrwb" >>ffmpeg_options
+echo " --enable-libopenjpeg" >>ffmpeg_options
+echo " --enable-postproc" >>ffmpeg_options
+echo " --enable-pthreads" >>ffmpeg_options
+echo " --enable-swscale" >>ffmpeg_options
+echo " --enable-vdpau" >>ffmpeg_options
+echo " --enable-x11grab" >>ffmpeg_options
+%ifnarch %{ix86} %{x8664}
+echo " --disable-mmx" >>ffmpeg_options
+%endif
+#% ifarch i386 i486
+#echo "        --disable-mmx" >>ffmpeg_options
+#% endif
+%if %{with nonfree}
+echo " --enable-nonfree" >>ffmpeg_options
+echo " --enable-libfaac" >>ffmpeg_options
+%endif
+echo " %{__enable_disable runtime runtime-cpudetect}" >>ffmpeg_options
 
-echo " --prefix=%{_prefix} " >>mplayer_options
+# set mplayer options:
+echo " --prefix=%{_prefix}" >>mplayer_options
 echo " --confdir=%{_sysconfdir}/mplayer" >>mplayer_options
 echo " --cc="%{__cc}"" >>mplayer_options
 echo " --extra-cflags="$CFLAGS"" >>mplayer_options
 #echo "        --real-ldflags="%{rpmldflags}"" >>mplayer_options
-echo " --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}"" >>mplayer_options
+echo " --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}} -lX11 -lXext"" >>mplayer_options
 %if %{with system_ffmpeg}
 echo " --disable-libavutil_a" >>mplayer_options
 echo " --disable-libavcodec_a" >>mplayer_options
@@ -287,7 +334,6 @@ echo "      %{__disable theora}" >>mplayer_options
 echo " %{__disable x264}" >>mplayer_options
 echo " %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}}" >>mplayer_options
 echo " %{__disable xvid}" >>mplayer_options
-echo " %{__disable vidix}" >>mplayer_options
 echo " %{__disable vdpau}" >>mplayer_options
 echo " %{__disable mencoder}" >>mplayer_options
 echo " --enable-dga1" >>mplayer_options
This page took 0.049469 seconds and 4 git commands to generate.