]> git.pld-linux.org Git - packages/mplayer2.git/blobdiff - mplayer2.spec
- drop vidix bcond and BR, not used anymore
[packages/mplayer2.git] / mplayer2.spec
index 41750d18241c8a99c2b12111d8ff80f99274ba29..ba8fcf1e411ae4d051bc5b03cf7c9901537b3c5e 100644 (file)
@@ -24,7 +24,7 @@
 %bcond_without libdts          # disable libdts support
 %bcond_without libdv           # disable libdv en/decoding support
 %bcond_without lirc            # without lirc support
-%bcond_without live            # without LIVE555 libraries
+%bcond_with    live            # without LIVE555 libraries
 %bcond_without lzo             # with LZO support (requires lzo 2.x)
 %bcond_without mad             # without mad (audio MPEG) support
 %bcond_without pulseaudio      # without pulseaudio output
@@ -38,7 +38,6 @@
 %bcond_without theora          # without theora support
 %bcond_without win32           # without win32 codecs support
 %bcond_without vdpau           # disable vdpau
-%bcond_without vidix           # disable vidix
 %bcond_without vorbis          # without Ogg-Vorbis audio support
 %bcond_with    system_vorbis   # use system libvorbis instead of internal tremor
 %bcond_without xvid            # disable XviD codec
@@ -63,11 +62,13 @@ Summary(pl.UTF-8):  Odtwarzacz filmów dla systemów uniksowych
 Summary(pt_BR.UTF-8):  Reprodutor de filmes
 Name:          mplayer2
 Version:       2.0
-Release:       0.1
+Release:       17
 License:       GPL
 Group:         Applications/Multimedia
 Source0:       http://ftp.mplayer2.org/pub/release/%{name}-build-%{version}.tar.xz
 # Source0-md5: 05b93784de995235e2758f182de15f73
+Patch0:                format-security.patch
+Patch1:                libdvdnav5.patch
 URL:           http://www.mplayer2.org/
 BuildRequires: OpenAL-devel
 BuildRequires: OpenGL-devel
@@ -89,15 +90,14 @@ BuildRequires:      faac-devel
 BuildRequires: freetype-devel >= 2.0.9
 BuildRequires: fribidi-devel
 BuildRequires: tar >= 1:1.22
-%{?with_vidix:BuildRequires:   vidix-devel}
 %{?with_altivec:BuildRequires: gcc >= 5:4.1}
 %{?with_gnomess:BuildRequires: dbus-glib-devel}
 %{?with_gif:BuildRequires:     giflib-devel}
 %{?with_gui:BuildRequires:     gtk+2-devel}
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
-%{?with_jack:%requires_eq      jack-audio-connection-kit-libs}
 BuildRequires: lame-libs-devel
 %{?with_caca:BuildRequires:    libcaca-devel}
+BuildRequires: libdc1394-devel
 %{?with_libdts:BuildRequires:  libdts-devel}
 %{?with_libdv:BuildRequires:   libdv-devel > 0.9.5}
 %{?with_dvdnav:BuildRequires:  libdvdnav-devel >= 4.1.3}
@@ -110,6 +110,7 @@ BuildRequires:      libpng-devel
 %{?with_smb:BuildRequires:     libsmbclient-devel}
 %{?with_theora:BuildRequires:  libtheora-devel}
 %{?with_vdpau:BuildRequires:   libvdpau-devel}
+BuildRequires: libvorbis-devel
 %{?with_vpx:BuildRequires:     libvpx-devel >= 0.9.1}
 %{?with_system_vorbis:BuildRequires:   libvorbis-devel}
 %{?with_x264:BuildRequires:    libx264-devel >= 0.1.3-1.20110327}
@@ -120,8 +121,10 @@ BuildRequires:     libxslt-progs
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
 %{?with_amr:BuildRequires:     opencore-amr-devel}
+BuildRequires: openjpeg-devel
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel >= 0.9}
+BuildRequires: python-modules
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.527
 BuildRequires: schroedinger-devel
@@ -217,12 +220,14 @@ MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
 
 %prep
-%setup -q -n %{name}
+%setup -q -n %{name}-build-%{version}
+%patch0 -p1
+%patch1 -p1
 
 # set ffmpeg options:
 echo " --arch=%{_target_base_arch}" >>ffmpeg_options
 echo " --cc="%{__cc}"" >>ffmpeg_options
-echo " --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}"" >>ffmpeg_options
+echo " --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags} -I/usr/include/openjpeg-1.5"" >>ffmpeg_options
 echo " --extra-ldflags="%{rpmcflags} %{rpmldflags}"" >>ffmpeg_options
 echo " --disable-debug" >>ffmpeg_options
 echo " --disable-optimizations" >>ffmpeg_options
@@ -263,7 +268,7 @@ echo "      --disable-mmx" >>ffmpeg_options
 echo " --enable-nonfree" >>ffmpeg_options
 echo " --enable-libfaac" >>ffmpeg_options
 %endif
-echo " --enable-runtime-cpudetect" >>ffmpeg_options
+echo " %{__enable_disable runtime runtime-cpudetect}" >>ffmpeg_options
 
 # set mplayer options:
 echo " --prefix=%{_prefix}" >>mplayer_options
@@ -271,7 +276,7 @@ echo "      --confdir=%{_sysconfdir}/mplayer" >>mplayer_options
 echo " --cc="%{__cc}"" >>mplayer_options
 echo " --extra-cflags="$CFLAGS"" >>mplayer_options
 #echo "        --real-ldflags="%{rpmldflags}"" >>mplayer_options
-echo " --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}"" >>mplayer_options
+echo " --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}} -lX11 -lXext"" >>mplayer_options
 %if %{with system_ffmpeg}
 echo " --disable-libavutil_a" >>mplayer_options
 echo " --disable-libavcodec_a" >>mplayer_options
@@ -329,7 +334,6 @@ echo "      %{__disable theora}" >>mplayer_options
 echo " %{__disable x264}" >>mplayer_options
 echo " %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}}" >>mplayer_options
 echo " %{__disable xvid}" >>mplayer_options
-echo " %{__disable vidix}" >>mplayer_options
 echo " %{__disable vdpau}" >>mplayer_options
 echo " %{__disable mencoder}" >>mplayer_options
 echo " --enable-dga1" >>mplayer_options
This page took 0.064113 seconds and 4 git commands to generate.