]> git.pld-linux.org Git - packages/mplayer2.git/blobdiff - mplayer2.spec
- release 7
[packages/mplayer2.git] / mplayer2.spec
index 1b1f5d74bdad6fee680b85358bc002ea1eae9bbb..abd78b6dda95123cc90048102a089c90cf0cf635 100644 (file)
@@ -45,7 +45,6 @@
 %bcond_without mencoder        # disable mencoder (a/v encoder) compilation
 %bcond_without sdl             # disable SDL
 %bcond_without doc             # don't build docs (slow)
-%bcond_with    shared          # experimental libmplayer.so support
 %bcond_without amr             # enable Adaptive Multi Rate (AMR) speech codec support
 %bcond_without gnomess         # disable controling gnome screensaver
 %bcond_without ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
 %bcond_without va              # VAAPI (Video Acceleration API)
 %bcond_without vpx             # VP8, a high-quality video codec
 
-%if %{_lib} == "lib64"
-%define                _suf    64
-%else
-%define                _suf    32
-%endif
-
-%define                subver  rc2
-%define                rel     1
 Summary:       MPlayer - THE Movie Player for UN*X
 Summary(de.UTF-8):     MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
 Summary(es.UTF-8):     Otro reproductor de películas
@@ -72,11 +63,11 @@ Summary(pl.UTF-8):  Odtwarzacz filmów dla systemów uniksowych
 Summary(pt_BR.UTF-8):  Reprodutor de filmes
 Name:          mplayer2
 Version:       2.0
-Release:       0.%{subver}.%{rel}
+Release:       7
 License:       GPL
 Group:         Applications/Multimedia
-Source0:       http://ftp.mplayer2.org/pub/release/%{name}-build-%{version}-%{subver}.tar.xz
-# Source0-md5: 92793d629181e059384c43972fa9a701
+Source0:       http://ftp.mplayer2.org/pub/release/%{name}-build-%{version}.tar.xz
+# Source0-md5: 05b93784de995235e2758f182de15f73
 URL:           http://www.mplayer2.org/
 BuildRequires: OpenAL-devel
 BuildRequires: OpenGL-devel
@@ -104,9 +95,9 @@ BuildRequires:       tar >= 1:1.22
 %{?with_gif:BuildRequires:     giflib-devel}
 %{?with_gui:BuildRequires:     gtk+2-devel}
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
-%{?with_jack:%requires_eq      jack-audio-connection-kit-libs}
 BuildRequires: lame-libs-devel
 %{?with_caca:BuildRequires:    libcaca-devel}
+BuildRequires: libdc1394-devel
 %{?with_libdts:BuildRequires:  libdts-devel}
 %{?with_libdv:BuildRequires:   libdv-devel > 0.9.5}
 %{?with_dvdnav:BuildRequires:  libdvdnav-devel >= 4.1.3}
@@ -119,8 +110,10 @@ BuildRequires:     libpng-devel
 %{?with_smb:BuildRequires:     libsmbclient-devel}
 %{?with_theora:BuildRequires:  libtheora-devel}
 %{?with_vdpau:BuildRequires:   libvdpau-devel}
+BuildRequires: libvorbis-devel
+%{?with_vpx:BuildRequires:     libvpx-devel >= 0.9.1}
 %{?with_system_vorbis:BuildRequires:   libvorbis-devel}
-%{?with_x264:BuildRequires:    libx264-devel >= 0.1.3}
+%{?with_x264:BuildRequires:    libx264-devel >= 0.1.3-1.20110327}
 BuildRequires: libxslt-progs
 %{?with_lirc:BuildRequires:    lirc-devel}
 %{?with_live:BuildRequires:    live-devel}
@@ -128,8 +121,10 @@ BuildRequires:     libxslt-progs
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
 %{?with_amr:BuildRequires:     opencore-amr-devel}
+BuildRequires: openjpeg-devel
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel >= 0.9}
+BuildRequires: python-modules
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.527
 BuildRequires: schroedinger-devel
@@ -225,14 +220,10 @@ MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
 
 %prep
-%setup -q -n %{name}
+%setup -q -n %{name}-build-%{version}
 
 # set ffmpeg options:
 echo " --arch=%{_target_base_arch}" >>ffmpeg_options
-#echo "        --prefix=%{_prefix}" >>ffmpeg_options
-#echo "        --libdir=%{_libdir}" >>ffmpeg_options
-#echo "        --shlibdir=%{_libdir}" >>ffmpeg_options
-#echo "        --mandir=%{_mandir}" >>ffmpeg_options
 echo " --cc="%{__cc}"" >>ffmpeg_options
 echo " --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}"" >>ffmpeg_options
 echo " --extra-ldflags="%{rpmcflags} %{rpmldflags}"" >>ffmpeg_options
@@ -254,8 +245,8 @@ echo "      --enable-libspeex" >>ffmpeg_options
 echo " --enable-libtheora" >>ffmpeg_options
 echo " --enable-libvorbis" >>ffmpeg_options
 echo " %{?with_vpx:--enable-libvpx}" >>ffmpeg_options
-# x264 >= 0.99
-#echo "        --enable-libx264" >>ffmpeg_options
+# x264 API >= 0.99
+echo " --enable-libx264" >>ffmpeg_options
 echo " --enable-libxvid" >>ffmpeg_options
 echo " --enable-libopencore-amrnb" >>ffmpeg_options
 echo " --enable-libopencore-amrwb" >>ffmpeg_options
@@ -268,9 +259,9 @@ echo "      --enable-x11grab" >>ffmpeg_options
 %ifnarch %{ix86} %{x8664}
 echo " --disable-mmx" >>ffmpeg_options
 %endif
-%ifarch i386 i486
-echo " --disable-mmx" >>ffmpeg_options
-%endif
+#% ifarch i386 i486
+#echo "        --disable-mmx" >>ffmpeg_options
+#% endif
 %if %{with nonfree}
 echo " --enable-nonfree" >>ffmpeg_options
 echo " --enable-libfaac" >>ffmpeg_options
@@ -283,7 +274,7 @@ echo "      --confdir=%{_sysconfdir}/mplayer" >>mplayer_options
 echo " --cc="%{__cc}"" >>mplayer_options
 echo " --extra-cflags="$CFLAGS"" >>mplayer_options
 #echo "        --real-ldflags="%{rpmldflags}"" >>mplayer_options
-echo " --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}"" >>mplayer_options
+echo " --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}} -lX11 -lXext"" >>mplayer_options
 %if %{with system_ffmpeg}
 echo " --disable-libavutil_a" >>mplayer_options
 echo " --disable-libavcodec_a" >>mplayer_options
This page took 0.107685 seconds and 4 git commands to generate.