add support for armhf
authorJan Palus <atler@pld-linux.org>
Fri, 4 Dec 2020 14:52:03 +0000 (15:52 +0100)
committerJan Palus <atler@pld-linux.org>
Fri, 4 Dec 2020 14:52:03 +0000 (15:52 +0100)
arm.patch [new file with mode: 0644]
mozjs78.spec

diff --git a/arm.patch b/arm.patch
new file mode 100644 (file)
index 0000000..098e67d
--- /dev/null
+++ b/arm.patch
@@ -0,0 +1,27 @@
+From: Jordan Petridis <jordan@centricular.com>
+Date: Sun, 16 Feb 2020 21:42:42 +0000
+Subject: sdk/mozjs68: import a patch to workaround arm compilation issue
+
+Our glibc headers don't include the expected structs needed
+to compile the code. The primary target of this code seems
+to be Android.
+
+Bug-Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1526653
+Origin: https://gitlab.gnome.org/GNOME/gnome-build-meta/blob/master/files/mozjs68/armv7_disable_WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS.patch
+---
+ js/src/wasm/WasmSignalHandlers.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/js/src/wasm/WasmSignalHandlers.cpp b/js/src/wasm/WasmSignalHandlers.cpp
+index a6610f3..78941bf 100644
+--- a/js/src/wasm/WasmSignalHandlers.cpp
++++ b/js/src/wasm/WasmSignalHandlers.cpp
+@@ -244,7 +244,7 @@ using mozilla::DebugOnly;
+ // If you run into compile problems on a tier-3 platform, you can disable the
+ // emulation here.
+-#if defined(__linux__) && defined(__arm__)
++#if 0 && defined(__linux__) && defined(__arm__)
+ #  define WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
+ #endif
index d79a6049571ce3a6abf59936d551f5441841afbd..8f4e2ad611ca3e6b2788b3e0fc62b297def4e3b4 100644 (file)
@@ -17,6 +17,7 @@ Patch1:               system-virtualenv.patch
 Patch2:                include-configure-script.patch
 Patch3:                x32.patch
 Patch4:                %{name}-x32-rust.patch
+Patch5:                arm.patch
 URL:           https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey
 BuildRequires: autoconf2_13 >= 2.13
 BuildRequires: cargo
@@ -36,7 +37,7 @@ BuildRequires:        rust >= 1.41.0
 BuildRequires: zlib-devel >= 1.2.3
 Requires:      nspr >= 4.25
 Requires:      zlib >= 1.2.3
-ExclusiveArch: %{x8664} %{ix86} x32 aarch64
+ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -76,6 +77,7 @@ Pliki nagłówkowe do biblioteki JavaScript.
 %ifarch x32
 %patch4 -p1
 %endif
+%patch5 -p1
 
 %build
 export PYTHON="%{__python}"
This page took 0.077326 seconds and 4 git commands to generate.