]> git.pld-linux.org Git - packages/mozjs68.git/blob - mozjs68.spec
351ab295900688c0cb6683073abf2946aa1cfd26
[packages/mozjs68.git] / mozjs68.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # tests build
4
5 Summary:        SpiderMonkey 68 - JavaScript implementation
6 Summary(pl.UTF-8):      SpiderMonkey 68 - implementacja języka JavaScript
7 Name:           mozjs68
8 Version:        68.12.0
9 Release:        3
10 License:        MPL v2.0
11 Group:          Libraries
12 #Source0:       http://ftp.gnome.org/pub/gnome/teams/releng/tarballs-needing-help/mozjs/mozjs-%{version}.tar.bz2
13 Source0:        http://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.xz
14 # Source0-md5:  80ae7816399f20cc61c9b15495b2341d
15 Patch0:         copy-headers.patch
16 Patch1:         system-virtualenv.patch
17 Patch2:         include-configure-script.patch
18 Patch3:         x32.patch
19 Patch4:         no-rust.patch
20 URL:            https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey
21 BuildRequires:  autoconf2_13 >= 2.13
22 # "TestWrappingOperations.cpp:27:1: error: non-constant condition for static assertion" with -fwrapv on gcc 6 and 7
23 %{?with_tests:BuildRequires:    gcc-c++ >= 6:8}
24 BuildRequires:  libicu-devel >= 59.1
25 BuildRequires:  libstdc++-devel >= 6:4.4
26 BuildRequires:  nspr-devel >= 4.19
27 BuildRequires:  perl-base >= 1:5.6
28 BuildRequires:  pkgconfig
29 BuildRequires:  python >= 1:2.5
30 BuildRequires:  python-psutil
31 BuildRequires:  python-virtualenv >= 1.9.1-4
32 BuildRequires:  readline-devel
33 BuildRequires:  rpm-perlprov
34 BuildRequires:  rpmbuild(macros) >= 1.294
35 BuildRequires:  zlib-devel >= 1.2.3
36 Requires:       nspr >= 4.19
37 Requires:       zlib >= 1.2.3
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 JavaScript Reference Implementation (codename SpiderMonkey). The
42 package contains JavaScript runtime (compiler, interpreter,
43 decompiler, garbage collector, atom manager, standard classes) and
44 small "shell" program that can be used interactively and with .js
45 files to run scripts.
46
47 %description -l pl.UTF-8
48 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
49 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
50 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
51 która może być używana interaktywnie lub z plikami .js do uruchamiania
52 skryptów.
53
54 %package devel
55 Summary:        Header files for JavaScript reference library
56 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       libstdc++-devel
60 Requires:       nspr-devel >= 4.19
61
62 %description devel
63 Header files for JavaScript reference library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe do biblioteki JavaScript.
67
68 %prep
69 %setup -q -n firefox-%{version}
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74 %patch4 -p1
75
76 %build
77 export PYTHON="%{__python}"
78 export AUTOCONF="%{_bindir}/autoconf2_13"
79 export SHELL="/bin/sh"
80 cd js/src
81 mkdir -p obj
82 cd obj
83
84 %define configuredir ".."
85 %configure2_13 \
86         --enable-gcgenerational \
87         --disable-jemalloc \
88         --enable-readline \
89         --enable-shared-js \
90         %{!?with_tests:--disable-tests} \
91         --enable-threadsafe \
92         --with-intl-api \
93         --with-system-icu \
94         --with-system-nspr \
95         --with-system-zlib
96
97 %{__make} \
98         HOST_OPTIMIZE_FLAGS= \
99         MODULE_OPTIMIZE_FLAGS= \
100         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
101         MOZ_PGO_OPTIMIZE_FLAGS= \
102         MOZILLA_VERSION=%{version}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 cd js/src/obj
108
109 %{__make} -C js/src install \
110     DESTDIR=$RPM_BUILD_ROOT \
111     MOZILLA_VERSION=%{version}
112
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc js/src/README.html
124 %attr(755,root,root) %{_bindir}/js68
125 %attr(755,root,root) %{_libdir}/libmozjs-68.so
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/js68-config
130 %{_includedir}/mozjs-68
131 %{_pkgconfigdir}/mozjs-68.pc
This page took 0.059567 seconds and 2 git commands to generate.