]> git.pld-linux.org Git - packages/mozjs68.git/blob - mozjs60.spec
- updated to 60.7.0 (using firefox sources)
[packages/mozjs68.git] / mozjs60.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # tests build
4
5 Summary:        SpiderMonkey 60 - JavaScript implementation
6 Summary(pl.UTF-8):      SpiderMonkey 60 - implementacja języka JavaScript
7 Name:           mozjs60
8 Version:        60.7.0
9 Release:        1
10 License:        MPL v2.0
11 Group:          Libraries
12 #Source0:       http://ftp.gnome.org/pub/gnome/teams/releng/tarballs-needing-help/mozjs/mozjs-%{version}.tar.bz2
13 Source0:        http://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.xz
14 # Source0-md5:  8e42357e8687ae2004b1493f1fbc0f04
15 Patch0:         copy-headers.patch
16 Patch1:         system-virtualenv.patch
17 Patch2:         include-configure-script.patch
18 Patch3:         x32.patch
19 URL:            https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey
20 BuildRequires:  autoconf2_13 >= 2.13
21 # "TestWrappingOperations.cpp:27:1: error: non-constant condition for static assertion" with -fwrapv on gcc 6
22 %{?with_tests:BuildRequires:    gcc-c++ >= 6:7}
23 BuildRequires:  libicu-devel >= 59.1
24 BuildRequires:  libstdc++-devel >= 6:4.4
25 BuildRequires:  nspr-devel >= 4.9.2
26 BuildRequires:  perl-base >= 1:5.6
27 BuildRequires:  pkgconfig
28 BuildRequires:  python >= 1:2.5
29 BuildRequires:  python-virtualenv >= 1.9.1-4
30 BuildRequires:  readline-devel
31 BuildRequires:  rpm-perlprov
32 BuildRequires:  rpmbuild(macros) >= 1.294
33 BuildRequires:  zlib-devel >= 1.2.3
34 Requires:       nspr >= 4.9.2
35 Requires:       zlib >= 1.2.3
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 JavaScript Reference Implementation (codename SpiderMonkey). The
40 package contains JavaScript runtime (compiler, interpreter,
41 decompiler, garbage collector, atom manager, standard classes) and
42 small "shell" program that can be used interactively and with .js
43 files to run scripts.
44
45 %description -l pl.UTF-8
46 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
47 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
48 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
49 która może być używana interaktywnie lub z plikami .js do uruchamiania
50 skryptów.
51
52 %package devel
53 Summary:        Header files for JavaScript reference library
54 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       libstdc++-devel
58 Requires:       nspr-devel >= 4.9.2
59
60 %description devel
61 Header files for JavaScript reference library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe do biblioteki JavaScript.
65
66 %prep
67 %setup -q -n firefox-%{version}
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71 %patch3 -p1
72
73 %build
74 export PYTHON="%{__python}"
75 export AUTOCONF="%{_bindir}/autoconf2_13"
76 export SHELL="/bin/sh"
77 cd js/src
78 mkdir -p obj
79 cd obj
80
81 %define configuredir ".."
82 %configure2_13 \
83         --enable-gcgenerational \
84         --disable-jemalloc \
85         --enable-readline \
86         --enable-shared-js \
87         %{!?with_tests:--disable-tests} \
88         --enable-threadsafe \
89         --with-intl-api \
90         --with-system-icu \
91         --with-system-nspr \
92         --with-system-zlib
93
94 %{__make} \
95         HOST_OPTIMIZE_FLAGS= \
96         MODULE_OPTIMIZE_FLAGS= \
97         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
98         MOZ_PGO_OPTIMIZE_FLAGS= \
99         MOZILLA_VERSION=%{version}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 cd js/src/obj
105
106 %{__make} -C js/src install \
107     DESTDIR=$RPM_BUILD_ROOT \
108     MOZILLA_VERSION=%{version}
109
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc js/src/README.html
121 %attr(755,root,root) %{_bindir}/js60
122 %attr(755,root,root) %{_libdir}/libmozjs-60.so
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/js60-config
127 %{_includedir}/mozjs-60
128 %{_pkgconfigdir}/mozjs-60.pc
This page took 0.065161 seconds and 3 git commands to generate.