]> git.pld-linux.org Git - packages/mozjs38.git/commitdiff
Added Disable-js-JIT-on-x32 and -x32 patches to fix build on x32 auto/th/mozjs38-38.8.0-1
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Tue, 21 Mar 2017 07:27:26 +0000 (08:27 +0100)
committerMarcin Banasiak <marcin.banasiak@gmail.com>
Tue, 21 Mar 2017 07:27:26 +0000 (08:27 +0100)
Disable-js-JIT-on-x32.patch [new file with mode: 0644]
mozjs38-x32.patch [new file with mode: 0644]
mozjs38.spec

diff --git a/Disable-js-JIT-on-x32.patch b/Disable-js-JIT-on-x32.patch
new file mode 100644 (file)
index 0000000..d5a603d
--- /dev/null
@@ -0,0 +1,26 @@
+Description: Disable the js JIT on x32.
+Author: Adam Borowski <kilobyte@angband.pl>
+Index: mozjs24-24.2.0/js/src/configure.in
+===================================================================
+--- mozjs24-24.2.0.orig/js/src/configure.in
++++ mozjs24-24.2.0/js/src/configure.in
+@@ -2072,6 +2072,8 @@ fi
+ dnl Configure JIT support
+ case "$target" in
++x86_64*-gnux32)
++    ;;
+ i?86-*)
+     ENABLE_METHODJIT=1
+     ENABLE_ION=1
+--- mozjs-24.2.0/js/src/configure~     2013-12-11 23:23:20.000000000 +0100
++++ mozjs-24.2.0/js/src/configure      2015-03-23 22:55:24.995319443 +0100
+@@ -8243,6 +8243,8 @@
+ case "$target" in
++x86_64*-gnux32)
++    ;;
+ i?86-*)
+     ENABLE_METHODJIT=1
+     ENABLE_ION=1
diff --git a/mozjs38-x32.patch b/mozjs38-x32.patch
new file mode 100644 (file)
index 0000000..7b91a59
--- /dev/null
@@ -0,0 +1,11 @@
+--- mozilla-esr38/js/src/jstypes.h.x32fix      2017-03-21 08:17:52.446161040 +0100
++++ mozilla-esr38/js/src/jstypes.h     2017-03-21 08:18:23.531014466 +0100
+@@ -142,7 +142,7 @@
+ # endif
+ #elif defined(__GNUC__)
+ /* Additional GCC defines are when running on Solaris, AIX, and HPUX */
+-# if defined(__x86_64__) || defined(__sparcv9) || \
++# if (defined(__x86_64__) && !defined(__ILP32__)) || defined(__sparcv9) || \
+         defined(__64BIT__) || defined(__LP64__)
+ #  define JS_64BIT
+ # endif
index c46fa3dcdd4765974d74bcac833a101dc8ae0b08..a8679e75baa25ad63a05632b6bc71a5e6d5f6c13 100644 (file)
@@ -11,6 +11,8 @@ Patch0:               %{name}-shell-version.patch
 Patch1:                %{name}-pkg-config-version.patch
 Patch2:                %{name}-1269317.patch
 Patch3:                %{name}-system-virtualenv.patch
+Patch4:                Disable-js-JIT-on-x32.patch
+Patch5:                %{name}-x32.patch
 URL:           https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/38
 BuildRequires: libffi-devel >= 5:3.0.9
 BuildRequires: libstdc++-devel >= 6:4.4
@@ -61,6 +63,8 @@ Pliki nagłówkowe do biblioteki JavaScript.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 cd js/src
 
This page took 0.12335 seconds and 4 git commands to generate.