]> git.pld-linux.org Git - packages/mozjs38.git/blob - mozjs38.spec
Use system virtualenv (should fix build on x32)
[packages/mozjs38.git] / mozjs38.spec
1 Summary:        SpiderMonkey 38 - JavaScript implementation
2 Summary(pl.UTF-8):      SpiderMonkey 38 - implementacja języka JavaScript
3 Name:           mozjs38
4 Version:        38.8.0
5 Release:        1
6 License:        MPL v2.0
7 Group:          Libraries
8 Source0:        https://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.bz2
9 # Source0-md5:  af46898414a433f8260c5373efb97d19
10 Patch0:         %{name}-shell-version.patch
11 Patch1:         %{name}-pkg-config-version.patch
12 Patch2:         %{name}-1269317.patch
13 Patch3:         %{name}-system-virtualenv.patch
14 URL:            https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/38
15 BuildRequires:  libffi-devel >= 5:3.0.9
16 BuildRequires:  libstdc++-devel >= 6:4.4
17 BuildRequires:  nspr-devel >= 4.9.2
18 BuildRequires:  perl-base >= 1:5.6
19 BuildRequires:  pkgconfig
20 BuildRequires:  python >= 1:2.5
21 BuildRequires:  python-virtualenv >= 1.9.1-4
22 BuildRequires:  readline-devel
23 BuildRequires:  rpm-perlprov
24 BuildRequires:  rpmbuild(macros) >= 1.294
25 BuildRequires:  zlib-devel >= 1.2.3
26 Requires:       nspr >= 4.9.2
27 Requires:       zlib >= 1.2.3
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 JavaScript Reference Implementation (codename SpiderMonkey). The
32 package contains JavaScript runtime (compiler, interpreter,
33 decompiler, garbage collector, atom manager, standard classes) and
34 small "shell" program that can be used interactively and with .js
35 files to run scripts.
36
37 %description -l pl.UTF-8
38 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
39 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
40 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
41 która może być używana interaktywnie lub z plikami .js do uruchamiania
42 skryptów.
43
44 %package devel
45 Summary:        Header files for JavaScript reference library
46 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       libstdc++-devel
50 Requires:       nspr-devel >= 4.9.2
51
52 %description devel
53 Header files for JavaScript reference library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe do biblioteki JavaScript.
57
58 %prep
59 %setup -q -n mozilla-esr38
60 %patch0 -p1
61 %patch1 -p1
62 %patch2 -p1
63 %patch3 -p1
64
65 cd js/src
66
67 # Correct sed expression for new sed
68 sed -i 's|\^\[:space:\]|^\[\[:space:\]\]|g' configure
69
70 %build
71 export PYTHON="%{__python}"
72 cd js/src
73 %configure2_13 \
74         --enable-readline \
75         --enable-system-ffi \
76         --enable-threadsafe \
77         --enable-shared-js \
78         --enable-gcgenerational \
79         --with-system-nspr \
80         --with-system-icu \
81         --with-system-zlib \
82         --with-intl-api
83
84 %{__make} \
85         HOST_OPTIMIZE_FLAGS= \
86         MODULE_OPTIMIZE_FLAGS= \
87         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
88         MOZ_PGO_OPTIMIZE_FLAGS= \
89         MOZILLA_VERSION=%{version}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} -C js/src install \
95     DESTDIR=$RPM_BUILD_ROOT \
96     MOZILLA_VERSION=%{version}
97
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc js/src/README.html
109 %attr(755,root,root) %{_bindir}/js38
110 %attr(755,root,root) %{_libdir}/libmozjs-38.so
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_bindir}/js38-config
115 %{_includedir}/mozjs-38
116 %{_pkgconfigdir}/mozjs-38.pc
This page took 0.097596 seconds and 3 git commands to generate.