]> git.pld-linux.org Git - packages/mozjs38.git/blob - mozjs38.spec
Added Disable-js-JIT-on-x32 and -x32 patches to fix build on x32
[packages/mozjs38.git] / mozjs38.spec
1 Summary:        SpiderMonkey 38 - JavaScript implementation
2 Summary(pl.UTF-8):      SpiderMonkey 38 - implementacja języka JavaScript
3 Name:           mozjs38
4 Version:        38.8.0
5 Release:        1
6 License:        MPL v2.0
7 Group:          Libraries
8 Source0:        https://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.bz2
9 # Source0-md5:  af46898414a433f8260c5373efb97d19
10 Patch0:         %{name}-shell-version.patch
11 Patch1:         %{name}-pkg-config-version.patch
12 Patch2:         %{name}-1269317.patch
13 Patch3:         %{name}-system-virtualenv.patch
14 Patch4:         Disable-js-JIT-on-x32.patch
15 Patch5:         %{name}-x32.patch
16 URL:            https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/38
17 BuildRequires:  libffi-devel >= 5:3.0.9
18 BuildRequires:  libstdc++-devel >= 6:4.4
19 BuildRequires:  nspr-devel >= 4.9.2
20 BuildRequires:  perl-base >= 1:5.6
21 BuildRequires:  pkgconfig
22 BuildRequires:  python >= 1:2.5
23 BuildRequires:  python-virtualenv >= 1.9.1-4
24 BuildRequires:  readline-devel
25 BuildRequires:  rpm-perlprov
26 BuildRequires:  rpmbuild(macros) >= 1.294
27 BuildRequires:  zlib-devel >= 1.2.3
28 Requires:       nspr >= 4.9.2
29 Requires:       zlib >= 1.2.3
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 JavaScript Reference Implementation (codename SpiderMonkey). The
34 package contains JavaScript runtime (compiler, interpreter,
35 decompiler, garbage collector, atom manager, standard classes) and
36 small "shell" program that can be used interactively and with .js
37 files to run scripts.
38
39 %description -l pl.UTF-8
40 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
41 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
42 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
43 która może być używana interaktywnie lub z plikami .js do uruchamiania
44 skryptów.
45
46 %package devel
47 Summary:        Header files for JavaScript reference library
48 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       libstdc++-devel
52 Requires:       nspr-devel >= 4.9.2
53
54 %description devel
55 Header files for JavaScript reference library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe do biblioteki JavaScript.
59
60 %prep
61 %setup -q -n mozilla-esr38
62 %patch0 -p1
63 %patch1 -p1
64 %patch2 -p1
65 %patch3 -p1
66 %patch4 -p1
67 %patch5 -p1
68
69 cd js/src
70
71 # Correct sed expression for new sed
72 sed -i 's|\^\[:space:\]|^\[\[:space:\]\]|g' configure
73
74 %build
75 export PYTHON="%{__python}"
76 cd js/src
77 %configure2_13 \
78         --enable-readline \
79         --enable-system-ffi \
80         --enable-threadsafe \
81         --enable-shared-js \
82         --enable-gcgenerational \
83         --with-system-nspr \
84         --with-system-icu \
85         --with-system-zlib \
86         --with-intl-api
87
88 %{__make} \
89         HOST_OPTIMIZE_FLAGS= \
90         MODULE_OPTIMIZE_FLAGS= \
91         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
92         MOZ_PGO_OPTIMIZE_FLAGS= \
93         MOZILLA_VERSION=%{version}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -C js/src install \
99     DESTDIR=$RPM_BUILD_ROOT \
100     MOZILLA_VERSION=%{version}
101
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc js/src/README.html
113 %attr(755,root,root) %{_bindir}/js38
114 %attr(755,root,root) %{_libdir}/libmozjs-38.so
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_bindir}/js38-config
119 %{_includedir}/mozjs-38
120 %{_pkgconfigdir}/mozjs-38.pc
This page took 0.0753 seconds and 3 git commands to generate.