]> git.pld-linux.org Git - packages/mozjs38.git/blob - mozjs38.spec
Initial release
[packages/mozjs38.git] / mozjs38.spec
1 Summary:        SpiderMonkey 38 - JavaScript implementation
2 Summary(pl.UTF-8):      SpiderMonkey 38 - implementacja języka JavaScript
3 Name:           mozjs38
4 Version:        38.8.0
5 Release:        1
6 License:        MPL v2.0
7 Group:          Libraries
8 Source0:        https://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.bz2
9 # Source0-md5:  af46898414a433f8260c5373efb97d19
10 Patch0:         %{name}-shell-version.patch
11 Patch1:         %{name}-pkg-config-version.patch
12 Patch2:         %{name}-1269317.patch
13 URL:            https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/38
14 BuildRequires:  libffi-devel >= 3.0.9
15 BuildRequires:  libffi-devel >= 5:3.0.9
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libstdc++-devel >= 6:4.4
18 BuildRequires:  nspr-devel >= 4.9.2
19 BuildRequires:  perl-base >= 1:5.6
20 BuildRequires:  pkgconfig
21 BuildRequires:  python >= 1:2.5
22 BuildRequires:  python-virtualenv >= 1.9.1-4
23 BuildRequires:  readline-devel
24 BuildRequires:  rpm-perlprov
25 BuildRequires:  rpmbuild(macros) >= 1.294
26 BuildRequires:  zlib-devel >= 1.2.3
27 Requires:       nspr >= 4.9.2
28 Requires:       zlib >= 1.2.3
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 JavaScript Reference Implementation (codename SpiderMonkey). The
33 package contains JavaScript runtime (compiler, interpreter,
34 decompiler, garbage collector, atom manager, standard classes) and
35 small "shell" program that can be used interactively and with .js
36 files to run scripts.
37
38 %description -l pl.UTF-8
39 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
40 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
41 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
42 która może być używana interaktywnie lub z plikami .js do uruchamiania
43 skryptów.
44
45 %package devel
46 Summary:        Header files for JavaScript reference library
47 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       libstdc++-devel
51 Requires:       nspr-devel >= 4.9.2
52
53 %description devel
54 Header files for JavaScript reference library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe do biblioteki JavaScript.
58
59 %prep
60 %setup -q -n mozilla-esr38
61 %patch0 -p1
62 %patch1 -p1
63 %patch2 -p1
64
65 cd js/src
66
67 # Correct sed expression for new sed
68 sed -i 's|\^\[:space:\]|^\[\[:space:\]\]|g' configure
69
70 %build
71 export PYTHON="%{__python}"
72 cd js/src
73 %configure2_13 \
74         --enable-readline \
75         --enable-system-ffi \
76         --enable-threadsafe \
77         --enable-shared-js \
78         --enable-gcgenerational \
79         --with-system-nspr \
80         --with-system-icu \
81         --with-system-zlib \
82         --with-intl-api
83
84 %{__make} \
85         HOST_OPTIMIZE_FLAGS= \
86         MODULE_OPTIMIZE_FLAGS= \
87         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
88         MOZ_PGO_OPTIMIZE_FLAGS= \
89         MOZILLA_VERSION=%{version}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} -C js/src install \
95     DESTDIR=$RPM_BUILD_ROOT \
96     MOZILLA_VERSION=%{version}
97
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc js/src/README.html
109 %attr(755,root,root) %{_bindir}/js38
110 %attr(755,root,root) %{_libdir}/libmozjs-38.so
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_bindir}/js38-config
115 %{_includedir}/mozjs-38
116 %{_pkgconfigdir}/mozjs-38.pc
This page took 0.069847 seconds and 3 git commands to generate.