]> git.pld-linux.org Git - packages/mozjs38.git/blob - mozjs38.spec
78d3d68884b98c64dcfc65db7317cbc743f20328
[packages/mozjs38.git] / mozjs38.spec
1 Summary:        SpiderMonkey 38 - JavaScript implementation
2 Summary(pl.UTF-8):      SpiderMonkey 38 - implementacja języka JavaScript
3 Name:           mozjs38
4 Version:        38.8.0
5 Release:        3
6 License:        MPL v2.0
7 Group:          Libraries
8 Source0:        https://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.bz2
9 # Source0-md5:  af46898414a433f8260c5373efb97d19
10 Patch0:         %{name}-shell-version.patch
11 Patch1:         %{name}-pkg-config-version.patch
12 Patch2:         %{name}-1269317.patch
13 Patch3:         %{name}-system-virtualenv.patch
14 Patch4:         Disable-js-JIT-on-x32.patch
15 Patch5:         %{name}-x32.patch
16 Patch6:         %{name}-copy-headers.patch
17 URL:            https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/38
18 BuildRequires:  libffi-devel >= 5:3.0.9
19 BuildRequires:  libstdc++-devel >= 6:4.4
20 BuildRequires:  nspr-devel >= 4.9.2
21 BuildRequires:  perl-base >= 1:5.6
22 BuildRequires:  pkgconfig
23 BuildRequires:  python >= 1:2.5
24 BuildRequires:  python-virtualenv >= 1.9.1-4
25 BuildRequires:  readline-devel
26 BuildRequires:  rpm-perlprov
27 BuildRequires:  rpmbuild(macros) >= 1.294
28 BuildRequires:  zlib-devel >= 1.2.3
29 Requires:       nspr >= 4.9.2
30 Requires:       zlib >= 1.2.3
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 JavaScript Reference Implementation (codename SpiderMonkey). The
35 package contains JavaScript runtime (compiler, interpreter,
36 decompiler, garbage collector, atom manager, standard classes) and
37 small "shell" program that can be used interactively and with .js
38 files to run scripts.
39
40 %description -l pl.UTF-8
41 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
42 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
43 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
44 która może być używana interaktywnie lub z plikami .js do uruchamiania
45 skryptów.
46
47 %package devel
48 Summary:        Header files for JavaScript reference library
49 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libstdc++-devel
53 Requires:       nspr-devel >= 4.9.2
54
55 %description devel
56 Header files for JavaScript reference library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe do biblioteki JavaScript.
60
61 %prep
62 %setup -q -n mozilla-esr38
63 %patch0 -p1
64 %patch1 -p1
65 %patch2 -p1
66 %patch3 -p1
67 %patch4 -p1
68 %patch5 -p1
69 %patch6 -p1
70
71 cd js/src
72
73 # Correct sed expression for new sed
74 sed -i 's|\^\[:space:\]|^\[\[:space:\]\]|g' configure
75
76 %build
77 export PYTHON="%{__python}"
78 cd js/src
79 %configure2_13 \
80         --enable-readline \
81         --enable-system-ffi \
82         --enable-threadsafe \
83         --enable-shared-js \
84         --enable-gcgenerational \
85         --with-system-nspr \
86         --with-system-icu \
87         --with-system-zlib \
88         --with-intl-api
89
90 %{__make} \
91         HOST_OPTIMIZE_FLAGS= \
92         MODULE_OPTIMIZE_FLAGS= \
93         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
94         MOZ_PGO_OPTIMIZE_FLAGS= \
95         MOZILLA_VERSION=%{version}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} -C js/src install \
101     DESTDIR=$RPM_BUILD_ROOT \
102     MOZILLA_VERSION=%{version}
103
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc js/src/README.html
115 %attr(755,root,root) %{_bindir}/js38
116 %attr(755,root,root) %{_libdir}/libmozjs-38.so
117
118 %files devel
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/js38-config
121 %{_includedir}/mozjs-38
122 %{_pkgconfigdir}/mozjs-38.pc
This page took 0.083114 seconds and 2 git commands to generate.